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Preface

Welcome to the C-SPY® Debugging Guide for RISC-V. The purpose of this guide
is to help you fully use the features in the IAR C-SPY® Debugger for debugging
your application based on RISC-V.

Who should read this guide

Read this guide if you plan to develop an application using IAR Embedded Workbench
and want to get the most out of the features available in C-SPY.

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

e The architecture and instruction set of the RISC-V core you are using (refer to the
chip manufacturer's documentation)

e The C or C++ programming language

e Application development for embedded systems

o The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer
to their respective documentation, see Other documentation, page 23.

How to use this guide

Each chapter in this guide covers a specific fopic area. In many chapters, information is
typically divided into different sections based on information types:

o Concepts, which describes the topic and gives overviews of features related to the
topic area. Any requirements or restrictions are also listed. Read this section to learn
about the topic area.

o Tasks, which lists useful tasks related to the topic area. For many of the tasks, you
can also find step-by-step descriptions. Read this section for information about
required tasks as well as for information about how to perform certain tasks.

® Reference information, which gives reference information related to the topic area.
Read this section for information about certain features or GUI components. You
can easily access this type of information for a GUI component in the IDE by
pressing F1.
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If you are new to using IAR Embedded Workbench, we suggest that you first go through
the tutorials, which you can find in IAR Information Center in the product, under
Product Explorer. They will help you get started.

Finally, we recommend the Glossary if you should encounter any unfamiliar terms in
the IAR user documentation.

What this guide contains

C-SPY® Debugging Guide
for RISC-V

Below is a brief outline and summary of the chapters in this guide.

Note: Some of the screenshots in this guide are taken from a similar product and not
from IAR Embedded Workbench for RISC-V.

PART |. BASIC DEBUGGING

® The IAR C-SPY Debugger introduces you to the C-SPY debugger and to the
concepts that are related to debugging in general and to C-SPY in particular. The
chapter also introduces the various C-SPY drivers. The chapter briefly shows the
difference in functionality that the various C-SPY drivers provide.

o Getting started using C-SPY helps you get started using C-SPY, which includes
setting up, starting, and adapting C-SPY for target hardware.

® [Executing your application describes the conceptual differences between source
and disassembly mode debugging, the facilities for executing your application, and
finally, how you can handle terminal input and output.

® JVariables and expressions describes the syntax of the expressions and variables
used in C-SPY, as well as the limitations on variable information. The chapter also
demonstrates the various methods for monitoring variables and expressions.

® Breakpoints describes the breakpoint system and the various ways to set
breakpoints.

® Memory and registers shows how you can examine memory and registers.

PART 2. ANALYZING YOUR APPLICATION
e Trace describes how you can inspect the program flow up to a specific state using
trace data.

o The application timeline describes the Timeline window, and how to use the
information in it to analyze your application’s behavior.

e Profiling describes how the profiler can help you find the functions in your
application source code where the most time is spent during execution.
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Code coverage describes how the code coverage functionality can help you verify
whether all parts of your code have been executed, thus identifying parts which have
not been executed.

PART 3. ADVANCED DEBUGGING

Multicore debugging describes how to debug a target with multiple cores.

Interrupts contains detailed information about the C-SPY interrupt simulation
system and how to configure the simulated interrupts to make them reflect the
interrupts of your target hardware.

C-SPY macros describes the C-SPY macro system, its features, the purposes of
these features, and how to use them.

The C-SPY command line utility—cspybat describes how to use C-SPY in batch
mode.

Flash loaders describes the flash loader, what it is and how to use it.

PART 4. ADDITIONAL REFERENCE INFORMATION

Debugger options describes the options you must set before you start the C-SPY
debugger.

Additional information on C-SPY drivers describes menus and features provided by
the C-SPY drivers not described in any dedicated topics.

Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online
help system in HTML format. You can access the documentation from the IAR
Information Center or from the Help menu in the IAR Embedded Workbench IDE. The
online help system is also available via the F1 key.

USER AND REFERENCE GUIDES

The complete set of IAR development tools is described in a series of guides.
Information about:

System requirements and information about how to install and register the IAR
products are available in the Installation and Licensing Quick Reference Guide and
the Licensing Guide.

Using the IDE for project management and building, is available in the /DE Project
Management and Building Guide for RISC-V.

Using the IAR C-SPY® Debugger, is available in the C-SPY® Debugging Guide
Jor RISC-V.
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Programming for the IAR C/C++ Compiler for RISC-V and linking, is available in
the AR C/C++ Development Guide for RISC-V.

Programming for the IAR Assembler for RISC-V, is available in the /AR Assembler
User Guide for RISC-V.

Performing a static analysis using C-STAT and the required checks, is available in
the C-STAT® Static Analysis Guide.

Using I-jet, refer to the JAR Debug probes User Guide for I-jet®.

Note: Additional documentation might be available depending on your product
installation.

THE ONLINE HELP SYSTEM

The context-sensitive online help contains information about:

IDE project management and building
Debugging using the IAR C-SPY® Debugger
The IAR C/C++ Compiler and Linker

The IAR Assembler

C-STAT

WEB SITES

Recommended web sites:

The chip manufacturer’s web site.

The RISC-V International web site, www.riscv.org, that contains information and
news about the RISC-V ISA. This includes the most recent specifications.

The IAR web site, www.iar.com, that holds application notes and other product
information.

The web site of the C standardization working group,
www.open-std.org/jtcl/sc22/wgl4.

o The web site of the C++ Standards Committee, www.open-std.org/jtcl/sc22/wg21.

e The C++ programming language web site, isocpp.org. This web site also has a list

of recommended books about C++ programming.

The C and C++ reference web site, en.cppreference.com.

Document conventions

C-SPY® Debugging Guide
for RISC-V

When, in the IAR documentation, we refer to the programming language C, the text also
applies to C++, unless otherwise stated.



Preface __o

When referring to a directory in your product installation, for example riscv\doc, the
full path to the location is assumed, for example c: \Program Files\IAR
Systems\Embedded Workbench N.n\riscv\doc, where the initial digit of the
version number reflects the initial digit of the version number of the IAR Embedded
Workbench shared components.

TYPOGRAPHIC CONVENTIONS
The IAR documentation set uses the following typographic conventions:

Style Used for

computer * Source code examples and file paths.
* Text on the command line.
* Binary, hexadecimal, and octal numbers.

parameter A placeholder for an actual value used as a parameter, for example
filename.h where £ilename represents the name of the file.

[option] An optional part of a linker or stack usage control directive, where [
and ] are not part of the actual directive, butany [, ], {, or } are part
of the directive syntax.

{option} A mandatory part of a linker or stack usage control directive, where {
and } are not part of the actual directive, butany [, ], {, or } are part
of the directive syntax.

[option] An optional part of a command line option, pragma directive, or library
filename.
[a|b]c] An optional part of a command line option, pragma directive, or library

filename with alternatives.

{a|b|c} A mandatory part of a command line option, pragma directive, or
library filename with alternatives.

bold Names of menus, menu commands, buttons, and dialog boxes that
appear on the screen.

italic * A cross-reference within this guide or to another guide.
* Emphasis.
An ellipsis indicates that the previous item can be repeated an arbitrary
number of times.

Identifies instructions specific to the IAR Embedded Workbench® IDE
interface.
Identifies instructions specific to the command line interface.

Identifies helpful tips and programming hints.
E
Table 1: Typographic conventions used in this guide
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Style Used for

Identifies warnings.

Table 1: Typographic conventions used in this guide (Continued)

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR, when
referred to in the documentation:

Brand name Generic term

IAR Embedded Workbench® for RISC-V IAR Embedded Workbench®
IAR Embedded Workbench® IDE for RISC-V the IDE

IAR C-SPY® Debugger for RISC-V C-SPY, the debugger

IAR C-SPY® Simulator the simulator

IAR C/C++ Compiler™ for RISC-V the compiler

IAR Assembler™ for RISC-V the assembler

IAR ILINK Linker™ ILINK, the linker

IAR DLIB Runtime Environment™ the DLIB runtime environment

Table 2: Naming conventions used in this guide

C-SPY® Debugging Guide
26 for RISC-V



Part |. Basic debugging

This part of the C-SPY® Debugging Guide for RISC-V includes these chapters:
e The IAR C-SPY Debugger

e Getting started using C-SPY

e Executing your application

e Variables and expressions

e Breakpoints

e Memory and registers

: .hﬁhhhhm
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The IAR C-SPY Debugger

e Introduction to C-SPY

Debugger concepts
e C-SPY drivers overview

e The IAR C-SPY Simulator

e The C-SPY hardware debugger drivers

Introduction to C-SPY

These topics are covered:

e An integrated environment
o General C-SPY debugger features

e RTOS awareness

AN INTEGRATED ENVIRONMENT

C-SPY is a high-level-language debugger for embedded applications. It is designed for
use with the IAR compilers and assemblers, and is completely integrated in the IDE,
providing development and debugging within the same application. This gives you
possibilities such as:

e FEditing while debugging
During a debug session, you can make corrections directly in the same source code

window that is used for controlling the debugging. Changes will be included in the
next project rebuild.

o Setting breakpoints at any point during the development cycle

You can inspect and modify breakpoint definitions also when the debugger is not
running, and breakpoint definitions flow with the text as you edit. Your debug
settings, such as watch properties, window layouts, and register groups will be
preserved between your debug sessions.

All windows that are open in the IAR Embedded Workbench workspace will stay open
when you start the C-SPY Debugger. In addition, a set of C-SPY-specific windows are
opened.
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GENERAL C-SPY DEBUGGER FEATURES

Because IAR provides an entire toolchain, the output from the compiler and linker can
include extensive debug information for the debugger, resulting in good debugging
possibilities for you.

C-SPY offers these general features:

Source and disassembly level debugging

C-SPY allows you to switch between source and disassembly debugging as required,
for both C or C++ and assembler source code.

Single-stepping on a function call level

Compared to traditional debuggers, where the finest granularity for source level
stepping is line by line, C-SPY provides a finer level of control by identifying every
statement and function call as a step point. This means that each function call—
inside expressions, and function calls that are part of parameter lists to other
functions—can be single-stepped. The latter is especially useful when debugging
C++ code, where numerous extra function calls are made, for example to object
constructors.

Code and data breakpoints

The C-SPY breakpoint system lets you set breakpoints of various kinds in the
application being debugged, allowing you to stop at locations of particular interest.
For example, you set breakpoints to investigate whether your program logic is correct
or to investigate how and when the data changes.

Monitoring variables and expressions

For variables and expressions there is a wide choice of facilities. You can easily
monitor values of a specified set of variables and expressions, continuously or on
demand. You can also choose to monitor only local variables, static variables, etc.

Container awareness

When you run your application in C-SPY, you can view the elements of library data
types such as STL lists and vectors. This gives you a very good overview and
debugging opportunities when you work with C++ STL containers.

Call stack information

The compiler generates extensive call stack information. This allows the debugger to
show, without any runtime penalty, the complete stack of function calls wherever the
program counter is. You can select any function in the call stack, and for each
function you get valid information for local variables and available registers.

Powerful macro system

C-SPY includes a powerful internal macro system, to allow you to define complex
sets of actions to be performed. C-SPY macros can be used on their own or in
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conjunction with complex breakpoints and—for some cores or devices—the
interrupt simulation system to perform a wide variety of tasks.

Additional general C-SPY debugger features
This list shows some additional features:

Threaded execution keeps the IDE responsive while running the target application
Automatic stepping

The source browser provides easy navigation to functions, types, and variables
Extensive type recognition of variables

Configurable registers (CPU and peripherals) and memory windows

Graphical stack view with overflow detection

Support for code coverage and function level profiling

The target application can access files on the host PC using file I/O

Optional terminal I/O emulation

RTOS AWARENESS

C-SPY supports RTOS-aware debugging. For information about which operating
systems that are currently supported, see the Information Center, available from the
Help menu.

RTOS plugin modules can be provided by IAR, and by third-party suppliers. Contact
your software distributor or IAR representative, alternatively visit the IAR web site, for
information about supported RTOS modules.

A C-SPY RTOS awareness plugin module gives you a high level of control and visibility
over an application built on top of an RTOS. It displays RTOS-specific items like task
lists, queues, semaphores, mailboxes, and various RTOS system variables. Task-specific
breakpoints and task-specific stepping make it easier to debug tasks.

A loaded plugin will add its own menu, set of windows, and buttons when a debug
session is started (provided that the RTOS is linked with the application). For
information about other RTOS awareness plugin modules, refer to the manufacturer of
the plugin module.

Debugger concepts

This section introduces some of the concepts and terms that are related to debugging in
general and to C-SPY in particular. This section does not contain specific information
related to C-SPY features. Instead, you will find such information in the other chapters
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of this documentation. The IAR user documentation uses the terms described in this
section when referring to these concepts.

These topics are covered:

C-SPY and target systems
The debugger

The target system

The application

C-SPY debugger systems
Third-party debuggers

C-SPY plugin modules

C-SPY AND TARGET SYSTEMS

You can use C-SPY to debug either a software target system or a hardware target system.

C-SPY® Debugging Guide
32 for RISC-V
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This figure gives an overview of C-SPY and possible target systems:

IAR C-SPY Debugger Target system with application software

|
I |
I |
| S|mLfIator Simulator I
| | driver |
I P !
| |
| I Emulator |
I driver j\[ e Target |

IAR Embedded | emulator [~ | hardware
Workbench | C-SPY !
|
! 3rd-party |
I driver |
| Target

| hardware I
|

|
|

|
|

|
|

|
|

|
|

|

= Provided by IAR Systems

|:| = Provided by IAR Systems or third-party vendors

THE DEBUGGER

The debugger, for instance C-SPY, is the program that you use for debugging your
applications on a target system.

THE TARGET SYSTEM

The target system is the system on which you execute your application when you are
debugging it. The target system can consist of hardware, either an evaluation board or
your own hardware design. It can also be completely or partially simulated by software.
Each type of target system needs a dedicated C-SPY driver.

THE APPLICATION

A user application is the software you have developed and which you want to debug
using C-SPY.

C-SPY DEBUGGER SYSTEMS

C-SPY consists of both a general part which provides a basic set of debugger features,
and a target-specific back end. The back end consists of two components: a processor
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module—one for every microcontroller, which defines the properties of the
microcontroller, and a C-SPY driver. The C-SPY driver is the part that provides
communication with and control of the target system. The driver also provides the user
interface—menus, windows, and dialog boxes—to the functions provided by the target
system, for instance, special breakpoints.

Typically, there are three main types of C-SPY drivers:

e Simulator driver

o ROM-monitor driver

e Emulator driver

C-SPY is available with a simulator driver, and depending on your product package,
optional drivers for hardware debugger systems. For an overview of the available C-SPY

drivers and the functionality provided by each driver, see C-SPY drivers overview, page
35.

THIRD-PARTY DEBUGGERS

You can use a third-party debugger together with the IAR toolchain as long as the
third-party debugger can read ELF/DWAREF, Intel-extended, or Motorola. For
information about which format to use with a third-party debugger, see the user
documentation supplied with that tool.

C-SPY PLUGIN MODULES

C-SPY is designed as a modular architecture with an open SDK that can be used for
implementing additional functionality to the debugger in the form of plugin modules.
These modules can be seamlessly integrated in the IDE.

Plugin modules are provided by IAR, or can be supplied by third-party vendors.
Examples of such modules are:

o The various C-SPY drivers for debugging using certain debug systems.

o RTOS plugin modules for support for real-time OS aware debugging.

e C-SPYLink that bridges IAR Visual State and IAR Embedded Workbench to make
true high-level state machine debugging possible directly in C-SPY, in addition to
the normal C level symbolic debugging. For more information, see the
documentation provided with IAR Visual State.

For more information about the C-SPY SDK, contact IAR.
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C-SPY drivers overview

At the time of writing this guide, the IAR C-SPY Debugger for RISC-V is available with
drivers for these target systems and evaluation boards:

e Simulator
e I-jet and I-jet Trace debug probes
e GDB Server

Note: In addition to the drivers supplied with IAR Embedded Workbench, you can also
load debugger drivers supplied by a third-party vendor; see Third-Party Driver options,
page 389.

DIFFERENCES BETWEEN THE C-SPY DRIVERS

This table summarizes the key differences between the C-SPY drivers:

Feature Simulator I-jet GDB Server
Code breakpointsI Unlimited Yes Yes
Data breakpoim:sI Yes Yes Yes
Execution in real time — Yes Yes?
Zero memory footprint Yes Yes Yes?
Simulated interrupts Yes — —
Real interrupts — Yes —
Interrupt logging Yes — —
Data logging Yes — —
Live watch Yes Yes —
Cycle counter Yes — —
Code coverageI Yes Yes —
Data coverage Yes — —
Function/instruction profilingI Yes Yes —
Trace Yes Yes —
Multicore debugging Yes Yes —

Table 3: Driver differences
1 With specific requirements or restrictions, see the respective chapter in this guide.

2. If connected to hardware.
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The IAR C-SPY Simulator

The C-SPY simulator simulates the functions of the target processor entirely in
software, which means that you can debug the program logic long before any hardware
is available. Because no hardware is required, it is also the most cost-effective solution
for many applications.

SUPPORTED FEATURES

The C-SPY simulator supports:

Instruction-level simulation
Memory configuration and validation

Interrupt simulation

Peripheral simulation (using the C-SPY macro system in conjunction with
immediate breakpoints).

Simulating hardware instead of using a hardware debugging system means that some
limitations do not apply, but that there are other limitations instead. For example:

e You can set an unlimited number of breakpoints in the simulator.

e When you stop executing your application, time actually stops in the simulator.
When you stop application execution on a hardware debugging system, there might
still be activities in the system. For example, peripheral units might still be active
and reading from or writing to SFR ports.

e Application execution is significantly much slower in a simulator compared to when
using a hardware debugging system. However, during a debug session, this might
not necessarily be a problem.

e The simulator is not cycle accurate.

e Peripheral simulation is limited in the C-SPY Simulator and therefore the simulator
is suitable mostly for debugging code that does not interact too much with
peripheral units.

The C-SPY hardware debugger drivers

C-SPY® Debugging Guide
for RISC-V

C-SPY can connect to a hardware debugger using a C-SPY hardware debugger driver as
an interface. Any C-SPY hardware debugger drivers are automatically installed during
the installation of AR Embedded Workbench.

IAR Embedded Workbench for RISC-V comes with a C-SPY hardware debugger driver
for the I-jet and I-jet Trace debug probes.
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These topics are covered:
e Communication overview
e Hardware installation

e USB driver installation

COMMUNICATION OVERVIEW

The C-SPY hardware debugger driver uses USB to communicate with the hardware
debugger. The hardware debugger communicates with the JTAG interface on the
microcontroller.

C-SPY debugger
— C-SPY I-jet driver

USB, parallel, serial, or
Ethernet connection

~  ITAG .r\fate‘:
\/JTAG cable ( . v

When a USB connection is used, a specific USB driver must be installed before you can
use the probe over the USB port. You can find the USB driver on the IAR Embedded
Workbench installation media.
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HARDWARE INSTALLATION

For best results, follow these steps.

Recommended power-up sequence

For information about the hardware installation, see the documentation supplied with
the target system from the manufacturer. The following power-up sequence is
recommended to ensure proper communication between the target board, debug probe,
and C-SPY:

Connect the probe to the target board.

Connect the USB cable to the debug probe.

Power up the debug probe, if it is not powered via USB.

Power up the target board, if it is not powered via the debug probe.
Start the C-SPY debug session.

If more than one debug probe is connected to your computer, the Debug Probe
Selection dialog box is displayed. In the dialog box, select the probe to use and click
OK. For more information, see --drv_communication, page 345.

To give the probe a nickname, select the probe in the dialog box and click the Edit
Nickname button. The nickname is saved locally on your computer and is available
when opening other projects.

Note: The Edit Nickname button might not be available for the C-SPY driver you are
using.

] Debug Probe Selection

Please select one of the following found probe(s)

Serial No.  Mickname  Info OK.
588 Iget-Trace ol
Edit Nickname

USB DRIVER INSTALLATION

C-SPY needs a USB driver, which for some probes, is automatically installed. If the
USB driver is not installed automatically, you will need to install it manually.
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Installing the I-jet USB driver

I-jet does not require any special driver software installation. Normally, all drivers for
I-jet are automatically installed as part of the installation of IAR Embedded Workbench.

If you need to install the USB driver manually, navigate to \Program Files\IAR
Systems\Embedded Workbench x.x\riscv\drivers\ijet\USB\32-bit or
64-bit (depending on your system). Start the dpinst . exe application. This will
install the USB driver. Note that the USB3 drivers are in the
\riscv\drivers\ijet\USB3 directory.

Installing the I-jet Trace USB driver

I-jet Trace does not require any special driver software installation. Normally, all drivers
for I-jet Trace are automatically installed as part of the installation of IAR Embedded
Workbench.

If you need to install the USB driver manually, navigate to
\riscv\drivers\jet\USB3\32-bit or 64-bit (in the installation directory). Start
the dpinst . exe application. This will install the USB driver.

The USB LED will flash twice after enumerating on the USB2 ports, and three times on
USB3 ports.
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C-SPY

e Setting up C-SPY
e Starting C-SPY
e Adapting for target hardware

e Reference information on starting C-SPY

Setting up C-SPY

These tasks are covered:
Setting up for debugging
Executing from reset
Using a setup macro file

Selecting a device description file

Loading plugin modules

SETTING UP FOR DEBUGGING

Before you start C-SPY, choose Project>Options>Debugger>Setup and select the
C-SPY driver that matches your debugger system—simulator or hardware debugger
system.

In the Category list, select the appropriate C-SPY driver and make your settings. For
information about these options, see Debugger options, page 373.

Click OK.
Choose Tools>Options to open the IDE Options dialog box:

e Select Debugger to configure the debugger behavior

e Select Stack to configure the debugger’s tracking of stack usage.

For more information about these options, see the IDE Project Management and
Building Guide for RISC-V. See also Adapting for target hardware, page 47.
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EXECUTING FROM RESET

The Run to option—available on the Debugger>Setup page—specifies a location you
want C-SPY to run to when you start a debug session as well as after each reset. C-SPY
will place a temporary breakpoint at this location and all code up to this point is executed
before stopping at the location. Note that this temporary breakpoint is removed when the
debugger stops, regardless of how. If you stop the execution before the Run to location
has been reached, the execution will not stop at that location when you start the
execution again.

The default location to run to is the main function. Type the name of the location if you
want C-SPY to run to a different location. You can specify assembler labels or whatever
can be evaluated to such, for instance function names.

If you leave the check box empty, the program counter will contain the regular hardware
reset address at each reset. The reset address is set by C-SPY.

If no breakpoints are available when C-SPY starts, a warning message notifies you that
single stepping will be required and that this is time consuming. You can then continue
execution in single-step mode or stop at the first instruction. If you choose to stop at the
first instruction, the debugger starts executing with the pC (program counter) at the
default reset location instead of the location you typed in the Run to box.

Note: This message will never be displayed in the C-SPY simulator, where breakpoints
are unlimited.

USING A SETUP MACRO FILE

A setup macro file is a macro file that you choose to load automatically when C-SPY
starts. You can define the setup macro file to perform actions according to your needs,
using setup macro functions and system macros. Thus, if you load a setup macro file you
can initialize C-SPY to perform actions automatically.

For more information about setup macro files and functions, see /ntroduction to C-SPY
macros, page 267.

For an example of how to use a setup macro file, see Initializing target hardware before
C-SPY starts, page 48.

To register a setup macro file:
Before you start C-SPY, choose Project>Options>Debugger>Setup.

Select Use macro file and type the path and name of your setup macro file, for
example Setup.mac. If you do not type a filename extension, the extension mac is
assumed.
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SELECTING A DEVICE DESCRIPTION FILE
C-SPY uses device description files to handle device-specific information.

A default device description file is automatically used based on your project settings. If
you want to override the default file, you must select your device description file. Device
description files from IAR are provided in the riscv\config directory and they have
the filename extension ddf.

For more information about device description files, see Adapting for target hardware,
page 47.

To override the default device description file:
I Before you start C-SPY, choose Project>Options>Debugger>Setup.

2 Select the Override default option, and choose a file using the Device description file
browse button.

Note: You can easily view your device description files that are used for your project.
Choose Project>Open Device Description File and select the file you want to view.
LOADING PLUGIN MODULES

On the Plugins page you can specify C-SPY plugin modules to load and make available
during debug sessions. Plugin modules can be provided by IAR, and by third-party
suppliers. Contact your software distributor or IAR representative, or visit the IAR web
site, for information about available modules.

For more information, see Plugins, page 380.

Starting C-SPY

When you have set up the debugger, you are ready to start a debug session.
These tasks are covered:

Starting a debug session

Loading executable files built outside of the IDE
Starting a debug session with source files missing
Loading multiple debug images

Editing in C-SPY windows

43



Starting C-SPY

44

C-SPY® Debugging Guide
for RISC-V

°3

STARTING A DEBUG SESSION

You can choose to start a debug session with or without loading the current executable
file.

To start C-SPY and download the current executable file, click the Download and
Debug button. Alternatively, choose Project>Download and Debug.

To start C-SPY without downloading the current executable file, click the Debug
without Downloading button. Alternatively, choose Project>Debug without
Downloading.

LOADING EXECUTABLE FILES BUILT OUTSIDE OF THE IDE

You can also load C-SPY with an application that was built outside the IDE, for example
applications built on the command line. To load an externally built executable file and
to set build options you must first create a project for it in your workspace.

To create a project for an externally built file:

Choose Project>Create New Project, and specify a project name.

To add the executable file to the project, choose Project>Add Files and make sure to
choose All Files in the file type drop-down list. Locate the executable file.

To start the executable file, click the Download and Debug button. The project can be
reused whenever you rebuild your executable file.

The only project options that are meaningful to set for this kind of project are options in
the General Options and Debugger categories. Make sure to set up the general project
options in the same way as when the executable file was built.

STARTING A DEBUG SESSION WITH SOURCE FILES MISSING

Normally, when you use the IAR Embedded Workbench IDE to edit source files, build
your project, and start the debug session, all required files are available and the process
works as expected.
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However, if C-SPY cannot automatically find the source files, for example if the
application was built on another computer, the Get Alternative File dialog box is
displayed:

Get Alternative File §|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

Typically, you can use the dialog box like this:

o The source files are not available—Select If possible, don’t show this dialog again
and then click Skip. C-SPY will assume that there is no source file available. The
dialog box will not appear again, and the debug session will not try to display the
source code.

e Alternative source files are available at another location—Specify an alternative
source code file, select If possible, don’t show this dialog again, and then click
Use this file. C-SPY will assume that the alternative file should be used. The dialog
box will not appear again, unless a file is needed for which there is no alternative
file specified and which cannot be located automatically.

If you restart the IAR Embedded Workbench IDE, the Get Alternative File dialog box
will be displayed again once even if you have selected If possible, don’t show this
dialog again. This gives you an opportunity to modify your previous settings.

For more information, see Get Alternative File dialog box, page 54.

LOADING MULTIPLE DEBUG IMAGES

Normally, a debuggable application consists of a single file that you debug. However,
you can also load additional debug files (debug images). This means that the complete
program consists of several debug images.

Typically, this is useful if you want to debug your application in combination with a
prebuilt ROM image that contains an additional library for some platform-provided
features. The ROM image and the application are built using separate projects in the
IAR Embedded Workbench IDE and generate separate output files.

If more than one debug image has been loaded, you will have access to the combined
debug information for all the loaded debug images. In the Images window you can
choose whether you want to have access to debug information for a single debug image
or for all images.
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To load additional debug images at C-SPY startup:

I Choose Project>Options>Debugger>Images and specify up to three additional
debug images to be loaded. For more information, see /mages, page 376.

2 Start the debug session.

To load additional debug images at a specific moment:

Use the __loadImage system macro and execute it using either one of the methods
described in Using C-SPY macros, page 269.

To display a list of loaded debug images:

Choose Images from the View menu. The Images window is displayed, see Images
window, page 53.

EDITING IN C-SPY WINDOWS
You can edit the contents of these windows:

Memory window

Symbolic Memory window
Registers window

Register User Groups Setup window
Auto window

Watch window

Locals window

Statics window

Live Watch window

Quick Watch window

Use these keyboard keys to edit the contents of these windows:

Enter Makes an item editable and saves the new value.

Esc Cancels a new value.

In windows where you can edit the Expression field and in the Quick Watch window,
you can specify the number of elements to be displayed in the field by adding a
semicolon followed by an integer. For example, to display only the three first elements
of an array named myArray, or three elements in sequence starting with the element
pointed to by a pointer, write:

myArray;3

C-SPY® Debugging Guide
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To display three elements pointed to by myPtr, myPtr+1, and myPtr+2, write:
myPtr;3

Optionally, add a comma and another integer that specifies which element to start with.
For example, to display elements 10-14, write:

myArray;5,10
To display myPtr+10, myPtr+11, myPtr+12, myPtr+13, and myPtr+14, write:
myPtr;5,10

Note: For pointers, there are no built-in limits on displayed element count, and no
validation of the pointer value.

Adapting for target hardware

These tasks are covered:

o Moditying a device description file

e Initializing target hardware before C-SPY starts

MODIFYING A DEVICE DESCRIPTION FILE

C-SPY uses device description files provided with the product to handle several of the
target-specific adaptations, see Selecting a device description file, page 43. Device
description files contain device-specific information such as:

e Memory information for device-specific memory zones, see C-SPY memory zones,
page 130. If you are using a C-SPY hardware debugger driver, the memory
information retrieved from the device description file is not always sufficient, see
Memory Configuration dialog box for C-SPY hardware debugger drivers, page 166.

e Definitions of memory-mapped peripheral units, device-specific CPU registers, and
groups of these.

Normally, you do not need to modify the device description file. However, if the
predefinitions are not sufficient for some reason, you can edit the file. Note, however,
that the format of these descriptions might be updated in future upgrades of the product.

Make a copy of the device description file that best suits your needs, and modify it
according to the description in the file. Reload the project to make the changes take
effect.

If you are using an I-jet or I-jet Trace debug probe, and the modified device description
5 filecontains modified memory ranges, make sure to select the option Use Factory in the
Memory Configuration dialog box.
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For information about how to load a device description file, see Selecting a device
description file, page 43.

INITIALIZING TARGET HARDWARE BEFORE C-SPY STARTS

You can use C-SPY macros to initialize target hardware before C-SPY starts. For
example, if your hardware uses external memory that must be enabled before code can
be downloaded to it, C-SPY needs a macro to perform this action before your
application can be downloaded.

I Create a new text file and define your macro function.

By using the built-in execUserPreload setup macro function, your macro function
will be executed directly after the communication with the target system is established
but before C-SPY downloads your application.

For example, a macro that enables external SDRAM could look like this:

/* Your macro function. */
enableExternal SDRAM ()
{
__message "Enabling external SDRAM\n";
__writeMemory32(...);

}

/* Setup macro determines time of execution. */
execUserPreload()
{
enableExternal SDRAM() ;
}

2 Save the file with the filename extension mac.
Before you start C-SPY, choose Project>Options>Debugger and click the Setup tab.
4 Select the Use macro file option, and choose the macro file you just created.

Your setup macro will now be loaded during the C-SPY startup sequence.

Reference information on starting C-SPY
Reference information about:
o C-SPY Debugger main window, page 49
® Images window, page 53

o Get Alternative File dialog box, page 54

C-SPY® Debugging Guide
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See also:

e Tools options for the debugger in the /DE Project Management and Building Guide
Jfor RISC-V.

C-SPY Debugger main window
When you start a debug session, these debugger-specific items appear in the main IAR
Embedded Workbench IDE window:
e A dedicated Debug menu with commands for executing and debugging your
application

o Depending on the C-SPY driver you are using, a driver-specific menu, often
referred to as the Driver menu in this documentation. Typically, this menu contains
menu commands for opening driver-specific windows and dialog boxes.

A special debug toolbar
A special Trace Settings button (for supported debugging systems)

A special multicore debugging toolbar

Several windows and dialog boxes specific to C-SPY

The C-SPY main window might look different depending on which components of the
product installation you are using.

Menu bar
These menus are available during a debug session:

Debug
Provides commands for executing and debugging the source application. Most
of the commands are also available as icon buttons on the debug toolbar.
C-SPY driver menu

Provides commands specific to a C-SPY driver. The driver-specific menu is only
available when the driver is used. For information about the driver-specific
menu commands, see Reference information on C-SPY driver menus, page 391.
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Debug menu

The Debug menu is available during a debug session. The Debug menu provides
commands for executing and debugging the source application. Most commands are
also available as icon buttons on the debug toolbar.

* | Go F5
Break

T Reset

0 Stop Debugging Ctrl=Shift+D

M Step Over F10

3 stepinto F11

™  step Out Shift=F11

By Next Statement

*]  Runto Cursor

s Autostep..,

*=  Set Mext Statement
C++ Exceptions 3
Memaory 3
Refresh
Logaging 3

These commands are available:
Go (F5)

Executes from the current statement or instruction until a breakpoint or program
exit is reached.

Note: If you are using symmetric multicore debugging, the Go command starts
only the core in focus.

" Break

Stops the application execution.

Note: If you are using symmetric multicore debugging, the Break command
stops only the core in focus.

S Reset
b
Resets the target processor. Click the drop-down button to access a menu with

additional commands.

Enable Run to '1abel', where label typically is main. Enables and disables
the project option Run to without exiting the debug session. This menu
command is only available if you have selected Run to in the Options dialog
box.

C-SPY® Debugging Guide
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Reset strategies, which contains a list of reset strategies supported by the C-SPY
driver you are using. This means that you can choose a different reset strategy
than the one used initially without exiting the debug session. Reset strategies are
only available if the C-SPY driver you are using supports alternate reset
strategies.

Stop Debugging (Ctrl+Shift+D)
Stops the debugging session and returns you to the project manager.

Step Over (F10)
Executes the next statement, function call, or instruction, without entering C or
C++ functions or assembler subroutines.

Step Into (F11)
Executes the next statement or instruction, or function call, entering C or C++
functions or assembler subroutines.

Step Out (Shift+F11)
Executes from the current statement up to the statement after the call to the
current function.

Next Statement
Executes directly to the next statement without stopping at individual function
calls.

Run to Cursor
Executes from the current statement or instruction up to a selected statement or
instruction.

Autostep
Displays a dialog box where you can customize and perform autostepping, see
Autostep settings dialog box, page 75.

Set Next Statement

Moves the program counter directly to where the cursor is, without executing
any source code. Note, however, that this creates an anomaly in the program
flow and might have unexpected effects.

C++ Exceptions>Break on Throw
Specifies that the execution shall break when the target application executes a
throw statement.

To use this feature, your application must be built with the option Library
low-level interface implementation selected and the language option C++
With exceptions.

This menu command is not supported by your product package.
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C++ Exceptions>Break on Uncaught Exception
Specifies that the execution shall break when the target application throws an
exception that is not caught by any matching catch statement.

To use this feature, your application must be built with the option Library
low-level interface implementation selected and the language option C++
With exceptions.

This menu command is not supported by your product package.

Memory>Save
Displays a dialog box where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 142.

Memory>Restore
Displays a dialog box where you can load the contents of a file in, for example
Intel-extended or Motorola s-record format to a specified memory zone, see
Memory Restore dialog box, page 143.

Refresh
Refreshes the contents of all debugger windows. Because window updates are
automatic, this is needed only in unusual situations, such as when target memory
is modified in ways C-SPY cannot detect. It is also useful if code that is
displayed in the Disassembly window is changed.

Logging>Set Terminal I/O Log file

Displays a dialog box where you can choose to log simulated target access
communication to a file. You can select the destination of the log file. See
Terminal 1/0 Log File dialog box, page 73.

Depending on the C-SPY driver you are using, these windows specific to C-SPY are
available during a debug session:

C-SPY Debugger main window

Disassembly window

Memory window

Symbolic Memory window

Registers window

Watch window

Locals window

Auto window

Live Watch window



Images window

Requirements

Display area
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Quick Watch window

Statics window

Call Stack window

Trace window

Function Trace window

Timeline window, see Reference information on application timeline, page 201
Terminal I/O window

Code Coverage window

Function Profiler window

Images window

Stack window

Symbols window

Additional windows are available depending on which C-SPY driver you are using.

The Images window is available from the View menu.

Images v o X
MNarme Core . Path

Timerlnterrupt CADocumentsilAR Embedded WorkbenchiarmiD ..

SerialPort v CADocuments\lAR Embedded Workbenchy...

This window lists all currently loaded debug images (debug files).

Normally, a source application consists of a single debug image that you debug.
However, you can also load additional images. This means that the complete debuggable
unit consists of several debug images. See also Loading multiple debug images, page 45.

Can be used with all C-SPY debugger drivers and debug probes.

C-SPY can use debug information from one or more of the loaded debug images
simultaneously. Double-click on a row to make C-SPY use debug information from that
debug image. The current choices are highlighted.
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This area lists the loaded debug images in these columns:
Name

The name of the loaded debug image.
Core N

Double-click in this column to toggle using debug information from the debug
image when that core is in focus.

Path
The path to the loaded debug image.

Related information
For related information, see:
e Loading multiple debug images, page 45
e [mages, page 376
®  Joadlmage, page 297

Get Alternative File dialog box

The Get Alternative File dialog box is displayed if C-SPY cannot automatically find
the source files to be loaded, for example if the application was built on another
computer.

Get Alternative File P§|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

See also Starting a debug session with source files missing, page 44.

Could not find the following source file

The missing source file.

Suggested alternative

Specify an alternative file.

C-SPY® Debugging Guide
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Use this file

After you have specified an alternative file, Use this file establishes that file as the alias
for the requested file. Note that after you have chosen this action, C-SPY will
automatically locate other source files if these files reside in a directory structure similar
to the first selected alternative file.

The next time you start a debug session, the selected alternative file will be preloaded
automatically.

Skip

C-SPY will assume that the source file is not available for this debug session.

If possible, don’t show this dialog again

Instead of displaying the dialog box again for a missing source file, C-SPY will use the
previously supplied response.

Related information

For related information, see Starting a debug session with source files missing, page 44.
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Executing your application

e Introduction to application execution

e Reference information on application execution

Introduction to application execution
These topics are covered:

Briefly about application execution
Source and disassembly mode debugging
Single stepping

Troubleshooting slow stepping speed
Running the application

Highlighting

Viewing the call stack

Terminal input and output

Debug logging

BRIEFLY ABOUT APPLICATION EXECUTION

C-SPY allows you to monitor and control the execution of your application. By
single-stepping through it, and setting breakpoints, you can examine details about the
application execution, for example the values of variables and registers. You can also use
the call stack to step back and forth in the function call chain.

The terminal I/O and debug log features let you interact with your application.

You can find commands for execution on the Debug menu and on the toolbar.

SOURCE AND DISASSEMBLY MODE DEBUGGING

C-SPY allows you to switch between source mode and disassembly mode debugging as
needed.

Source debugging provides the fastest and easiest way of developing your application,
without having to worry about how the compiler or assembler has implemented the
code. In the editor windows you can execute the application one statement at a time
while monitoring the values of variables and data structures.
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Disassembly mode debugging lets you focus on the critical sections of your application,
and provides you with precise control of the application code. You can open a
disassembly window which displays a mnemonic assembler listing of your application
based on actual memory contents rather than source code, and lets you execute the
application exactly one machine instruction at a time.

Regardless of which mode you are debugging in, you can display registers and memory,
and change their contents.

SINGLE STEPPING

C-SPY allows more stepping precision than most other debuggers because it is not
line-oriented but statement-oriented. The compiler generates detailed stepping
information in the form of step points at each statement, and at each function call. That
is, source code locations where you might consider whether to execute a step into or a
step over command. Because the step points are located not only at each statement but
also at each function call, the step functionality allows a finer granularity than just
stepping on statements.

There are several factors that can slow down the stepping speed. If you find it too slow,
see Troubleshooting slow stepping speed, page 60 for some tips.

The step commands
There are four step commands:

e Step Into
e Step Over
e Next Statement
e Step Out

Using the Autostep settings dialog box, you can automate the single stepping. For more
information, see Autostep settings dialog box, page 75.

If your application contains an exception that is caught outside the code which would
normally be executed as part of a step, C-SPY terminates the step at the catch
statement.
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Consider this example and assume that the previous step has taken you to the £ (i)
function call (highlighted):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

int main()

{

£(i);
value ++;

Step Into

While stepping, you typically consider whether to step into a function and continue
stepping inside the function or subroutine. The Step Into command takes you to the first
step point within the subroutine g (n-1):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

The Step Into command executes to the next step point in the normal flow of control,
regardless of whether it is in the same or another function.

Step Over

The Step Over command executes to the next step point in the same function, without
stopping inside called functions. The command would take you to the g (n-2) function
call, which is not a statement on its own but part of the same statement as g (n-1) . Thus,
you can skip uninteresting calls which are parts of statements and instead focus on
critical parts:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}
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Next Statement

The Next Statement command executes directly to the next statement, in this case
return value, allowing faster stepping:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

Step Out

When inside the function, you can—if you wish—use the Step Out command to step
out of it before it reaches the exit. This will take you directly to the statement
immediately after the function call:

extern int g(int);
int f(int n)
{
value = g(n-1) + g(n-2) g(n-3);
return value;
}
int main()

{

£(i);
value ++;

}

The possibility of stepping into an individual function that is part of a more complex
statement is particularly useful when you use C code containing many nested function
calls. It is also very useful for C++, which tends to have many implicit function calls,
such as constructors, destructors, assignment operators, and other user-defined
operators.

This detailed stepping can in some circumstances be either invaluable or unnecessarily
slow. For this reason, you can also step only on statements, which means faster stepping.

TROUBLESHOOTING SLOW STEPPING SPEED

If you find that stepping speed is slow, these troubleshooting tips might speed up

stepping:

e If you are using a hardware debugger system, keep track of how many hardware
breakpoints that are used and make sure some of them are left for stepping.
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Stepping in C-SPY is normally performed using breakpoints. When C-SPY performs
a step command, a breakpoint is set on the next statement and the application
executes until it reaches this breakpoint. If you are using a hardware debugger
system, the number of hardware breakpoints—typically used for setting a stepping
breakpoint in code that is located in flash/ROM memory—is limited. If you, for
example, step into a C switch statement, breakpoints are set on each branch; this
might consume several hardware breakpoints. If the number of available hardware
breakpoints is exceeded, C-SPY switches into single stepping on assembly level,
which can be very slow.

For more information, see Breakpoints in the C-SPY hardware debugger drivers,
page 108 and Breakpoint consumers, page 109.

e Disable trace data collection, using the Enable/Disable button in both the Trace
and the Function Profiling windows. Trace data collection might slow down
stepping because the collected trace data is processed after each step. Note that it is
not sufficient to just close the corresponding windows to disable trace data
collection.

o Choose to view only a limited selection of SFR registers. You can choose between
two alternatives. Either type # SFR_name (Where SFR_name reflects the name of the
SFR you want to monitor) in the Watch window, or create your own filter for
displaying a limited group of SFRs in the Registers window. Displaying many SFR
registers might slow down stepping because all registers must be read from the
hardware after each step. See Defining application-specific register groups, page
133.

e Close the Memory and Symbolic Memory windows if they are open, because the
visible memory must be read after each step and that might slow down stepping.

o Close any window that displays expressions such as Watch, Live Watch, Locals,
Statics if it is open, because all these windows read memory after each step and that
might slow down stepping.

e Close the Stack window if it is open. Choose Tools>Options>Stack and disable the
Enable graphical stack display and stack usage tracking option if it is enabled.

e If possible, increase the communication speed between C-SPY and the target
board/emulator.

RUNNING THE APPLICATION

Go

The Go command continues execution from the current position until a breakpoint or
program exit is reached.

Note: If you are using symmetric multicore debugging, the Go command starts only the
core in focus.

6l



Introduction to application execution

62

C-SPY® Debugging Guide
for RISC-V

Run to Cursor

The Run to Cursor command executes to the position in the source code where you
have placed the cursor. The Run to Cursor command also works in the Disassembly
window and in the Call Stack window.

HIGHLIGHTING

At each stop, C-SPY highlights the corresponding C or C++ source or instruction with
a green color, in the editor and the Disassembly window respectively. In addition, a
green arrow appears in the editor window when you step on C or C++ source level, and
in the Disassembly window when you step on disassembly level. This is determined by
which of the windows is the active window. If none of the windows are active, it is
determined by which of the windows was last active.

Tutor.c I!EEE

void init_fib({ woid )

i

int i = 45;
o root[0] = root[l] = 1;

for { i=2 ; i<MAX _FIE : i++)
{

For simple statements without function calls, the whole statement is typically
highlighted. When stopping at a statement with function calls, C-SPY highlights the first
call because this illustrates more clearly what Step Into and Step Over would mean at
that time.

Occasionally, you will notice that a statement in the source window is highlighted using
a pale variant of the normal highlight color. This happens when the program counter is
at an assembler instruction which is part of a source statement but not exactly at a step
point. This is often the case when stepping in the Disassembly window. Only when the
program counter is at the first instruction of the source statement, the ordinary highlight
color is used.

Code coverage

From the context menu in the Code Coverage window, you can toggle highlight colors
and icons in the editor window that show code coverage analysis for the source code,
see Code Coverage window, page 227.

These are the colors and icons that are used:

e Red highlight color and a red diamond—the code range has not been executed.
e Green highlight color—100% of the code range has been executed.

e Yellow highlight color and a red diamond—parts of the code range have been
executed.
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This figure illustrates all three code coverage highlight colors:
callCount = 0;

InitFib():
L while (callCount < MRX FIE)

=

DoForegroundProcess () ;

VIEWING THE CALL STACK

The compiler generates extensive call frame information. This allows C-SPY to show,
without any runtime penalty, the complete function call chain at any time.

Typically, this is useful for two purposes:

e Determining in what context the current function has been called

e Tracing the origin of incorrect values in variables and in parameters, thus locating
the function in the call chain where the problem occurred.

The Call Stack window shows a list of function calls, with the current function at the
top. When you inspect a function in the call chain, the contents of all affected windows
are updated to display the state of that particular call frame. This includes the editor,
Locals, Register, Watch, and Disassembly windows. A function would normally not
make use of all registers, so these registers might have undefined states and be displayed
as dashes (---).

In the editor and Disassembly windows, a green highlight indicates the topmost, or
current, call frame; a yellow highlight is used when inspecting other frames.

For your convenience, it is possible to select a function in the call stack and click the
Run to Cursor command to execute to that function.

Assembler source code does not automatically contain any call frame information. To
see the call chain also for your assembler modules, you can add the appropriate CFI
assembler directives to the assembler source code. For more information, see the /AR
Assembler User Guide for RISC-V.

Note: For highly optimized code, C-SPY might not be able to identify all calls. This
means that for highly optimized code, the call stack is not entirely trustworthy.

TERMINAL INPUT AND OUTPUT

Sometimes you might have to debug constructions in your application that use stdin
and stdout without an actual hardware device for input and output. The Terminal /O
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window lets you enter input to your application, and display output from it. You can also
direct terminal I/O to a file, using the Terminal I/O Log Files dialog box.

This facility is useful in two different contexts:
F o If your application uses stdin and stdout
e For producing debug trace printouts

For more information, see Terminal 1/O window, page 72 and Terminal 1/O Log File
dialog box, page 73.

DEBUG LOGGING

The Debug Log window displays debugger output, such as diagnostic messages,
macro-generated output, and information about trace.

It can sometimes be convenient to log the information to a file where you can easily
5  inspectit, see Debug Log window, page 73. The two main advantages are:

e The file can be opened in another tool, for instance an editor, so you can navigate
and search within the file for particularly interesting parts.

e The file provides history about how you have controlled the execution, for instance,
which breakpoints that have been triggered etc.

Reference information on application execution

Reference information about:

Disassembly window, page 65

Call Stack window, page 70

Terminal 1/0 window, page 72

Terminal 1/O Log File dialog box, page 73
Debug Log window, page 73

Report Assert dialog box, page 75

Autostep settings dialog box, page 75

See also Terminal I/O options in the /IDE Project Management and Building Guide for
RISC-V.
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Disassembly window

The C-SPY Disassembly window is available from the View menu.

[ Go to memory address ] [ Select zone to display ] I Toggle embedded source code
Disassembly \ W x
Goto ' '
C Disassembly it
¢| 20000020  OOCOOOEF callz0 main
B ' ¢ 20000024  11COOOEF callz0 exit
—oce coverage "___ ¢ 20000028  0OOOOOGF i 0%20000028
information . R -
i int main{int i)
C (3
malr:
| =
20000030 00112623 sw ra, OxCisp)
20000034 00812423 sw =0, 8{=p)
[Current position for (1 = 0, result 1; i = TWO_POWER; i++)
—_— 20000038 00000413 m 80, zero
2000003C 00100593 1i12 al, 1
20000040  FEBLAF23 sw al, -2{gp)
for (i = 0, result 1; 1 = TWO_POWER; i++)
|
20000048  0OOA45863 bye £0, a0, 0x20000058
[ Breakpeint miltiplyByTwol) ;
2000004C  020000EF callz0 multiplyBy Two
for (i = 0, result = 1; i = TWO_POWER; i++)
20000050 00140413 addi s0, =0, 1 >
This figure reflects the C-SPY simulator.
This window shows the application being debugged as disassembled application code.
To change the default color of the source code in the Disassembly window:
I Choose Tools>Options>Debugger.
2 Set the default color using the Source code color in disassembly window option.
To view the corresponding assembler code for a function, you can select it in the editor
5  window and drag it to the Disassembly window.
See also Source and disassembly mode debugging, page 57.
Requirements

Can be used with all C-SPY debugger drivers and debug probes.

65



Reference information on application execution

Toolbar

The toolbar contains:

Go to
The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 130.

Toggle Mixed-Mode

Toggles between displaying only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information.

Display area

The display area shows the disassembled application code. This area contains these
graphic elements:

Green highlight color Indicates the current position, that is the next assembler
instruction to be executed. To move the cursor to any line
in the Disassembly window, click the line. Alternatively,
move the cursor using the navigation keys.

Yellow highlight color Indicates a position other than the current position, such
as when navigating between frames in the Call Stack
window or between items in the Trace window.

Red dot Indicates a breakpoint. Double-click in the gray left-side
margin of the window to set a breakpoint. For more
information, see Breakpoints, page 105.

Green diamond Code coverage icon—indicates code that has been
executed.

Red diamond Code coverage icon—indicates code that has not been
executed.

Red/yellow diamond (red Code coverage icon—indicates a branch that is never
top/yellow bottom) taken.

Red/yellow diamond (redleft Code coverage icon—indicates a branch that is always
side/yellow right side) taken.

If instruction profiling has been enabled from the context menu, an extra column in the
left-side margin appears with information about how many times each instruction has

C-SPY® Debugging Guide
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been executed. For debug probes that support it, C-SPY can capture full instruction trace
in real time.

Context menu

This context menu is available:
Move to PC

Run to Cursor

Code Coverage

Instruction Profiling

Toggle Breakpoint (Code)
Toggle Breakpoint (Log)
Toggle Breakpoint (Trace Start)
Toggle Breakpoint (Trace Stop)
Enable/Disable Breakpoint
Edit Breakpoint...

Set Mext Statement

Copy Window Contents
Mixed-Mode

Find in Trace
Zone
Note: The contents of this menu are dynamic, which means that the commands on the
menu might depend on your product package.
These commands are available:
Move to PC
Displays code at the current program counter location.

Run to Cursor
Executes the application from the current position up to the line containing the
cursor.

Code Coverage

Displays a submenu that provides commands for controlling code coverage.
This command is only enabled if the driver you are using supports it.

Enable Toggles code coverage on or off.

Show Toggles the display of code coverage on or off. Code
coverage is indicated by ared, green, and red/yellow
diamonds in the left margin.
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Clear Clears all code coverage information.
Next Different Moves the insertion point to the next line in the
Coverage > window with a different code coverage status than

the selected line.

Previous Different Moves the insertion point to the closest preceding
Coverage < line in the window with a different code coverage
status than the selected line.

Instruction Profiling

Displays a submenu that provides commands for controlling instruction
profiling. This command is only enabled if the driver you are using supports it.

Enable Toggles instruction profiling on or off.

Show Toggles the display of instruction profiling on or off.
For each instruction, the left-side margin displays
how many times the instruction has been executed.

Clear Clears all instruction profiling information.

Toggle Breakpoint (Code)
Toggles a code breakpoint. Assembler instructions and any corresponding label
at which code breakpoints have been set are highlighted in red. For more
information, see Code breakpoints dialog box, page 118.

Toggle Breakpoint (Log)
Toggles alog breakpoint for trace printouts. Assembler instructions at which log
breakpoints have been set are highlighted in red. For more information, see Log
breakpoints dialog box, page 120.

Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, the trace
data collection starts. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see 7race
Start Trigger breakpoint dialog box, page 191.

Toggle Breakpoint (Trace Stop)

Toggles a Trace Stop breakpoint. When the breakpoint is triggered, the trace
data collection stops. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see 7race
Stop Trigger breakpoint dialog box, page 193.
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Enable/Disable Breakpoint

Enables and Disables a breakpoint. If there is more than one breakpoint at a
specific line, all those breakpoints are affected by the Enable/Disable
command.

Edit Breakpoint

Displays the breakpoint dialog box to let you edit the currently selected
breakpoint. If there is more than one breakpoint on the selected line, a submenu
is displayed that lists all available breakpoints on that line.

Set Next Statement
Sets the program counter to the address of the instruction at the insertion point.

Copy Window Contents
Copies the selected contents of the Disassembly window to the clipboard.

Mixed-Mode

Toggles between showing only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information.

Find in Trace

Searches the contents of the Trace window for occurrences of the given
location—the position of the insertion point in the source code—and reports the
result in the Find in Trace window. This menu command requires support for
Trace in the C-SPY driver you are using, see Differences between the C-SPY
drivers, page 35.

Zone
Selects a memory zone, see C-SPY memory zones, page 130.
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Call Stack window

Requirements

Display area
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The Call Stack window is available from the View menu.

Call Stack * o X

T Fibonacci::next()

2 main

Destination for Step ‘
[_call_main + 0x9]

Jump te main from label
plus offset

This window displays the C function call stack with the current function at the top. To
inspect a function call, double-click it. C-SPY now focuses on that call frame instead.

If the next Step Into command would step to a function call, the name of the function is
displayed in the gray bar at the top of the window. This is especially useful for implicit
function calls, such as C++ constructors, destructors, and operators.

See also Viewing the call stack, page 63.

Can be used with all C-SPY debugger drivers and debug probes.

Each entry in the display area is formatted in one of these ways:

function(values) *** A C/C++ function with debug information.

Provided that Show Arguments is enabled, values
is a list of the current values of the parameters, or
empty if the function does not take any parameters.

=*x_if present, indicates that the function has been
inlined by the compiler. For information about
function inlining, see the /AR C/C++ Development
Guide for RISC-V.

[label + offset] An assembler function, or a C/C++ function without
debug information.

<exception_frame> An interrupt.
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Context menu

This context menu is available:
Go to Source
Show Arguments
Run to Cursor
Copy Window Contents
Toggle Breakpoint (Code)
Toggle Breakpoint (Log)
Toggle Breakpoint (Trace Start)
Toggle Breakpoint (Trace Stop)
Enable/Disable Breakpoint

These commands are available:

Go to Source
Displays the selected function in the Disassembly or editor windows.

Show Arguments
Shows function arguments.

Run to Cursor
Executes until return to the function selected in the call stack.

Copy Window Contents
Copies the contents of the Call Stack window and stores them on the clipboard.

Toggle Breakpoint (Code)
Toggles a code breakpoint.

Toggle Breakpoint (Log)
Toggles a log breakpoint.

Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, trace data
collection starts. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Toggle Breakpoint (Trace Stop)

Toggles a Trace Stop breakpoint. When the breakpoint is triggered, trace data
collection stops. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Enable/Disable Breakpoint
Enables or disables the selected breakpoint.
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Terminal I/O window

The Terminal I/0O window is available from the View menu.

Terminal /O *
Output: Loq file: Off
A Fibonacci object was created. -
A Fibonacci object that starts at Fil
1

1 13

2

3 21

5

8 34

13

21 55

34

55 89

Fl 10 2
Input: Chl codes H Options...

Buffer size: 1]

Use this window to enter input to your application, and display output from it.
To use this window, you must:
I Link your application with the option Include C-SPY debugging support.

C-SPY will then direct stdin, stdout and stderr to this window. If the Terminal I/O
window is closed, C-SPY will open it automatically when input is required, but not for
output.

See also Terminal input and output, page 63.

Requirements
Can be used with all C-SPY debugger drivers and debug probes.
Input
Type the text that you want to input to your application.
Ctrl codes
Opens a menu for input of special characters, such as EOF (end of file) and NUL.
0:x00-0x0f  »
O:x10-0:x1F »
EOQF
Options

Opens the IDE Options dialog box where you can set options for terminal I/O. For
information about the options available in this dialog box, see Terminal I/O options in
IDE Project Management and Building Guide for RISC-V'.
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Terminal 1/O Log File dialog box

Requirements

The Terminal I/O Log File dialog box is available by choosing Debug>Logging>Set
Terminal 1/0 Log File.

Terminal I/0 Log File

Terminal [/0 Log File 0Ok

™ Enable Teminal 10 log file
J Cancel

Use this dialog box to select a destination log file for terminal I/O from C-SPY.

See also Terminal input and output, page 63.

Can be used with all C-SPY debugger drivers and debug probes.

Terminal 1/O Log File

Debug Log window

Controls the logging of terminal I/O. To enable logging of terminal I/O to a file, select
Enable Terminal 1/0 log file and specify a filename. The default filename extension is
log. A browse button is available for your convenience.

The Debug Log window is available by choosing View>Messages>Debug Log.

Debug Log v 0 X

Log
Mon Jun 19, 2017 13:21:16: Loaded module
ton Jun 19, 2017 13:21:16: Target reset

4 I 2

This window displays debugger output, such as diagnostic messages, macro-generated
output, and information about trace. When opened, this window is, by default, grouped
together with the other message windows, see IDE Project Management and Building
Guide for RISC-V.

Double-click any rows in one of the following formats to display the corresponding
source code in the editor window:

<path> (<row>) :<message>
<path> (<row>,<column>) :<message>
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See also Debug logging, page 64.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Context menu

This context menu is available:
Filter Level:
Al
Messages
Warnings
Errors

Copy
Select All

Clear All

Live Log to File >

These commands are available:

All

Shows all messages sent by the debugging tools and drivers.
Messages

Shows all C-SPY messages.
‘Warnings

Shows warnings and errors.
Errors

Shows errors only.
Copy

Copies the contents of the window.
Select All

Selects the contents of the window.
Clear All

Clears the contents of the window.
Live Log to File

Displays a submenu with commands for writing the debug messages to a log file
and setting filter levels for the log.
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Report Assert dialog box

The Report Assert dialog box appears if you have a call to the assert function in your
application source code, and the assert condition is false. In this dialog box you can
choose how to proceed.

Report Assert P§|

The following Failed:

File: C:\Documents and SettingsiMy DocumentsiIAR Embedded Workbenchiresolve.cpp
Line: 35

Expression Failed:

a

Abort | Debug |

Abort
The application stops executing and the runtime library function abort, which is part
of your application on the target system, will be called. This means that the application
itself terminates its execution.

Debug
C-SPY stops the execution of the application and returns control to you.

Ignore

The assertion is ignored and the application continues to execute.

Autostep settings dialog box
The Autostep settings dialog box is available by choosing Debug>Autostep.

Autostep settings @

[ Step Into [Source level] hd ] [ Start ]

Delay [milliseconds): 1000 Cancel

Use this dialog box to configure autostepping.

Select the step command you want to automate from the drop-down menu. The step will
be performed with the specified interval. For a description of the available step
commands, see Single stepping, page 58. You can stop the autostepping by clicking the
Break button on the debug toolbar.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.
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Delay (milliseconds)

The delay between each step command in milliseconds. The step is repeated with this
interval.
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e Introduction to working with variables and expressions
e Working with variables and expressions

e Reference information on working with variables and expressions

Introduction to working with variables and expressions

This section introduces different methods for looking at variables and introduces some
related concepts.

These topics are covered:

e Briefly about working with variables and expressions
o C-SPY expressions

e Limitations on variable information

BRIEFLY ABOUT WORKING WITH VARIABLES AND
EXPRESSIONS

There are several methods for looking at variables and calculating their values. These
methods are suitable for basic debugging:

e Tooltip watch—in the editor window—provides the simplest way of viewing the
value of a variable or more complex expressions. Just point at the variable with the
mouse pointer. The value is displayed next to the variable.

e The Auto window displays a useful selection of variables and expressions in, or
near, the current statement. The window is automatically updated when execution
stops.

o The Locals window displays the local variables, that is, auto variables and function
parameters for the active function. The window is automatically updated when
execution stops.

o The Watch window allows you to monitor the values of C-SPY expressions and
variables. The window is automatically updated when execution stops.

o The Live Watch window repeatedly samples and displays the values of expressions
while your application is executing. Variables in the expressions must be statically
located, such as global variables.

o The Statics window displays the values of variables with static storage duration.
The window is automatically updated when execution stops.
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o The Macro Quicklaunch window and the Quick Watch window give you precise
control over when to evaluate an expression.

o The Symbols window displays all symbols with a static location, that is, C/C++
functions, assembler labels, and variables with static storage duration, including
symbols from the runtime library.

These additional methods for looking at variables are suitable for more advanced
analysis:

e The Data Log window and the Data Log Summary window display logs of
accesses to up to four different memory locations you choose by setting data log
breakpoints. Data logging can help you locate frequently accessed data. You can
then consider whether you should place that data in more efficient memory.

For more information about these windows, see The application timeline, page 197.

C-SPY EXPRESSIONS

C-SPY expressions can include any type of C expression, except for calls to functions.
The following types of symbols can be used in expressions:

C/C++ symbols

Assembler symbols (register names and assembler labels)

C-SPY macro functions

C-SPY macro variables

Expressions that are built with these types of symbols are called C-SPY expressions and
there are several methods for monitoring these in C-SPY. Examples of valid C-SPY
expressions are:

i+ 3

i =42

myVar = cVar

cVar = myVar + 2

#asm_label

#R2

#PC

my_macro_func (19)

If you have a static variable with the same name declared in several different functions,
use the notation function: : variable to specify which variable to monitor.

C/C++ symbols

C symbols are symbols that you have defined in the C source code of your application,
for instance variables, constants, and functions (functions can be used as symbols but
cannot be executed). C symbols can be referenced by their names. Note that C++
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symbols might implicitly contain function calls which are not allowed in C-SPY
symbols and expressions.

Note: Some attributes available in C/C++, like volatile, are not fully supported by
C-SPY. For example, this line will not be accepted by C-SPY:

sizeof (unsigned char volatile __memattr *)
However, this line will be accepted:

sizeof (unsigned char __memattr *)

Assembler symbols

Assembler symbols can be assembler labels or registers, for example the program
counter, the stack pointer, or other CPU registers. If a device description file is used, all
memory-mapped peripheral units, such as I/O ports, can also be used as assembler
symbols in the same way as the CPU registers. See Modifving a device description file,
page 47.

Assembler symbols can be used in C-SPY expressions if they are prefixed by #.

Example What it does
#PC++ Increments the value of the program counter.
myVar = #SP Assigns the current value of the stack pointer register to your

C-SPY variable.
myVar = #label Sets myVar to the value of an integer at the address of label.

myptr = &#label7 Sets myptr to an int * pointer pointing at label7.

Table 4: C-SPY assembler symbols expressions

In case of a name conflict between a hardware register and an assembler label, hardware
registers have a higher precedence. To refer to an assembler label in such a case, you
must enclose the label in back quotes * (ASCII character 0x60). For example:

Example What it does
#PC Refers to the program counter.
#'pPC" Refers to the assembler label PC.

Table 5: Handling name conflicts between hardware registers and assembler labels

Which processor-specific symbols are available by default can be seen in the Registers
window, using the CPU Registers register group. See Registers window, page 152.
C-SPY macro functions

Macro functions consist of C-SPY macro variable definitions and macro statements
which are executed when the macro is called.
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For information about C-SPY macro functions and how to use them, see Briefly about
the macro language, page 268.

C-SPY macro variables

Macro variables are defined and allocated outside your application, and can be used in
a C-SPY expression. In case of a name conflict between a C symbol and a C-SPY macro
variable, the C-SPY macro variable will have a higher precedence than the C variable.
Assignments to a macro variable assign both its value and type.

For information about C-SPY macro variables and how to use them, see Reference
information on the macro language, page 274.

Using sizeof
According to standard C, there are two syntactical forms of sizeof:

sizeof (type)
sizeof expr

The former is for types and the latter for expressions.

Note: In C-SPY, do not use parentheses around an expression when you use the sizeof
operator. For example, use sizeof x+2 instead of sizeof (x+2).

LIMITATIONS ON VARIABLE INFORMATION

The value of a C variable is valid only on step points, that is, the first instruction of a
statement and on function calls. This is indicated in the editor window with a bright
green highlight color. In practice, the value of the variable is accessible and correct more
often than that.

When the program counter is inside a statement, but not at a step point, the statement or
part of the statement is highlighted with a pale variant of the ordinary highlight color.

Effects of optimizations

The compiler is free to optimize the application software as much as possible, as long
as the expected behavior remains. The optimization can affect the code so that
debugging might be more difficult because it will be less clear how the generated code
relates to the source code. Typically, using a high optimization level can affect the code
in a way that will not allow you to view a value of a variable as expected.
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Consider this example:

myFunction ()

{
int 1 = 42;

x = computer(i); /* Here, the value of i is known to C-SPY */

}

From the point where the variable i is declared until it is actually used, the compiler
does not need to waste stack or register space on it. The compiler can optimize the code,
which means that C-SPY will not be able to display the value until it is actually used. If
you try to view the value of a variable that is temporarily unavailable, C-SPY will
display the text:

Unavailable

If you need full information about values of variables during your debugging session,
you should use the lowest optimization level during compilation, that is, None.

Working with variables and expressions

These tasks are covered:

e Using the windows related to variables and expressions

e Viewing assembler variables

See also Analyzing your application’s timeline, page 198.

USING THE WINDOWS RELATED TO VARIABLES AND
EXPRESSIONS

Where applicable, you can add, modity, and remove expressions, and change the display
format in the windows related to variables and expressions.

To add a value you can also click in the dotted rectangle and type the expression you
want to examine. To modify the value of an expression, click the Value field and modify
its content. To remove an expression, select it and press the Delete key.

For text that is too wide to fit in a column—in any of these windows, except the Trace
g5  window—and thus is truncated, just point at the text with the mouse pointer and tooltip
information is displayed.

Right-click in any of the windows to access the context menu which contains additional
commands. Convenient drag-and-drop between windows is supported, except for in the
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Locals window, data logging windows, and the Quick Watch window where it is not
relevant.

VIEWING ASSEMBLER VARIABLES

An assembler label does not convey any type information at all, which means C-SPY
cannot easily display data located at that label without getting extra information. To
view data conveniently, C-SPY by default treats all data located at assembler labels as
variables of type int. However, in the Watch, Live Watch, and Quick Watch
windows, you can select a different interpretation to better suit the declaration of the
variables.

In this figure, you can see four variables in the Watch window and their corresponding
declarations in the assembler source file to the left:

- f) + x Watch1
NHAME main — | Expression YWalue Location Type
= ssmvarl 42 0x=00000080 int
PUBLIC _ iar program start asmvar? 456 O=00000084 int
astrvard 55 O0=00000088 <8-bit unsigned>
SECTION .intwec : CODE (2)
CODES2 <clickto ... Default Format
__ilar program start EibanjEotnat
B main Octal Format
v Decimal Format
SECTION .text : CODE (2) Hexadecimal Format
Char Format
asmvarl: DC32 42
asmvar2: DC32 456 Show As b Asls
asmvar3: DC8 55 8-bit Signed
asmvard: DC8 10 Saveto File...
16-bit Signed
CopE32 16-bit Unsigned
& main NOE 32-bit Signed
B main 32-bit Unsigned
64-bit Signed
END 64-bit Unsigned
float
double

Note that asmvar4 is displayed as an int, although the original assembler declaration
probably intended for it to be a single byte quantity. From the context menu you can
make C-SPY display the variable as, for example, an 8-bit unsigned variable. This has
already been specified for the asmvar3 variable.
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Reference information on working with variables and expressions

Auto window

Requirements

Reference information about:

Auto window, page 83

Locals window, page 86
Watch window, page 88

Live Watch window, page 91
Statics window, page 94
Quick Watch window, page 97
Symbols window, page 100

Resolve Symbol Ambiguity dialog box, page 103

See also:

® Reference information on trace, page 179 for trace-related reference information

® Macro Quicklaunch window, page 331

The Auto window is available from the View menu.
Auto

Expression Yalue Location
+ MextCounter NextCounter (0x40EB)

filh 1 Memory : 0xFEFT74
+ GetFib GetFilb (0x141)

callCount & Memory : 0<FEFAS

Type
woid ...
uint3z2_t
uint32_t(..
signed int

This window displays a useful selection of variables and expressions in, or near, the
current statement. Every time execution in C-SPY stops, the values in the Auto window
are recalculated. Values that have changed since the last stop are highlighted in red.

See also Editing in C-SPY windows, page 46.

Can be used with all C-SPY debugger drivers and debug probes.
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Context menu
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This area contains these columns:

Expression
The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.
Location
The location in memory where this variable is stored.

Type
The data type of the variable.

This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As ¥
Save to File...

+~  Right Align 'Value' Column

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.
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These commands are available:

Remove
Removes the selected expression from the window.

Remove All

Removes all expressions listed in the window.

Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves content to a file in a tab-separated format.

Right Align ‘Value’ Column
Right-aligns the contents of the Value column.
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Options
Displays the IDE Options dialog box where you can set various options for
C-SPY windows.

The Locals window is available from the View menu.
Locals w 0 X

Yariable  Value Location Type
i 1244 Memory : 0xFEF72 signed int

This window displays the local variables and parameters for the current function. Every
time execution in C-SPY stops, the values in the window are recalculated. Values that
have changed since the last stop are highlighted in red.

See also Editing in C-SPY windows, page 46.

Can be used with all C-SPY debugger drivers and debug probes.

This area contains these columns:

Variable

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.

Location
The location in memory where this variable is stored.

Type
The data type of the variable.
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Context menu

This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As ¥
Save to File...

+~  Right Align 'Value' Column

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove

Removes the selected expression from the window.

Remove All
Removes all expressions listed in the window.

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.
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Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As
Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves content to a file in a tab-separated format.
Right Align ‘Value’ Column

Right-aligns the contents of the Value column.
Options

Displays the IDE Options dialog box where you can set various options for
C-SPY windows.

The Watch window is available from the View menu.

Watch 1 * o X
Expression Yalue Location Type

2 Memory : 0xFEFAS signed int
<array> Memory : 0xFEFB0 uint32_t[10]
1 Memory : 0xFEFR0 uint3z2_t

1 Memory : 0xFEFa4 uint3z2_t

2 Memory : 0xFEFRE uint3z2_t

3 Memory : 0xFEFAC uint3z2_t

5 Memory : 0xFEF90 uint3z2_t

a Memory : 0xFEF94 uint3z2_t

13 Memory : 0xFEF98 uint3z2_t

21 Memory : 0xFEF9C uint3z2_t

34 Memory : 0xFEFAD uint3z2_t

55 Memory : 0xFEFA4 uint3z2_t

Use this window to monitor the values of C-SPY expressions or variables. You can open
up to four instances of this window, where you can view, add, modify, and remove
expressions. Tree structures of arrays, structs, and unions are expandable, which means
that you can study each item of these.
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Every time execution in C-SPY stops, the values in the Watch window are recalculated.
Values that have changed since the last stop are highlighted in red.

Be aware that expanding very large arrays can cause an out-of-memory crash. To avoid
this, expansion is automatically performed in steps of 5000 elements.

See also Editing in C-SPY windows, page 46.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Display area
This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope.

Value
The value of the variable. Values that have changed are highlighted in red.
Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.
This column is editable.

Location
The location in memory where this variable is stored.

Type

The data type of the variable.
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This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As ¥
Save to File...

+~  Right Align 'Value' Column

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove

Removes the selected expression from the window.

Remove All
Removes all expressions listed in the window.

Default Format

Binary Format

Octal Format

Decimal Format

Hexadecimal Format

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.



Live Watch window

Requirements
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Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As
Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves content to a file in a tab-separated format.

Right Align ‘Value’ Column
Right-aligns the contents of the Value column.
Options

Displays the IDE Options dialog box where you can set various options for
C-SPY windows.

The Live Watch window is available from the View menu.

Live Watch * o X
Expression Yalue Location Type
= GetFib GetFib (0x141) uint3zZ_t(_ne..

------ GetFib (0x141) Memory:Oxl41 uint32_t{int_f.

This window repeatedly samples and displays the value of expressions while your
application is executing. Variables in the expressions must be statically located, such as
global variables.

See also Editing in C-SPY windows, page 46.

One of these alternatives:

o The C-SPY simulator
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o The I-jet driver and a device that supports runtime memory access via the system
bus

This area contains these columns:

Expression
The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.
Location
The location in memory where this variable is stored.

Type
The data type of the variable.

This context menu is available:

Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As ¥
Save to File...

+~  Right Align 'Value' Column

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.
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These commands are available:

Remove
Removes the selected expression from the window.

Remove All

Removes all expressions listed in the window.

Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves content to a file in a tab-separated format.

Right Align ‘Value’ Column
Right-aligns the contents of the Value column.
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Statics window

Options
Displays the IDE Options dialog box where you can set various options for
C-SPY windows.

The Statics window is available from the View menu.

Statics * o X
Yariable Yalue Location Type Module =
= fibStat <UsingClassesifib Stat> <class> Memory:0xFE140  class Fibonacci UsingClasses
e Current 7] Memory : OxFB140  uint_fastd_t
= msFib <FibonacciByClass\FibonaccizmsFib»  size=100 v:0xFB134 class vector<uint3z2_t» FibonacciByClass |z
= <Raw> =class> 0xFE134 class vector<uint3z_t»
<class> v:0xFB134  wectorcuint3Z_t>:_lmpl
=class> v:0xFB134 class _Vector_walue<allocatar..
=class> v:0xFB134 class _ClassUtil_AllocHaolder..
# _hbyfirst OxAOED v:0xFB134  woid __near®
# _hylast 0xA270 0xFBL36  woid __near®
# _hdyend 0xA270 0xFBL38  woid __near®
0 OxFAOED  uint32_t
i} v:0xFAOE4  uint32_t 3

Requirements

C-SPY® Debugging Guide
for RISC-V

This window displays the values of variables with static storage duration that you have
selected. Typically, that is variables with file scope but it can also be static variables in
functions and classes. Note that volatile declared variables with static storage
duration will not be displayed.

Every time execution in C-SPY stops, the values in the Statics window are recalculated.
Values that have changed since the last stop are highlighted in red.

Click any column header (except for Value) to sort on that column.
See also Editing in C-SPY windows, page 46.

To select variables to monitor:

In the window, right-click and choose Select Statics from the context menu. The
window now lists all variables with static storage duration.

Either individually select the variables you want to display, or choose one of the Select
commands from the context menu.

When you have made your selections, choose Select Statics from the context menu to
toggle back to normal display mode.

Can be used with all C-SPY debugger drivers and debug probes.
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Display area
This area contains these columns:

Variable

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not

editable.
Value
The value of the variable. Values that have changed are highlighted in red.
Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.
This column is editable.
Location
The location in memory where this variable is stored.
Type
The data type of the variable.
Module

The module of the variable.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...

v Select Statics
Select All
Select None
Select All in ‘Tutor'

Select None in ‘Tutor'

These commands are available:

Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

C-SPY® Debugging Guide
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Show As
Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves the content of the Statics window to a log file.

Select Statics
Selects all variables with static storage duration—this command also enables all
Select commands below. Select the variables you want to monitor. When you
have made your selections, select this menu command again to toggle back to
normal display mode.

Select All

Selects all variables.

Select None
Deselects all variables.

Select All in module

Selects all variables in the selected module.

Select None in module

Deselects all variables in the selected module.

The Quick Watch window is available from the View menu and from the context menu
in the editor window.

Quick Watch * O X

@ Timer -

Expression Yalue Location  Type
TimerStatus() 'Timer disabled® macro string

Use this window to watch the value of a variable or expression and evaluate expressions
at a specific point in time.

In contrast to the Watch window, the Quick Watch window gives you precise control
over when to evaluate the expression. For single variables this might not be necessary,
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but for expressions with possible side effects, such as assignments and C-SPY macro
functions, it allows you to perform evaluations under controlled conditions.

See also Editing in C-SPY windows, page 46.

To evaluate an expression:

In the editor window, right-click on the expression you want to examine and choose
Quick Watch from the context menu that appears.

The expression will automatically appear in the Quick Watch window.
Alternatively:

In the Quick Watch window, type the expression you want to examine in the
Expressions text box.

Click the Recalculate button to calculate the value of the expression.

For an example, see Using C-SPY macros, page 269.

Can be used with all C-SPY debugger drivers and debug probes.

This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope.

Value
The value of the variable. Values that have changed are highlighted in red.
Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.
This column is editable.

Location
The location in memory where this variable is stored.

Type

The data type of the variable.
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Context menu

This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As ¥
Save to File...

+~  Right Align 'Value' Column

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove

Removes the selected expression from the window.

Remove All
Removes all expressions listed in the window.

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.
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Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As
Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 82.

Save to File

Saves content to a file in a tab-separated format.

Right Align ‘Value’ Column
Right-aligns the contents of the Value column.
Options

Displays the IDE Options dialog box where you can set various options for
C-SPY windows.

The Symbols window is available from the View menu.

X
- Clear
Syrmbaol Location Full Marme Module Type i
B Code:0x0020 7B TABS_ENTRY_MOD  Lahel
?call_main Code:0x0039 7call_main Tocmain Label
?ocmain Code:0x002E  7cmain ?ocmain Label
DoForegroundProcess Code:0x0294 DoForegroundProcess  Interrupt Function
Fik IData:0x23  Fih Utilities Yariable |_
GetFib Code:0x01A6 GetFib Ltilities Function |~
IE SFR: 0xA8 IE Interrupt Lahel
IE_hit SFRE:0xA8 IE_hit Interrupt Label
InitFik Code:0x0137  InitFib Lhtilities Function
Initllart Code:0x028C  |nitlart Interrupt Function
FCOM SFR:0x27 FCOM Interrupt Label
PCOM_hit SFR:0x87 PCOM_hit Interrupt Label
FutFib Code:0x01CE  PutFib Lhtilities Function =

This window displays all symbols with a static location, that is, C/C++ functions,
assembler labels, and variables with static storage duration, including symbols from the
runtime library.
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You can drag the contents of cells in the Symbol, Location, and Full Name columns
and drop in some other windows in the IDE.

Can be used with all C-SPY debugger drivers and debug probes.

The toolbar contains:

<filter by name>

Type the first characters of the symbol names that you want to find, and press
Enter. All symbols (of the types you have selected on the context menu) whose
name starts with these characters will be displayed. If you have chosen not to
display some types of symbols, the window will list how many of those that
were found but are not displayed.

Use the drop-down list to use old search strings. The search box has a history
depth of eight search entries.

Clear
Cancels the effects of the search filter and restores all symbols in the window.

This area contains these columns:

Symbol
The symbol name.

Location
The memory address.

Full name

The symbol name—often the same as the contents of the Symbol column but
differs for example for C++ member functions.

Module
The program module where the symbol is defined.

Type
The symbol type, whether it is a function, label, or variable.

Click the column headers to sort the list by symbol name, location, full name, module,
or type.
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This context menu is available:

Functions
v Variables
Labels

Add to Watch
Add to Live Watch

Copy 3 Row
Symbol
Location
Full Name
Module

Type
These commands are available:

Functions
Toggles the display of function symbols on or off in the list.

Variables
Toggles the display of variables on or off in the list.

Labels
Toggles the display of labels on or off in the list.

Add to Watch
Adds the selected symbol to the Watch window.

Add to Live Watch
Adds the selected symbol to the Live Watch window.

Copy
Copies the contents of the cells on the selected line.
Row Copies all contents of the selected line.
Symbol Copies the contents of the Symbol cell on the selected line.
Location Copies the contents of the Location cell on the selected line.
Full Name Copies the contents of the Full Name cell on the selected line.
Module Copies the contents of the Module cell on the selected line.

Type Copies the contents of the Type cell on the selected line.
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Resolve Symbol Ambiguity dialog box

The Resolve Symbol Ambiguity dialog box appears, for example, when you specify a
symbol in the Disassembly window to go to, and there are several instances of the same
symbol due to templates or function overloading.

Resolve Symbol Ambiguity

Ambiguous symbol: foo

Fleaze select one symbal:

foo[void]
fon<T: Cancel

Requirements
Can be used with all C-SPY debugger drivers and debug probes.

Ambiguous symbol

Indicates which symbol that is ambiguous.
Please select one symbol

A list of possible matches for the ambiguous symbol. Select the one you want to use.
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Breakpoints

e Introduction to setting and using breakpoints
e Setting breakpoints

e Reference information on breakpoints

Introduction to setting and using breakpoints
These topics are covered:

Reasons for using breakpoints

Briefly about setting breakpoints

Breakpoint types

Breakpoint icons

Breakpoints in the C-SPY simulator

Breakpoints in the C-SPY hardware debugger drivers

Breakpoint consumers

REASONS FOR USING BREAKPOINTS

C-SPY® lets you set various types of breakpoints in the application you are debugging,
allowing you to stop at locations of particular interest. You can set a breakpoint at a code
location to investigate whether your program logic is correct, or to get trace printouts.
In addition to code breakpoints, and depending on what C-SPY driver you are using,
additional breakpoint types might be available. For example, you might be able to set a
data breakpoint, to investigate how and when the data changes.

You can let the execution stop under certain conditions, which you specify. You can also
let the breakpoint trigger a side effect, for instance executing a C-SPY macro function,
by transparently stopping the execution and then resuming. The macro function can be
defined to perform a wide variety of actions, for instance, simulating hardware behavior.

All these possibilities provide you with a flexible tool for investigating the status of your
application.

BRIEFLY ABOUT SETTING BREAKPOINTS

You can set breakpoints in many various ways, allowing for different levels of
interaction, precision, timing, and automation. All the breakpoints you define will
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appear in the Breakpoints window. From this window you can conveniently view all
breakpoints, enable and disable breakpoints, and open a dialog box for defining new
breakpoints. The Breakpoint Usage window also lists all internally used breakpoints,
see Breakpoint consumers, page 109.

Breakpoints are set with a higher precision than single lines, using the same mechanism
as when stepping. For more information about the precision, see Single stepping, page
58.

You can set breakpoints while you edit your code even if no debug session is active. The
breakpoints will then be validated when the debug session starts. Breakpoints are
preserved between debug sessions.

Note: For most hardware debugger systems it is only possible to set breakpoints when
the application is not executing.

BREAKPOINT TYPES

Depending on the C-SPY driver you are using, C-SPY supports different types of
breakpoints.

Code breakpoints

Code breakpoints are used for code locations to investigate whether your program logic
is correct or to get trace printouts. Code breakpoints are triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will stop, before the
instruction is executed.

Log breakpoints

Log breakpoints provide a convenient way to add trace printouts without having to add
any code to your application source code. Log breakpoints are triggered when an
instruction is fetched from the specified location. If you have set the breakpoint on a
specific machine instruction, the breakpoint will be triggered and the execution will
temporarily stop and print the specified message in the C-SPY Debug Log window.

Trace Start/Stop Trigger breakpoints
Trace Start Trigger and Trace Stop Trigger breakpoints start and stop trace data
collection—a convenient way to analyze instructions between two execution points.

Data breakpoints

Data breakpoints are primarily useful for variables that have a fixed address in memory.
If you set a breakpoint on an accessible local variable, the breakpoint is set on the
corresponding memory location. The validity of this location is only guaranteed for

C-SPY® Debugging Guide
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small parts of the code. Data breakpoints are triggered when data is accessed at the
specified location.

The execution will usually stop directly after the instruction that accessed the data has
been executed.

Data Log breakpoints

Data log breakpoints are triggered when a specified memory address is accessed. A log
entry is written in the Data Log window for each access.

You can set data log breakpoints using the Breakpoints window, the Memory window,
and the editor window.

Using a single instruction, the microcontroller can only access values that are four bytes
or less. If you specity a data log breakpoint on a memory location that cannot be
accessed by one instruction, for example a double or a too large area in the Memory
window, the result might not be what you intended.

Immediate breakpoints

The C-SPY simulator lets you set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
simulated processor is about to read data from a location or immediately after it has
written data. Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the simulated processor reads from a
memory-mapped location, a C-SPY macro function can intervene and supply
appropriate data. Conversely, when the simulated processor writes to a memory-mapped
location, a C-SPY macro function can act on the value that was written.

107



Introduction to setting and using breakpoints

C-SPY® Debugging Guide
108  for RISC-V

BREAKPOINT ICONS

A breakpoint is marked with an icon in the left margin of the editor window, and the icon
varies with the type of breakpoint:

Tutor.c m |

unsigned int get_fib({ int nr |

" {
| RECinr > ) s (nr <= MAX FIB) |
{
keturn { rooclnr- ] 7
}

I Code breakpoint l

I Log breakpoint l .

I Toeltip information l | |tog @ Utilities.c:37.5
—_— Memory:0x6a [Fetch ]

] return [ 0 ];:
'

Disabled code
breakpeint

If the breakpoint icon does not appear, make sure the option Show bookmarks is
selected, see Editor options in the IDE Project Management and Building Guide for
RISC-V.

Just point at the breakpoint icon with the mouse pointer to get detailed tooltip
information about all breakpoints set on the same location. The first row gives user
breakpoint information, the following rows describe the physical breakpoints used for
implementing the user breakpoint. The latter information can also be seen in the
Breakpoint Usage window.

Note: The breakpoint icons might look different for the C-SPY driver you are using.

BREAKPOINTS IN THE C-SPY SIMULATOR

The C-SPY simulator supports all breakpoint types. The number of breakpoints is
unlimited.

BREAKPOINTS IN THE C-SPY HARDWARE DEBUGGER
DRIVERS

Using the C-SPY drivers for hardware debugger systems you can set various breakpoint
types. The amount of breakpoints you can set depends on the number of hardware
breakpoints available on the target system or whether there are any available software
breakpoints, in which case the number of breakpoints you can set is unlimited.

If there are software breakpoints available, the debugger will first use these before using
hardware breakpoints. Exceeding the number of available hardware breakpoints, when
software breakpoints are not available, causes the debugger to single step. This will
significantly reduce the execution speed. For this reason you must be aware of the
different breakpoint consumers.
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For information about the characteristics of breakpoints for the different target systems,
see the manufacturer’s documentation.

BREAKPOINT CONSUMERS

A debugger system includes several consumers of breakpoints.

User breakpoints

The breakpoints you define in the breakpoint dialog box or by toggling breakpoints in
the editor window often consume one physical breakpoint each, but this can vary greatly.
Some user breakpoints consume several physical breakpoints and conversely, several
user breakpoints can share one physical breakpoint. User breakpoints are displayed in
the same way both in the Breakpoint Usage window and in the Breakpoints window,
for example Data @|R] callCount.

C-SPY itself
C-SPY itself also consumes breakpoints. C-SPY will set a breakpoint if:

o The debugger option Run to has been selected, and any step command is used.
These are temporary breakpoints which are only set during a debug session. This
means that they are not visible in the Breakpoints window.

e The linker option Include C-SPY debugging support has been selected.

In the DLIB runtime environment, C-SPY will set a system breakpoint on the
__DebugBreak label.

These types of breakpoint consumers are displayed in the Breakpoint Usage window,
for example, C-SPY Terminal I/O & libsupport module.
C-SPY plugin modules

For example, modules for real-time operating systems can consume additional
breakpoints. Specifically, by default, the Stack window consumes one physical
breakpoint.

To disable the breakpoint used by the Stack window:
Choose Tools>Options>Stack.
Deselect the Stack pointer(s) not valid until program reaches: /abel option.

To disable the Stack window entirely, choose Tools>Options>Stack and make sure all
options are deselected.
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These tasks are covered:

Various ways to set a breakpoint

Toggling a simple code breakpoint

Setting breakpoints using the dialog box

Setting a data breakpoint in the Memory window
Setting breakpoints using system macros

Useful breakpoint hints

VARIOUS WAYS TO SET A BREAKPOINT

You can set a breakpoint in various ways:

o Toggling a simple code breakpoint.

o Using the New Breakpoints dialog box and the Edit Breakpoints dialog box

available from the context menus in the editor window, Breakpoints window, and
in the Disassembly window. The dialog boxes give you access to all breakpoint
options.

Setting a data breakpoint on a memory area directly in the Memory window.

Using predefined system macros for setting breakpoints, which allows automation.

The different methods offer different levels of simplicity, complexity, and automation.

TOGGLING A SIMPLE CODE BREAKPOINT

Toggling a code breakpoint is a quick method of setting a breakpoint. The following
methods are available both in the editor window and in the Disassembly window:

Click in the gray left-side margin of the window

Place the insertion point in the C source statement or assembler instruction where
you want the breakpoint, and click the Toggle Breakpoint button in the toolbar

o Choose Edit>Toggle Breakpoint

e Right-click and choose Toggle Breakpoint from the context menu.

SETTING BREAKPOINTS USING THE DIALOG BOX

The advantage of using a breakpoint dialog box is that it provides you with a graphical
interface where you can interactively fine-tune the characteristics of the breakpoints.
You can set the options and quickly test whether the breakpoint works according to your
intentions.
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All breakpoints you define using a breakpoint dialog box are preserved between debug

sessions.

You can open the dialog box from the context menu available in the editor window,
Breakpoints window, and in the Disassembly window.

To set a new breakpoint:

Choose View>Breakpoints to open the Breakpoints window.

In the Breakpoints window, right-click, and choose New Breakpoint from the context

menu.

On the submenu, choose the breakpoint type you want to set. Depending on the C-SPY
driver you are using, different breakpoint types are available.

In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.

To modify an existing breakpoint:

In the Breakpoints window, editor window, or in the Disassembly window, select the
breakpoint you want to modify and right-click to open the context menu.
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If there are several breakpoints on the same source code line, the breakpoints will be
listed on a submenu.

On the context menu, choose the appropriate command.
In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.

SETTING A DATA BREAKPOINT IN THE MEMORY WINDOW

You can set breakpoints directly on a memory location in the Memory window.
Right-click in the window and choose the breakpoint command from the context menu
that appears. To set the breakpoint on a range, select a portion of the memory contents.

The breakpoint is not highlighted in the Memory window—instead, you can see, edit,
and remove it using the Breakpoints window, which is available from the View menu.
The breakpoints you set in the Memory window will be triggered for both read and
write accesses. All breakpoints defined in this window are preserved between debug
sessions.

Note: Setting breakpoints directly in the Memory window is only possible if the driver
you use supports this.

SETTING BREAKPOINTS USING SYSTEM MACROS

You can set breakpoints not only in the breakpoint dialog box but also by using built-in
C-SPY system macros. When you use system macros for setting breakpoints, the
breakpoint characteristics are specified as macro parameters.

Macros are useful when you have already specified your breakpoints so that they fully
meet your requirements. You can define your breakpoints in a macro file, using built-in
system macros, and execute the file at C-SPY startup. The breakpoints will then be set
automatically each time you start C-SPY. Another advantage is that the debug session
will be documented, and that several engineers involved in the development project can
share the macro files.

Note: If you use system macros for setting breakpoints, you can still view and modify
them in the Breakpoints window. In contrast to using the dialog box for defining
breakpoints, all breakpoints that are defined using system macros are removed when you
exit the debug session.
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These breakpoint macros are available:

C-SPY macro for breakpoints Simulator I-jet GDB Server
__setCodeBreak Yes Yes Yes
__setDataBreak Yes Yes Yes
__setLogBreak Yes Yes —
__setDataLogBreak Yes — —
__setSimBreak Yes — —
__setTraceStartBreak Yes Yes —
__setTraceStopBreak Yes Yes —
__clearBreak Yes Yes Yes

Table 6: C-SPY macros for breakpoints

For information about each breakpoint macro, see Reference information on C-SPY
system macros, page 283.

Setting breakpoints at C-SPY startup using a setup macro file

You can use a setup macro file to define breakpoints at C-SPY startup. Follow the
procedure described in Using C-SPY macros, page 269.

USEFUL BREAKPOINT HINTS

Below are some useful hints related to setting breakpoints.

Tracing incorrect function arguments

If a function with a pointer argument is sometimes incorrectly called with a NULL
argument, you might want to debug that behavior. These methods can be useful:

e Set a breakpoint on the first line of the function with a condition that is true only
when the parameter is 0. The breakpoint will then not be triggered until the
problematic situation actually occurs. The advantage of this method is that no extra
source code is needed. The drawback is that the execution speed might become
unacceptably low.

® You can use the assert macro in your problematic function, for example:
int MyFunction (int * MyPtr)
{

assert (MyPtr != 0); /* Assert macro added to your source
code. */
/* Here comes the rest of your function. */
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The execution will break whenever the condition is true. The advantage is that the
execution speed is only slightly affected, but the drawback is that you will get a small
extra footprint in your source code. In addition, the only way to get rid of the
execution stop is to remove the macro and rebuild your source code.

e Instead of using the assert macro, you can modify your function like this:

int MyFunction (int * MyPtr)
{

if (MyPtr == 0)

MyDummyStatement; /* Dummy statement where you set a
breakpoint. */

/* Here comes the rest of your function. */
}
You must also set a breakpoint on the extra dummy statement, so that the execution
will break whenever the condition is true. The advantage is that the execution speed
is only very slightly affected, but the drawback is that you will still get a small extra
footprint in your source code. However, in this way you can get rid of the execution
stop by just removing the breakpoint.

Performing a task and continuing execution

You can perform a task when a breakpoint is triggered and then automatically continue
execution.

You can use the Action text box to associate an action with the breakpoint, for instance
a C-SPY macro function. When the breakpoint is triggered and the execution of your
application has stopped, the macro function will be executed. In this case, the execution
will not continue automatically.

Instead, you can set a condition which returns 0 (false). When the breakpoint is
triggered, the condition—which can be a call to a C-SPY macro that performs a task—
is evaluated and because it is not true, execution continues.

Consider this example where the C-SPY macro function performs a simple task:

__var my_counter;

count ()

{
my_counter += 1;
return O0;

}

To use this function as a condition for the breakpoint, type count () in the Expression
text box under Conditions. The task will then be performed when the breakpoint is
triggered. Because the macro function count returns 0, the condition is false and the
execution of the program will resume automatically, without any stop.
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Reference information on breakpoints
Reference information about:

Breakpoints window, page 115

Breakpoint Usage window, page 117

Code breakpoints dialog box, page 118

Log breakpoints dialog box, page 120

Data breakpoints dialog box (Simulator), page 121

Data breakpoints dialog box (for C-SPY hardware debugger drivers), page 123
Data Log breakpoints dialog box, page 124

Immediate breakpoints dialog box, page 125

Enter Location dialog box, page 126

Resolve Source Ambiguity dialog box, page 128
See also:

® Reference information on C-SPY system macros, page 283

® Reference information on trace, page 179

Breakpoints window

The Breakpoints window is available from the View menu.

Breakpoints x
Type Location Extra

@ Code UsingClasses.cpp:39.3

0 Log UsingClasses.cpp:39.10

This window lists all breakpoints you define.

Use this window to conveniently monitor, enable, and disable breakpoints—you can
also define new breakpoints and modify existing breakpoints.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.
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Display area

Context menu
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This area lists all breakpoints you define. For each breakpoint, information about the
breakpoint type, source file, source line, and source column is provided.

This context menu is available:

Go to Source
Edit...

Delete
Enable

Enable All
Disable All
Delete All

MNew Breakpoint 3

These commands are available:

Go to Source

Moves the insertion point to the location of the breakpoint, if the breakpoint has
a source location. Double-click a breakpoint in the Breakpoints window to
perform the same command.

Edit
Opens the breakpoint dialog box for the breakpoint you selected.

Delete
Deletes the breakpoint. Press the Delete key to perform the same command.

Enable

Enables the breakpoint. The check box at the beginning of the line will be
selected. You can also perform the command by manually selecting the check
box. This command is only available if the breakpoint is disabled.

Disable

Disables the breakpoint. The check box at the beginning of the line will be
deselected. You can also perform this command by manually deselecting the
check box. This command is only available if the breakpoint is enabled.

Enable All
Enables all defined breakpoints.

Disable All
Disables all defined breakpoints.
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Delete All
Deletes all defined breakpoints.

New Breakpoint
Displays a submenu where you can open the breakpoint dialog box for the
available breakpoint types. All breakpoints you define using this dialog box are
preserved between debug sessions.

Breakpoint Usage window

Requirements

The Breakpoint Usage window is available from the menu specific to the C-SPY driver
you are using.

Breakpoint Usage x
# Breakpaint
71 Memory : 0x3C3F [Fetch 1

=1 Memory :0x4D75 [Fetch 1
- C-SPY Terminal I/0 && library support module

This window lists all breakpoints currently set in the target system, both the ones you
have defined and the ones used internally by C-SPY. The format of the items in this
window depends on the C-SPY driver you are using.

The window gives a low-level view of all breakpoints, related but not identical to the list
of breakpoints displayed in the Breakpoints window.

C-SPY uses breakpoints when stepping. If your target system has a limited number of

hardware breakpoints, exceeding the number of available hardware breakpoints will

cause the debugger to single step. This will significantly reduce the execution speed.

Therefore, in a debugger system with a limited amount of hardware breakpoints, you can

use the Breakpoint Usage window for:

e Identifying all breakpoint consumers

o Checking that the number of active breakpoints is supported by the target system

o Configuring the debugger to use the available breakpoints in a better way, if
possible.

For more information, see Breakpoints in the C-SPY hardware debugger drivers, page
108.

Can be used with all C-SPY debugger drivers and debug probes.
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Display area

For each breakpoint in the list, the address and access type are displayed. Each
breakpoint in the list can also be expanded to show its originator.

Code breakpoints dialog box

Requirements

Break At

Size

C-SPY® Debugging Guide
118  for RISC-V

The Code breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.

& Code
Break at:
Edit...
Size
@ Auto
) Manual
Action
Expression:
Condtions
Expression:
@ Condttion true Skip court: 0
_) Condition changed

This figure reflects the C-SPY simulator.

Use the Code breakpoints dialog box to set a code breakpoint, see Setting breakpoints
using the dialog box, page 110.

Can be used with all C-SPY debugger drivers and debug probes.

Specity the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 126.

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:

Auto

The size will be set automatically, typically to 1.



Breakpoints °

Manual
Specify the size of the breakpoint range in the text box.

Note: This option might not be supported by the combination of C-SPY driver and
device that you are using.

Action

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 113.

Conditions
Specify simple or complex conditions:
Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 78.
Condition true
The breakpoint is triggered if the value of the expression is true.
Condition changed
The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.
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Log breakpoints dialog box

The Log breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.
0 Log

Trigger at:

Message: [T C-Spy macro "__message" style

Condtions
Expression:

@ Condition true

_) Condition changed

This figure reflects the C-SPY simulator.

Use the Log breakpoints dialog box to set a log breakpoint, see Setting breakpoints
using the dialog box, page 110.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Trigger at

Specity the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 126.

Message

Specify the message you want to be displayed in the C-SPY Debug Log window. The
message can either be plain text, or—if you also select the option C-SPY macro
""__message'" style—a comma-separated list of arguments.

C-SPY macro "__message" style

Select this option to make a comma-separated list of arguments specified in the Message
text box be treated exactly as the arguments to the C-SPY macro language statement
__message, see Formatted output, page 277.

C-SPY® Debugging Guide

for RISC-V
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Conditions
Specity simple or complex conditions:
Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 78.
Condition true

The breakpoint is triggered if the value of the expression is true.

Condition changed

The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Data breakpoints dialog box (Simulator)

The Data breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

Data
Break at:
Edit...
Access Type Size
@ Read/write 0 a’m | 1
() Read - Manua
) Write Action
Expression:
Condtions
Expression:
(@ Condition true Skip court: 0
() Condition changed

This figure reflects the C-SPY simulator.

Use the Data breakpoints dialog box to set a data breakpoint, see Setting breakpoints
using the dialog box, page 110. Data breakpoints never stop execution within a single
instruction. They are recorded and reported after the instruction is executed.

Requirements
The C-SPY simulator.

Break At

Specity the data location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 126.
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Access Type

Size

Action

Conditions
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Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read
Reads from location.

Write

Writes to location.

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:

Auto
The size will automatically be based on the type of expression the breakpoint is
set on. For example, if you set the breakpoint on a 12-byte structure, the size of
the breakpoint will be 12 bytes.

Manual

Specify the size of the breakpoint range in the text box.

For data breakpoints, this can be useful if you want the breakpoint to be triggered on
accesses to data structures, such as arrays, structs, and unions.

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 113.

Specify simple or complex conditions:

Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 78.

Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed

The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.
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Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.

Data breakpoints dialog box (for C-SPY hardware debugger drivers)

The Data breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

e Data

Break at:
Access type Size
@ Read/Wits oo 1
) Read S
) Write Trig_gerlange
Match data Effective
< [®<00000000 Oed= o requested rangs
<. |FFFFFFFF

Use the Data breakpoints dialog box to set a data breakpoint, see Setting breakpoints

using the dialog box, page 110. Data breakpoints never stop execution within a single

instruction. They are recorded and reported after the instruction is executed.
Requirements

Any C-SPY hardware debugger driver.

Break At
Specify the data location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 126.
Access Type
Selects the type of memory access that triggers the breakpoint:

Read/Write

Reads from or writes to location.

Read
Reads from location.
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Write

Writes to location.

Size

These options are not available in the current version of the product.

Match data

These options are not available in the current version of the product.

Trigger range

These options are not available in the current version of the product.

Data Log breakpoints dialog box

The Data Log breakpoints dialog box is available from the context menu in the
Breakpoints window.

Data Log

Break at:
myVar

Access Type
~) Readfwrite
' Read

Use the Data Log breakpoints dialog box to set a maximum of four data log breakpoints
on memory addresses, see Setting breakpoints using the dialog box, page 110.

See also Data Log breakpoints, page 107 and Getting started using data logging, page
201.

Requirements
The C-SPY simulator.

Break At

Specify a memory location as a variable (with static storage duration) or as an address.

C-SPY® Debugging Guide
124 for RISC-V



Access Type

Breakpoints °

Selects the type of access to the variable that generates a log entry:

Read/Write
Read and write accesses from or writes to location of the variable.

Read

Read accesses from the location of the variable.

Write

Write accesses to location of the variable.

Immediate breakpoints dialog box

Requirements

Trigger at

The Immediate breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

Immediate

Trigger at:
Edit...
Access Type Action
@ Read Expression:
) Write

In the C-SPY simulator, you can use the Immediate breakpoints dialog box to set an
immediate breakpoint, see Setting breakpoints using the dialog box, page 110.
Immediate breakpoints do not stop execution at all—they only suspend it temporarily.

The C-SPY simulator.

Specity the data location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 126.
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Access Type

Action

Selects the type of memory access that triggers the breakpoint:
Read

Reads from location.

Write
Writes to location.

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 113.

Enter Location dialog box

Type

C-SPY® Debugging Guide
for RISC-V

The Enter Location dialog box is available from the breakpoints dialog box, either
when you set a new breakpoint or when you edit a breakpoint.

Enter Location @

Type Expression:
@ Expreszion

Absolute address

Source location

[ (0] 3 ]| Cancel |

Use the Enter Location dialog box to specify the location of the breakpoint.

Note: This dialog box looks different depending on the Type you select.

Selects the type of location to be used for the breakpoint, choose between:

Expression

A C-SPY expression, whose value evaluates to a valid code or data location.

A code location, for example the function main, is typically used for code
breakpoints.

A data location is the name of a variable and is typically used for data
breakpoints. For example, my_var refers to the location of the variable my_var,
and arr [3] refers to the location of the fourth element of the array arr. For
static variables declared with the same name in several functions, use the syntax
my_func::my_static_variable to refer to a specific variable.
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For more information about C-SPY expressions, see C-SPY expressions, page
78.

Absolute address

An absolute location on the form zone: hexaddress or simply hexaddress
(for example Memory: 0x42). zone refers to C-SPY memory zones and
specifies in which memory the address belongs, see C-SPY memory zones, page
130.

Source location
A location in your C source code using the syntax:

{filename}.row.column.

filename specifies the filename and full path.

row specifies the row in which you want the breakpoint.
column specifies the column in which you want the breakpoint.

For example, {C:\src\prog.c}.22.3 sets a breakpoint on the third character
position on row 22 in the source file prog. c. Note that in quoted form, for
example in a C-SPY macro, you must instead write
{C:\\src\\prog.c}.22.3.

Note that the Source location type is usually meaningful only for code locations in code
breakpoints. Depending on the C-SPY driver you are using, Source location might not
be available for data and immediate breakpoints.
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Resolve Source Ambiguity dialog box

The Resolve Source Ambiguity dialog box appears, for example, when you try to set a
breakpoint on templates and the source location corresponds to more than one function.

Resolve Source Ambiguity

The zource location coresponds to multiple functions.
‘which onefz] do you mean?

woid foo(T, T #|[with T=unsigned long] Al

woid foo(T, T #|[with T=double]

Cancel

™ Automatically choose all

If you check. this item, the dialog will not be shown again
unless you re-enable it in the Tools->Dptions dialog, on
the Debugger page.

To resolve a source ambiguity, perform one of these actions:

e In the text box, select one or several of the listed locations and click Selected.

e Click AllL
All

The breakpoint will be set on all listed locations.
Selected

The breakpoint will be set on the source locations that you have selected in the text box.
Cancel

No location will be used.

Automatically choose all

Determines that whenever a specified source location corresponds to more than one
function, all locations will be used.

Note that this option can also be specified in the IDE Options dialog box, see Debugger
options in the /IDE Project Management and Building Guide for RISC-V.

C-SPY® Debugging Guide
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Memory and registers

e Introduction to monitoring memory and registers
e Monitoring memory and registers

e Reference information on memory and registers

Introduction to monitoring memory and registers
These topics are covered:

e Briefly about monitoring memory and registers
e C-SPY memory zones
e Memory configuration for the C-SPY simulator

e Memory configuration for C-SPY hardware debugger drivers

BRIEFLY ABOUT MONITORING MEMORY AND REGISTERS

C-SPY provides many windows for monitoring memory and registers, most of them
available from the View menu:

o The Memory window

Gives an up-to-date display of a specified area of memory—a memory zone—and
allows you to edit it. Data coverage along with execution of your application is
highlighted with different colors. You can fill specified areas with specific values and
you can set breakpoints directly on a memory location or range. Y ou can open several
instances of this window, to monitor different memory areas. The content of the
window can be regularly updated while your application is executing.

e The Symbolic Memory window

Displays how variables with static storage duration are laid out in memory. This can
be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example by buffer overruns.

o The Stack window

Displays the contents of the stack, including how stack variables are laid out in
memory. In addition, integrity checks of the stack can be performed to detect and
warn about problems with stack overflow. For example, the Stack window is useful
for determining the optimal size of the stack. You can open up to two instances of
this window, each showing different stacks or different display modes of the same
stack.
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o The Registers window

Gives an up-to-date display of the contents of the processor registers and SFRs, and
allows you to edit them. Because of the large amount of registers—memory-mapped
peripheral unit registers and CPU registers—it is inconvenient to show all registers
concurrently in the Registers window. Instead you can divide registers into
application-specific groups. You can choose to load either predefined register groups
or define your own groups. You can open several instances of this window, each
showing a different register group.

o The SFR Setup window

Displays the currently defined SFRs that C-SPY has information about, both
factory-defined (retrieved from the device description file) and custom-defined
SFRs. If required, you can use the Edit SFR dialog box to customize the SFR
definitions.

To view the memory contents for a specific variable, simply drag the variable to the
Memory window or the Symbeolic Memory window. The memory area where the
variable is located will appear.

Reading the value of some registers might influence the runtime behavior of your
application. For example, reading the value of a UART status register might reset a
pending bit, which leads to the lack of an interrupt that would have processed a received
byte. To prevent this from happening, make sure that the Registers window containing
any such registers is closed when debugging a running application.

C-SPY MEMORY ZONES

In C-SPY, the term zone is used for a named memory area. A memory address, or
location, is a combination of a zone and a numerical offset into that zone. By default,
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the RISC-V architecture has one memory-mapped zone, Memory, which covers the
whole RISC-V memory range.
0x0000'0000

OXFFFF'FFFF (RV32)
OxXFFFF'FFFF'FFFF'FFFF (RV64)

Default zone Memory

In addition to this zone, the control and status registers (CSRs) are accessed through the
non memory-mapped CSRMemory Zone.

Memory zones are used in several contexts, most importantly in the Memory and
Disassembly windows, and in C-SPY macros. In the windows, use the Zone box to
choose which memory zone to display.

For normal memory, the default zone Memory can be used, but certain I/O registers
might require to be accessed as 8, 16, 32, or 64 bits to give correct results. By using
different memory zones, you can control the access width used for reading and writing
in, for example, the Memory window. When using the zone Memory, the debugger
automatically selects the most suitable access width.

Note: For the C-SPY I-jet driver, you can specify the automatic selection of access
width in the Edit Memory Range dialog box, see Edit Memory Range dialog box for
C-SPY hardware debugger drivers, page 169.

MEMORY CONFIGURATION FOR THE C-SPY SIMULATOR

To simulate the target system properly, the C-SPY simulator needs information about
the memory configuration. By default, C-SPY uses a configuration based on
information retrieved from the device description file.

The C-SPY simulator provides various mechanisms to improve the configuration
further:

o If the default memory configuration does not specify the required memory address
ranges, you can specify the memory address ranges shall be based on:
o The zones predefined in the device description file

o The section information available in the debug file

131



Introduction to monitoring memory and registers

e Or, you can define your own memory address ranges, which you typically might
want to do if the files do not specify memory ranges for the specific device that
you are using, but instead for a family of devices (perhaps with various amounts
of on-chip RAM).

e For each memory address range, you can specify an access type. If a memory access
occurs that does not agree with the specified access type, C-SPY will regard this as
an illegal access and warn about it. In addition, an access to memory that is not
defined is regarded as an illegal access. The purpose of memory access checking is
to help you to identify memory access violations.

For more information, see Memory Configuration dialog box for the C-SPY simulator,
page 162.

MEMORY CONFIGURATION FOR C-SPY HARDWARE
DEBUGGER DRIVERS

To handle memory as efficiently as possible during debugging, C-SPY needs
information about the memory configuration. By default, C-SPY uses a configuration
based on information retrieved from the device description file.

You should make sure the memory address ranges match the memory available on your
device. Providing C-SPY with information about the memory layout of the target system
is helpful in terms of both performance and functionality:

e Reading (and writing) memory (if your debug probe is connected through a USB
port) can be fast, but is usually the limiting factor when C-SPY needs to update
many debugger windows. C-SPY can cache memory contents to speed up
performance, provided it has correct information about the target memory.

e You can inform C-SPY that the content of certain memory address ranges will not
be changed during a debug session. C-SPY can keep a copy of that memory
readable even when the target system does not normally allow reading (such as
when it is executing).

Note that if you specify the cache type ROM/Flash, C-SPY treats such memory as
constant during the whole debug session (which improves efficiency, when updating
some C-SPY windows). If your application modifies flash memory during runtime,
do not use the ROM/Flash cache type.

® You can prevent C-SPY from accessing memory outside specified memory address
ranges, which can be important for certain hardware.

The Memory Configuration dialog box is automatically displayed the first time you
start the C-SPY driver for a given project, unless the device description file contains a
memory description which is explicitly tagged as correct and complete. Subsequent
starts will not display the dialog box unless you have made project changes that might

C-SPY® Debugging Guide
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cause the memory configuration to change, for example if you have selected another
device description file.

For more information, see Memory Configuration dialog box for C-SPY hardware
debugger drivers, page 166.

Monitoring memory and registers
These tasks are covered:

e Defining application-specific register groups
o Monitoring stack usage

DEFINING APPLICATION-SPECIFIC REGISTER GROUPS

Defining application-specific register groups minimizes the amount of registers
displayed in the Registers windows and makes the debugging easier.

To define application-specific register groups:

I Choose View>Registers>Register User Groups Setup during a debug session.

Register User Groups Setup x

Group Farmat
= regCroupine

Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Binary

Hexadecimal
Binary
Binary
Hexadecimal

e click to add reg>
<click to add group>

Right-clicking in the window displays a context menu with commands. For information
about these commands, see Register User Groups Setup window, page 155.

2 Click on <click to add group> and specify the name of your group, for example
My Timer Group and press Enter.
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3 Underneath the group name, click on <click to add reg> and type the name of a

register, and press Enter. You can also drag a register name from another window in the
IDE. Repeat this for all registers that you want to add to your group.

As an optional step, right-click any registers for which you want to change the integer
base, and choose Format from the context menu to select a suitable base.

When you are done, your new group is now available in the Registers windows.

If you want to define more application-specific groups, repeat this procedure for each
group you want to define.

Note: If a certain SFR that you need cannot be added to a group, you can register your
own SFRs. For more information, see SFR Setup window, page 157.

MONITORING STACK USAGE
These are the two main use cases for the Stack window:

® Monitoring stack memory usage

e Monitoring the stack memory content.

In both cases, C-SPY retrieves information about the defined stack size and its allocation
from the definition in the linker configuration file of the section holding the stack. If you,
for some reason, have modified the stack initialization in the system startup code,
cstartup, you should also change the section definition in the linker configuration file
accordingly, otherwise the Stack window cannot track the stack usage. For more
information, see the /AR C/C++ Development Guide for RISC-V'.

To monitor stack memory usage:

Before you start C-SPY, choose Tools>Options. On the Stack page:

o Select Enable graphical stack display and stack usage tracking. This option also
enables the option Warn when exceeding stack threshold. Specify a suitable
threshold value.

e Note also the option Warn when stack pointer is out of bounds. Any such
warnings are displayed in the Debug Log window.
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IDE Options

- Commen Fonts

i Key Bindings
Language

(#)- Editor

Messages

: - Praject

‘... Saurce Cade Control

Debmmar

| .. Stack

] Enable graphical stack display and stack usage traciing

S0 % stack usage threshold
Wam when exceeding stack threshold

[7] Wam when stack pointer is out of bounds

Stack porrneig)mst v=lid vt = oo i reaches

main

Wamings
@ Log
() Log and alert

[ Limit stack display to

Help

Start C-SPY.

When your application is first loaded, and upon each reset, the memory for the stack area
is filled with the dedicated byte value 0xCD before the application starts executing.

Choose View>Stack>Stack 1 to open the Stack window.

Note that you can open up to two Stack windows, each showing a different stack—if
several stacks are available—or the same stack with different display settings.

Start executing your application.

Whenever execution stops, the stack memory is searched from the end of the stack until
a byte whose value is not 0xCD is found, which is assumed to be how far the stack has
been used. The light gray area of the stack bar represents the unused stack memory area,
whereas the dark gray area of the bar represents the used stack memory.
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For this example, you can see that only 44% of the reserved memory address range was
used, which means that it could be worth considering decreasing the size of memory:

Used stack memary, Unused stack memary,
Stack pointer J in dark gray in light gray

Stack 1 \ [ [ | x

q |
36 bytes used out of 80 (44%) —

Location Data Stack range: Memony:0:3FBO0 - Memory:0x4000 Frame
OxF0O
0x3FFB 0Oxdl
0x3FFC 0x40180000

Toeltip informartion with facts
about used stack memory

4 m | +

Note: Although this is a reasonably reliable way to track stack usage, there is no
guarantee that a stack overflow is detected. For example, a stack can incorrectly grow
outside its bounds, and even modify memory outside the stack area, without actually
modifying any of the bytes near the end of the stack range. Likewise, your application
might modify memory within the stack area by mistake.

To monitor the stack memory content:

I Before you start monitoring stack memory, you might want to disable the option
Enable graphical stack display and stack usage tracking to improve performance
during debugging.

2 Start C-SPY.
Choose View>Stack>Stack 1 to open the Stack window.

Note that you can access various context menus in the display area from where you can
change display format, etc.

4 Start executing your application.

C-SPY® Debugging Guide
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Whenever execution stops, you can monitor the stack memory, for example to see
function parameters that are passed on the stack:

Current stack pointer |

.

Stack 1 *x
Stack -
Location ' Data “ariahle “alue Type Frame
0x3FDE| 0x0001 p.mHandle 1 int [0] _dwrite
0x3FED Ox3FES p.mBuffer 0x3FEB "‘n' unsigned charconst® [0] __chwrite
0x3FE2 0x0001 p.msize 1 size_t [0] __dwrite
0x3FE4 0x0001 p.mBetunst. 1 size_t [0] __dwrite

0x3FE6 0x72

0x3FE7 0Oxdl

0x3FE8 0x000A000A
0x3FEC 0xCDCD4048
0x3FF0 0xCDCDCDCD
0x3FF4 0xCDCDCDCD
0x3FF8 0x0000CDCD
0x3FFC 0x401441D2

Reference information on memory and registers

Reference information about:

Memory window, page 138

Memory Save dialog box, page 142

Memory Restore dialog box, page 143

Fill dialog box, page 144

Symbolic Memory window, page 145

Stack window, page 148

Registers window, page 152

Register User Groups Setup window, page 155

SFR Setup window, page 157

Edit SFR dialog box, page 160

Memory Configuration dialog box for the C-SPY simulator, page 162
Edit Memory Range dialog box for the C-SPY simulator, page 164
Memory Configuration dialog box for C-SPY hardware debugger drivers, page 166

Edit Memory Range dialog box for C-SPY hardware debugger drivers, page 169
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Memory window

The Memory window is available from the View menu.

Available zones Context menu button

‘ Live update

vi \ \ // x
o : B L
£f £f £f ff ff

000feefd £f £f £f ££f ££f ££f ££ ££  ........ -
000feefl f£f £f £f £ff £f £f ££f £f  ........
R 000fef00 48 65 6c 6c 6 20 57 6f Hello Wo
Mem ory DO0fef0s 72 62 64 21 00 00 68 6a rld!

000feflD Bc 74 7a 4c 00 OO OO OO .
Bddieszes 000fefld OO0 OO OO OO OO OO OO OO0
000fef20 OO0 OO OO OO OO OO OO OO0
000fef2f ﬁﬁfrOO 00 00 cd cd cd cd
DDDfeﬁ}G” cd cd cd cd cd cd cd cd
DDQEéfBS 3c 01 00 ed £f £f £f £f
_,GﬁDfef4D £ff £f £f £f £f £f £f £f
000fef4d £f £f £f ££f ££f ££f ££ ££  ........

Go to location

Data coverage
information

Q00fefs0 f£f £f£-ff £f £f £f £f ££f . .......

Mem ory contents Mem ory contents in ASCII format

This window gives an up-to-date display of a specified area of memory—a memory
zone—and allows you to edit it. You can open several instances of this window, which
is very convenient if you want to keep track of several memory or register zones, or
monitor different parts of the memory.

To view the memory corresponding to a variable, you can select it in the editor window
5  anddrag it to the Memory window.

See also Editing in C-SPY windows, page 46.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Toolbar
The toolbar contains:
Go to
The memory location or symbol you want to view.
Zone

Selects a memory zone, see C-SPY memory zones, page 130.

Context menu button

Displays the context menu.

C-SPY® Debugging Guide
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Update Now
Updates the content of the Memory window while your application is
executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing.

Live Update
Updates the contents of the Memory window regularly while your application
is executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing. To set
the update frequency, specify an appropriate frequency in the IDE
Options>Debugger dialog box.

Display area

The display area shows the addresses currently being viewed, the memory contents in
the format you have chosen, and—provided that the display mode is set to 1x Units—
the memory contents in ASCII format. You can edit the contents of the display area, both
in the hexadecimal part and the ASCII part of the area.

Data coverage is displayed with these colors:

Yellow Indicates data that has been read.
Blue Indicates data that has been written
Green Indicates data that has been both read and written.

Note: Data coverage is not supported by all C-SPY drivers. Data coverage is supported
by the C-SPY simulator.
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Context menu

This context menu is available:
Copy

Paste
Zone 3

v lxUnits
2x Units
4x Units
8x Units

v Little Endian
Big Endian

Data Coverage 3

Find...

Replace...

Mermory Fill...
Memory Save...

Mermory Restore...
Set Data Breakpoint

Set Data Log Breakpoint

These commands are available:

Copy
Paste

Standard editing commands.

Zone

Selects a memory zone, see C-SPY memory zones, page 130.

1x Units

Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
8x Units

Displays the memory contents as 8-byte groups.

Little Endian
Displays the contents in little-endian byte order.

C-SPY® Debugging Guide
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Big Endian
Displays the contents in big-endian byte order.

Data Coverage

Choose between:

Enable toggles data coverage on or off.

Show toggles between showing or hiding data coverage.
Clear clears all data coverage information.

These commands are only available if your C-SPY driver supports data

coverage.

Find
Displays a dialog box where you can search for text within the Memory
window—read about the Find dialog box in the IDE Project Management and
Building Guide for RISC-V.

Replace
Displays a dialog box where you can search for a specified string and replace
each occurrence with another string—read about the Replace dialog box in the
IDE Project Management and Building Guide for RISC-V'.

Memory Fill

Displays a dialog box, where you can fill a specified area with a value, see Fill
dialog box, page 144.

Memory Save

Displays a dialog box, where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 142.

Memory Restore
Displays a dialog box, where you can load the contents of a file in Intel-hex or
Motorola s-record format to a specified memory zone, see Memory Restore
dialog box, page 143.

Set Data Breakpoint

Sets breakpoints directly in the Memory window. The breakpoint is not
highlighted—you can see, edit, and remove it in the breakpoint dialog box. The
breakpoints you set in this window will be triggered for both read and write
access. For more information, see Setting a data breakpoint in the Memory
window, page 112.
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Set Data Log Breakpoint

Sets a breakpoint on the start address of a memory selection directly in the
Memory window. The breakpoint is not highlighted—you can see, edit, and
remove it in the breakpoint dialog box. The breakpoints you set in this window
will be triggered by both read and write accesses—to change this, use the
Breakpoints window. For more information, see Data Log breakpoints, page
107 and Getting started using data logging, page 201.

Memory Save dialog box

The Memory Save dialog box is available by choosing Debug>Memory>Save or from

Requirements

Zone

Start address

End address

File format

C-SPY® Debugging Guide
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the context menu in the Memory window.

Memory Save

Zone:

==l

IMemory 7 I [ Save

]

End address:
0xFF

Start address:
0x30

File format:

Iintel-exhended - I

Filename:
C:\Documents\IAR Embedded Workbench'memory.hex

Close

=

Use this dialog box to save the contents of a specified memory area to a file.

Can be used with all C-SPY debugger drivers and debug probes.

Selects a memory zone, see C-SPY memory zones, page 130.

Specify the start address of the memory range to be saved.

Specify the end address of the memory range to be saved.

Selects the file format to be used, which is Intel-extended by default.



Filename

Save
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Specify the destination file to be used. A browse button is available.

Saves the selected range of the memory zone to the specified file.

Memory Restore dialog box

Requirements

Zone

Filename

Restore

The Memory Restore dialog box is available by choosing Debug>Memory>Restore
or from the context menu in the Memory window.

Merory Restore @
Zone:
| Memory - | [ Restore ]
Close
Filename:
C:'\Documents\TAR \memory . hex l:l

Use this dialog box to load the contents of a file in Intel-extended or Motorola S-record
format to a specified memory zone.

Can be used with all C-SPY debugger drivers and debug probes.

Selects a memory zone, see C-SPY memory zones, page 130.

Specify the file to be read. A browse button is available.

Loads the contents of the specified file to the selected memory zone.
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Fill dialog box

Requirements

Start address

Length

Zone

Value

Operation

C-SPY® Debugging Guide
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The Fill dialog box is available from the context menu in the Memory window.

Fill =
Start address: Length: Zone:
01010 004 Memory -
Walue: Operation
O=FF @ Copy AND
XOR oR
[ (0] 8 ] | Cancel |

Use this dialog box to fill a specified area of memory with a value.

Can be used with all C-SPY debugger drivers and debug probes.

Type the start address—in binary, octal, decimal, or hexadecimal notation.

Type the length—in binary, octal, decimal, or hexadecimal notation.

Selects a memory zone, see C-SPY memory zones, page 130.

Type the 8-bit value to be used for filling each memory location.

These are the available memory fill operations:

Copy

AND

XOR

Value will be copied to the specified memory area.

An AND operation will be performed between Value and the existing contents of
memory before writing the result to memory.

An XOR operation will be performed between Value and the existing contents of
memory before writing the result to memory.
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OR

An OR operation will be performed between Value and the existing contents of
memory before writing the result to memory.

Symbolic Memory window
The Symbolic Memory window is available from the View menu during a debug

session.

Symbolic Memory x
Go to: hd |Data v||Pre\c'ious|[ Mext ]
Location Data “ariable  Value Type 0

0x21 0x0000 callCount O int

Ox23 0x0001  Fib[0] 1 unsigned int

0x25 0x0001  Fib[1] 1 unsigned int =
0x27 0x0002  Fik[2] 2 unsigned int 3
0x29 0x0003  Fib[3] 3 unsigned int

0x2B 0x0005  Fib[4] 5| unsigned int

0x2D 0x0008  Fib[E] a unsigned int

0x2F 0x000D  Fib[E] 13 unsigned int

Ox3l 0x0015  Fib[7] 21 unsigned int

Ox33 0x0022  Fib[8] 34 unsigned int -

This window displays how variables with static storage duration, typically variables
with file scope but also static variables in functions and classes, are laid out in memory.
This can be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example buffer overruns. Other areas of use
are spotting alignment holes or for understanding problems caused by buffers being
overwritten.

To view the memory corresponding to a variable, you can select it in the editor window
5  anddragit to the Symbolic Memory window.

See also Editing in C-SPY windows, page 46.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Toolbar

The toolbar contains:

Go to
The memory location or symbol you want to view.

Zone

Selects a memory zone, see C-SPY memory zones, page 130.
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Previous

Highlights the previous symbol in the display area.

Next
Highlights the next symbol in the display area.

Display area
This area contains these columns:

Location

The memory address.

Data
The memory contents in hexadecimal format. The data is grouped according to
the size of the symbol. This column is editable.

Variable
The variable name—requires that the variable has a fixed memory location.
Local variables are not displayed.

Value
The value of the variable. This column is editable.

Type

The type of the variable.
There are several different ways to navigate within the memory space:

Text that is dropped in the window is interpreted as symbols
The scroll bar at the right-side of the window

The Next and Previous toolbar buttons

The Go to toolbar list box can be used for locating specific locations or symbols.

Note: Rows are marked in red when the corresponding value has changed.

C-SPY® Debugging Guide
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This context menu is available:

MNext Symbol
Previous Symbol
1x Units

v 2xUnits
4x Units
Add to Watch
Add to Live Watch

v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format

These commands are available:

Next Symbol
Highlights the next symbol in the display area.

Previous Symbol

Highlights the previous symbol in the display area.

1x Units

Memory and registers __¢

Displays the memory contents as single bytes. This applies only to rows that do

not contain a variable.
2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
Add to Watch

Adds the selected symbol to the Watch window.

Add to Live Watch

Adds the selected symbol to the Live Watch window.

Default format

Displays the memory contents in the default format.

Binary format
Displays the memory contents in binary format.
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Stack window

[ Stack view l

peinter

Requirements
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Current stack ‘

Octal format

Displays the memory contents in octal format.

Decimal format

Displays the memory contents in decimal format.

Hexadecimal format

Displays the memory contents in hexadecimal format.

Char format

Displays the memory contents in char format.

The Stack window is available from the View menu.

I Current stack pointer ] I Used memory stack, in gray ‘

e The graphical

- \ e X stack bar with
s -/ (NI . | sootip
Location Data Yariable Value Type Frame information
0x04DC | 1244 signedint [0] InitFik

004 DC
0x<CD00
Ox0432
00000
+10 0x0408
+12 0xCDOO

Unused stack
| memary, in
light gray

This window is a memory window that displays the contents of the stack. The graphical
stack bar shows stack usage.

Note: By default, this window uses one physical breakpoint. For more information, see
Breakpoint consumers, page 109.

For information about options specific to the Stack window, see the IDE Project
Management and Building Guide for RISC-V.

Can be used with all C-SPY debugger drivers and debug probes.
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Toolbar
The toolbar contains:

Stack
Selects which stack to view. This applies to cores with multiple stacks.

The graphical stack bar
Displays the state of the stack graphically.
The left end of the stack bar represents the bottom of the stack, in other words, the
position of the stack pointer when the stack is empty. The right end represents the end

of the memory address range reserved for the stack. The graphical stack bar turns red
when the stack usage exceeds a threshold that you can specify.

To enable the stack bar, choose Tools>Options>Stack>Enable graphical stack
display and stack usage tracking. This means that the functionality needed to detect
and warn about stack overflows is enabled.

Place the mouse pointer over the stack bar to get tooltip information about stack usage.

=

Display area
This area contains these columns:

Location
Displays the location in memory. The addresses are displayed in increasing
order. The address referenced by the stack pointer, in other words the top of the
stack, is highlighted in a green color.

Data
Displays the contents of the memory unit at the given location. From the Stack
window context menu, you can select how the data should be displayed—as a
1-, 2-, or 4-byte group of data.

Variable
Displays the name of a variable, if there is a local variable at the given location.
Variables are only displayed if they are declared locally in a function, and
located on the stack and not in registers.

Value
Displays the value of the variable.

Type

Displays the data type of the variable.
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Context menu
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Frame

Displays the name of the function that the call frame corresponds to.

This context menu is available:
v Show Variables
Show Offsets
1x Units
2x Units
v dxUnits

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format

Options...

These commands are available:

Show Variables

Displays separate columns named Variables, Value, and Frame in the Stack
window. Variables located at memory addresses listed in the Stack window are
displayed in these columns.

Show Offsets

Displays locations in the Location column as offsets from the stack pointer.
When deselected, locations are displayed as absolute addresses.

1x Units

Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.

4x Units
Displays the memory contents as 4-byte groups.
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Default Format

Binary Format

Octal Format

Decimal Format

Hexadecimal Format

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Options
Opens the IDE Options dialog box where you can set options specific to the

Stack window, see the IDE Project Management and Building Guide for
RISC-V.
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Registers window

Requirements
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The Registers windows are available from the View menu.

Registers 3 x
Find: < > Group:| CPU Registers (ABI) w
MName Yalue Access

ra 0x2000' 00b4 FeadvWrite
sp 0xB000' 0£d0 Ready'rite
gp 0x2000' 0000 Ready'rite
tp 00000 0000 Fieadi'rite
s0/Ep 00000 0000 Fieadi'rite
81 0x0000' 0000 Ready'rite
B2 0x0000' 0000 Ready'rite
B3 0x0000' 0000 Ready'rite
=4 0x0000' 0000 Ready'rite
85 0x0000' 0000 Ready'rite
B6 0x0000' 0000 Ready'rite
87 0x0000' 0000 Ready'rite
B8 0x0000' 0000 Ready'rite
B9 0x0000' 0000 Ready'rite
=10 0x0000' 0000 Ready'rite
=811 0x0000' 0000 Ready'rite
al 0x0000' 0001 Ready'rite

These windows give an up-to-date display of the contents of the processor registers and
special function registers, and allow you to edit the contents of some of the registers.
Optionally, you can choose to load either predefined register groups or your own
user-defined groups.

You can open up to four instances of this window, which is convenient for keeping track
of different register groups.

See also Editing in C-SPY windows, page 46.

To enable predefined register groups:

Select a device description file that suits your device, see Selecting a device description
file, page 43. These files contain predefined register groups.

Display the registers of a register group by selecting it from the Group drop-down
menu on the toolbar, or by right-clicking in the window and choosing View Group
from the context menu.

For information about creating your own user-defined register groups, see Defining
application-specific register groups, page 133.

Can be used with all C-SPY debugger drivers and debug probes.



Memory and registers __¢

Toolbar

The toolbar contains:

Find
Specify the name, or part of a name, of a register (or group) that you want to
find. Press the Enter key and the first matching register, or group with a
matching register, is displayed. User-defined register groups are not searched.
The search box preserves a history of previous searches. To repeat a search,
select it from the search history and press Enter.

Group

Selects which predefined register group to display. Additional register groups
are predefined in the device description files that make SFR registers available
in the Registers windows. The device description file contains a section that
defines the special function registers and their groups. If some of your SFRs are
missing, you can register your own SFRs in a Custom group, see SFR Setup
window, page 157.

Display area
Displays registers and their values. Some registers are expandable, which means that the
register contains interesting bits or subgroups of bits.

If you drag a numerical value, a valid expression, or a register name from another part
of the IDE to an editable value cell in a Registers window, the value will be changed to
that of what you dragged. If you drop a register name somewhere else in the window,
the window contents will change to display the first register group where this register is
found.

Name

The name of the register.

Value

The current value of the register. Every time C-SPY stops, a value that has
changed since the last stop is highlighted. Some of the registers are editable. To
edit the contents of an editable register, click on the register and modify its
value. Press Esc to cancel the change.

To change the display format of the value, right-click on the register and choose
Format from the context menu.

Access

The access type of the register. Some of the registers are read-only, while others
are write-only.
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Context menu

C-SPY® Debugging Guide
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For the C-SPY Simulator, these additional support registers are available in the CPU
Registers group:

CYCLECOUNTER Cleared when an application is started or reset, and is
incremented with the number of used cycles during

execution.
CCSTEP Shows the number of used cycles during the last performed
C/C++ source or assembler step.
CCTIMERI1 and Two trip counts that can be cleared manually at any given
CCTIMER2 time. They are incremented with the number of used cycles

during execution.

This context menu is available:

View Group 3
View User Group
Format 3

Open User Groups Setup Window

Save to File...
Find Mext Register G
Find Previous Register SHIFT-G

These commands are available:

View Group
Selects which predefined register group to display.

View User Group

Selects which user-defined register group to display. For information about
creating your own user-defined register groups, see Defining
application-specific register groups, page 133.

Format

Changes the display format for the contents of the register you clicked on. The
display format setting affects different types of registers in different ways. Your
selection of display format is saved between debug sessions.

Open User Groups Setup Window

Opens a window where you can create your own user-defined register groups,
see Register User Groups Setup window, page 155.
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Save to File
Opens a standard Save dialog box to save the contents of the window to a
tab-separated text file.

Find Next Register
Finds the predefined register or register group that comes immediately after
what your search found. After the last register was found, this search wraps
around and finds the first register again.

Find Previous Register
Finds the matching predefined register or register group that comes immediately
before what your search found. After the first register was found, this search
wraps around and finds the last register again.

Register User Groups Setup window

The Register User Groups Setup window is available from the View menu or from the
context menu in the Registers windows.
Register User Groups Setup x

Group Farmat
- regCroupine

Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Binary

Hexadecimal
Binary
Binary
Hexadecimal

e click to add reg>
<click to add group>

Use this window to define your own application-specific register groups. These register
groups can then be viewed in the Registers windows.

Defining application-specific register groups means that the Registers windows can
display just those registers that you need to watch for your current debugging task. This
makes debugging much easier.
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Requirements

Display area

Context menu
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Can be used with all C-SPY debugger drivers and debug probes.

This area contains these columns:

Group

The names of register groups and the registers they contain. Clickingon <click
to add group> or <click to add reg> and typing the name of a register
group or register, adds new groups and registers, respectively. You can also drag
a register name from another window in the IDE. Click a name to change it.

A dimmed register name indicates that it is not supported by the selected device.

Format

Shows the display format for the register’s value. To change the display format
of the value, right-click on the register and choose Format from the context
menu. The selected format is used in all Registers windows.

This context menu is available:
Format 4
Rermove
Clear Group

Remove All Groups

Save to File...

These commands are available:

Format
Changes the display format for the contents of the register you clicked on. The
display format setting affects different types of registers in different ways. Your
selection of display format is saved between debug sessions.

Remove
Removes the register or group you clicked on.

Clear Group
Removes all registers from the group you clicked on.

Remove All Groups

Deletes all user-defined register groups from your project.
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Save to File

Opens a standard Save dialog box to save the contents of the window to a
tab-separated text file.

SFR Setup window
The SFR Setup window is available from the Project menu.
SFR Setup X
MName Address Zone  Size Access 5
+  MyOwnSFR Ox20004000 Mermory g Fead only
+ MyHideSFR 0x20004004 Mermory 16 Maone
TIKMZ_CR1 0x40000000 hemaony 32 Readhd/frite
o TIMZ_CR2 0x40000004 Merory 32 Fead only
TIMZ_SMCR 0x40000008 hemaony 32 Readhd/frite
TIMZ_DIER 0x4000000C hemaony 32 Readhd/frite
TIM2_5R 0x40000010 Merory a2 Eeadhirite
TIMZ_EGR 0x40000014 hemaony 32 Readhd/frite -

This window displays the currently defined SFRs that C-SPY has information about.
You can choose to display only factory-defined or custom-defined SFRs, or both. If
required, you can use the Edit SFR dialog box to customize the SFR definitions, see
Edit SFR dialog box, page 160. For factory-defined SFRs (that is, retrieved from the ad £
file in use), you can only customize the access type.

To quickly find an SFR, drag a text or hexadecimal number string and drop in this
window. If what you drop starts with a 0 (zero), the Address column is searched,
otherwise the Name column is searched.

Any custom-defined SFRs are added to a dedicated register group called Custom, which
you can choose to display in the Registers window. Your custom-defined SFRs are
saved in projectCustomSFR.sfr. This file is automatically loaded in the IDE when
you start C-SPY with a project whose name matches the prefix of the filename of the
sfr file.

You can only add or modify SFRs when the C-SPY debugger is not running.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.
Display area
This area contains these columns:

Status
A character that signals the status of the SFR, which can be one of:

blank, a factory-defined SFR.
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C, a factory-defined SFR that has been modified.
+, a custom-defined SFR.

?, an SFR that is ignored for some reason. An SFR can be ignored when a
factory-defined SFR has been modified, but the SFR is no longer available, or it
is located somewhere else or with a different size. Typically, this might happen
if you change to another device.

Name
A unique name of the SFR.

Address

The memory address of the SFR.
Zone

Selects a memory zone, see C-SPY memory zones, page 130.
Size

The size of the register, which can be any of 8, 16, 32, or 64.

Access

The access type of the register, which can be one of Read/Write, Read only,
‘Werite only, or None.

You can click a name or an address to change the value. The hexadecimal 0x prefix for
the address can be omitted, the value you enter will still be interpreted as hexadecimal.
For example, if you enter 4567, you will get 0x4567.

You can click a column header to sort the SFRs according to the column property.
Color coding used in the display area:

e Green, which indicates that the corresponding value has changed

o Red, which indicates an ignored SFR.

C-SPY® Debugging Guide
158  for RISC-V



Context menu

This context menu is available:

v

Show All
Show Custom SFRs only
Show Factory SFRs only

Add...

Edit...

Delete

Delete/Revert All Custom SFRs
Save Custom SFRs...

& bits
16 bits
32 bits

64 bits

Read/Write
Read only
Write only

MNone

These commands are available:

Show All

Shows all SFR.

Show Custom SFRs only

Shows all custom-defined SFRs.

Show Factory SFRs only
Shows all factory-defined SFRs retrieved from the ddf file.

Add

Memory and registers __¢

Displays the Edit SFR dialog box where you can add a new SFR, see Edit SFR

dialog box, page 160.

Edit

Displays the Edit SFR dialog box where you can edit an SFR, see Edit SFR

dialog box, page 160.

Delete

Delete/Revert All Custom SFRs

Deletes an SFR. This command only works on custom-defined SFRs.

Deletes all custom-defined SFRs and reverts all modified factory-defined SFRs

to their factory settings.
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Edit SFR dialog box

Requirements

Name

C-SPY® Debugging Guide
for RISC-V

Save Custom SFRs

Opens a standard Save dialog box to save all custom-defined SFRs.
8]16|32|64 bits

Selects display format for the selected SFR, which can be 8, 16, 32, or 64 bits.

Note that the display format can only be changed for custom-defined SFRs.
Read/Write|Read only|Write only|None

Selects the access type of the selected SFR, which can be Read/Write, Read
only, Write only, or None. Note that for factory-defined SFRs, the default
access type is indicated.

The Edit SFR dialog box is available from the context menu in the SFR Setup window.
Edit SFR (=23

SFR

M ame:
MyOwnSFR Carcel

Address: Zone:
0400004567 Memary -
Size Access
@ 8 bits @ Read wiite
16 bitz Fiead only
32 bitz write: only
B4 bits MHone

Definitions of the SFRs are retrieved from the device description file in use. Use this
dialog box to either modify these factory-defined definitions or define new SFRs. See
also SFR Setup window, page 157.

Can be used with all C-SPY debugger drivers and debug probes.

Specify the name of the SFR that you want to add or edit.
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Address
Specify the address of the SFR that you want to add or edit. The hexadecimal 0x prefix
for the address can be omitted, the value you enter will still be interpreted as
hexadecimal. For example, if you enter 4567, you will get 0x4567.

Zone
Selects the memory zone for the SFR you want to add or edit. The list of zones is
retrieved from the ddf file that is currently used.

Size
Selects the size of the SFR. Choose between 8, 16, 32, or 64 bits. Note that the display
format can only be changed for custom-defined SFRs.

Access

Selects the access type of the SFR. Choose between Read/Write, Read only, Write
only, or None. Note that for factory-defined SFRs, the default access type is indicated.

161



Reference information on memory and registers

162

Memory Configuration dialog box for the C-SPY simulator
The Memory Configuration dialog box is available from the C-SPY driver menu.

Memory Configuration @

Usze ranges based on “
@ Device description file
() Debug file segment information [only shown while debugging)

Zone Name Start End Type Size s
Memory CODE FLRSH 0x00000000 Ox003FFFFF Read only 4 Mbytes
Memory CODE FLRSH 0x00800000 Ox00SFFFFF Read only 2 Mbytes
Memory CODE FLRSH 0x01000000 0x01007FFF Read only 3Z kbytes E
Memory LOCRL RRM PEZ 0xFESDOO00O OxFESFFFFF Read/Write 152 kbytes
Memory LOCRL RAM PE1 OxFEBDOOOO OxFEBFFFFF Read/Write 152 kbytes

[T Use marual ranges

Ignored Zone Start End Type Size Hew...

Edit...
Delete

Drelete Al

Memory access checking
Check for: Action:

[ Access type violation Log violations

(@ Log and stop execution

Use this dialog box to specify which set of memory address ranges to be used by C-SPY
during debugging.

See also Memory configuration for the C-SPY simulator, page 131.

Requirements
The C-SPY simulator.

Use ranges based on
Specify if the memory configuration should be retrieved from a predefined
configuration. Choose between:

Device description file

Retrieves the memory configuration from the device description file that you
have specified. See Selecting a device description file, page 43.

This option is used by default.

C-SPY® Debugging Guide
for RISC-V
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Debug file segment information
Retrieves the memory configuration from the debug file, which has retrieved it
from the linker configuration file. This information is only available during a
debug session. The advantage of using this option is that the simulator can catch
memory accesses outside the linked application.

Memory information is displayed in these columns:

Zone

The memory zone, see C-SPY memory zones, page 130.
Name

The name of the memory address range.
Start

The start address for the memory address range, in hexadecimal notation.
End

The end address for the memory address range, in hexadecimal notation.
Type

The access type of the memory address range.
Size

The size of the memory address range.

Use manual ranges

Specify your own ranges manually via the Edit Memory Range dialog box. To open
this dialog box, click New to specify a new memory address range, or select an existing
memory address range and click Edit to modify it. For more information, see Edit
Memory Range dialog box for the C-SPY simulator, page 164.

The ranges you define manually are saved between debug sessions.

An X in the column Ignored means that C-SPY has detected that the specified manual
range is illegal, for example because it overlaps another range. C-SPY will not use such
an area.

Memory access checking

Check for determines what to check for:
e Access type violation.
Action selects the action to be performed if an access violation occurs. Choose between:

e Log violations

e Log and stop execution.
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Any violations are logged in the Debug Log window.

Buttons

These buttons are available for the manual ranges:

New
Opens the Edit Memory Range dialog box, where you can specify a new
memory address range and associate an access type with it, see Edit Memory
Range dialog box for the C-SPY simulator, page 164.

Edit
Opens the Edit Memory Range dialog box, where you can edit the selected
memory address range. See Edit Memory Range dialog box for the C-SPY
simulator, page 164.

Delete
Deletes the selected memory address range definition.

Delete All

Deletes all defined memory address range definitions.

Edit Memory Range dialog box for the C-SPY simulator

The Edit Memory Range dialog box is available from the Memory Configuration
dialog box.

Edit Memary Range &J

Memory range
Zone:
l Memary T ] Cancel

Start address: End address:
OxFFFFEFOO OxFFFFEFD3

4 bytes

Access type:
) RaM

_) ROM#Flash
@ SFR

%

Use this dialog box to specify your own memory address ranges, and their access types.

See also Memory Configuration dialog box for the C-SPY simulator, page 162

C-SPY® Debugging Guide
164  for RISC-V
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Requirements
The C-SPY simulator.

Memory range
Defines the memory address range specific to your device:

Zone
Selects a memory zone, see C-SPY memory zones, page 130.

Start address

Specify the start address for the memory address range, in hexadecimal
notation.

End address
Specify the end address for the memory address range, in hexadecimal notation.

Access type
Selects an access type for the memory address range. Choose between:
o RAM, for read/write memory
e ROM/Flash, for read-only memory
e SFR, for SFR read/write memory.
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Memory Configuration dialog box for C-SPY hardware debugger drivers

The Memory Configuration dialog box is available from the C-SPY driver menu.

Memory Configuration

It i impartant for C-5PY that the target memory is described fully and accurately. Your project settings normally specify this, as follows

Factary ranges

Selected device description file in Project Options:

C:AProgram Files (#BE)MAR Systemsi\Embedded ‘Waorkbench BY\COMFIG \debuggerM32L152CE. ddf

It specifies the following default memany ranges;

0x00000000-0x00007£EE
32 kbytes (ROM/Flash]

Zone Name Start End Type Size Extra ol
Memory RMem 0x00000000 0x00007FFF Read only 32 kbytes
Memory Flash 0x08000000 0x08007FFF Read only 32 kbytes
Memory EEFROM 0x08080000 0x08080FFF Read/Write 4 kKovtes =
Memory ROM 0x1FF0O0O000 0x1FFROO0LF Read only 512 klbytes 32 bytes
Memory RAM 0x20000000 0x200027FF Read/Write 10 kbwtes
Memory RAM 1 0x22000000 0x2204FFFF Read/Write 320 kovtes b
Memory Periph 0x40000000 0x400263FF SFR 153 kbytes
Memory Periph 1 0x42000000 0x427787FF SFR 7 Moytes 482 kbytes i
Used ranges
This is the memary configuration that will be used. You can modify this as needed
Zone Start End Cache Type Size Extra Comment ol New
Memory 0x00000000 Ox0DO0007FFF ROM/Flash 32 kbytes
Memory 008000000 0x08007FFF ROM/Flash 32 koytes
Memory 008080000 0x08080FFF RAM 4 kbytes =
Memory Ox1FFOO0OD 0x1FF800L1F ROM/Flash 512 kbytes 32 bvtes
Memory 020000000 0x200027FF RAM 10 kbytes
Memory 022000000 0x2204FFFF RAM 320 kbytes b
Memory 040000000 0x400263FF Uncached/SFR 153 kbytes
Memory 042000000 0x427787FF Uncached/SFR 7 Moytes 482 kbytes S

Requirements

C-SPY® Debugging Guide

for RISC-V

C-SPY uses a default memory configuration based on information retrieved from the
device description file in use. If memory configuration is missing in the device
description file, C-SPY tries to provide a usable factory default. See Selecting a device

description file, page 43.

Use this dialog box to verify, and if needed, modify the memory address ranges so that
they match the memory available on your device.

You can only change the memory configuration when C-SPY is not running.

See also Memory configuration for C-SPY hardware debugger drivers, page 132.

Any C-SPY hardware debugger driver.
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Factory ranges

Identifies which device description file that is currently selected and lists the default
memory address ranges retrieved from the file in these columns:

Zone

The memory zone, see C-SPY memory zones, page 130.
Name

The name of the memory address range.
Start

The start address for the memory address range, in hexadecimal notation.
End

The end address for the memory address range, in hexadecimal notation.
Type

The access type of the memory address range.
Size

The size of the memory address range.

Used ranges

These columns list the memory address ranges that will be used by C-SPY. The columns
are normally identical to the factory ranges, unless you have added, removed, or
modified ranges.

Zone

Selects a memory zone, see C-SPY memory zones, page 130.
Start

The start address for the memory address range, in hexadecimal notation.
End

The end address for the memory address range, in hexadecimal notation.
Cache Type

The cache type of the memory address range.
Size

The size of the memory address range.
Comment

Memory area information.
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Graphical bar

Buttons

C-SPY® Debugging Guide
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Use the buttons to override the default memory address ranges that are retrieved from
the device description file.

A graphical bar that visualizes the entire theoretical memory address range for the
device. Defined ranges are highlighted in green.

These buttons are available for manual ranges:

New
Opens the Edit Memory Range dialog box, where you can specify a new
memory address range and associate a cache type with it, see Edit Memory
Range dialog box for C-SPY hardware debugger drivers, page 169.

Edit
Opens the Edit Memory Range dialog box, where you can edit the selected
memory address area. See Edit Memory Range dialog box for C-SPY hardware
debugger drivers, page 169.

Remove
Removes the selected memory address range definition.

Use Factory

Restores the list of used ranges to the factory ranges.
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Edit Memory Range dialog box for C-SPY hardware debugger drivers

The Edit Memory Range dialog box is available from the Memory Configuration
dialog box.

Edit Memary Range &J

Memory range
Zone:

ll\"lemor_l,l—VJ Cancel

Start address: End address:
0«0 Ox1FFFF
128 kbytes
Cache type: Extra attributes
2 R [ Access width (8.16.32)
) ROM/Flash
1 Uncached/SFR

Use this dialog box to specify the memory address ranges, and assign a cache type to
each range.

See also Memory configuration for C-SPY hardware debugger drivers, page 132.

Requirements

Any C-SPY hardware debugger driver.

Memory range
Defines the memory address range specific to your device:
Zone
Selects a memory zone, see C-SPY memory zones, page 130.

Start address

Specify the start address for the memory address range, in hexadecimal
notation.

End address

Specify the end address for the memory address range, in hexadecimal notation.
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Cache type

Selects a cache type to the memory address range. Choose between:

RAM

When the target CPU is not executing, all read accesses from memory are loaded
into the cache. For example, if two Memory windows show the same part of
memory, the actual memory is only read once from the hardware to update both
windows. If you modify memory from a C-SPY window, your data is written to
cache only. Before any target execution, even stepping a single machine
instruction, the RAM cache is flushed so that all modified bytes are written to
the memory on your hardware.

ROM/Flash

This memory is assumed not to change during a debug session. Any code within
such a range that is downloaded when you start a debug session (or technically,
any such code that is part of the application being debugged) is stored in the
cache and remains there. Other parts of such ranges are loaded into the cache
from memory on demand, but are then kept during the debug session. Note that
C-SPY will not allow you to modify such memory from C-SPY windows.

Even though flash memory is normally used as a fixed read-only memory, there
are applications that modify parts of flash memory at runtime. For example,
some part of flash memory might be used for a file system or simply to store
non-volatile information. To reflect this in C-SPY, you should choose the RAM
cache type for those instead. Then C-SPY will assume that those parts can
change at any time during execution.

SFR/Uncached

A range of this type is completely uncached. All read or write commands from
a C-SPY window will access the hardware immediately. Typically, this type is
useful for special function registers, which can have all sorts of unusual
behavior, such as having different values at every read access. This can in turn
have side-effects on other registers when they are written, not containing the
same value as was previously written, etc.

If you do not have the appropriate information about your device, you can specify an
entire memory as SFR/Uncached. This is not incorrect, but might make C-SPY slower
when updating windows. In fact, this caching type is sometimes used by the default
when there is no memory address range information available.

If required, you can disable caching—choose C-SPY driver>Disable Debugger Cache.

C-SPY® Debugging Guide
170  for RISC-V
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Extra attributes

Provides extra attributes.

Access width [8,16,32,64]

Forces C-SPY to use 8, 16, 32, or 64-bit width when accessing memory in this
range. Specify 8, 16, 32, or 64 in the text box.

This option might not be available in the C-SPY driver you are using.
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Part 2. Analyzing your
application

This part of the C-SPY® Debugging Guide for RISC-V includes these chapters:
e Trace

e The application timeline

e Profiling

e Code coverage

.hﬁhhhhm
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Trace

e Introduction to using trace
e Collecting and using trace data

e Reference information on trace

Introduction to using trace
These topics are covered:

e Reasons for using trace

e Briefly about trace

e Requirements for using trace

See also:

o Getting started using data logging, page 201

o Getting started using interrupt logging, page 250
e Profiling, page 215

REASONS FOR USING TRACE

By using trace, you can inspect the program flow up to a specific state, for instance an
application crash, and use the trace data to locate the origin of the problem. Trace data
can be useful for locating programming errors that have irregular symptoms and occur
sporadically.

BRIEFLY ABOUT TRACE

To use trace in C-SPY requires that your target system can generate trace data. Once
generated, C-SPY can collect it and you can visualize and analyze the data in various
windows and dialog boxes.

C-SPY supports collecting trace data from these target systems:

e SiFive devices with support for Nexus-based trace
o The C-SPY simulator
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External trace

External real-time trace is a continuously collected sequence of every executed
instruction for a selected portion of the execution. The trace buffer is located in the
debug probe and is continuously consumed by the C-SPY driver. However, if the data
rate is too high, the data transfer will stall and the trace buffer could eventually fill up.
The trace buffer collects trace data in real time, but the data is not displayed in the
C-SPY windows until after the execution has stopped.

Note: Collecting this type of trace data requires an I-jet Trace debug probe.

RAM trace

RAM trace uses a designated on-chip trace buffer. The trace buffer collects trace data in
real time, but the data is not displayed in the C-SPY windows until after the execution
has stopped.

Note: The amount of trace data (including code coverage and function profiling) that
can be collected is limited by the size of the on-chip trace RAM buffer.

Serial trace

Serial trace is a sequence of events of various kinds, generated by the on-chip debug
hardware. The most important events are:
o PC sampling

The hardware can sample and transmit the value of the program counter at regular
intervals.

o [nterrupt logs
The hardware can generate and transmit data related to the execution of interrupts.
® Data logs

Using Data Log breakpoints, the hardware can be configured to generate and
transmit events whenever a certain variable, or simply an address range, is accessed
by the CPU.

Note: Collecting this type of trace data requires a combination of debug probe and target
hardware that support it.
Trace features in C-SPY

In C-SPY, you can use the trace-related windows—Trace, Function Trace, Timeline,
and Find in Trace.
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REQUIREMENTS FOR USING TRACE

The C-SPY simulator supports trace-related functionality, and there are no specific
requirements.

Requirements for using Nexus-based trace

To use Nexus-based trace, you need an I-jet or I-jet Trace debug probe and an
appropriate adapter. SRAM-based and External trace is supported. External trace
requires an I-jet Trace debug probe.

Collecting and using trace data

These tasks are covered:

o Getting started with trace

e Trace data collection using breakpoints
e Searching in trace data

e Browsing through trace data

GETTING STARTED WITH TRACE
To collect trace data, no specific build settings are required.

Start C-SPY and choose I-jet>Trace Settings. In the Trace Settings dialog box that is
displayed, check if you need to change any of the default settings and set the Mode
option to the type of trace you want to collect. If you made any changes, exit C-SPY
and restart the debug session.

For more information about the Trace Settings dialog box, see Trace Settings dialog
box, page 180.

Note: If you are using the C-SPY simulator you can ignore this step.

Open the Trace window—available from the driver-specific menu—and click the
Activate button to enable collecting trace data.

Start the execution. When the execution stops, for example because a breakpoint is
triggered, trace data is displayed in the Trace window. For more information about the
window, see Trace window, page 183.
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TRACE DATA COLLECTION USING BREAKPOINTS

A convenient way to collect trace data between two execution points is to start and stop
the data collection using dedicated breakpoints.

Choose between these alternatives:

e In the editor or Disassembly window, position your insertion point, right-click, and
toggle a Trace Start Trigger or Trace Stop Trigger breakpoint from the context
menu.

e In the Breakpoints window, choose New Breakpoint>Trace Start Trigger or
Trace Stop Trigger from the context menu.

o The C-SPY system macros __setTraceStartBreak and
__setTraceStopBreak can also be used.

For more information about these breakpoints, see Trace Start Trigger breakpoint dialog
box, page 191 and Trace Stop Trigger breakpoint dialog box, page 193, respectively.

SEARCHING IN TRACE DATA

When you have collected trace data, you can perform searches in the collected data to
locate the parts of your code or data that you are interested in, for example, a specific
interrupt or accesses of a specific variable.

You specify the search criteria in the Find in Trace dialog box and view the result in the
Find in Trace window.

The Find in Trace window is very similar to the Trace window, showing the same
columns and data, but only those rows that match the specified search criteria.
Double-clicking an item in the Find in Trace window brings up the same item in the
Trace window.

To search in your trace data:

On the Trace window toolbar, click the Find button.

In the Find in Trace dialog box, specify your search criteria.
Typically, you can choose to search for:

e A specific piece of text, for which you can apply further search criteria
e An address range

e A combination of these, like a specific piece of text within a specific address range.
For more information about the various options, see Find in Trace dialog box, page 194.

When you have specified your search criteria, click Find. The Find in Trace window
is displayed, which means you can start analyzing the trace data. For more information,
see Find in Trace window, page 195.
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BROWSING THROUGH TRACE DATA

To follow the execution history, simply look and scroll in the Trace window.
Alternatively, you can enter browse mode.

To enter browse mode, double-click an item in the Trace window, or click the Browse
toolbar button.

The selected item turns yellow and the source and Disassembly windows will highlight
the corresponding location. You can now move around in the trace data using the up and
down arrow keys, or by scrolling and clicking—the source and Disassembly windows
will be updated to show the corresponding location. This is like stepping backward and
forward through the execution history.

Double-click again to leave browse mode.

Reference information on trace
Reference information about:

Trace Settings button in the IDE toolbar, page 179
Trace Settings dialog box, page 180

Trace window, page 183

Function Trace window, page 190

Trace Start Trigger breakpoint dialog box, page 191
Trace Stop Trigger breakpoint dialog box, page 193
Find in Trace dialog box, page 194

Find in Trace window, page 195

Trace Settings button in the IDE toolbar
During a debug session using a C-SPY driver, a debug probe, and a device that all
support trace, this button is added to the toolbar in the main Embedded Workbench IDE
window:

i)

L= Trace Settings...

Trace functionality is OMN, in use by:
Trace
Instruction count for flat profiling
Streaming Instruction Count

Click this button to open the Trace Settings dialog box, see Trace Settings dialog box,
page 180. Hover over the button to get information about whether trace is on or off and
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which functionality that is used. The button is green when trace is enabled and gray
when it is disabled.

Trace Settings dialog box

The Trace Settings dialog box is available from the C-SPY I-jet menu.
Trace Settings =

Mode: [External (parallel pins) - Opt

Info:  SoC: SiFive Insight (TE v}, I-jet Trace-CM(64MB), Decoder1.11
Status: Ready: nCov=63+6(part)
Core Control
PC | Full
[] 5tall (prevents FIFO overflow)
Instrumentation Trace
[] Enable Printing
RAM (on chip) Sink Configuration

Size: | 4KB Stop Trace On Full

External (parallel pins) Sink Cenfiguration

Port: TraceClic  28.0MHz

Decoder Configuration
PC Trace

Streaming Code Coverage

Use this dialog box to configure trace generation and collection.

See also Getting started with trace, page 177.

Requirements

The I-jet driver and a device that supports trace.

Mode

The main trace mode. Some changes to the trace mode are not possible during a debug
session; see the Debug Log for detailed information.

Note: Not all types of trace can be used by all combinations of debug probe and target
hardware. A setting that cannot be used will be ignored; see the Debug Log for detailed
information.

C-SPY® Debugging Guide
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Choose between:

Off (disabled)

This disables I-jet trace completely. If the I-jet trace mode is Off, trace cannot
be enabled or used in any trace-related windows for the I-jet driver. This setting
ensures that trace modules will not do any reading/writing to the target system.

If, for some reason, trace seems to be available in a debug session when the
device you are debugging does not support it, you can use this setting to turn the
(non-functional) trace features off.

Auto (probe dependent)
Selects External, RAM, or Serial trace, in that order, depending on the best
match of the capabilities of the debug probe and the trace components of the
target system.

External (parallel pins)
Collects External trace data, see External trace, page 176.

RAM (on chip)

Collects RAM trace data, see RAM trace, page 176.
Serial (serial pin)

Collects Serial trace data, see Serial trace, page 176.

Opt
Use this field with device families from some SoC vendors to make settings required to
use trace. For detailed information, see the document
RISC-V-Trace-Control-Interface.adoc, available on github.com.

Info
Gives information about the target device and the debug probe, showing the amount of
probe memory and the version of the decoder that is used for processing trace. This field
is read-only.

Status

Displays the status of current trace capture. This field is read-only. The elements that can
be displayed in this field are:

status:

The current status of the trace collection, one of: Ready, Streaming (capturing
full trace in real time), Active (capturing and buffering trace), and Done.
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Stall

Enable printing

Size

Stop trace on full

Port

TraceClk

C-SPY® Debugging Guide
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Unread xMB (y%)
If the decoding is slower than the streaming data rate, x is the amount of raw
trace not yet read (y% of the probe trace memory). For RAM trace, or if PC
Trace is disabled, this element might be omitted.

nlnst=z
z is the number of instructions that have been decoded from the processed raw
trace stream.

nCov=a+b(part)
a is the number of completely covered instructions and b the number of partially

executed instructions.

The messages in the Debug Log window give a fuller description of the trace collection.

Stalls the core to prevent on-chip FIFO overflow. Note that when core is stalled,
real-time behavior might be affected. Use this option only when you see trace overflows.

Makes it possible for the executing application to send text to the stdout and stderr
streams by way of trace output, rather than by temporarily stopping at a breakpoint.

Using this option requires that the standard C library is configured with the option to
direct the stdout/stderr streams via Trace ITC. To configure the library this way,
choose Project>Options>General Options>Library Configuration.

Displays the on-chip RAM size when the Mode is set to RAM. This field is read-only.

Stops RAM trace collection before the trace buffer becomes full.

Specifies which trace port pins to use when the Mode is set to External. A setting that
cannot be used will be ignored; see the Debug Log for detailed information.

The frequency of the trace clock (TraceClk) pin used for External trace, as measured by
the debug probe.
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Refreshes the measurement of the trace clock frequency.

Shows whether PC Trace records are being produced or not. This check box is
read-only—the production of PC Trace records is enabled/disabled in the individual
debugger windows that make use of them.

Note: Without PC Trace, the decoding of the trace stream improves as coverage maps
and counters can be updated live.

Streaming code coverage

Trace window

Requirements

Trace toolbar

Shows whether code coverage maps and counters are being produced or not. This check
box is read-only—streaming code coverage is enabled/disabled in the individual
debugger windows that make use of it.

The Trace window is available from the C-SPY driver menu.
This window displays the collected trace data.
The content of the Trace window depends on the C-SPY driver you are using.

See also Collecting and using trace data, page 177.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace

The toolbar in the Trace window contains:

m Enable/Disable

X

Enables and disables collecting and viewing trace data in this window.

Clear trace data

Clears the trace buffer. Both the Trace window and the Function Trace window
are cleared.
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m B B =

Toggle source
Toggles the Trace column between showing only disassembly or disassembly
together with the corresponding source code.

Browse

Toggles browse mode on or off for a selected item in the Trace window, see
Browsing through trace data, page 179.

Find
Displays a dialog box where you can perform a search, see Find in Trace dialog
box, page 194.

Save
Displays a standard Save As dialog box where you can save the collected trace
data to a text file, with tab-separated columns.

Edit Settings

In the C-SPY simulator, this button is not enabled.

For the C-SPY I-jet driver, this button displays the Trace Settings dialog box,
see Trace Settings dialog box, page 180.

Progress bar

When a large amount of trace data has been collected, there might be a delay
before all of it has been processed and can be displayed. The progress bar
reflects that processing.

Display area (in the C-SPY simulator)

This area displays a collected sequence of executed machine instructions. In addition,
the window can display trace data.

Trace
DEEEEIEE

Timestamp  Trace Fead Addr Fead Data Write Addr White Data. ™
- ! BOGANAGE  Pur an &
1 20000004 addi gp. gp. 0=106
2 80000008 lui =p. 1
3 s00o0o0oc addi sp. sp. 0=x110
4 BO0DOD10 lui al, 0x30000
5 20000014 addi al, al, 0=40
L4 6 80000018 cerroi zZ8ro. mtve
7 s000001c csrrs zero. mtve. ..
8 80000020 lui al, 2
9 20000024 csrrs zero. msta. ..
10 80000028 cerrvi zero, fosr
> 11 &oo0o0o02c c.jal __low_leve. ..
_ low level init:
12 a0o00023C c.li al, 1
€ 13 8000023E c.ret
14 8000002E beq al, zero., ...
3 15 80000032 c.jal __iar data
__dar data_init2:
16 80000154 c.addilesp -0x10 v

This area contains these columns for the C-SPY simulator:
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The leftmost column contains identifying icons to simplify navigation within
the buffer:

The yellow diamond indicates the trace execution point, marking when
target execution has started.

[}- The right green arrow indicates a call instruction.
__.:] The left green arrow indicates a return instruction.
I The dark green bookmark indicates a navigation bookmark.
o The red arrow indicates an interrupt.
| The violet bar indicates the results of a search.
Timestamp
The number of cycles elapsed to this point.

Trace
The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

Read Addr, Read Data, Write Addr, Write Data
These columns show reads and writes to memory.

A red-colored row indicates that the previous row and the red row are not consecutive.

This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.
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Display area (in the C-SPY I-jet driver)

This area displays a collected sequence of executed machine instructions and other trace

data.
Trace =
O EE YIRS
Timestamp  Address Trace Exc.. *
786 0x40400124 c.addilésp 0x10
< 787 0x40400126 c.ret
> 788 0x4040002e c.jal exit
exit:
789 0x404001b2 c.] _exit
_exit:
790 0x40400194 addi =p, sp. -0x10
791 0x40400128 =A%) ra, 0xC(sp)
792 0x4040019c =W al, 8i=p)
793 0x404001a0 1w al, B({sp)
> 794 0x404001a4 c.jal __exit
_ exit:
795 0x404000de c.addilésp -0x20 -

This area contains these columns for the C-SPY I-jet driver:

The leftmost column contains identifying icons to simplify navigation within
the buffer:

The yellow diamond indicates the trace execution point, marking when
target execution has started.

[}'— The right green arrow indicates a call instruction.
{] The left green arrow indicates a return instruction.
[ The dark green bookmark indicates a navigation bookmark.
¢ The red arrow indicates an interrupt.
| The violet bar indicates the results of a search.
Timestamp
An internal I-jet index number.

Address
The address of the instruction associated with the trace frame.

Trace

The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

C-SPY® Debugging Guide
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Except

The type of exception, when it occurs.

A red-colored row indicates that the previous row and the red row are not consecutive.
This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.

Context menu

This context menu is available:
v Enable
Clear

Embed Source

Browse

Find 3
Find All...

MNavigate 3
Bookmarks 3
Timestamp 3

Save...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands. Note that the shortcuts to the
submenu commands do not use the Ctrl key.

These commands are available:

Enable

Enables and disables collecting and viewing trace data in this window.

Clear
Clears the trace buffer. Both the Trace window and the Function Trace window
are cleared.

Embed source
Toggles the Trace column between showing only disassembly or disassembly
together with the corresponding source code.

Browse

Toggles browse mode on or off for a selected item in the Trace window, see
Browsing through trace data, page 179.
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Find>Find (F)
Displays a dialog box where you can perform a search in the Trace window, see
Find in Trace dialog box, page 194. The contents of the window will scroll to
display the first match.

Find>Find Next (G)
Finds the next occurrence of the specified string.

Find>Find Previous (Shift+G)

Finds the previous occurrence of the specified string.

Find>Clear (Shift+F)
Removes all search highlighting in the window.

Find All

Displays a dialog box where you can perform a search in the Trace window, see
Find in Trace dialog box, page 194. The search results are displayed in the Find
in Trace window—available by choosing the View>Messages command, see
Find in Trace window, page 195.

Navigate>After Current Loop (L)

Identifies the selected program counter and scans the trace data forward,
collecting program counters, until it finds the same address again. It has now
detected a loop. (Loops longer than 1000 instructions are not detected.) Then it
navigates forward until it finds a program counter that is not part of the collected
set. This is useful for navigating out of many iterations of an idle or polling loop.

Navigate>Before Current Loop (Shift+L)
Behaves as After Current Loop, but navigates backward out of the loop.
Navigate>After Current Function (U)
Navigates to the next unmatched return instruction. This is similar to stepping
out of the current function.
Navigate>Before Current Function (Shift+U)
Navigates to the closest previous unmatched call instruction.

Navigate>Next Statement (S)

Navigates to the next instruction that belongs to a different C statement than the
starting point. It skips function calls, i.e. it tries to reach the next statement in
the starting frame.

Navigate>Previous Statement (Shift+S)

Behaves as Next statement, but navigates backward to the closest previous
different C statement.
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Navigate>Next on Same Address (A)

Navigates to the next instance of the starting program counter address, typically
to the next iteration of a loop.

Navigate>Previous on Same Address (Shift+A)

Navigates to the closest previous instance of the starting program counter
address.

Navigate>Next Interrupt (I)

Navigates to the next interrupt entry. (To then find the matching interrupt exit,
follow up with After Current Function.)

Navigate>Previous Interrupt (Shift+I)
Navigates to the closest previous interrupt entry.

Navigate>Next Execution Start Point (E)

Navigates to the next point where the CPU was started, for example places
where the application stopped at breakpoints, or was stepped.

Navigate>Previous Execution Start Point (Shift+E)
Navigates to the closest previous point where the CPU was started.

Navigate>Next Discontinuity (D)

Navigates to the next discontinuity in the trace data.

Navigate>Previous Discontinuity (Shift+D)

Navigates to the closest previous discontinuity in the trace data.

Bookmarks>Toggle (+)
Adds a new navigation bookmark or removes an existing bookmark.

Bookmarks>Goto Next (B)

Navigates to the next navigation bookmark.
Bookmarks>Goto Previous (Shift+B)

Navigates to the closest previous navigation bookmark.
Bookmarks>Clear All

Removes all navigation bookmarks.

Bookmarks>/ocation (0-9)

At the bottom of the submenu, the ten most recently defined bookmarks are
listed, with a shortcut key each from 0-9.
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Timestamp>Set as Zero Point (Z)

Sets the selected row as a reference “zero” point in the collected sequence of
trace data. The count of rows in the Trace window will show this row as 0 and
recalculate the timestamps of all other rows in relation to this timestamp.

Timestamp>Go to Zero Point (Shift+Z)
Navigates to the reference “zero” point in the collected sequence of trace data
(if you have set one).

Timestamp>Clear Zero Point

Removes the reference “zero” point from the trace data and restores the original
timestamps of all rows.

Save

Displays a standard Save As dialog box where you can save the collected trace
data to a text file, with tab-separated columns.

Function Trace window

Requirements

C-SPY® Debugging Guide
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The Function Trace window is available from the C-SPY driver menu during a debug
session.

Function Trace x
Timestamp  Address Call/Return G
0 SRS
12 0=xB000023C _low_level init
14 0xzB000002E _ iar program_start + 46
16 0=80000154 ._ iar_data_init?2
28 0xB0000214 ..__lar_ copy_init?2
106 0=B80000174 . dar data_init2 + 32
112 0x80000034 _ iar program =tart + 52
v

This window displays a subset of the trace data displayed in the Trace window. Instead
of displaying all rows, the Function Trace window shows:

o The functions called or returned to, instead of the traced instruction

o The corresponding trace data.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace
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Display area

For the C-SPY I-jet driver and the C-SPY simulator, and depending on the trace source,
these columns are available:

Timestamp
For the simulator, this shows the number of cycles elapsed to this point.

For the I-jet driver, this shows an internal I-jet index number.

Address
The address of the executed instruction.

Call/Return
The function that was called or returned to.

Context menu

The context menu in this window is a subset of the context menu in the Trace window.
All operations performed using this context menu will have effect also in the Trace
window, and vice versa. For a description of the menu commands, see Trace window,
page 183.

Trace Start Trigger breakpoint dialog box

The Trace Start Trigger dialog box is available from the context menu that appears
when you right-click in the Breakpoints window.

Edit Breakpoint @
o Trace Start Trigger

Break at:

Edit...

Use this dialog box to set a Trace Start Trigger breakpoint where you want to start
collecting trace data. If you want to collect trace data only for a specific range, you must
also set a Trace Stop Trigger breakpoint where you want to stop collecting data.

See also Trace Stop Trigger breakpoint dialog box, page 193 and Trace data collection
using breakpoints, page 178.
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4

To set a Trace Start Trigger breakpoint:

In the editor or Disassembly window, right-click and choose Trace Start Trigger from
the context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.

In the Breakpoints window, right-click and choose New Breakpoint>Trace Start
Trigger.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Break at text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection starts.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace

Specify the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 126.
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Trace Stop Trigger breakpoint dialog box

Requirements

4

The Trace Stop Trigger dialog box is available from the context menu that appears
when you right-click in the Breakpoints window.

Edit Breakpoint @
° Trace Stop Trigger

Break at:

Edit...

Use this dialog box to set a Trace Stop Trigger breakpoint where you want to stop
collecting trace data. If you want to collect trace data only for a specific range, you might
also need to set a Trace Start Trigger breakpoint where you want to start collecting data.

See also Trace Start Trigger breakpoint dialog box, page 191 and Trace data collection
using breakpoints, page 178.

To set a Trace Stop Trigger breakpoint:

In the editor or Disassembly window, right-click and choose Trace Stop Trigger from
the context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.

In the Breakpoints window, right-click and choose New Breakpoint>Trace Stop
Trigger.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Break at text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection stops.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace
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Break At

Specity the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 126.

Find in Trace dialog box

Requirements

Text search

C-SPY® Debugging Guide
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The Find in Trace dialog box is available by clicking the Find button on the Trace
window toolbar or by choosing Edit>Find and Replace>Find.

Note that the Edit>Find and Replace>Find command is context-dependent. It displays
the Find in Trace dialog box if the Trace window is the current window or the Find
dialog box if the editor window is the current window.

Find in Trace *
Text search IT'
| v]
Cancel
[IMatch case

[IMatch whole word

[ only search in one column

Address range

Start | 0x0 |

End | OxFFFF |

Use this dialog box to specify the search criteria for advanced searches in the trace data.

The search results are displayed in the Find in Trace window—available from the
View>Messages menu, see Find in Trace window, page 195.

See also Searching in trace data, page 178.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace

Specify the string you want to search for. To specify the search criteria, choose between:

Match case

Searches only for occurrences that exactly match the case of the specified text.
Otherwise int will also find INT, Int, and so on.
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Match whole word

Searches only for the string when it occurs as a separate word. Otherwise int
will also find print, sprintf, and so on.

Only search in one column
Searches only in the column you selected from the drop-down list.

Address range

Specify the address range you want to display or search. The trace data within the
address range is displayed. If you have also specified a text string in the Text search
field, the text string is searched for within the address range.

Find in Trace window

The Find in Trace window is available from the View>Messages menu. Alternatively,
it is automatically displayed when you perform a search using the Find in Trace dialog
box or perform a search using the Find in Trace command available from the context
menu in the editor window.

Find in Trace *
Timestamp  Address Trace Exc.. =
33 0x40400144 c.swsp =0, 8
36 0x4040014a c.li =0, 0
39 0x40400168 blt =0, al, 0=40400156
41 0x40400158 rem al, =0, a0 ; [RV=HM] -
43 0x4040015¢ c.mw al, =0 i
57 0x40400164 c.addi =0, 1
59 0x40400168 blt =0, al, 0=40400156
61 0x40400158 rem al, =0, a0 ; [RV=HM]
63 0x4040014e c.mv al, =0 s
4 m 3

This window displays the result of searches in the trace data. Double-click an item in the
Find in Trace window to bring up the same item in the Trace window.

Before you can view any trace data, you must specify the search criteria in the Find in
Trace dialog box, see Find in Trace dialog box, page 194.

See also Searching in trace data, page 178.

Requirements

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace
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Display area

The Find in Trace window looks like the Trace window and shows the same columns
and data, but only those rows that match the specified search criteria.

C-SPY® Debugging Guide
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The application timeline

e Introduction to analyzing your application’s timeline
e Analyzing your application’s timeline

e Reference information on application timeline

Introduction to analyzing your application’s timeline
These topics are covered:

e Briefly about analyzing the timeline

o Requirements for timeline support
See also:

e Trace, page 175

BRIEFLY ABOUT ANALYZING THE TIMELINE

C-SPY can provide information for various aspects of your application, collected when
the application is running. This can help you to analyze the application’s behavior.

You can view the timeline information in different representations:

e Asdifferent graphs that correlate with the running application in relation to a shared
time axis.
e As detailed logs

o As summaries of the logs.

Timeline information can be provided for:

Call stack Can be represented in the Timeline window, as a graph that displays the
sequence of function calls and returns collected by the trace system. You
get timing information between the function invocations.

Note that there is also a related Call Stack window and a Function
Trace window, see Call Stack window, page 70 and Function Trace
window, page 190, respectively.
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Data logging Based on data logs collected by the trace system for up to four different
variables or address ranges, specified by means of Data Log
breakpoints. Choose to display the data logs:

o In the Timeline window, as a graph of how the values change over
time.
o In the Data Log window and the Data Log Summary window.
Interrupt Based on interrupt logs collected by the trace system. Choose to display
logging the interrupt logs:
o In the Timeline window, as a graph of the interrupt events during
the execution of your application.
o In the Interrupt Log window and the Interrupt Log Summary

window.

Interrupt logging can, for example, help you locate which interrupts you
can fine-tune to make your application more efficient.

For more information, see the chapter Interrupts.

REQUIREMENTS FOR TIMELINE SUPPORT

Depending on the capabilities of the hardware, the debug probe, and the C-SPY driver
you are using, timeline information is supported for:

Target system Call Stack Data logging Interrupt logging
C-SPY simulator Yes Yes Yes
C-SPY I-Jet driver Yes — —

Table 7: Support for timeline information

For more information about requirements related to trace data, see Requirements for
using trace, page 177.

Analyzing your application’s timeline

C-SPY® Debugging Guide

198  for RISC-V

These tasks are covered:

e Displaying a graph in the Timeline window
e Navigating in the graphs

e Analyzing performance using the graph data

e Getting started using data logging
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See also:

o Using the interrupt system, page 247

DISPLAYING A GRAPH IN THE TIMELINE WINDOW

The Timeline window can display several graphs—follow this example procedure to
display any of these graphs. For an overview of the graphs and what they display, see
Briefly about analyzing the timeline, page 197.

Choose Timeline from the C-SPY driver menu to open the Timeline window.

In the Timeline window, right-click in the window and choose Select Graphs from the
context menu to select which graphs to be displayed.

In the Timeline window, right-click in the graph area and choose Enable from the
context menu to enable a specific graph.

Click Go on the toolbar to start executing your application. The graphs that you have
enabled appear.

NAVIGATING IN THE GRAPHS

After you have performed the steps in Displaying a graph in the Timeline window, page
199, you can use any of these alternatives to navigate in the graph:

e Right-click and from the context menu choose Zoom In or Zoom Out.
Alternatively, use the + and — keys. The graph zooms in or out depending on which
command you used.

e Right-click in the graph and from the context menu choose Navigate and the
appropriate command to move backwards and forwards on the graph. Alternatively,
use any of the shortcut keys—arrow keys, Home, End, and Ctrl+End.

o Double-click on a sample of interest to highlight the corresponding source code in
the editor window and in the Disassembly window.

e Click on the graph and drag to select a time interval, which will correlate to the
running application. The selection extends vertically over all graphs, but appears
highlighted in a darker color for the selected graph. Press Enter or right-click and
from the context menu choose Zoom>Zoom to Selection. The selection zooms in.
Use the navigation keys in combination with the Shift key to extend the selection.

ANALYZING PERFORMANCE USING THE GRAPH DATA
The Timeline window provides a set of tools for analyzing the graph data.

In the Timeline window, right-click and choose Time Axis Unit from the context
menu. Select which unit to be used on the time axis—choose between Seconds and
Cycles. If Cycles is not available, the graphs are based on different clock sources.
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2 Execute your application to display a graph, following the steps described in
Displaying a graph in the Timeline window, page 199.

3 Whenever execution stops, point at the graph with the mouse pointer to get detailed
tooltip information for that location.

— } }

IRQTI at level 1
CPU Clock (5 MHz)

t1: 20148.00 us (100740 cycles)
t2: 20859.20 us (104296 cycles) |

T(t2 - t1): 711.20 us (3556 cycles)

L | BN

—| '7
— =
I = U
IR
Tl
=
0.020s 0.021s 0.022s 0.023s 0.0;

Note that if you have enabled several graphs, you can move the mouse pointer over the
different graphs to get graph-specific information.

4 Click in the graph and drag to select a time interval. Point in the graph with the mouse
pointer to get timing information for the selection.

Start time of

e 127
selection in
seconds and yﬂw
cycles tl: 181.70 us (1817 cycles)

Fl-t2: 194,50 us (1945 cycles ) (MThe frequency that N

correspends tothe

u
-T (£2 - t1): 12.80 us (128 cycles) ul | time incerval

in secends and

‘ End of selection

cycles == i 1/T: 78125 Hz ————— Typically, useful for
; T < periadically
. 5s 0.00020s 0.00025s OCCUrring events.

The time interval
of the selection

C-SPY® Debugging Guide
200 for RISC-V



The application timeline °

GETTING STARTED USING DATA LOGGING
I To set a data log breakpoint, use one of these methods:

e In the Breakpoints window, right-click and choose New Breakpoint>Data Log to
open the breakpoints dialog box. Set a breakpoint on the memory location that you
want to collect log information for. This can be specified either as a variable or as an
address.

e Inthe Memory window, select a memory area, right-click and choose Set Data Log
Breakpoint from the context menu. A breakpoint is set on the start address of the
selection.

e In the editor window, select a variable, right-click and choose Set Data Log
Breakpoint from the context menu. The breakpoint will be set on the part of the
variable that the microcontroller can access using one instruction.

You can set up to four data log breakpoints. For more information, see Data Log
breakpoints, page 107.

2 Choose C-SPY driver>Data Log to open the Data Log window. Optionally, you can
also choose:

o C-SPY driver>Data Log Summary to open the Data Log Summary window

3 From the context menu, available in the Data Log window, choose Enable to enable
the logging.

Start executing your application program to collect the log information.

To view the data log information, look in the Data Log window, or the Data Log
Summary window.

6 If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

7 To disable data logging, choose Disable from the context menu in each window where
you have enabled it.

Reference information on application timeline
Reference information about:

Timeline window—Call Stack graph, page 207
Data Log window, page 202

°
°
® Data Log Summary window, page 205
°

Viewing Range dialog box, page 212
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Data Log window

Requirements

Display area

C-SPY® Debugging Guide
for RISC-V

See also:

o Timeline window—Interrupt Log graph, page 263

The Data Log window is available from the C-SPY driver menu.

Time | Program Counter | 11 Address 52 Address &)
. lG6Es === W 0=0000 @ 0=2004
0.160us O=FFEOOD49 = @ 0=x2000
24 .480us O0=FFEOOOBS R 0=0000 @ 0=2006
24 .720us O=xFFEOOOBF W 0z0042 @ 0z2004
24 .760us O=FFEOOOCE R 0O=0042 @ 0=2006
24 .960us O=FFEOODOE4 W O=00004444 @ 0=2000 y
FE FEfGes O=FFE00104 R 0O=0042 @ O=2004+7
79.000us — W O0=0084 @ 0=2004
100.800us O=FFEOO104 R 0=0084 @ 0=2006
101.040us O=FFEOO10E /// W 0=00CA @ 0=2004
JFE Edfus Overflow 2
136.880us 0OxFFEOOL0E~ = @ 0=2004 a3
White rows indicate Grey rows indicate

read accesses write accesses

Use this window to log accesses to up to four different memory locations or areas.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

See also Getting started using data logging, page 201.

The C-SPY simulator.

Each row in the display area shows the time, the program counter, and, for every tracked
data object, its value and address. All information is cleared on reset. The information
is displayed in these columns:
Time

The time for the data access is based on the clock frequency.

If the time is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.
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This column is available when you have selected Show time from the context
menu.

Cycles
The number of cycles from the start of the execution until the event.

If a cycle is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.

This column is available when you have selected Show cycles from the context
menu.

Program Counter*
Displays one of these:

An address, which is the content of the pc, that is, the address of the instruction
that performed the memory access.

---, the target system failed to provide the debugger with any information.

Overflow in red, the communication channel failed to transmit all data from the
target system.

Value

Displays the access type and the value (using the access size) for the location or
area you want to log accesses to. For example, if zero is read using a byte access
it will be displayed as 0x00, and for a long access it will be displayed as
0x00000000.

To specify what data you want to log accesses to, use the Data Log breakpoint
dialog box. See Data Log breakpoints, page 107.

Address

The actual memory address that is accessed. For example, if only a byte of a
word is accessed, only the address of the byte is displayed. The address is
calculated as base address + offset, where the base address is retrieved from the
Data Log breakpoint dialog box and the offset is retrieved from the logs. If the
log from the target system does not provide the debugger with an offset, the
offset contains + 2.

* You can double-click a line in the display area. If the value of the pc for that line is
available in the source code, the editor window displays the corresponding source code
(this does not include library source code).
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Context menu

C-SPY® Debugging Guide
for RISC-V

This context menu is available:
v Enable
Clear
v Hexadecimal

Save to File...

v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will also happen when you reset the
debugger.

Hexadecimal
Toggles between displaying the selected value in decimal or hexadecimal
format. Note that this setting also affects the log window.

Save to File

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column. If the Time column is displayed by default in the
C-SPY driver you are using, this menu command is not available.

Show Cycles

Displays the Cycles column. If the Cycles column is not supported in the C-SPY
driver you are using, this menu command is not available.
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Data Log Summary window
The Data Log Summary window is available from the C-SPY driver menu.

& Data Total Accesses Read Accesses Write Accesses Unknown Accesses
tvarl 42 8 25 17
tVar2 66 17 49 2]
tvar3 32 32 2] 2]

E Approximative time count: 16

H:E_} Overflow count: 8

E Current fime: 4301.52 us

5

a8

This window displays a summary of data accesses to specific memory location or areas.

See also Getting started using data logging, page 201.

Requirements
The C-SPY simulator.

Display area

Each row in this area displays the type and the number of accesses to each memory

location or area in these columns. Summary information is listed at the bottom of the

display area.

Data
The name of the data object you have selected to log accesses to. To specify
what data object you want to log accesses to, use the Data Log breakpoint
dialog box. See Data Log breakpoints, page 107.

Total Accesses
The total number of accesses.
If the sum of read accesses and write accesses is less than the total accesses, the
target system for some reason did not provide valid access type information for
all accesses.

Read Accesses

The total number of read accesses.

Write Accesses
The total number of write accesses.
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Unknown Accesses

The number of unknown accesses, in other words, accesses where the access
type is not known.

Approximative time count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zZero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time/Current cycles

Context menu

The information displayed depends on the C-SPY driver you are using.
For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

This context menu is available:

v

v

C-SPY® Debugging Guide
206 for RISC-V

Enable
Clear

Save to File...

Show Time

Show Cycles
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These commands are available:

Enable

Enables the logging system. The system will log information also when the
window is closed.

Clear

Deletes the log information. Note that this will also happen when you reset the
debugger.

Save to File

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time

Displays the Time column. If the Time column is displayed by default in the
C-SPY driver you are using, this menu command is not available.

Show Cycles

Displays the Cycles column. If the Cycles column is not supported in the C-SPY
driver you are using, this menu command is not available.

Timeline window—Call Stack graph

The Timeline window is available from the C-SPY driver menu during a debug session.

I Timing information

Timeline =
b -
_w _w _w| _w _w
[putchar]| [putchar]| [putchar]| [putchar]| [putchar]| 3
) |?Springboa| |?Springboa| |?Springboa| |?Springboa| |?Springboa|
putch [_printf 517
?Spring [printf 537 |
_Printf | [nmiHandler::??INTVEC 16 1
printf | [nmiHandler:??INTVEC 16 ;
main 87 / <
9.9999225__.-’" 8.000024s 8.000026s 9.9_9'99285 8.000030s 8.000032s
Il [T 3
Commaon time axis ] { Selection for current graph
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Requirements

This window displays trace data represented as different graphs, in relation to a shared
time axis.

The Call Stack graph displays the sequence of function calls and returns collected by the
trace system.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace

Display area for the Call Stack graph

C-SPY® Debugging Guide
for RISC-V

Each function invocation is displayed as a horizontal bar which extends from the time
of entry until the return. Called functions are displayed above its caller. The horizontal
bars use four different colors:

Medium green for normal C functions with debug information

Light green for functions known to the debugger through an assembler label

Medium yellow for normal interrupt handlers, with debug information

Light yellow for interrupt handlers known to the debugger through an assembler
label

The timing information represents the number of cycles spent in, or between, the
function invocations.

At the bottom of the window, there is a shared time axis that uses seconds or cycles as
the time unit.

Click in the graph to display the corresponding source code.

Note: For highly optimized code, C-SPY might not be able to identify all calls. This
means that for highly optimized code, the call stack is not entirely trustworthy.
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Context menu

This context menu is available:

MNavigate
v Auto Scroll

Zoom

Call Stack
Enable

v | Show Timing
Go to Source
Save to File...
MNavigate Call Stack
Select Graphs
Time Axis Unit

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Navigate
Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll
Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Zoom
Commands for zooming the window, in other words, changing the time scale.
Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.
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Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.
Call Stack

A heading that shows that the Call stack-specific commands below are available.

Enable
Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.

Show Timing

Toggles the display of the timing information on or off.

Go To Source
Displays the corresponding source code in an editor window, if applicable.

Save to File
Saves all contents (or the selected contents) of the Call Stack graph to a file. The
menu command is only available when C-SPY is not running.
Navigate Call Stack>After Current Loop (L)
Identifies the selected program counter and scans the trace data forward,
collecting program counters, until it finds the same address again. It has now
detected a loop. (Loops longer than 1000 instructions are not detected.) Then it
navigates forward until it finds a program counter that is not part of the collected
set. This is useful for navigating out of many iterations of an idle or polling loop.
Navigate Call Stack>Before Current Loop (Shift+L)
Behaves as After Current Loop, but navigates backward out of the loop.

Navigate Call Stack>After Current Function (U)

Navigates to the next unmatched return instruction. This is similar to stepping
out of the current function.

Navigate Call Stack>Before Current Function (Shift+U)
Navigates to the closest previous unmatched call instruction.
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Navigate Call Stack>Next Statement (S)

Navigates to the next instruction that belongs to a different C statement than the
starting point. It skips function calls, i.e. it tries to reach the next statement in
the starting frame.

Navigate Call Stack>Previous Statement (Shift+S)

Behaves as Next statement, but navigates backward to the closest previous
different C statement.

Navigate Call Stack>Next on Same Address (A)

Navigates to the next instance of the starting program counter address, typically
to the next iteration of a loop.

Navigate Call Stack>Previous on Same Address (Shift+A)

Navigates to the closest previous instance of the starting program counter
address.

Navigate Call Stack>Next Interrupt (I)

Navigates to the next interrupt entry. (To then find the matching interrupt exit,
follow up with After Current Function.)

Navigate Call Stack>Previous Interrupt (Shift+I)
Navigates to the closest previous interrupt entry.

Navigate Call Stack>Next Execution Start Point (E)

Navigates to the next point where the CPU was started, for example places
where the application stopped at breakpoints, or was stepped.

Navigate Call Stack>Previous Execution Start Point (Shift+E)

Navigates to the closest previous point where the CPU was started.
Navigate Call Stack>Next Discontinuity (D)

Navigates to the next discontinuity in the trace data.
Navigate Call Stack>Previous Discontinuity (Shift+D)

Navigates to the closest previous discontinuity in the trace data.
Select Graphs

Selects which graphs to be displayed in the Timeline window.
Time Axis Unit

Selects the unit used in the time axis—choose between Seconds and Cycles.

If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.
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Profile Selection

Enables profiling time intervals in the Function Profiler window. Note that this
command is only available if the C-SPY driver supports PC Sampling.

Viewing Range dialog box
The Viewing Range dialog box is available from the context menu that appears when

you right-click in any graph in the Timeline window that uses the linear, levels or
columns style.

Viewing Range g|

Range for power:
(& Auto {currently 0 - 70)
O Factory (5 - 200)
O Custom

Lowest value: Highest value:

Scale:

O Linear
(%) Logarithmic

[ ok |[ Cancel ]

Use this dialog box to specify the value range, that is, the range for the Y-axis for the
graph.

Requirements
The C-SPY simulator.

Range for ...

Selects the viewing range for the displayed values:

Auto
Uses the range according to the range of the values that are actually collected,
continuously keeping track of minimum or maximum values. The currently
computed range, if any, is displayed in parentheses. The range is rounded to
reasonably even limits.

Factory

For the Power Log graph—Uses the range according to the properties of the
measuring hardware (only if supported by the product edition you are using).

For all other graphs—Uses the range according to the value range of the
variable, for example 0-65535 for an unsigned 16-bit integer.

C-SPY® Debugging Guide
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Scale

Custom

Use the text boxes to specify an explicit range.

Selects the scale type of the Y-axis:

e Linear

e Logarithmic

The application timeline °
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Profiling
e Introduction to the profiler

e Using the profiler

e Reference information on the profiler

Introduction to the profiler
These topics are covered:

e Reasons for using the profiler
e Briefly about the profiler

e Requirements for using the profiler

REASONS FOR USING THE PROFILER

Function profiling can help you find the functions in your source code where the most
time is spent during execution. You should focus on those functions when optimizing
your code. A simple method of optimizing a function is to compile it using speed
optimization. Alternatively, you can move the data used by the function into more
efficient memory. For detailed information about efficient memory usage, see the /AR
C/C++ Development Guide for RISC-V.

Alternatively, you can use filtered profiling, which means that you can exclude, for
example, individual functions from being profiled. To profile only a specific part of your
code, you can select a time interval—using the Timeline window—for which C-SPY
produces profiling information.

Instruction profiling can help you fine-tune your code on a very detailed level, especially
for assembler source code. Instruction profiling can also help you to understand where
your compiled C/C++ source code spends most of its time, and perhaps give insight into
how to rewrite it for better performance.

BRIEFLY ABOUT THE PROFILER

Function profiling information is displayed in the Function Profiler window, that is,
timing information for the functions in an application. Profiling must be turned on
explicitly using a button on the window’s toolbar, and will stay enabled until it is turned
off.
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For debug probes that support it, C-SPY can capture full instruction trace in real time,
and process the information for the Function Profiler window.

Instruction profiling information is displayed in the Disassembly window, that is, the
number of times each instruction has been executed.

Profiling sources

The profiler can use different mechanisms, or sources, to collect profiling information.
Depending on the available trace source features, one or more of the sources can be used
for profiling:

o Trace (calls)

The full instruction trace is analyzed to determine all function calls and returns.
When the collected instruction sequence is incomplete or discontinuous, the
profiling information is less accurate.

o Trace (flat)
Each instruction in the full instruction trace or each PC Sample is assigned to a
corresponding function or code fragment, without regard to function calls or returns.
This is most useful when the application does not exhibit normal call/return
sequences, such as when you are using an RTOS, or when you are profiling code
which does not have full debug information.

REQUIREMENTS FOR USING THE PROFILER

The C-SPY simulator supports the profiler; there are no specific requirements.

To use the profiler in a hardware debugger system, you need an I-jet or I-jet Trace debug
probe and a device that supports trace. For information about the different types of trace
data and their limitations, see Briefly about trace, page 175.

This table lists the C-SPY driver profiling support:

C-SPY driver Trace (calls) Trace (flat)
C-SPY simulator Yes Yes

C-SPY I-Jet driver — Yes

GDB Server — —

Table 8: C-SPY driver profiling support

Using the profiler

C-SPY® Debugging Guide
for RISC-V

These tasks are covered:

o Getting started using the profiler on function level
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e Analyzing the profiling data

e Getting started using the profiler on instruction level

GETTING STARTED USING THE PROFILER ON FUNCTION
LEVEL

To display function profiling information in the Function Profiler window:

Build your application using these options:

Category Setting
C/C++ Compiler Output>Generate debug information
Linker Output>Include debug information in output

Table 9: Project options for enabling the profiler

When you have built your application and started C-SPY, choose C-SPY
driver>Function Profiler to open the Function Profiler window, and click the
Enable button to turn on the profiler. Alternatively, choose Enable from the context
menu that is available when you right-click in the Function Profiler window.

Start executing your application to collect the profiling information.

Profiling information is displayed in the Function Profiler window. To sort, click on
the relevant column header.

When you start a new sampling, you can click the Clear button—alternatively, use the
context menu—to clear the data.

ANALYZING THE PROFILING DATA
Here follow some examples of how to analyze the data.

The first figure shows the result of profiling using Source: Trace (calls). The profiler

follows the program flow and detects function entries and exits.

e For the InitFib function, Flat Time 231 is the time spent inside the function itself.

e For the InitFib function, Acc Time 487 is the time spent inside the function itself,
including all functions InitFib calls.

e For the InitFib/GetFib function, Acc Time 256 is the time spent inside GetFib (but
only when called from InitFib), including any functions GetFib calls.
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e Further down in the data, you can find the GetFib function separately and see all of
its subfunctions (in this case none).

X
Function Calls Flat Tirme  FlatTime (%)  Acc. Time  Acc Time (%)
= rnain 1 165 3.58 4356 94 .39 |—|
| DoForegroundProcess 10 3704
InitFik i 487
PutFib 10 3174 68.78 3174 68.78
MextCounter 10 100 A il 7 100 il
= InitFib il @ 5.01 487 10.55
= GetFib 18 256
GetFib 28 4186 9.01 4186 9.01
=  DoForegroundProcess 10 270 5.85 3704 80.26
MextCounter 10
PutFik 10
= <Cther> 0 98.a5
HiE main 1
Source: Trace (calls)
Source: Trace (flat)
4 i | »

The second figure shows the result of profiling using Source: Trace (flat). In this case,
the profiler does not follow the program flow, instead the profiler only detects whether
the pc address is within the function scope. For incomplete trace data, the data might
contain minor errors.

C-SPY® Debugging Guide
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For the InitFib function, Flat Time 231 is the time (number of hits) spent inside the

function itself.

<|dle>

<Mo function>
DoForegroundProcess
GetFib

InitFiky

MextCounter

PutFib

__crain, ?main

__ dwrite

_ exit
__iar_close_ftio
__iar_copy_init3
__iar_data_init3
__iar_get_ttio
__iar_lookup_ttich
__iar_sh_stdout

- IEEEEEEEREEEEEEERE

I

FCCount  PC Count (%)

0
5
90
260
141
&0
230
4

v

v

0.00
0.21
&l o5
11.12
6.03
2.57
9.84
0.17
R

Enable
Clear

Filtering

Source; alls’
@e: Trace (flat)

m

To secure valid data when using a debug probe, make sure to use the maximum trace
buffer size and set a breakpoint in your code to stop the execution before the buffer is

full.

Note: The <No function> entry represents PC values that are not within the known
C-SPY ranges for the application.

GETTING STARTED USING THE PROFILER ON INSTRUCTION

LEVEL

To display instruction profiling information in the Disassembly window:

When you have built your application and started C-SPY, choose View>Disassembly
to open the Disassembly window, and choose Instruction Profiling>Enable from the
context menu that is available when you right-click in the left-hand margin of the

Disassembly window.

Make sure that the Show command on the context menu is selected, to display the

profiling information.

Start executing your application to collect the profiling information.

When the execution stops, for instance because the program exit is reached or a
breakpoint is triggered, you can view instruction level profiling information in the
left-hand margin of the window.
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Disassembly

Goto

mair

ey @

Disassembly
__enable_interrupt() ;

0xB80002as: Oxb662
08000200 : Oxe001

DoForegroundProcess() ;
0xB000202: OxE7E£f Oxffes
< MA¥X_FIE)

while (callCount
0xB0002b6: 0x4803
0xB000208 : 0xG800
0xB0002ba: O0x280a
0xB0002bc: Oxd3f9
0xB0002be: Oxbdol
0xB0002c0: O0x40013804
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POF
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»

i
08000206

DoForegroundProces

RO, [PC, #0Oxc]
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RO, #10
0xB000202
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For each instruction, the number of times it has been executed is displayed.

Reference information on the profiler

Reference information about:

® [Function Profiler window, page 220

See also:

® Disassembly window, page 65

o Trace Settings dialog box, page 180

Function Profiler window
The Function Profiler window is available from the C-SPY driver menu.
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Function

DoForegroundProcess
GetFib
InitFiky
Initllart
PutFib
UanReceiveHandler
main

Calls Flat Time

49 5770 31.14
[u) [u) 0.00
[u) [u) 0.00
[u) [u) 0.00
4 1332 7.19
4 =11 0.52
[u) [u) 0.00

Flat Time ()

Acc. Time  Acc. Time (%)
7198 38.84
[u) 0.00
[u) 0.00
[u) 0.00
1332 7.19
1428 7.71
[u) 0.00

This window displays function profiling information.
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When Trace (flat) is selected, a checkbox appears on each line in the left-side margin of
the window. Use these checkboxes to include or exclude lines from the profiling.
Excluded lines are dimmed but not removed.

See also Using the profiler, page 216.

Requirements
One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace

Toolbar

The toolbar contains:

I Enable/Disable
O
Enables or disables the profiler.
ﬁl Clear
Clears all profiling data.
E Save

Opens a standard Save As dialog box where you can save the contents of the
window to a file, with tab-separated columns. Only non-expanded rows are
included in the list file.

Graphical view

Overlays the values in the percentage columns with a graphical bar.

Progress bar
Displays a backlog of profiling data that is still being processed. If the rate of
incoming data is higher than the rate of the profiler processing the data, a
backlog is accumulated. The progress bar indicates that the profiler is still
processing data, but also approximately how far the profiler has come in the
process.

Note that because the profiler consumes data at a certain rate and the target
system supplies data at another rate, the amount of data remaining to be
processed can both increase and decrease. The progress bar can grow and shrink
accordingly.
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The content in the display area depends on which source that is used for the profiling
information:

For the Trace (calls) source, the display area contains one line for each function
compiled with debug information enabled. When some profiling information has
been collected, it is possible to expand rows of functions that have called other
functions. The child items for a given function list all the functions that have been
called by the parent function and the corresponding statistics.

For the Trace (flat) source, the display area contains one line for each C function of
your application, but also lines for sections of code from the runtime library or from
other code without debug information, denoted only by the corresponding
assembler labels. Each executed pC address from trace data is treated as a separate
sample and is associated with the corresponding line in the Profiling window. Each
line contains a count of those samples.

For information about which views that are supported in the C-SPY driver you are using,
see Requirements for using the profiler, page 216.

More specifically, the display area provides information in these columns:

Function (All sources)

The name of the profiled C function.

Calls (Trace (calls))

The number of times the function has been called.

Flat time (Trace (calls))

The time expressed as the estimated number of executed instructions spent
inside the function.

Flat time (%) (Trace (calls))

Flat time expressed as a percentage of the total time.

Acc. time (Trace (calls))

The time expressed as the estimated number of executed instructions spent
inside the function.

Acc. time (%) (Trace (calls))

Accumulated time expressed as a percentage of the total time.

PC Count (Trace (flat))

The number of executed instructions associated with the function.
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PC Count (%) (Trace (flat))

The number of executed instructions associated with the function as a
percentage of the total number of executed instructions.

Context menu

This context menu is available:
v Enable

Clear

v Source: Trace (calls)

Source: Trace (flat)

Save to File...

Show Source

The contents of this menu depend on the C-SPY driver you are using.
These commands are available:

Enable

Enables the profiler. The system will also collect information when the window
is closed.

Clear
Clears all profiling data.

Filtering
Selects which part of your code to profile. Choose between:

Check All—Excludes all lines from the profiling.
Uncheck All—Includes all lines in the profiling.
Load—Reads all excluded lines from a saved file.

Save—Saves all excluded lines to a file. Typically, this can be useful if you are
a group of engineers and want to share sets of exclusions.

These commands are only available when using Trace (flat).

Source

Selects which source to be used for the profiling information. See also Profiling
sources, page 216.

Note that the available sources depend on the C-SPY driver you are using.
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Choose between:

Trace (calls)—the instruction count for instruction profiling is only as complete
as the collected trace data.

Trace (flat}—the instruction count for instruction profiling is only as complete
as the collected trace data.
Save to File

Saves all profiling data to a file.

Show Source

Opens the editor window (if not already opened) and highlights the selected
source line.

C-SPY® Debugging Guide
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Code coverage

e Introduction to code coverage
e Using code coverage

e Reference information on code coverage

Introduction to code coverage
These topics are covered:

e Reasons for using code coverage
e Briefly about code coverage

o Requirements and restrictions for using code coverage

REASONS FOR USING CODE COVERAGE

The code coverage functionality is useful when you design your test procedure to verify
whether all parts of the code have been executed. It also helps you identify parts of your
code that are not reachable.

BRIEFLY ABOUT CODE COVERAGE

The Code Coverage window reports the status of the current code coverage analysis for
C or C++ code. For every program, module, and function, the analysis shows the
percentage of code that has been executed since code coverage was turned on up to the
point where the application has stopped. In addition, all statements that have not been
executed are listed. The analysis will continue until turned off.

For debug probes that support it, C-SPY can capture full instruction trace in real time,
and process the information for the Code Coverage window.

Note: Assembler code is not covered in the Code Coverage window. To view code
coverage for assembler code, use the Disassembly window.

REQUIREMENTS AND RESTRICTIONS FOR USING CODE
COVERAGE

Code coverage is supported by the C-SPY simulator and there are no specific
requirements or restrictions.
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To use code coverage in a hardware debugger system, you need an I-jet or I-jet Trace
debug probe and a device that supports trace. For information about the different types
of trace data and their limitations, see Briefly about trace, page 175.

Using code coverage

These tasks are covered:

e Getting started using code coverage

GETTING STARTED USING CODE COVERAGE

To get started using code coverage:

Before you can use the code coverage functionality, you must build your application
using these options:

Category Setting
C/C++ Compiler Output>Generate debug information
Linker Output>Include debug information in output

Table 10: Project options for enabling code coverage

After you have built your application and started C-SPY, choose View>Code
Coverage to open the Code Coverage window.

Click the Activate button, alternatively choose Activate from the context menu, to
switch on code coverage.

Start the execution. When the execution stops, for instance because the program exit is
reached or a breakpoint is triggered, the code coverage information is updated
automatically.

Reference information on code coverage

C-SPY® Debugging Guide
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Reference information about:
o Code Coverage window, page 227
See also Single stepping, page 58.
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Requirements

ow

The Code Coverage window is available from the View menu.

Code coverage ___4

Code Coverage x
ollalé)
Code Cowverage (%) Code Range File Line Column =
= % GetStarted(Program) 75.8
: % Fibonacci (Module) 90.9 Fibonacei.c
-4 4 DoForegroundP... 100.0
~# ¢ NextCounter 100.0
% main a0.0
4 DoForegroun. . . 0x2000032c-0x2000032 51 5-26 E
4 return 0; 0x2000033c-0x2000034b 53 N
@ Utilities(Module) 68.2 |tilities.c
..o % GetFib 50.0
# retval = Ou; 0x200001 £c-0x200001££ 44 5-16
4 return retval; 0x20000200-0x20000203 4k 316
""" ¢ InitFib 100.0
4 PutFib 58.3
4 dec = 10u, 0x20000044-0x20000047 52 12-21
¢ 1if (out == ... 0x20000048-0x20000053 54 3-20
¢ putchar({'#'); 0%20000054-0x2000005f BB 517
@ putchar('in'); 0%20000060- 0x2000006k B0 518 "

This window reports the status of the current code coverage analysis. For every program,
module, and function, the analysis shows the percentage of code that has been executed
since code coverage was turned on up to the point where the application has stopped. In
addition, all statements that have not been executed are listed. The analysis will continue

until turned off.

Only source code that was compiled with debug information is displayed. Therefore,
startup code, exit code, and library code are not displayed in the window. Furthermore,
coverage information for statements in inlined functions is not displayed. Only the
statement containing the inlined function call is marked as executed.

A statement is considered to be executed when all its instructions have been executed.
By default, when a statement has been executed, it is removed from the window and the
percentage is increased correspondingly.

One of these alternatives:

o The C-SPY simulator

o The I-jet driver and a device that supports trace
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Toolbar

Display area
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The toolbar contains buttons for switching code coverage on and off, clearing the code
coverage information, and saving/restoring the code coverage session. See the
description of the context menu for more detailed information.

The toolbar contains these buttons:

Activate

Switches code coverage on and off during execution.

Clear
Clears the code coverage information. All step points are marked as not
executed.

Save session

Saves your code coverage session data to a * . dat file. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command might not be supported by the C-SPY driver you are
using.

Restore session

Restores previously saved code coverage session data. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command might not be supported by the C-SPY driver you are
using.

Double-clicking a statement or a function in the Code Coverage window displays that
statement or function as the current position in the editor window, which becomes the
active window.

These columns are available:

Code

The code coverage information is displayed as a tree structure, showing the
program, module, function, and statement levels. You can use the plus (+) sign
and minus (-) sign icons to expand and collapse the structure.

These icons give you an overview of the current status on all levels:

Red diamond—0% of the modules or functions has been executed.
Green diamond—100% of the modules or functions has been executed.

e Red and green diamond—Some of the modules or functions have been
executed. This is most directly visible at the instruction level for a branch
instruction or a conditionally executed instruction. For example, coverage



Code coverage ___4

data can indicate that while a branch instruction has executed, control flow
has not both branched and continued in straight execution. Or, in the case of
a conditional instruction, it indicates if the instruction has executed both
with the controlling flag set, and with the controlling flag not set.

Red, green, and yellow colors can be used as highlight colors in the source editor
window. In the editor window, the yellow color signifies partially executed.
Coverage (%)
The amount of statements that has been covered so far, that is, the number of
executed statements divided with the total number of statements.
Code Range
The address range in code memory where the statement is located.
File
The source file where the step point is located.
Line
The source file line where the step point is located.
Column
The source file column where the step point is located.

Context menu

This context menu is available:
v Activate
Clear
Hide Covered Step Points

Show Coverage in Editor

Save Session...
Restore Session...

Save As...

These commands are available:

g Activate

Switches code coverage on and off during execution.
+=| Clear
hui

Hide Covered Step Points

Toggles the display of covered step points on and off. When this option is
selected, executed statements are removed from the window.

Clears the code coverage information. All step points are marked as not
executed.
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Show Coverage in Editor

Toggles the red, green, and yellow highlight colors that indicate code coverage
in the source editor window on and off.

ﬁ | Save session
Saves your code coverage session data to a * . dat file. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command is available on the toolbar. This command might not be
supported by the C-SPY driver you are using.

ﬁ Restore session

Restores previously saved code coverage session data. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command is available on the toolbar. This command might not be
supported by the C-SPY driver you are using.

Save As

Saves the current code coverage result in a text file.

C-SPY® Debugging Guide
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Part 3. Advanced
debugging

This part of the C-SPY® Debugging Guide for RISC-V includes these chapters:
e Multicore debugging

e Interrupts

e C-SPY macros

e The C-SPY command line utility—cspybat

e Flash loaders

.hﬁhhhhm
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Multicore debugging

e Introduction to multicore debugging
e Debugging multiple cores

e Reference information on multicore debugging

Introduction to multicore debugging
These topics are covered:

e Briefly about multicore debugging
e Symmetric multicore debugging
e Asymmetric multicore debugging

o Requirements and restrictions for multicore debugging

BRIEFLY ABOUT MULTICORE DEBUGGING

Multicore debugging means that you can debug targets with multiple cores. The C-SPY
debugger supports multicore debugging in two ways:

o Symmetric multicore debugging (SMP), which means debugging two or more
identical cores. This is handled using a single instance of the IAR Embedded
Workbench IDE.

o Asymmetric multicore debugging (AMP), which means debugging two or more
cores based on different architectures. It could be two different RISC-V-cores, for
example an RV32EM and an RV32IMFD. This is handled using two or more
cooperating instances of the IAR Embedded Workbench IDE.

SYMMETRIC MULTICORE DEBUGGING

Symmetric multicore debugging means that the target has two or more identical cores
on the board (usually on the same chip) that typically can be accessed through a single
debug probe.

In the debugger, at any given time the windows show the state of only one of the cores—
the one in focus.

This is an overview of special support for symmetric multicore debugging:

e You can control which core you want the debugger to focus on. This affects editor
windows and the Disassembly, Registers, Watch, Locals, Call Stack window, etc.
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o The Cores window shows a list of all available cores, and gives some information
about each core, such as its execution state. The Multicore toolbar is a complement
to the Cores window,

o The Stack window can show the stack for each core by means of dedicated stack
sections.

o RTOS support is available in separate multicore-aware plugins, Typically, they work
like their single-core plugin counterparts, but handle multiple active tasks on
separate cores. The plugins might also provide the information required by the
Stack window to display the stack for any selected task.

ASYMMETRIC MULTICORE DEBUGGING

Asymmetric multicore means that the target has two or more cores based on different
architectures. To debug the target, two or more IDE instances can be used, where each
instance is connected to one or more identical cores. The IDE instances synchronize so
that debugging sessions can be started and stopped, and the cores can be controlled from
any of the instances. Except for shared memory, each debugging session can only show
information (variables, call stack, etc) about its own cores.

You start one IDE instance manually and that instance is referred to as the master. When
you start an asymmetric multicore debugging session, the master instance can initiate
one or more partner (or slave) instances. The partner instances will be reused if they are
already running.

All instances each require their own project, master and partners. You must set up each
project with the correct processor variant, linker, and debugger options. The master
project must also be configured to act as multicore master or have multicore master
mode enabled.

One possible strategy for download is to combine the debug images for the cores into
one and let the master project download the combined image. In this scenario, the
partners must be configured to attach to a running target, and/or to suppress any
downloading.

Another strategy is to download the master and partners as separate binary images, in
which case you must make sure to avoid any unintentional overlaps in memory.

This is an overview of special support for asymmetric multicore debugging:

e You can control whether to automatically start and stop the whole application or to
run the cores independently of each other.

e Each instance of the IDE displays debug information for the cores that it is
connected to.
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o The Cores window shows a list of all available cores, and gives some information
about each core, such as its execution state. The Multicore toolbar is a complement
to the Cores window,

e When you set a breakpoint, it is only connected to one core, and when the
breakpoint is triggered, that core is stopped.

Note: Stepwise execution in an asymmetric multicore project has one limitation: When
you step in the Disassembly window, or in a C/C++ source window and no breakpoints
are available, the stepping will only affect the current core.

REQUIREMENTS AND RESTRICTIONS FOR MULTICORE
DEBUGGING

The C-SPY simulator supports multicore debugging and there are no specific
requirements or restrictions.

To use multicore debugging in your hardware debugger system, you need a specific
combination of C-SPY driver and debug probe:

o The IAR C-SPY I-jet driver
e An I-jet or I-jet Trace debug probe

Note: There might be restrictions in trace support due to limitations in the hardware you
are using.

Debugging multiple cores

These tasks are covered:

e Setting up for symmetric multicore debugging
e Setting up for asymmetric multicore debugging

e Starting and stopping a multicore debug session

SETTING UP FOR SYMMETRIC MULTICORE DEBUGGING

I Choose Project>Options>Debugger>Multicore and specify the number of cores you
have.

2 You can now start your debug session.

SETTING UP FOR ASYMMETRIC MULTICORE DEBUGGING

There are a number of ways that you can set up for multicore debugging, but this strategy
is recommended:
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1: Preparing the projects
Create a workspace with two or more projects, one for each core or set of cores.

Select an appropriate download strategy. One possible download strategy would be to
combine the images for the cores into one and let the master project download the
combined image. In this scenario, the partners would have to be configured to attach to
a running target, and/or to suppress any downloading.

In the intended master project, choose Project>Options>Debugger>Multicore to
open the Multicore options page.

2A: Setting up one partner project

Select Simple. Specify the options Partner workspace (path), Partner project
(project name), and Partner configuration (build configuration). These settings are
used when the partner session starts.

Mutticore

Symmetric multicore

Asymmetric multicore
(O Disabled
(® Simple

Partner workspace: |C:'-.Temp'-.My‘.'\a'orkspace.eww |

Partner project: | MyProject |

Partner configuration: | Debug
Attach partner to running target Partner cores: IZ
COvemide partner debugger location
Partner debugger: |C:'-.Pn:|gram Files AR Systems'-.Embed|
() Advanced

2 Select the option Attach partner to running target. Use the Partner cores option to

specify the number of cores in the partner project.

By default, the Embedded Workbench instance associated with the partner project must
be installed in the same directory as the Embedded Workbench instance associated with
the master project, for example in c: \Program Files\IAR Systems\Embedded
Workbench N. n. If the two Embedded Workbench instances were installed in different
locations (perhaps because they are not based on the same version (. n) of the
Embedded Workbench shared components), you must select Override partner
debugger location and specify the installation directory of the Embedded Workbench
for the partner project. Note that the Embedded Workbench for the partner project must
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be based on version 9.1.7 or later of the shared components—to check this, choose
Help>About>Product Info.

For more information about the multicore settings, see Multicore, page 377

2B: Setting up two or more partner projects

I Select Advanced. Create a multicore session file in XML format with information
about location and settings of the partner projects and use the browse button to specity
this file. For more information about this file, see The multicore session file, page 241.
These settings are used when the partner session starts.

Mutticore

Symmetric multicore

Asymmetric multicore
(O Disabled
O Simple

Attach partner to running target 2

COvemide partner debugger location

(® Advanced

Session configuration: |C:'-.Temp'-.SessionSpecJcml |

3: Make final settings
I Select appropriate reset strategies for all projects:
e In the master project, choose Project>Options>C-SPY driver>Setup>Reset and
select a reset strategy, typically Hardware.

e In the Workspace window, switch to the partner projects one at a time. Then for
each project, choose Project>Options>C-SPY driver>Setup>Reset and select a
reset strategy for the partner session that does not affect the master session,
typically Software.

2 Make sure to use compatible settings for the debug probe for all projects.
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The master and partner instances are indicated in the main IDE window title bar.

File Edit WView Project Debug Ijet Tools Window Help

NOE = I O C o &

i .
@ GettingStarted Partner 1 -;’-\R Embedded Workbench I

File Edit WView Project Debug Ijet Tools Winde
NOoEA = X0/ D C

Workspace - o x ’ﬁ
FibonaceiSlave - Debug ~ | |ME
Files L .

B [ GetingStarted

= @ Fibonacci - Debug 4

STARTING AND STOPPING A MULTICORE DEBUG SESSION

To start a multicore debug session, for example use the standard Download and
Debug command, either in the master or in a partner session.

To stop a multicore debug session, for example use the standard Stop Debugging
command, which will stop all debugging sessions.

Reference information on multicore debugging

C-SPY® Debugging Guide
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Reference information about:
o Cores window, page 239
® Multicore toolbar, page 241

® The multicore session file, page 241
See also:

o  getNumberOfCores, page 295
o  getSelectedCore, page 295
o  selectCore, page 308
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Cores window

The Cores window is available from the View menu.

Cores * o X
Core Status PC Cycles
[ 0:PE Stopped 0=40400152 -
o 7oA Stead fad 400140 -

This window shows a list of all available cores, and gives some information about each
core, such as its execution state. The line highlighted in bold is the core currently in
focus, which means that any window showing information that is specific to a core will
be updated to reflect the state of the core in focus. This includes highlights in editor
windows and the Disassembly, Registers, Watch, Locals, Call Stack window, and so
on. Double-click a line to focus on that core.

Note: For asymmetric multicore debugging, only local cores can be in focus.

See also Debugging multiple cores, page 235.

Requirements
One of these alternatives:

o The C-SPY simulator
e An I-jet or I-jet Trace debug probe

Display area
A row in this area shows information about a core, in these columns:
Execution state
Displays one of these icons to indicate the execution state of the core:
- in focus, not executing
O not in focus, not executing
El in focus, executing
Cx not in focus, executing
j in focus, unknown status
not in focus, unknown status

Core
The name of the core.
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Status
The status of the execution, which can be one of Stopped, Running, Sleeping,
or Unknown.

PC
The value of the program counter.

Cycles | Time
The value of the cycle counter or the execution time since the start of the
execution, depending on the debugger driver you are using.

For symmetric multicore debugging, this context menu is available:
Start Core
Stop Core
Focus on Core (also double-click)
v Run/Step/Stop affect all cores

Run/Step/Stop affect current core only

These commands are available:

Start Core
Starts the selected core.

Stop Core

Stops the selected core.

Focus on Core (also double-click)
Focuses on the selected core.

Run/Step/Stop affect all cores
The Run, Step, Stop commands affect all cores.

Run/Step/Stop affect current core only

The Run/Step/Stop commands only affect the current core. This menu
command is only supported if your device supports it.

Note: These commands are not supported by all target hardware.
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Multicore toolbar

The Multicore toolbar can be toggled on/off from the Window>Toolbars submenu
when you have enabled multicore debugging, see Setting up for asymmetric multicore
debugging, page 235.

Execution state

Start all cores
for core 0

U:ElY 1::>V|I W

Commands for
starting/stopping
core 0

Stop all cores

This toolbar is a complement to and shows the same state as the Cores window. Each
core has a button with an adjacent drop-down menu. Click a button to make C-SPY
focus on that core.

Note: You can use the toolbar commands to start and stop cores in the associated
debugging session.

The multicore session file

This file in XML format can be used to specify an asymmetric debug session with more
than two IDE instances. You specify the location of the file to the IDE on the
Project>Options>Debugger>Multicore page. For more information, see Setting up
for asymmetric multicore debugging, page 235, and Multicore, page 377,

XML specification
The multicore session file needs to look like this:

<?xml version="1.0" encoding="utf-8"?>
<sessionSetup>

<partner>
<name>Name_of_master_instance</name>
<workspace>Path_to_workspace</workspace>
<project>Name_of_ project</project>
<config>Build _config</config>
<numberOfCores>N</numberOfCores>
<attachToRunningTarget>true/false</attachToRunningTarget>
</partner>
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<partner>
<name>Name_of_partner_instance_Il</name>
<workspace>Path_to_workspace</workspace>
<project>Name_of_ project</project>
<config>Build config</config>
<numberOfCores>N</numberOfCores>
<attachToRunningTarget>true/false</attachToRunningTarget>

<debuggerpath>Path_to_Embedded_workbench</debuggerpath>
</partner>

<partner>
<name>Name_of_partner_instance_N</name>
<workspace>Path_to_workspace</workspace>
<project>Name_of_project</project>
<config>Build _config</config>
<numberOfCores>N</numberOfCores>
<attachToRunningTarget>true/false</attachToRunningTarget>

<debuggerpath>Path_to_Embedded_workbench</debuggerpath>
</partner>

</sessionSetup>

C-SPY® Debugging Guide
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Interrupts

e Introduction to interrupts
e Using the interrupt system

e Reference information on interrupts

Introduction to interrupts
These topics are covered:

Briefly about the interrupt simulation system
Interrupt characteristics

Interrupt simulation states

C-SPY system macros for interrupt simulation

Target-adapting the interrupt simulation system

Briefly about interrupt logging
See also:
® Reference information on C-SPY system macros, page 283

® Breakpoints, page 105
o The [AR C/C++ Development Guide for RISC-V

BRIEFLY ABOUT THE INTERRUPT SIMULATION SYSTEM

By simulating interrupts, you can test the logic of your interrupt service routines and

debug the interrupt handling in the target system long before any hardware is available.
If you use simulated interrupts in conjunction with C-SPY macros and breakpoints, you
can compose a complex simulation of, for instance, interrupt-driven peripheral devices.

The C-SPY Simulator includes an interrupt simulation system where you can simulate
the execution of interrupts during debugging. You can configure the interrupt simulation
system so that it resembles your hardware interrupt system.

The interrupt system has the following features:

e Simulated interrupt support for RISC-V
e Single-occasion or periodical interrupts based on the cycle counter

e Predefined interrupts for various devices
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e Configuration of hold time, probability, and timing variation
State information for locating timing problems

Configuration of interrupts using a dialog box or a C-SPY system macro—that is,
one interactive and one automating interface. In addition, you can instantly force an
interrupt.

e A log window that continuously displays events for each defined interrupt.
e A status window that shows the current interrupt activities.
All interrupts you define using the Interrupt Configuration window are preserved

between debug sessions, unless you remove them. A forced interrupt, on the other hand,
exists only until it has been serviced and is not preserved between sessions.

The interrupt simulation system is activated by default, but if not required, you can turn
off the interrupt simulation system to speed up the simulation. To turn it off, use either
the Interrupt Configuration window or a system macro.

INTERRUPT CHARACTERISTICS

The simulated interrupts consist of a set of characteristics which lets you fine-tune each
interrupt to make it resemble the real interrupt on your target hardware. You can specify
a first activation time, a repeat interval, a hold time, a variance, and a probability.

H H H
Activation | |_‘ |_|—| | | |
signal } I | I I
F‘meI ] | | | l |
cycles
B Ton ot wt it
A A+R A+2R A+3R

*If probability is less than 100%, some interrupts may be omitted.

A = Activation time
R = Repeat interval
H =Hold time

Y =Variance

The interrupt simulation system uses the cycle counter as a clock to determine when an
interrupt should be raised in the simulator. You specify the first activation time, which
is based on the cycle counter. C-SPY will generate an interrupt when the cycle counter
has passed the specified activation time. However, interrupts can only be raised between
instructions, which means that a full assembler instruction must have been executed
before the interrupt is generated, regardless of how many cycles an instruction takes.

To define the periodicity of the interrupt generation you can specify the repeat interval
which defines the amount of cycles after which a new interrupt should be generated. In
addition to the repeat interval, the periodicity depends on the two options probability—
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the probability, in percent, that the interrupt will actually appear in a period—and
variance—a time variation range as a percentage of the repeat interval. These options
make it possible to randomize the interrupt simulation. You can also specify a kold time
which describes how long the interrupt remains pending until removed if it has not been
processed. If the hold time is set to infinite, the corresponding pending bit will be set
until the interrupt is acknowledged or removed.

INTERRUPT SIMULATION STATES

The interrupt simulation system contains status information that you can use for locating
timing problems in your application. The Interrupt Status window displays the
available status information. For an interrupt, these states can be displayed: Idle,
Pending, Executing, or Suspended.

Normally, a repeatable interrupt has a specified repeat interval that is longer than the
execution time. In this case, the status information at different times looks like this:

Hold time
- >
| T

| | |
Interrupt A B | C DI E F | G H
activation | I \ - = =
signal
En | | I

——— Iq

| .
Execution time for

interrupt handler

Time Status

A Idle

B Pending
D Executing

E Idle

F Pending

G, H Executing
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However, if the interrupt repeat interval is shorter than the execution time, and the
interrupt is reentrant (or non-maskable), the status information at different times looks
like this:

Hold time
T
1 |
Interrupt A B C D Ei F G
activation ! ! L
signal : !
1

Execution time for

interrupt invocation (1) Execution time for

interrupt invocation (2)

Time Status
A Idle
B Pending

C,DE Executing
FG 1stinterrupt: Suspended
2nd interrupt: Executing

An execution time that is longer than the repeat interval might indicate that you should
rewrite your interrupt handler and make it faster, or that you should specify a longer
repeat interval for the interrupt simulation system.

C-SPY SYSTEM MACROS FOR INTERRUPT SIMULATION

Macros are useful when you already have sorted out the details of the simulated interrupt
so that it fully meets your requirements. If you write a macro function containing
definitions for the simulated interrupts, you can execute the functions automatically
when C-SPY starts. Another advantage is that your simulated interrupt definitions will
be documented if you use macro files, and if you are several engineers involved in the
development project you can share the macro files within the group.

The C-SPY Simulator provides these predefined system macros related to interrupts:

__cancelAllInterrupts
__cancellInterrupt
__disablelInterrupts
__enablelInterrupts

__orderInterrupt

__popSimulatorInterruptExecutingStack

The parameters of the first five macros correspond to the equivalent entries of the
Interrupt Configuration window.

For more information about each macro, see Reference information on C-SPY system
macros, page 283.
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TARGET-ADAPTING THE INTERRUPT SIMULATION SYSTEM

The interrupt simulation system is easy to use. However, to take full advantage of the
interrupt simulation system you should be familiar with how to adapt it for the processor
you are using.

The interrupt simulation has the same behavior as the hardware. This means that the
execution of an interrupt is dependent on the status of the global interrupt enable bit. The
execution of maskable interrupts is also dependent on the status of the individual
interrupt enable bits.

To simulate device-specific interrupts, the interrupt system must have detailed
information about each available interrupt. This information is provided in the device
description files.

For information about device description files, see Selecting a device description file,
page 43.

BRIEFLY ABOUT INTERRUPT LOGGING

Interrupt logging provides you with comprehensive information about the interrupt
events. This might be useful, for example, to help you locate which interrupts you can
fine-tune to become faster. You can log entrances and exits to and from interrupts. You
can also log internal interrupt status information, such as triggered, expired, etc. In the
IDE:

o The logs are displayed in the Interrupt Log window

o A summary is available in the Interrupt Log Summary window

e The Interrupt graph in the Timeline window provides a graphical view of the
interrupt events during the execution of your application

Requirements for interrupt logging

Interrupt logging is supported by the C-SPY simulator.

See also Getting started using interrupt logging, page 250.

Using the interrupt system

These tasks are covered:

e Simulating a simple interrupt
e Simulating an interrupt in a multi-task system

e Getting started using interrupt logging
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See also:

o Using C-SPY macros, page 269 for details about how to use a setup file to define
simulated interrupts at C-SPY startup

e The tutorial Simulating an interrupt in the Information Center.

SIMULATING A SIMPLE INTERRUPT

This example demonstrates the method for simulating a timer interrupt. However, the
procedure can also be used for other types of interrupts.

To simulate and debug an interrupt:

Assume this simple application for a SiFive E24 Arty 100T device. It contains an
interrupt service routine for a timer, which increments a tick variable. The main
function sets the necessary status registers. The application exits when 100 interrupts
have been generated.

#pragma language = extended
#include <sdtio.h>

#include <stint.h>

#include <intrinsics.h>
#include <SiFive/ioe24arty.h>

static volatile uint_fast8_t ticks = 0;
void main (void)
{

// Enable timer interrupt (CLINT)

_ _set_bits_csr(_CSR_MIE, 0x80);

__enable_interrupt () ; /* Enable interrupts */
while (ticks < 100); /* Wait loop */

// Disable timer interrupt (CLINT)
__clear_bits_csr(_CSR_MIE, 0x80);

_ _disable_interrupt(); /* Disable interrupts */
printf ("Done\n") ;

/* Timer interrupt service routine */
#pragma vector = 7
__interrupt void basic_timer (void)
{
ticks += 1;

}
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Add your interrupt service routine to your application source code and add the file to
your project.

Choose Project>Options>Debugger>Setup and select a device description file. The
device description file contains information about the interrupt that C-SPY needs to be
able to simulate it. Use the Use device description file browse button to locate the dd £
file.

Build your project and start the simulator.

Choose Simulator>Interrupt Configuration to open the Interrupt Configuration
window. Right-click in the window and select Enable Interrupt Simulation on the
context menu. For the timer example, verify these settings:

Option Settings
Interrupt TIMER
First activation 4000
Repeat interval 2000
Hold time 10
Probability (%) 100
Variance (%) 0

Table 11: Timer interrupt settings
Click OK.

Execute your application. If you have enabled the interrupt properly in your application
source code, C-SPY will:

e Generate an interrupt when the cycle counter has passed 4000

e Continuously repeat the interrupt after approximately 2000 cycles.

To watch the interrupt in action, choose Simulator>Interrupt Log to open the
Interrupt Log window.

From the context menu, available in the Interrupt Log window, choose Enable to
enable the logging. If you restart program execution, status information about
entrances and exits to and from interrupts will now appear in the Interrupt Log
window.

For information about how to get a graphical representation of the interrupts correlated
with a time axis, see The application timeline, page 197.

SIMULATING AN INTERRUPT IN A MULTI-TASK SYSTEM

If you are using interrupts in such a way that the normal instruction used for returning
from an interrupt handler is not used, for example in an operating system with
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task-switching, the simulator cannot automatically detect that the interrupt has finished
executing. The interrupt simulation system will work correctly, but the status
information in the Interrupt Configuration window might not look as you expect. If
too many interrupts are executing simultaneously, a warning might be issued.

To simulate a normal interrupt exit:
Set a code breakpoint on the instruction that returns from the interrupt function.

Specify the __popSimulatorInterruptExecutingStack macro as a condition to
the breakpoint.

When the breakpoint is triggered, the macro is executed and then the application
continues to execute automatically.
GETTING STARTED USING INTERRUPT LOGGING

Choose C-SPY driver>Interrupt Log to open the Interrupt Log window. Optionally,
you can also choose:

o C-SPY driver>Interrupt Log Summary to open the Interrupt Log Summary
window

o C-SPY driver>Timeline to open the Timeline window and view the Interrupt graph

From the context menu in the Interrupt Log window, choose Enable to enable the
logging.
Start executing your application program to collect the log information.

To view the interrupt log information, look in the Interrupt Log or Interrupt Log
Summary window, or the Interrupt graph in the Timeline window.

If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

To disable interrupt logging, from the context menu in the Interrupt Log window,
toggle Enable off.
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Reference information about:

Interrupt Configuration window, page 251
Available Interrupts window, page 254

°

°

® Interrupt Status window, page 255
e [nterrupt Log window, page 257

°

Interrupt Log Summary window, page 260
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o Timeline window—Interrupt Log graph, page 263

Interrupt Configuration window
The Interrupt Configuration window is available by choosing Simulator>Interrupt

Configuration.

Interrupt Configuration x
Interrupt Id Type Description First Activation  RepeatInterval  Hold Time Yariance (%) Probability (%)
Ml 0 Single -2 0x08 0 0 inf 0 100
IELO 1 Single 1 0x40 o 0 inf 0 100
HardFault 2 Single -1 0x0C PRIL.. 0 0 inf 0 100
[

| Build | Debug Log | Interrupt Configuration |

This window lists all installed interrupts. Use this window to enable or disable
individual interrupts or the interrupt simulation system, and to edit the properties of
installed interrupts.

See also Using the interrupt system, page 247.

Requirements
The C-SPY simulator.

Display area
This area contains these columns:

Interrupt
Lists all installed interrupts. Use the checkbox to enable or disable the interrupt.

1D
A unique interrupt identifier.

Type
Shows the type of the interrupt. The type can be one of:

Forced, a single-occasion interrupt defined in the Available Interrupts
window.

Single, a single-occasion interrupt.
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Repeat, a periodically occurring interrupt.

If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).

Description

A description of the selected interrupt, if available. The description is retrieved
from the selected device description file and consists of a string describing the
vector address, the enable bit, the pending bit, the default priority, whether it is
an exception or an interrupt, maskable or non-maskable, and the interrupt type
(Reserved), separated by space characters. For interrupts specified using the
system macro __orderInterrupt, the Description box is empty.

First Activation
The value of the cycle counter after which the specified interrupt will be
generated. Click to edit.

Repeat Interval
The periodicity of the interrupt in cycles. Click to edit.

Hold Time
How long, in cycles, the interrupt remains pending until removed if it has not
been processed. Click to edit. If you specify inf, the corresponding pending bit
will be set until the interrupt is acknowledged or removed.

Variance %

A timing variation range, as a percentage of the repeat interval, in which the
interrupt might occur for a period. For example, if the repeat interval is 100 and
the variance 5%, the interrupt might occur anywhere between T=95 and T=105,
to simulate a variation in the timing. Click to edit.

Probability %

The probability, in percent, that the interrupt will actually occur within the
specified period. Click to edit.
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Context menu
This context menu is available:
v | Enable Interrupt Simulation
IELO:
v Enable

Rermove

Add Interrupt 3

Rermove All

Open Available Interrupts Window

These commands are available:

Enable Interrupt Simulation
Enables or disables the entire interrupt simulation system. If the interrupt
simulation is disabled, the definitions remain but no interrupts are generated.
Note that you can also enable and disable installed interrupts individually by
using the check box to the left of the interrupt name in the list of installed
interrupts.

Enable

Enables or disables the individual interrupt you clicked on.

Remove
Removes the individual interrupt you clicked on.

Add Interrupt
Selects an interrupt to install. The drop-down list contains all available
interrupts. Your selection will automatically update the Description box. The
list is populated with entries from the device description file that you have
selected.

Remove All
Removes all installed interrupts in the window.

Open Available Interrupts Window

Opens the Available Interrupts window, see Available Interrupts window, page
254.
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The Available Interrupts window is available from the C-SPY driver menu.

Available Interrupts x
Interrupt Description i
IELSZ 10x1B0
IELS3 10x1B4
IEL34 10x1B8
IELS5 10<1BC
Memianage 10x10
Tl -2 0=08
PendSy 1038
SWC 10x2C
SysTick 10x3C
UsageFault 10x18 i

Use this window for an overview of all available interrupts for your project. You can also
use it for forcing an interrupt instantly. This is useful when you want to check your
interrupt logic and interrupt routines. Just start typing an interrupt name and focus shifts
to the first line found with that name.

The hold time for a forced interrupt is infinite, and the interrupt exists until it has been
serviced or until a reset of the debug session.

To sort the window contents, click on either the Interrupt or the Description column
header. A second click on the same column header reverses the sort order.

To force an interrupt:
Enable the interrupt simulation system, see Interrupt Configuration window, page 251.

Activate the interrupt by choosing the Force Interrupt command from the context
menu.

The C-SPY simulator.

This area lists all available interrupts and their definitions. This information is retrieved
from the selected device description file. See this file for a detailed description.
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This context menu is available:
Add to Configuration

Force Interrupt

Open Configuration Window

These commands are available:

Add to Configuration

Installs the selected interrupt and adds it to the Interrupt Configuration
window.

Force Interrupt
Triggers the selected interrupt.
Open Configuration Window

Opens the Interrupt Configuration window, see Interrupt Configuration
window, page 251.

Interrupt Status window

Requirements

Display area

The Interrupt Status window is available from the C-SPY driver menu.

Interrupt Status * O X

Interrupt D Type Status Mext Time Timing [eycles]
TIM_INT 1 Single Idle o 0
MNRAI 0 Single Idle 0 0
SClo_lo 2 Repeat{macra) Idle 4000 4000 + n*2000

This window shows the status of all the currently active interrupts, in other words
interrupts that are either executing or waiting to be executed.

The C-SPY simulator.

This area contains these columns:

Interrupt

Lists all interrupts.
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ID
A unique interrupt identifier.
Type
The type of the interrupt. The type can be one of:
Forced, a single-occasion interrupt defined in the Available Interrupts
window.
Single, a single-occasion interrupt.
Repeat, a periodically occurring interrupt.
If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).
Status
The state of the interrupt:
Idle, the interrupt activation signal is low (deactivated).
Pending, the interrupt activation signal is active, but the interrupt has not been
yet acknowledged by the interrupt handler.
Executing, the interrupt is currently being serviced, that is the interrupt handler
function is executing.
Suspended, the interrupt is currently suspended due to execution of an interrupt
with a higher priority.
(deleted) is added to Executing and Suspended if you have deleted a currently
active interrupt. (deleted) is removed when the interrupt has finished executing.
Next Time
The next time an idle interrupt is triggered. Once a repeatable interrupt stats
executing, a copy of the interrupt will appear with the state Idle and the next time
set. For interrupts that do not have a next time—that is pending, executing, or
suspended—the column will show --.
Timing

The timing of the interrupt. For a Single and Forced interrupt, the activation
time is displayed. For a Repeat interrupt, the information has the form:
Activation Time + n*Repeat Time. For example, 2000 + n*2345. This
means that the first time this interrupt is triggered, is at 2000 cycles and after that
with an interval of 2345 cycles.

C-SPY® Debugging Guide
256 for RISC-V
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Requirements

Display area
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The Interrupt Log window is available from the C-SPY driver menu.

Interrupt Log *®
Time  Interrupt Status Frogram Counter Execution Time i
189.32 us IRQTO Triggered Bx13E8
111.26 us IRQTO Enter Bx13F@
135.78 us IRQT1 Enter Bx1126
148.72 us IRQT1 Leave Bx1378 12.94 us
189.34 us Overflow
29?:’-_39 us  IRQTO Leave Bx1126 96.84 us
230.00 us IRQTO Triggered 9x1118
231.34 us IRQTO Enter 0x1126
248.26\us IRQTO Leave Bx1122 . 8.92 us
300.00 s IRQTL Enter . ---
371.12 L,Ii"& IRQT1 Leave N, Bx1128 \71.12 us
431.3@ ud_ IROTI Enter - -
\ -
Red indicates overflows Light-celored rows !:)arker =
and italic indicates indicate entrances indicate exits
approximate values to interrupts from interrupts .

This window logs entrances to and exits from interrupts. The C-SPY Simulator also logs
internal state changes.

The information is useful for debugging the interrupt handling in the target system.
When the Interrupt Log window is open, it is updated continuously at runtime.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

For more information, see Getting started using interrupt logging, page 250.

For information about how to get a graphical view of the interrupt events during the
execution of your application, see Timeline window—Interrupt Log graph, page 263.

The C-SPY simulator.

This area contains these columns:
Time

The time for the interrupt entrance, based on an internally specified clock
frequency.
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This column is available when you have selected Show Time from the context
menu.

Cycles
The number of cycles from the start of the execution until the event.

This column is available when you have selected Show Cycles from the context
menu.

Interrupt
The interrupt as defined in the device description file.

Status
Shows the event status of the interrupt:

Triggered, the interrupt has passed its activation time.

Forced, the same as Triggered, but the interrupt was forced from the Available
Interrupts window.

Enter, the interrupt is currently executing.
Leave, the interrupt has been executed.

Expired, the interrupt hold time has expired without the interrupt being
executed.

Rejected, the interrupt has been rejected because the necessary interrupt
registers were not set up to accept the interrupt.

Program Counter
The value of the program counter when the event occurred.

Execution Time/Cycles
The time spent in the interrupt, calculated using the Enter and Leave
timestamps. This includes time spent in any subroutines or other interrupts that
occurred in the specific interrupt.

C-SPY® Debugging Guide
258 for RISC-V
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Context menu

This context menu is available:
v Enable

Clear

Save to File...

v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will also happen when you reset the
debugger.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column. If the Time column is displayed by default in the
C-SPY driver you are using, this menu command is not available.

Show Cycles

Displays the Cycles column. If the Cycles column is not supported in the C-SPY
driver you are using, this menu command is not available.
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Interrupt Log Summary window

The Interrupt Log Summary window is available from the

C-SPY driver menu.

Interrupt Log Summary x
Interrupt Count First Time  Total (Time)  Total (>4) Fastest Slowest in Intersal Max Interval
ADC 5 25 . 560us 95 . 400us 17 .61 16.320us 30.120us 192 640us 1284 . 100us
RTC 4 41 . 700us 55.200us 22 BB 13.800us 13.800us 27 .060us 2687 . 420us

Approximative time count. 1
Cwerflow count. 1
Currenttime:  3350.080us us

Requirements

Display area

C-SPY® Debugging Guide

for RISC-V

This window displays a summary of logs of entrances to and

exits from interrupts.

For more information, see Getting started using interrupt logging, page 250.

For information about how to get a graphical view of the interrupt events during the
execution of your application, see Timeline window—Interrupt Log graph, page 263.

The C-SPY simulator.

Each row in this area displays statistics about the specific interrupt based on the log
information in these columns; and summary information is listed at the bottom of the

display area:
Interrupt

The type of interrupt that occurred.
Count

The number of times the interrupt occurred.
First Time

The first time the interrupt was executed.
Total (Time)**

The accumulated time spent in the interrupt.
Total (%)

The time in percent of the current time.

Fastest®*

The fastest execution of a single interrupt of this type.
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Slowest**

The slowest execution of a single interrupt of this type.

Min Interval
The shortest time between two interrupts of this type.
The interval is specified as the time interval between the entry time for two
consecutive interrupts.
Max Interval
The longest time between two interrupts of this type.
The interval is specified as the time interval between the entry time for two
consecutive interrupts.
Approximative time count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
Zero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time/Current cycles
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

** Calculated in the same way as for the Execution time/cycles in the Interrupt Log
window.
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This context menu is available:
v Enable

Clear

Save to File...

v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will also happen when you reset the
debugger.

Save to File

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column. If the Time column is displayed by default in the
C-SPY driver you are using, this menu command is not available.

Show Cycles

Displays the Cycles column. If the Cycles column is not supported in the C-SPY
driver you are using, this menu command is not available.
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Timeline window—Interrupt Log graph

Requirements

Display area

The Interrupt Log graph displays interrupts collected by the trace system. In other
words, the graph provides a graphical view of the interrupt events during the execution
of your application.

Active interrupt l |Overf|ow |

Timeline \ V4 i ®

P — 3 O

e [
= i E==—Traa

2.00815s 8.000208s 8.00025s 8.000308s 8.90835s

Commaon time axis

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

The C-SPY simulator.

o The label area at the left end of the graph displays the names of the interrupts.

o The graph itself shows active interrupts as a thick green horizontal bar where the

white figure indicates the time spent in the interrupt. This graph is a graphical
representation of the information in the Interrupt Log window, see Interrupt Log
window, page 257.

If the bar is displayed without horizontal borders, there are two possible causes:

o The interrupt is reentrant and has interrupted itself. Only the innermost interrupt
will have borders.

o There are irregularities in the interrupt enter-leave sequence, probably due to
missing logs.

If the bar is displayed without a vertical border, the missing border indicates an

approximate time for the log.

A red vertical line indicates overflow, which means that the communication channel
failed to transmit all interrupt logs from the target system.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.
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Context menu

This context menu is available:

MNavigate 3
v Auto Scroll
Zoom 3
Interrupts
v | Enable
Clear

Go to Source

Sort by 3
IRQTO: 2
Select Graphs 3
Tirme Axis Unit 3

Note: The exact contents of the context menu you see on the screen depends on which
features that your combination of software and hardware supports. However, the list of
menu commands below is complete and covers all possible commands.

These commands are available:

Navigate

Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:

right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:

Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll

Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Zoom

Commands for zooming the window, in other words, changing the time scale.

Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:

Return.

C-SPY® Debugging Guide
264 for RISC-V
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Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Interrupts

A heading that shows that the Interrupt Log-specific commands below are
available.

Enable

Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.

Clear

Deletes the log information. Note that this will also happen when you reset the
debugger.

Go To Source
Displays the corresponding source code in an editor window, if applicable.

Sort by

Sorts the entries according to their ID or name. The selected order is used in the
graph when new interrupts appear.

source

Goes to the previous/next log for the selected source.
Select Graphs

Selects which graphs to be displayed in the Timeline window.
Time Axis Unit

Selects the unit used in the time axis—choose between Seconds and Cycles.

If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.
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e Introduction to C-SPY macros

e Using C-SPY macros

e Reference information on the macro language

e Reference information on reserved setup macro function names
e Reference information on C-SPY system macros

e Graphical environment for macros

Introduction to C-SPY macros

These topics are covered:

e Reasons for using C-SPY macros
e Briefly about using C-SPY macros
e Briefly about setup macro functions and files

e Briefly about the macro language

REASONS FOR USING C-SPY MACROS

You can use C-SPY macros either by themselves or in conjunction with complex
breakpoints and interrupt simulation to perform a wide variety of tasks. Some examples
where macros can be useful:

e Automating the debug session, for instance with trace printouts, printing values of
variables, and setting breakpoints.

e Hardware configuring, such as initializing hardware registers.

e Feeding your application with simulated data during runtime.

e Simulating peripheral devices, see the chapter Inferrupts. This only applies if you
are using the simulator driver.

e Developing small debug utility functions.
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BRIEFLY ABOUT USING C-SPY MACROS
To use C-SPY macros, you should:

e Write your macro variables and functions and collect them in one or several macro
files

e Register your macros
e Execute your macros
For registering and executing macros, there are several methods to choose between.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register or execute your macro.

BRIEFLY ABOUT SETUP MACRO FUNCTIONS AND FILES

There are some reserved setup macro function names that you can use for defining
macro functions which will be called at specific times, such as:

e Once after communication with the target system has been established but before
downloading the application software

e Once after your application software has been downloaded

e FEach time the reset command is issued

o Once when the debug session ends

To define a macro function to be called at a specific stage, you should define and register

a macro function with one of the reserved names. For instance, if you want to clear a

specific memory area before you load your application software, the macro setup

function execUserPreload should be used. This function is also suitable if you want

to initialize some CPU registers or memory-mapped peripheral units before you load
your application software.

You should define these functions in a sefup macro file, which you can load before
C-SPY starts. Your macro functions will then be automatically registered each time you
start C-SPY. This is convenient if you want to automate the initialization of C-SPY, or
if you want to register multiple setup macros.

For more information about each setup macro function, see Reference information on
reserved setup macro function names, page 279.

BRIEFLY ABOUT THE MACRO LANGUAGE

The syntax of the macro language is very similar to the C language. There are:

® Macro statements, which are similar to C statements.

® Macro functions, which you can define with or without parameters and return
values.
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e Predefined built-in system macros, similar to C library functions, which perform
useful tasks such as opening and closing files, setting breakpoints, and defining
simulated interrupts.

® Macro variables, which can be global or local, and can be used in C-SPY
expressions.

® Macro strings, which you can manipulate using predefined system macros.

For more information about the macro language components, see Reference information
on the macro language, page 274.

Example

Consider this example of a macro function which illustrates the various components of
the macro language:

__var oldval;
CheckLatest (val)
{
if (oldval != wval)
{
__message "Message: Changed from ", oldval, " to ", val, "\n";
oldval = wval;
}
}

Note: Reserved macro words begin with double underscores to prevent name conflicts.

Using C-SPY macros

These tasks are covered:

Registering C-SPY macros—an overview

Executing C-SPY macros—an overview

Registering and executing using setup macros and setup files
Executing macros using Quick Watch

Executing a macro by connecting it to a breakpoint

Aborting a C-SPY macro

For more examples using C-SPY macros, see:

e The tutorial about simulating an interrupt, which you can find in the Information
Center

® Initializing target hardware before C-SPY starts, page 48
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REGISTERING C-SPY MACROS—AN OVERVIEW

C-SPY must know that you intend to use your defined macro functions, and therefore
you must register your macros. There are various ways to register macro functions:

You can register macro functions during the C-SPY startup sequence, see
Registering and executing using setup macros and setup files, page 271.

You can register macros interactively in the Macro Registration window, see
Macro Registration window, page 327. Registered macros appear in the Debugger
Macros window, see Debugger Macros window, page 329.

You can register a file containing macro function definitions, using the system
macro __registerMacroFile. This means that you can dynamically select which
macro files to register, depending on the runtime conditions. Using the system
macro also lets you register multiple files at the same moment. For information
about the system macro, see __registerMacrokFile, page 308.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register your macro.

EXECUTING C-SPY MACROS—AN OVERVIEW

There are various ways to execute macro functions:

You can execute macro functions during the C-SPY startup sequence and at other

predefined stages during the debug session by defining setup macro functions in a

setup macro file, see Registering and executing using setup macros and setup files,
page 271.

The Quick Watch window lets you evaluate expressions, and can thus be used for
executing macro functions. For an example, see Executing macros using Quick
Watch, page 271.

The Macro Quicklaunch window is similar to the Quick Watch window, but is
more specifically designed for C-SPY macros. See Macro Quicklaunch window,
page 331.

A macro can be connected to a breakpoint; when the breakpoint is triggered the

macro is executed. For an example, see Executing a macro by connecting it to a
breakpoint, page 272.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to execute your macro.
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REGISTERING AND EXECUTING USING SETUP MACROS AND
SETUP FILES

It can be convenient to register a macro file during the C-SPY startup sequence. To do
this, specify a macro file which you load before starting the debug session. Your macro
functions will be automatically registered each time you start the debugger.

If you use the reserved setup macro function names to define the macro functions, you
can define exactly at which stage you want the macro function to be executed.

To define a setup macro function and load it during C-SPY startup:
Create a new text file where you can define your macro function.
For example:

execUserSetup ()

{

__registerMacroFile ("MyMacroUtils.mac") ;
__registerMacroFile("MyDeviceSimulation.mac") ;

}

This macro function registers the additional macro files MyMacroUtils.mac and
MyDeviceSimulation.mac. Because the macro function is defined with the function
name execUserSetup, it will be executed directly after your application has been
downloaded.

Save the file using the filename extension mac.

Before you start C-SPY, choose Project>Options>Debugger>Setup. Select the Use
macro file option, and choose the macro file you just created.

The macros will now be registered during the C-SPY startup sequence.

EXECUTING MACROS USING QUICK WATCH

The Quick Watch window lets you dynamically choose when to execute a macro
function.

Consider this simple macro function that checks the status of a timer enable bit:

TimerStatus ()
{
if ((TimerStatreg & 0x01) != 0)/* Checks the status of reg */
return "Timer enabled"; /* C-SPY macro string used */
else
return "Timer disabled"; /* C-SPY macro string used */
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Save the macro function using the filename extension mac.

To load the macro file, choose View>Macros>Macro Registration. The Macro
Registration window is displayed. Click Add and locate the file using the file browser.
The macro file appears in the list of macros in the Macro Registration window.

Select the macro you want to register and your macro will appear in the Debugger
Macros window.

Choose View>Quick Watch to open the Quick Watch window, type the macro call
TimerStatus () in the text field and press Return,

Alternatively, in the macro file editor window, select the macro function name
TimerStatus (). Right-click, and choose Quick Watch from the context menu that

appears.
Quick Watch * O X

Expression Yalue Location  Type
TimerStatus() 'Timer disabled® macro string

The macro will automatically be displayed in the Quick Watch window. For more
information, see Quick Watch window, page 97.

EXECUTING A MACRO BY CONNECTING IT TO A
BREAKPOINT

You can connect a macro to a breakpoint. The macro will then be executed when the
breakpoint is triggered. The advantage is that you can stop the execution at locations of
particular interest and perform specific actions there.

For instance, you can easily produce log reports containing information such as how the
values of variables, symbols, or registers change. To do this you might set a breakpoint
on a suspicious location and connect a log macro to the breakpoint. After the execution
you can study how the values of the registers have changed.

To create a log macro and connect it to a breakpoint:
Assume this skeleton of a C function in your application source code:

int fact(int x)

{

}
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2 Create a simple log macro function like this example:

logfact ()
{
__message "fact(" ,x, ")";

}
The __message statement will log messages to the Debug Log window.
Save the macro function in a macro file, with the filename extension mac.

3 To register the macro, choose View>Macros>Macro Registration to open the Macro
Registration window and add your macro file to the list. Select the file to register it.
Your macro function will appear in the Debugger Macros window.

4 To set a code breakpoint, click the Toggle Breakpoint button on the first statement
within the function fact in your application source code. Choose View>Breakpoints
to open the Breakpoints window. Select your breakpoint in the list of breakpoints and
choose the Edit command from the context menu.

5 To connect the log macro function to the breakpoint, type the name of the macro
function, logfact (), in the Action field and click OK to close the dialog box.

6 Execute your application source code. When the breakpoint is triggered, the macro
function will be executed. You can see the result in the Debug Log window.

Note that the expression in the Action field is evaluated only when the breakpoint causes

the execution to really stop. If you want to log a value and then automatically continue

execution, you can either:

e Use a Log breakpoint, see Log breakpoints dialog box, page 120

e Use the Condition field instead of the Action field. For an example, see Performing
a task and continuing execution, page 114.

7 You can easily enhance the log macro function by, for instance, using the __ fmessage
statement instead, which will print the log information to a file. For information about
the __ fmessage statement, see Formatted output, page 277.

For an example where a serial port input buffer is simulated using the method of
connecting a macro to a breakpoint, see the tutorial Simulating an interrupt in the
Information Center.

ABORTING A C-SPY MACRO

To abort a C-SPY macro:
I Press Ctrl+Shift+. (period) for a short while.

2 A message that says that the macro has terminated is displayed in the Debug Log
window.
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This method can be used if you suspect that something is wrong with the execution, for
example because it seems not to terminate in a reasonable time.

Reference information on the macro language
Reference information about:

Macro functions, page 274
Macro variables, page 274
Macro parameters, page 275
Macro strings, page 275
Macro statements, page 276

Formatted output, page 277

MACRO FUNCTIONS

C-SPY macro functions consist of C-SPY variable definitions and macro statements
which are executed when the macro is called. An unlimited number of parameters can
be passed to a macro function, and macro functions can return a value on exit.

A C-SPY macro has this form:

macroName (parameterList)
{
macroBody

}

where parameterList is a list of macro parameters separated by commas, and
macroBody is any series of C-SPY variable definitions and C-SPY statements.

Type checking is neither performed on the values passed to the macro functions nor on
the return value.

MACRO VARIABLES

A macro variable is a variable defined and allocated outside your application. It can then
be used in a C-SPY expression, or you can assign application data—values of the
variables in your application—to it. For more information about C-SPY expressions, see
C-SPY expressions, page 78.

The syntax for defining one or more macro variables is:
__var nameList;

where nameList is a list of C-SPY variable names separated by commas.

C-SPY® Debugging Guide
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A macro variable defined outside a macro body has global scope, and it exists
throughout the whole debugging session. A macro variable defined within a macro body
is created when its definition is executed and destroyed on return from the macro.

By default, macro variables are treated as signed integers and initialized to 0. When a
C-SPY variable is assigned a value in an expression, it also acquires the type of that
expression. For example:

Expression What it means

myvar = 3.5; myvar is now type double, value 3.5.

myvar = (int*)i; myvar is now type pointer to int, and the value is the
same as i.

Table 12: Examples of C-SPY macro variables

In case of a name conflict between a C symbol and a C-SPY macro variable, C-SPY
macro variables have a higher precedence than C variables. Note that macro variables
are allocated on the debugger host and do not affect your application.

MACRO PARAMETERS

A macro parameter is intended for parameterization of device support. The named

parameter will behave as a normal C-SPY macro variable with these differences:

o The parameter definition can have an initializer

e Values of a parameters can be set through options (either in the IDE or in cspybat).

e A value set from an option will take precedence over a value set by an initializer

e A parameter must have an initializer, be set through an option, or both. Otherwise, it
has an undefined value, and accessing it will cause a runtime error.

The syntax for defining one or more macro parameters is:

__param param[=value, ...;]

Use the command line option --macro_param to specify a value to a parameter, see
--macro_param, page 360.

MACRO STRINGS

In addition to C types, macro variables can hold values of macro strings. Note that
macro strings differ from C language strings.

When you write a string literal, such as "Hello! ", in a C-SPY expression, the value is
a macro string. It is not a C-style character pointer char*, because char* must point to
a sequence of characters in target memory and C-SPY cannot expect any string literal to
actually exist in target memory.
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You can manipulate a macro string using a few built-in macro functions, for example
__strFind or __subString. The result can be a new macro string. You can
concatenate macro strings using the + operator, for example str + "tail". You can
also access individual characters using subscription, for example st [3]. You can get the
length of a string using sizeof (str). Note that a macro string is not
NULL-terminated.

The macro function __toString is used for converting from a NULL-terminated C
string in your application (char* or char[]) to a macro string. For example, assume
this definition of a C string in your application:

char const *cstr = "Hello";

Then examine these macro examples:

__var str; /* A macro variable */

str = cstr /* str is now just a pointer to char */

sizeof str /* same as sizeof (char*), typically 2 or 4 */
str = __toString(cstr,512) /* str is now a macro string */
sizeof str /* 5, the length of the string */

str[l] /* 101, the ASCII code for 'e' */

str += " World!" /* str is now "Hello World!" */

See also Formatted output, page 277.

MACRO STATEMENTS

Statements are expected to behave in the same way as the corresponding C statements
would do. The following C-SPY macro statements are accepted:

Expressions
expression;

For more information about C-SPY expressions, see C-SPY expressions, page 78.

Conditional statements

if (expression)
Statement

if (expression)
Statement
else
Statement

C-SPY® Debugging Guide
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Loop statements

for (init_expression; cond_expression; update_expression)
Statement

while (expression)
Statement

do
Statement
while (expression);

Return statements
return;

return expression;

If the return value is not explicitly set, signed int 0 is returned by default.

Blocks

Statements can be grouped in blocks.

{
statementl
statement2

statementN

FORMATTED OUTPUT

C-SPY provides various methods for producing formatted output:

__message argList; Prints the output to the Debug Log window.
__fmessage file, argList; Prints the output to the designated file.
__smessage argList; Returns a string containing the formatted output.

where argList is a comma-separated list of C-SPY expressions or strings, and £ileis
the result of the __openFile system macro, see  openkile, page 301.
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To produce messages in the Debug Log window:

varl = 42;
var2 = 37;
__message "This line prints the values ", varl, " and ", var2,

" in the Debug Log window.";

This produces this message in the Debug Log window:

This line prints the values 42 and 37 in the Debug Log window.
To write the output to a designated file:

__fmessage myfile, "Result is ", res, "!\n";

To produce strings:

myMacroVar = __smessage 42, " is the answer.";

myMacroVar now contains the string "42 is the answer.".

Specifying display format of arguments

To override the default display format of a scalar argument (number or pointer) in
argList, suffix it with a : followed by a format specifier. Available specifiers are:

b for binary scalar arguments

%0 for octal scalar arguments

%d for decimal scalar arguments

$x for hexadecimal scalar arguments
%c for character scalar arguments

These match the formats available in the Watch and Locals windows, but number
prefixes and quotes around strings and characters are not printed.

Example:

__message "The character '", cvar:%c, "' has the decimal value
", cvar;

Depending on the value of the variables, this produces this message:
The character 'A' has the decimal value 65

Note: A character enclosed in single quotes (a character literal) is an integer constant
and is not automatically formatted as a character. For example:

__message 'A', " is the numeric value of the character ",
'A':%C;
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would produce:
65 is the numeric value of the character A

Optionally, a number can be inserted between the % and the letter, to format an integer
to that minimum width. Binary, octal, and hexadecimal numbers will be left-padded
with zeros, decimal numbers and characters will be padded with spaces. Note that
numbers that do not fit within the requested minimum width will not be truncated.

Examples:

__message 31:%4x; // 001f
__message 31:%44d; // 31
__message 31:%8b; // 00011111

Note: The default format for certain types is primarily designed to be useful in the
Watch window and other related windows. For example, a value of type char is
formatted as 'A' (0x41), while a pointer to a character (potentially a C string) is
formatted as 0x8102 "Hello", where the string part shows the beginning of the string
(currently up to 60 characters).

When printing a value of type char*, use the $x format specifier to print just the pointer
value in hexadecimal notation, or use the system macro __toString to get the full
string value.

Reference information on reserved setup macro function names

There are reserved setup macro function names that you can use for defining your setup
macro functions. By using these reserved names, your function will be executed at
defined stages during execution. For more information, see Briefly about setup macro
functions and files, page 268.

Reference information about:

® execUserAttach

® execUserPreload

® execUserExecutionStarted
® execUserExecutionStopped
® execUserFlashInit

® execUserSetup

® execUserFlashReset

® execUserPreReset

® ecxecUserReset

[ ]

execUserExit
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execUserAttach

Syntax
For use with

Description

execUserPreload

Syntax
For use with

Description

® execUserFlashExit

® execUserCoreConnect

execUserAttach
The C-SPY I-jet driver.
Called after the debugger attaches to a running application at its current location without

resetting the target system (the option Attach to running target).

Implement this macro to set up the memory map, breakpoints, interrupts, register macro
files, etc.

execUserPreload
All C-SPY drivers.
Called after communication with the target system is established but before

downloading the target application.

Implement this macro to initialize memory locations and/or registers which are vital for
loading data properly.

Note: Do not use this macro if you are using a flash loader. Use the macro
execUserFlashInit instead to perform early initializations required by the flash
loader, see execUserFlashlnit, page 281.

execUserExecutionStarted

Syntax
For use with

Description

C-SPY® Debugging Guide
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execUserExecutionStarted
The C-SPY simulator.
Called when the debugger is about to start or resume execution. The macro is not called

when performing a one-instruction assembler step, in other words, Step or Step Into in
the Disassembly window.
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execUserExecutionStopped

Syntax execUserExecutionStopped
For use with The C-SPY simulator.
Description Called when the debugger has stopped execution. The macro is not called when

performing a one-instruction assembler step, in other words, Step or Step Into in the
Disassembly window.

execUserFlashinit

Syntax execUserFlashInit

For use with The C-SPY hardware debugger drivers.

Description Called once before the flash loader is downloaded to RAM. Implement this macro
typically for setting up the memory map required by the flash loader. This macro is only
called when you are programming flash, and it should only be used for flash loader
functionality.

execUserSetup

Syntax execUserSetup

For use with All C-SPY drivers.

Description Called once after the target application is downloaded.

Implement this macro to set up the memory map, breakpoints, interrupts, register macro
files, etc.

If you define interrupts or breakpoints in a macro file that is executed at system start
(using execUserSetup) we strongly recommend that you also make sure that they are
removed at system shutdown (using execUserExit). An example is available in
SetupSimple.mac, see the tutorials in the Information Center.

The reason for this is that the simulator saves interrupt settings between sessions and if
they are not removed they will get duplicated every time execUserSetup is executed
again. This seriously affects the execution speed.
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execUserFlashReset

Syntax
For use with

Description

execUserPreReset

Syntax
For use with

Description

execUserReset

Syntax
For use with

Description

execUserExit

Syntax
For use with

Description

C-SPY® Debugging Guide
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execUserFlashReset

The C-SPY hardware debugger drivers.

Called once after the flash loader is downloaded to RAM, but before execution of the
flash loader. This macro is only called when you are programming flash, and it should

only be used for flash loader functionality.

execUserPreReset
All C-SPY drivers.

Called each time just before the reset command is issued.

Implement this macro to set up any required device state.

execUserReset

All C-SPY drivers.

Called each time just after the reset command is issued.

Implement this macro to set up and restore data.

execUserExit
All C-SPY drivers.

Called once when the debug session ends.

Implement this macro to save status data etc.
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execUserFlashEXxit
Syntax execUserFlashExit
For use with The C-SPY hardware debugger drivers.
Description Called once when the flash programming ends.

Implement this macro to save status data etc. This macro is useful for flash loader
functionality.

execUserCoreConnect

Sym:ax execUserCoreConnect
For use with The C-SPY I-jet driver.
Description Called immediately when connection with the probe is established.

Implement this macro to perform actions before connecting the CPU. This macro is
useful for unlocking/erasing a secured device.

Reference information on C-SPY system macros

This section gives reference information about each of the C-SPY system macros.
This table summarizes the pre-defined system macros:

Macro Description

__argCount Returns the number of arguments in a string. See the
documentation in the Flash Loader Development Guide.

_ _abortLaunch Aborts the launch of the debugger

__bytes2Wordlé Extracts a | 6-bit word from a buffer. See the
documentation in the Flash Loader Development Guide.

__bytes2Word32 Extracts a 32-bit word from a buffer. See the
documentation in the Flash Loader Development Guide.

__cancelAllInterrupts Cancels all ordered interrupts

__cancelInterrupt Cancels an interr‘upt

__clearBreak Clears a breakpoint

__closeFile Closes a file that was opened by __openFile

Table 13: Summary of system macros
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Macro

Description

__delay
__disableInterrupts
__driverType
__enablelInterrupts

__evaluate

__fillMemory8
__fillMemorylé6
_fillMemory32

__fillMemory64

__gdbserver_exec_command

__getArg

__getNumberOfCores
__getSelectedCore
__isBatchMode
__isMacroSymbolDefined
__loadImage

__makeString

_memoryRestore

_ _mmemorySave

__messageBoxYesCancel
__messageBoxYesNo
__openFile

__orderInterrupt

__popSimulatorInterruptExec

utingStack
__probeType
__readFile

__readFileByte

Delays execution

Disables generation of interrupts
Verifies the driver type

Enables generation of interrupts

Interprets the input string as an expression and
evaluates it

Fills a specified memory area with a byte value
Fills a specified memory area with a 2-byte value
Fills a specified memory area with a 4-byte value
Fills a specified memory area with an 8-byte value
Send strings or commands to the GDB Server

Returns an argument from a string. See the
documentation in the Flash Loader Development Guide.

Gets the number local cores being debugged.
Gets the number of the current core.

Checks if C-SPY is running in batch mode or not.
Checks if a C-SPY macro symbol is defined.
Loads a debug image

Creates a new buffer string. See the documentation
in the Flash Loader Development Guide.

Restores the contents of a file to a specified memory

zone

Saves the contents of a specified memory area to a
file

Displays a Yes/Cancel dialog box for user interaction
Displays a Yes/No dialog box for user interaction
Opens a file for I/O operations

Generates an interrupt

Informs the interrupt simulation system that an
interrupt handler has finished executing

Verifies the probe type
Reads from the specified file

Reads one byte from the specified file

Table 13: Summary of system macros (Continued)
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Macro Description

__readMemory$, Reads one byte from the specified memory location
__readMemoryByte

__readMemorylé6 Reads two bytes from the specified memory location
__readMemory32 Reads four bytes from the specified memory location
__readMemory64 Reads eight bytes from the specified memory location
__readMemoryBuffer Reads bytes and returns them as a string. See the

__registerMacroFile

__resetFile

__selectCore

__setCodeBreak

__setDataBreak

__setDataLogBreak

__setLogBreak

__setSimBreak

__setTraceStartBreak

__setTraceStopBreak

__sourcePosition

__strFind

_subString

__systeml

__system2

__system3

__targetDebuggerVersion

_ _toLower

__toString

documentation in the Flash Loader Development Guide.
Registers macros from the specified file
Rewinds a file opened by __openFile

Switches focus from the current core to the specified
core.

Sets a code breakpoint

Sets a data breakpoint

Sets a data log breakpoint

Sets a log breakpoint

Sets a simulation breakpoint

Sets a trace start trigger breakpoint
Sets a trace stop trigger breakpoint

Returns the file name and source location if the
current execution location corresponds to a source
location

Searches a given string for the occurrence of another
string

Extracts a substring from another string
Starts an external application

Starts an external application with stdout and
stderr collected in one variable

Starts an external application with stdout and
stderr collected in separate variables

Returns the version of the target debugger

Returns a copy of the parameter string where all the
characters have been converted to lower case

Prints strings

Table 13: Summary of system macros (Continued)
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Macro Description

_toUpper Returns a copy of the parameter string where all the

characters have been converted to upper case
__unloadImage Unloads a debug image

__wallTime_ms Returns the current host computer CPU time in
milliseconds

__writeFile Werites to the specified file

__writeFileByte Writes one byte to the specified file

__writeMemoryS§, Writes one byte to the specified memory location

__writeMemoryByte

__writeMemoryl6 Writes a two-byte word to the specified memory
location

__writeMemory32 Writes a four-byte word to the specified memory
location

__writeMemory64 Writes an eight-byte word to the specified memory
location

__writeMemoryBuffer Writes bytes from a buffer. See the documentation in

the Flash Loader Development Guide.

Table 13: Summary of system macros (Continued)

__abortLaunch
Syntax __abortLaunch (message)
Parameters message
A string that is printed as an error message when the macro executes.
Return value None.
For use with All C-SPY drivers.
Description This macro can be used for aborting a debugger launch, for example if another macro

sees that something goes wrong during initialization and cannot perform a proper setup.

This is an emergency stop when launching, not a way to end an ongoing debug session
like the C library function abort ().
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Exmnpb if (!__messageBoxYesCancel ("Do you want to mass erase to unlock
the device?", "Unlocking device"))
{ __abortLaunch("Unlock canceled. Debug session cannot
continue."); }
__cancelAlllnterrupts
Syntax __cancelAllInterrupts()
Return value int 0
For use with The C-SPY Simulator.
Description Cancels all ordered interrupts.
__cancellnterrupt
Syntax __cancelInterrupt (interrupt_id)
Parameters interrupt_id

The value returned by the corresponding __orderInterrupt macro call
(unsigned long).

Return value

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 14: __cancellnterrupt return values

For use with The C-SPY Simulator.

Description Cancels the specified interrupt.
__clearBreak

Syntax __clearBreak (break_id)

Parameters break_id

The value returned by any of the set breakpoint macros.
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Return value int 0

For use with All C-SPY drivers.

Description Clears a user-defined breakpoint.

See also Breakpoints, page 105.
__closeFile

Syntax __closeFile(fileHandle)

Parameters fileHandle

A macro variable used as filehandle by the __openFile macro.

Return value int 0

For use with All C-SPY drivers.

Description Closes a file previously opened by __openFile.
__delay

Syntax __delay(value)

Parameters value

The number of milliseconds to delay execution.

Return value int 0
For use with All C-SPY drivers.
Description Delays execution the specified number of milliseconds.
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__disablelnterrupts

Syntax __disableInterrupts()

Return value

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 15:  disablelnterrupts return values

For use with The C-SPY Simulator.

Description Disables the generation of interrupts.
__driverType

Syntax __driverType (driver_id)

Parameters driver_id

A string corresponding to the driver you want to check for. Choose one of these:
"sim" corresponds to the simulator driver
"gdbserv" corresponds to the C-SPY GDB Server driver

"ijet" corresponds to the C-SPY I-jet driver

Return value

Result Value
Successful 1
Unsuccessful 0

Table 16:  driverType return values
For use with All C-SPY drivers.

Description Checks to see if the current C-SPY driver is identical to the driver type of the
driver_id parameter.

Example __driverType("sim")

If the simulator is the current driver, the value 1 is returned. Otherwise 0 is returned.
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__enablelnterrupts

Syntax

Return value

For use with

Description

__evaluate

Syntax

Parameters

Return value

For use with

Description

Example
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__enablelInterrupts()

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 17:  enablelnterrupts return values
The C-SPY Simulator.

Enables the generation of interrupts.

__evaluate(string, valuePtr)
string
Expression string.

valuePtr

Pointer to a macro variable storing the result.

Result Value
Successful int 0
Unsuccessful int 1

Table 18:  evaluate return values
All C-SPY drivers.

This macro interprets the input string as an expression and evaluates it. The result is
stored in a variable pointed to by valueptr.

This example assumes that the variable i is defined and has the value 5:
__evaluate("i + 3", &myVar)

The macro variable myvar is assigned the value 8.
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__fillMemory8
Syntax __fillMemory8(value, address, zone, length, format)
Parameters value
An integer that specifies the value.

address

An integer that specifies the memory start address.

zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
length
An integer that specifies how many bytes are affected.
format
A string that specifies the exact fill operation to perform. Choose between:
Copy value will be copied to the specified memory area.
AND An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.
OR An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.
XOR An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.
Return value int 0
For use with All C-SPY drivers.
Description Fills a specified memory area with a byte value.
Example __fillMemory8(0x80, 0x700, "Memory", 0x10, "OR");
__fillMemoryl 6
Syntax __fillMemoryl6 (value, address, zone, length, format)
Parameters value

An integer that specifies the value.
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address

An integer that specifies the memory start address.

zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
length
An integer that defines how many 2-byte entities to be affected.
format
A string that specifies the exact fill operation to perform. Choose between:
Copy value will be copied to the specified memory area.
AND An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.
OR An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.
XOR An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.
Return value int 0
For use with All C-SPY drivers.
Description Fills a specified memory area with a 2-byte value.
Example __fillMemoryl6 (0xCDCD, 0x7000, "Memory", 0x200, "Copy"):;
__fillMemory32
Syntax __fillMemory32 (value, address, zone, length, format)
Parameters value
An integer that specifies the value.
address
An integer that specifies the memory start address.
zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.

C-SPY® Debugging Guide
292  for RISC-V



C-SPY macros __

length
An integer that defines how many 4-byte entities to be affected.

format

A string that specifies the exact fill operation to perform. Choose between:

Copy value will be copied to the specified memory area.

AND An AND operation will be performed between value
and the existing contents of memory before writing
the result to memory.

OR An OR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

XOR An XOR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

Return value int 0

For use with All C-SPY drivers.

Description Fills a specified memory area with a 4-byte value.

Example __fillMemory32 (0x0000FFFF, 0x4000, "Memory", 0x1000, "XOR");
__fillMemoryé64

Syntax __fillMemory64 (value, address, zone, length, format)

Parameters value

An integer that specifies the value.

address

An integer that specifies the memory start address.

zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.

length

An integer that defines how many 8-byte entities to be affected.
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format

A string that specifies the exact fill operation to perform. Choose between:

Copy value will be copied to the specified memory area.

AND An AND operation will be performed between value
and the existing contents of memory before writing
the result to memory.

OR An OR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

XOR An XOR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

Return value int 0

For use with All C-SPY drivers.

Description Fills a specified memory area with an 8-byte value.

Example __fillMemory64 (0x0155'FFFF'FFFF'FFFF, 0x4000, "Memory", 0x1000,
"AND") ;

__gdbserver_exec_command

Syntax __gdbserver_exec_command ("string")
Parameters

string String or command sent to the GDB Server. For more
information, see the GDB server documentation.

For use with The C-SPY GDB Server driver.

Description Use this option to send strings or commands to the GDB Server.
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__getNumberOfCores
Syntax __getNumberOfCores ()
Return value The number of local cores being debugged.
For use with The C-SPY simulator.

The C-SPY I-jet driver.

Description This macro returns the number of local cores being debugged.
Example test ()
{
__var 1i;
for (i = 0; i < __getNumberOfCores(); i++ )

{

__selectCore(i);

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
" \nll ;
}
}
See also _getSelectedCore, page 295 and __ selectCore, page 308
__getSelectedCore
Syntax __getSelectedCore ()
Return value The current core. The cores are numbered from 0 and upwards.
For use with The C-SPY simulator.
The C-SPY I-jet driver.
Description Gets the number of the current core.
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Example

See also

__isBatchMode

Syntax

Return value

For use with

Description

test ()
{

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

__selectCore(0);

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

__selectCore(l);

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

A typical result of the above macro would be (assuming that the original core was
number 1):

0000213C
Core: 0 pc 00000494
Core: 1 pc = 0000213C

Core: 1 pc

__selectCore, page 308.

_ _isBatchMode ()

Result Value
True int 1
False int 0

Table 19: __isBatchMode return values
All C-SPY drivers.

This macro returns True if the debugger is running in batch mode, otherwise it returns
False.

__isMacroSymbolDefined

Syntax

Parameters

Return value

C-SPY® Debugging Guide

for RISC-V

__isMacroSymbolDefined (symbol)

symbol
The name of a C-SPY macro variable or macro function (a string).

1 if symbol is an existing macro symbol. 0 if symbo1 is not defined.



For use with

Description

Example

__loadlmage

Syntax

Parameters

Return value

For use with

Description

C-SPY macros __

All C-SPY drivers.

This macro identifies whether a string is the name of an existing C-SPY macro symbol
(variable or function) or not.

var someVariable;

if (__isMacroSymbolDefined("someVariable"))
someVariable = 42;

else
__message "The someVariable symbol is not defined!";

__loadImage(path, offset, debugInfoOnly)

path
A string that identifies the path to the debug image to download. The path must
either be absolute or use argument variables. For information about argument
variables, see the /DE Project Management and Building Guide for RISC-V'.
offset
An integer that identifies the offset to the destination address for the downloaded
debug image.
debugInfoOnly

A non-zero integer value if no code or data should be downloaded to the target
system, which means that C-SPY will only read the debug information from the
debug file. Or, 0 (zero) for download.

Value Result

Non-zero integer number A unique module identification.

int 0 Loading failed.

Table 20:  loadlmage return values
All C-SPY drivers.

Loads a debug image (debug file).
Note: Images are only downloaded to RAM and no flash loading will be performed.
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Example | Your system consists of a ROM library and an application. The application is your active
project, but you have a debug file corresponding to the library. In this case you can add
this macro call in the execUserSetup macro in a C-SPY macro file, which you
associate with your project:

__loadImage("ROMfile", 0x8000, 1);

This macro call loads the debug information for the ROM library RoMf i 1e without
downloading its contents (because it is presumably already in ROM). Then you can
debug your application together with the library.

Example 2 Your system consists of a ROM library and an application, but your main concern is the
library. The library needs to be programmed into flash memory before a debug session.
While you are developing the library, the library project must be the active project in the
IDE. In this case you can add this macro call in the execUserSetup macro in a C-SPY
macro file, which you associate with your project:

__loadImage("ApplicationFile", 0x8000, O0);

The macro call loads the debug information for the application and downloads its
contents (presumably into RAM). Then you can debug your library together with the

application.
See also Images, page 376 and Loading multiple debug images, page 45.
__memoryRestore
Syntax __memoryRestore (zone, filename, offset)
Parameters zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.

filename

A string that specifies the file to be read. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the /DE Project Management and Building Guide for
RISC-V.

offset

An integer offset. When restoring data from the file into memory, this offset is
added to the addresses specified in the file. For example, if the file contains data
from 0x0—0x1FF and the offset is 0x400, the data will be placed in memory in
the range 0x400—0x5FF. This makes it possible to restore data into memory on
addresses larger than 32-bit, even if the file format only supports 32-bit
addresses.
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Return value
For use with
Description
Example

See also

__memorySave

Syntax

Parameters

C-SPY macros __

int 0
All C-SPY drivers.

Reads the contents of a file and saves it to the specified memory zone.

_memoryRestore ("Memory", "c:\\temp\\saved_mem.hex", 0x400);

Memory Restore dialog box, page 143.

__memorySave (start, stop, format, filename, zerostart)

start

A string that specifies the first location of the memory area to be saved.

stop

A string that specifies the last location of the memory area to be saved.

format

A string that specifies the format to be used for the saved memory. Choose
between:

intel-extended
motorola
motorola-sl9
motorola-s28
motorola-s37

filename
A string that specifies the file to write to. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the /DE Project Management and Building Guide for
RISC-V.
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Return value
For use with
Description

Example

See also

zerostart

An integer. If it is 1 (or any non-zero value), the addresses in the saved file will
start from 0x0. For example, if the specified memory range is 0x400—0x5FF,
the address range in the file will be 0x0—0x1FF. This makes it possible to save
memory from addresses larger than 32-bit to file formats which only support
32-bit addresses. If the parameter is 0, the file will contain the specified
addresses as given.

int 0
All C-SPY drivers.
Saves the contents of a specified memory area to a file.

__memorySave ("Memory:0x00", "Memory:0xFF", "intel-extended",
"c:\\temp\\saved_memory.hex", 0);

Memory Save dialog box, page 142.

__messageBoxYesCancel

Syntax

Parameters

Return value

For use with

Description

C-SPY® Debugging Guide
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__messageBoxYesCancel (message, caption)

message
A message that will appear in the message box.
caption

The title that will appear in the message box.

Result Value
Yes 1
No 0

Table 21:  messageBoxYesCancel return values
All C-SPY drivers.

Displays a Yes/Cancel dialog box when called and returns the user input. Typically, this
is useful for creating macros that require user interaction.
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__messageBoxYesNo
Syntax __messageBoxYesNo (message, caption)
Parameters message

A message that will appear in the message box.

caption

The title that will appear in the message box.

Return value

Result Value
Yes 1
No 0
Table 22: __messageBoxYesNo return values
For use with All C-SPY drivers.
Description Displays a Yes/No dialog box when called and returns the user input. Typically, this is

useful for creating macros that require user interaction.

__openFile
Syntax __openFile(filename, access)
Parameters filename

The file to be opened. The filename must include a path, which must either be
absolute or use argument variables. For information about argument variables,
see the IDE Project Management and Building Guide for RISC-V.

access

The access type (string).

These are mandatory but mutually exclusive:

"a" append, new data will be appended at the end of the open file

"r" read (by default in text mode; combine with b for binary mode: rb)
"w" write (by default in text mode; combine with b for binary mode: wb)
These are optional and mutually exclusive:

"b" binary, opens the file in binary mode

"t ASCII text, opens the file in text mode
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This access type is optional:

"+ together with r, w, or a; r+ orw+ is read and write, while a+ is read and

append
Return value
Result Value
Successful The file handle
Unsuccessful An invalid file handle, which tests as False

Table 23: __openkile return values
For use with All C-SPY drivers.

Description Opens a file for I/O operations. The default base directory of this macro is where the
currently open project file (* . ewp) is located. The argument to __openFile can
specity a location relative to this directory. In addition, you can use argument variables
such as $PROJ_DIRS and $TOOLKIT_DIRS in the path argument.

Exmnph __var myFileHandle; /* The macro variable to contain */
/* the file handle */
myFileHandle = __openFile("$PROJ_DIRS$\\Debug\\Exe\\test.tst",
npwy

if (myFileHandle)
{

/* successful opening */

See also For information about argument variables, see the /DE Project Management and
Building Guide for RISC-V.

__orderinterrupt
Syntax __orderInterrupt(specification, first_activation,
repeat_interval, variance, infinite_hold time,
hold_time, probability)
Parameters specification

The interrupt (string). The specification can either be the full specification used
in the device description file (dd£f) or only the name. In the latter case the
interrupt system will automatically get the description from the device
description file.
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first_activation

The first activation time in cycles (integer)

repeat_interval

The periodicity in cycles (integer)

variance

The timing variation range in percent (integer between 0 and 100)

infinite hold_time

1 if infinite, otherwise 0.

hold_time
The hold time (integer)

probability
The probability in percent (integer between 0 and 100)
Return value The macro returns an interrupt identifier (unsigned long).

If the syntax of specification is incorrect, it returns -1.

For use with The C-SPY simulator.

Description Generates an interrupt.

Example This example generates a repeating interrupt using an infinite hold time first activated
after 4000 cycles:

__orderInterrupt( "USARTR_VECTOR", 4000, 2000, 0, 1, 0, 100 );

__popSimulatorinterruptExecutingStack

Syntax __popSimulatorInterruptExecutingStack (void)

Return value int 0

For use with The C-SPY simulator.

Description Informs the interrupt simulation system that an interrupt handler has finished executing,

as if the normal instruction used for returning from an interrupt handler was executed.

This is useful if you are using interrupts in such a way that the normal instruction for
returning from an interrupt handler is not used, for example in an operating system with
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See also

__probeType

Syntax

Parameters

Return value

For use with

Description

Example

__readFile

Syntax

Parameters
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task-switching. In this case, the interrupt simulation system cannot automatically detect
that the interrupt has finished executing.

Simulating an interrupt in a multi-task system, page 249.

__probeType (probe_id)

probe_id
A string corresponding to the probe you want to check for. Choose one of these:
"I-jet" corresponds to the I-jet probe
"I-jet-Trace" corresponds to the I-jet Trace probe.

The strings are case-insensitive.

Result Value
Successful 1
Unsuccessful 0

Table 24:  probeType return values
The C-SPY I-jet driver.

Checks to see if the current connected probe is identical to the probe type of the
probe_id parameter.

__probeType("I-jet")

If I-jet is the current connected probe, the value 1 is returned. Otherwise 0 is returned.

__readFile(fileHandle, valuePtr)

fileHandle
A macro variable used as filehandle by the __openFile macro.

valuePtr

A pointer to a variable.



Return value

For use with

Description

Example

__readFileByte

Syntax

Parameters

Return value
For use with
Description

Example
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Result Value
Successful 0
Unsuccessful Non-zero error number

Table 25: __readFile return values
All C-SPY drivers.

Reads a sequence of hexadecimal digits from the given file and converts them to an
unsigned long which is assigned to the value parameter, which should be a pointer
to a macro variable.

Only printable characters representing hexadecimal digits and white-space characters
are accepted, no other characters are allowed.

__var number;
if (__readFile(myFileHandle, &number) == 0)
{
// Do something with number
}

In this example, if the file pointed to by myFileHandle contains the ASCII characters
1234 abcd 90ef, consecutive reads will assign the values 0x1234 Oxabcd 0x90ef
to the variable number.

__readFileByte(fileHandle)

fileHandle

A macro variable used as filehandle by the __openFile macro.
-1 upon error or end-of-file, otherwise a value between 0 and 255.
All C-SPY drivers.
Reads one byte from a file.

__var byte;
while ( (byte = __readFileByte(myFileHandle)) != -1 )
{

/* Do something with byte */
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__readMemory8, __readMemoryByte
Syntax __readMemory8 (address, zone)
__readMemoryByte (address, zone)
Parameters address
The memory address (integer).
zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
Return value The macro returns the value from memory.
For use with All C-SPY drivers.
Description Reads one byte from a given memory location.
Example __readMemory8 (0x0108, "Memory") ;
__readMemoryl 6
Syntax __readMemoryl6 (address, zone)
Parameters address
The memory address (integer).
zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
Return value The macro returns the value from memory.
For use with All C-SPY drivers.
Description Reads a two-byte word from a given memory location.
Example __readMemoryl6 (0x0108, "Memory");
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__readMemory32

Syntax

Parameters

Return value
For use with
Description

Example

__readMemoryé4

Syntax

Parameters

Return value
For use with
Description

Example
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__readMemory32 (address, zone)

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.
The macro returns the value from memory.
All C-SPY drivers.
Reads a four-byte word from a given memory location.

__readMemory32 (0x0108, "Memory") ;

__readMemory64 (address, zone)

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.
The macro returns the value from memory.
All C-SPY drivers.
Reads an eight-byte word from a given memory location.

__readMemory64 (0x8000, "Memory") ;
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__registerMacroFile

Syntax

Parameters

Return value
For use with

Description

Example

See also

__resetFile

Syntax

Parameters

Return value
For use with

Description

__selectCore

Syntax

Parameters
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__registerMacroFile (filename)

filename

A file containing the macros to be registered (string). The filename must include
a path, which must either be absolute or use argument variables. For information
about argument variables, see the IDE Project Management and Building Guide
for RISC-V.

int 0

All C-SPY drivers.

Registers macros from a setup macro file. With this function you can register multiple
macro files during C-SPY startup.

__registerMacroFile("c:\\testdir\\macro.mac") ;

Using C-SPY macros, page 269.

__resetFile(fileHandle)

fileHandle
A macro variable used as filehandle by the __openFile macro.

int 0
All C-SPY drivers.

Rewinds a file previously opened by __openFile.

__selectCore(int core)

core

The core to switch to. The cores are numbered from 0 and upwards.



Return value

For use with

Description

Example

See also

__setCodeBreak

Syntax

Parameters

int 0

The C-SPY simulator.
The C-SPY I-jet driver.

C-SPY macros __

Switches focus from the current core to the specified core for the duration of the macro

invocation or until any next invocation of __selectCore.

test ()
{
__message "Core:
“\n”;
__selectCore(0);
__message "Core:
“\n”;
__selectCore(l);
__message "Core:
“\n”;

__getSelectedCore(),

__getSelectedCore(),

__getSelectedCore(),

#PC:%x,

#PC:%x,

#PC:%x,

A typical result of the above macro would be (assuming that the original core was

number 1):

Core: 1 pc =
Core: 0 pc =
Core: 1 pc =

_getSelectedCore, page 295.

__setCodeBreak (location,

location

0000213C
00000494
0000213C

action)

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter

Location dialog box, page 126.

count

An integer that specifies the number of times that a breakpoint condition must

be fulfilled before a break occurs the next time.
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condition

The breakpoint condition. This must be a valid C-SPY expression, for instance
a C-SPY macro function.

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 26: __setCodeBreak return values
For use with All C-SPY drivers.

Description Sets a code breakpoint, that is, a breakpoint which is triggered just before the processor
fetches an instruction at the specified location.

Examples __setCodeBreak ("{D:\\src\\prog.c}.12.9", 3, "d>16", "TRUE",
"ActionCode()");
This example sets a code breakpoint on the label main in your source:
__setCodeBreak("main", 0, "1", "TRUE", "");

This example sets the breakpoint within a specific source file and line without using the
absolute file path to the source:

__setCodeBreak("{main.c}.288.7", 0, "1", "TRUE", "");
See also Breakpoints, page 105.
__setDataBreak
Syntax __setDhataBreak(location, count, condition, cond_type, access,
action)
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Parameters

Return value

For use with

Description

Example

See also
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location

A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
information about the location types, see Enter Location dialog box, page 126.

count
An integer that specifies the number of times that a breakpoint condition must
be fulfilled before a break occurs the next time.

condition

The breakpoint condition (string).

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 27:  setDataBreak return values
The C-SPY simulator.

Sets a data breakpoint, that is, a breakpoint which is triggered directly after the processor
has read or written data at the specified location.

__var brk;
brk = __setDataBreak ("Memory:0x4710", 3, "d>6", "TRUE",

"W", "ActionData()");
__clearBreak (brk) ;

Breakpoints, page 105.
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__setDatalogBreak
Syntax __setDataLogBreak (variable, access)
Parameters variable

A string that defines the variable the breakpoint is set on, a variable of integer
type with static storage duration. The microcontroller must also be able to
access the variable with a single-instruction memory access, which means that
you can only set data log breakpoints on 8-bit variables.

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 28: __setDatal.ogBreak return values

For use with The C-SPY simulator.

Description Sets a data log breakpoint, that is, a breakpoint which is triggered when a specified
variable is accessed. Note that a data log breakpoint does not stop the execution, it just

generates a data log.

Example __var brk;
brk = __setDatalLogBreak ("MyVar", "R");

__clearBreak (brk) ;

See also Breakpoints, page 105 and Getting started using data logging, page 201.
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Syntax

Parameters

Return value

For use with

Description

C-SPY macros __

__setLogBreak(location, message, msg_type, condition,
cond_type)

location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 126.

message

The message text.

msg._type
The message type; choose between:

TEXT, the message is written word for word.

ARGS, the message is interpreted as a comma-separated list of C-SPY
expressions or strings.

condition

The breakpoint condition (string).

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful 0

Table 29:  setLogBreak return values
All C-SPY drivers.

Sets a log breakpoint, that is, a breakpoint which is triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will temporarily halt and
print the specified message in the C-SPY Debug Log window.
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Example

See also

__setSimBreak

Syntax

Parameters

Return value

For use with

C-SPY® Debugging Guide
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__var logBpl;
__var logBp2;

logOn ()
{
logBpl = __setLogBreak ("{C:\\temp\\Utilities.c}.23.1",
"\"Entering trace zone at :\", #PC:%X", "ARGS", "1", "TRUE");
logBp2 = __setLogBreak ("{C:\\temp\\Utilities.c}.30.1",
"Leaving trace zone...", "TEXT", "1", "TRUE");

logOff ()

{
__clearBreak (logBpl) ;
__clearBreak (logBp2) ;

Formatted output, page 277 and Breakpoints, page 105.

__setSimBreak(location, access, action)

location

A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
information about the location types, see Enter Location dialog box, page 126.

access

The memory access type: "R" for read or "w" for write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 30:  setSimBreak return values

The C-SPY simulator.
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Description Use this system macro to set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
processor is about to read data from a location or immediately after it has written data.
Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the processor reads at a
memory-mapped location, a C-SPY macro function can intervene and supply the
appropriate data. Conversely, when the processor writes to a memory-mapped location,
a C-SPY macro function can act on the value that was written.

__setTraceStartBreak
Syntax __setTraceStartBreak (location)
Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 126.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful 0
Table 31: __setTraceStartBreak return values
For use with The C-SPY simulator.

The C-SPY I-jet driver and a device that supports trace.

Description Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is started.
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Example

See also

__setTraceStopBreak

Syntax

Parameters

Return value

For use with

Description

Example

C-SPY® Debugging Guide
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__var startTraceBp;
__var stopTraceBp;

traceOn ()
{
startTraceBp = __setTraceStartBreak
("{C:\\TEMP\\Utilities.c}.23.1");
stopTraceBp = __setTraceStopBreak

("{C:\\temp\\Utilities.c}.30.1");

traceOff ()

{
__clearBreak (startTraceBp) ;
__clearBreak (stopTraceBp) ;

Trace Start Trigger breakpoint dialog box, page 191.

__setTraceStopBreak (location)

location
A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 126.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful int 0

Table 32:  setTraceStopBreak return values

The C-SPY simulator.

The C-SPY I-jet driver and a device that supports trace.

Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is stopped.

See  setTraceStartBreak, page 315.
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See also Trace Stop Trigger breakpoint dialog box, page 193.
__sourcePosition

Syntax __sourcePosition(linePtr, colPtr)

Parameters linePtr

Pointer to the variable storing the line number

colPtr

Pointer to the variable storing the column number

Return value

Result Value
Successful Filename string
Unsuccessful Empty (" ") string
Table 33: __sourcePosition return values
For use with All C-SPY drivers.
Description If the current execution location corresponds to a source location, this macro returns the

filename as a string. It also sets the value of the variables, pointed to by the parameters,
to the line and column numbers of the source location.

__strFind
Syntax __strFind(macroString, pattern, position)
Parameters macroString
A macro string.
pattern
The string pattern to search for
position
The position where to start the search. The first position is 0
Return value The position where the pattern was found or -1 if the string is not found.
For use with All C-SPY drivers.
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Description This macro searches a given string (macroString) for the occurrence of another string
(pattern).

Example __strFind("Compiler", "pile", 0) = 3
__strFind("Compiler", "foo", 0) = -1

See also Macro strings, page 275.

__subString
Syntax __subString(macroString, position, length)
Parameters macroString

A macro string.
position
The start position of the substring. The first position is 0.

length
The length of the substring

Return value A substring extracted from the given macro string.

For use with All C-SPY drivers.

Description This macro extracts a substring from another string (macroString).
Example __subString("Compiler", 0, 2)

The resulting macro string contains Co.
__subString("Compiler", 3, 4)

The resulting macro string contains pile.

See also Macro strings, page 275.
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__systeml

Syntax

Parameters

Return value
For use with

Description

Example

__system2

Syntax

Parameters

Return value

For use with

C-SPY macros __

__systenl (string)

string
The command line used to start an external application. In some cases, the full
path is needed. If it contains space characters, quotation marks escaped with
backslashes (\ ") can be added to encapsulate the path, and, separately, the
arguments to the application, like this:
"\"D:\\My projects\\my app\\app.exe\" \"some argument\"".

The exit code returned from the external application. If the application could not be
launched or fails to return an appropriate exit code, 1 is returned.

All C-SPY drivers.

This macro launches an external application. It ignores all output returned from the
application. Terminates the launched application if the application has not finished
within 10 seconds.

__var exitCode;

exitCode = systeml ("mkdir tmp") ;

system2 (string, &output)

string

The command line used to start an external application. In some cases, the full
path is needed. If it contains space characters, quotation marks escaped with
backslashes (\ ") can be added to encapsulate the path, and, separately, the
arguments to the application, like this:

"\"D:\\My projects\\my app\\app.exe\" \"some argument\"".

output

The output returned from the application. Both the stdout and the stderr
streams are stored in this variable.

The exit code returned from the external application. If the application could not be
launched or fails to return an appropriate exit code, 1 is returned.

All C-SPY drivers.
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Description

Example

__system3

Syntax

Parameters

Return value

For use with

Description

C-SPY® Debugging Guide
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This macro launches an external application. The output from both the stdout and the
stderr streams is stored in output. If no data has been received from the launched
application within 10 seconds, or when the returned data exceeds 65535 bytes, the
application is terminated. This restriction prevents the Embedded Workbench IDE from
freezing or crashing because of misbehaving applications.

var exitCode;
var out_err;

exitCode = __system2("dir /S", &out_err);

__message "Output from the dir command:";
__message out_err;

__system3 (string, &output, &error)

string
The command line used to start an external application. In some cases, the full
path is needed. If it contains space characters, quotation marks escaped with
backslashes (\ ") can be added to encapsulate the path, and, separately, the
arguments to the application, like this:
"\"D:\\My projects\\my app\\app.exe\" \"some argument\"".

output
The output returned from the stdout output stream of the application.

error

The output returned from the stderr output stream of the application.

The exit code returned from the external application. If the application could not be
launched or fails to return an appropriate exit code, 1 is returned.

All C-SPY drivers.

This macro launches an external application. The output from the stdout stream is
stored in output and the stderr stream is stored in error. If no data has been
received from the launched application within 10 seconds, or when the returned data
exceeds 65535 bytes, the application is terminated. This restriction prevents the
Embedded Workbench IDE from freezing or crashing because of misbehaving
applications.
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Example __var exitCode;
__var out;
__var err;
exitCode = __system3("dir /S", &out, &err);

__message "Output from the dir command:";
__message out;

message "Error text from the dir command:";
message err;

__targetDebuggerVersion

Syntax __targetDebuggerVersion ()
Return value A string that represents the version number of the C-SPY debugger processor module.
For use with All C-SPY drivers.
Description This macro returns the version number of the C-SPY debugger processor module.
Example __var toolVer;
toolVer = __targetDebuggerVersion() ;
__message "The target debugger version is, ", toolVer;
__tolLower
Syntax __toLower (macroString)
Parameters macroString

A macro string.

Return value The converted macro string.
For use with All C-SPY drivers.
Description This macro returns a copy of the parameter macroString where all the characters have

been converted to lower case.

Example __toLower ("IAR")

The resulting macro string contains iar.
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__toLower ("Mix42")

The resulting macro string contains mix42.

See also Macro strings, page 275.
__toString

Syntax __toString(C_string, maxlength)

Parameters C_string

Any null-terminated C string.

maxlength

The maximum length of the returned macro string.

Return value Macro string.
For use with All C-SPY drivers.
Description This macro is used for converting C strings (char* or char []) into macro strings.
Example Assuming your application contains this definition:
char const * hptr = "Hello World!";

this macro call:
_toString (hptr, 5)

would return the macro string containing Hello.

See also Macro strings, page 275.
__toUpper

Syntax __toUpper (macroString)

Parameters macroString

A macro string.
Return value The converted string.

For use with All C-SPY drivers.
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Description This macro returns a copy of the parameter macroString where all the characters have
been converted to upper case.

Example __toUpper ("string")

The resulting macro string contains STRING.

See also Macro strings, page 275.
__unloadlmage

Syntax __unloadImage (module_id)

Parameters module_id

An integer which represents a unique module identification, which is retrieved
as a return value from the corresponding __1oadImage C-SPY macro.

Return value

Value Result
module_id A unique module identification (the same as the input
parameter).
int 0 The unloading failed.
Table 34:  unloadlmage return values
For use with All C-SPY drivers.
Description Unloads debug information from an already downloaded debug image.
See also Loading multiple debug images, page 45 and Images, page 376.
__wallTime_ms
Syntax __wallTime_ms ()
Return value Returns the current host computer CPU time in milliseconds.
For use with All C-SPY drivers.
Description This macro returns the current host computer CPU time in milliseconds. The first call

will always return 0.
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Example __var til;
__var t2;

tl = _ _wallTime_ms();

__var 1i;

for (1 =0; 1 < 1000; i++)
__message "Tick";

t2 = __wallTime_ms();
__message "Elapsed time: ", t2 - tl;
__writeFile
Syntax __writeFile(fileHandle, value)
Parameters fileHandle
A macro variable used as filehandle by the __openFile macro.
value
An integer.

Return value int 0

For use with All C-SPY drivers.

Description Prints the integer value in hexadecimal format (with a trailing space) to the file file.
Note: The __fmessage statement can do the same thing. The __writeFile macro is
provided for symmetry with __readFile.

__writeFileByte
Syntax __writeFileByte(fileHandle, value)
Parameters fileHandle
A macro variable used as filehandle by the __openFile macro.
value
An integer.
Return value int 0
For use with All C-SPY drivers.
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Writes one byte to the file £ileHandle.

__writeMemory8, __writeMemoryByte

Syntax

Parameters

Return value
For use with
Description

Example

__writeMemoryl 6

Syntax

Parameters

Return value
For use with

Description

__writeMemory8 (value, address, zone)
__writeMemoryByte(value, address, zone)

value

An integer.

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.
int 0
All C-SPY drivers.
Writes one byte to a given memory location.

__writeMemory8 (0x2F, 0x8020, "Memory");

__writeMemoryl6 (value, address, zone)

value

An integer.

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 130.
int 0
All C-SPY drivers.

Writes two bytes to a given memory location.
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Example __writeMemoryl6 (0x2FFF, 0x8020, "Memory");
__writeMemory32
Syntax __writeMemory32 (value, address, zone)
Parameters value
An integer.
address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
Return value int 0
For use with All C-SPY drivers.
Description Writes four bytes to a given memory location.
Example __writeMemory32 (0x5555FFFF, 0x8020, "Memory");
__writeMemory64
Syntax __writeMemory64 (value, address, zone)
Parameters value
An integer.
address
The memory address (integer).
zone
A string that specifies the memory zone, see C-SPY memory zones, page 130.
Return value int 0
For use with All C-SPY drivers.
Description Writes eight bytes to a given memory location.
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Example __writeMemory64 (OXFFFF'FFFF'8000'0000, OxXFFFF'8000, "Memory");

Graphical environment for macros
Reference information about:
® Macro Registration window, page 327
® Debugger Macros window, page 329
® Macro Quicklaunch window, page 331

Macro Registration window

The Macro Registration window is available from the View>Macros submenu during
a debug session.

Macro Registration x
Add Remove Remove Al Reload
File Full Path it
V| SetupSimple.mac ChtutonSetupSimple.mac
SetupAdvanced.mac ChtutonSetupAdvanced.mac

Use this window to list, register, and edit your debugger macro files.
Double-click a macro file to open it in the editor window and edit it.

See also Registering C-SPY macros—an overview, page 270.

Requirements

Can be used with all C-SPY debugger drivers and debug probes.

Display area

This area contains these columns:

File
The name of an available macro file. To register the macro file, select the check
box to the left of the filename. The name of a registered macro file appears in
bold style.

Full path

The path to the location of the added macro file.
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Context menu
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This context menu is available:
Add...
Remove
Remowve All

Reload
Open File

Open Debugger Macros Window

These commands are available:

Add

Opens a file browser where you can locate the macro file that you want to add
to the list. This menu command is also available as a function button at the top
of the window.

Remove

Removes the selected debugger macro file from the list. This menu command is
also available as a function button at the top of the window.

Remove All

Removes all macro files from the list. This menu command is also available as
a function button at the top of the window.

Reload
Registers the selected macro file. Typically, this is useful when you have edited
a macro file. This menu command is also available as a function button at the
top of the window.

Open File
Opens the selected macro file in the editor window.

Open Debugger Macros Window
Opens the Debugger Macros window.
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Debugger Macros window
The Debugger Macros window is available from the View>Macros submenu during a
debug session.
Click the Name header or the File

header to sort alphabetically on
either function name or filename.

Debugger Macros x
MName Parameters File it
Access i} SetupSimulation.mac 3
__abortlaunch (string)

__cancelAllinterrupts 0

__cancellnterrupt {inf)

__clearBreak {id)

__closeFile (file) :

_ delay fvalug) Sglect amacroand '

_ disablelnterrupts i ick Fl for reference ©

__driverType {string)  information £ -

Use this window to list all registered debugger macro functions, either predefined
system macros or your own. This window is useful when you edit your own macro
functions and want an overview of all available macros that you can use.

o Click the column headers Name or File to sort alphabetically on either function
name or filename.
e Double-clicking a macro defined in a file opens that file in the editor window.

o To open a macro in the Macro Quicklaunch window, drag it from the Debugger
Macros window and drop it in the Macro Quicklaunch window.

e Select a macro and press F1 to get online help information for that macro.

Requirements
Can be used with all C-SPY debugger drivers and debug probes.

Display area
This area contains these columns:

Name
The name of the debugger macro.

Parameters
The parameters of the debugger macro.

File
For macros defined in a file, the name of the file is displayed. For predefined
system macros, -System Macro- is displayed.
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Context menu

This context menu is available:
Open File

Add to Quicklaunch Window

User Macros
System Macros
v All Macros

Open Macro Registration Window
These commands are available:
Open File
Opens the selected debugger macro file in the editor window.

Add to Quicklaunch Window
Adds the selected macro to the Macro Quicklaunch window.

User Macros
Lists only the debugger macros that you have defined yourself.

System Macros
Lists only the predefined system macros.

All Macros
Lists all debugger macros, both predefined system macros and your own.

Open Macro Registration Window
Opens the Macro Registration window.
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Macro Quicklaunch window

[elk

Requirements

The Macro Quicklaunch window is available from the View menu.

= Expression Result
G testEval()
G nval Error (col 1): Unknown or ambiguous symbol. nval
G testEval2() 0
G s2-37
G incval() 3
=
2
B
=
5
&
2
= Macro Quicklaunch B

Use this window to evaluate expressions, typically C-SPY macros.

For some devices, there are predefined C-SPY macros available with device support,
typically provided by the chip manufacturer. These macros are useful for performing
certain device-specific tasks. The macros are available in the Macro Quicklaunch
window and are easily identified by their green icon.

The Macro Quicklaunch window is similar to the Quick Watch window, but is
primarily designed for evaluating C-SPY macros. The window gives you precise control
over when to evaluate an expression.

See also Executing C-SPY macros—an overview, page 270.
To add an expression:
Choose one of these alternatives:

e Drag the expression to the window

e In the Expression column, type the expression you want to examine.

If the expression you add and want to evaluate is a C-SPY macro, the macro must first
be registered, see Registering C-SPY macros—an overview, page 270.

To evaluate an expression:

Double-click the Recalculate icon to calculate the value of that expression.

Can be used with all C-SPY debugger drivers and debug probes.
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Display area

[e]

Context menu
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This area contains these columns:

Recalculate icon
To evaluate the expression, double-click the icon. The latest evaluated
expression appears in bold style.

Expression
One or several expressions that you want to evaluate. Click <click to add>
to add an expression. If the return value has changed since last time, the value
will be displayed in red.

Result
Shows the return value from the expression evaluation.

This context menu is available:
Evaluate Mow
Remove

Rermove All

These commands are available:

Evaluate Now

Evaluates the selected expression.

Remove
Removes the selected expression.

Remove All
Removes all selected expressions.



The C-SPY command line
utility—cspybat

e Summary of C-SPY command line options

e Reference information on C-SPY command line options

Using C-SPY in batch mode

You can execute C-SPY in batch mode if you use the command line utility cspybat,
installed in the directory common\bin.

These topics are covered:

e Starting cspybat
e Output

e Invocation syntax

STARTING CSPYBAT

I To start cspybat you must first create a batch file. An easy way to do that is to use one
of the batch files that C-SPY automatically generates when you start C-SPY in the
IDE.

C-SPY generates a batch file projectname. buildconfiguration.cspy.bat every
time C-SPY is initialized. In addition, two more files are generated:

® project.buildconfiguration.general.xcl, which contains options specific
to cspybat

® project.buildconfiguration.driver.xcl, which contains options specific to
the C-SPY driver you are using

You can find the files in the directory $PROJ_DIRS\settings. The files contain the
same settings as the IDE, and provide hints about additional options that you can use.

2 To start cspybat, you can use this command line:

project.cspybat.bat [debugfile]
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Note that debugfileis optional. You can specify it if you want to use a different debug
file than the one that is used in the project.buildconfiguration.general .xcl
file.

OUTPUT
When you run cspybat, these types of output can be produced:

o Terminal output from cspybat itself

All such terminal output is directed to stderr. Note that if you run cspybat from
the command line without any arguments, the cspybat version number and all
available options including brief descriptions are directed to stdout and displayed
on your screen.

e Terminal output from the application you are debugging

All such terminal output is directed to stdout, provided that you have used the
--plugin option. See --plugin, page 361.

® [Error return codes
cspybat returns status information to the host operating system that can be tested in
abatch file. For successful, the value int 0 is returned, and for unsuccessful the value
int 1 is returned.

INVOCATION SYNTAX

The invocation syntax for cspybat is:

cspybat processor_DLL driver_DLL debug_file
[cspybat_options] --backend driver_options

Note: In those cases where a filename is required—including the DLL files—you are
recommended to give a full path to the filename.
Parameters

The parameters are:

Parameter Description

processor_DLL The processor-specific DLL file—available in
riscv\bin.

driver_ DLL The C-SPY driver DLL file—available in riscv\bin.

debug_file The object file that you want to debug (filename

extension out). See also —debug_file, page 342.

Table 35: cspybat parameters
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Description

cspybat_options

--backend

driver_options

The command line options that you want to pass to
cspybat. Note that these options are optional. For
information about each option, see Reference
information on C-SPY command line options, page 338.

Marks the beginning of the parameters to the C-SPY
driver; all options that follow will be sent to the driver.
Note that this option is mandatory.

The command line options that you want to pass to
the C-SPY driver. Note that some of these options are
mandatory and some are optional. For information
about each option, see Reference information on C-SPY
command line options, page 338.

Table 35: cspybat parameters (Continued)

Summary of C-SPY command line options
Reference information about:

General cspybat options

Options available for all C-SPY drivers

Options available for the simulator driver

Options available for all hardware debugger drivers
Options available for the C-SPY I-jet driver
Options available for the C-SPY GDB Server driver
Options available for the C-SPY third-party drivers

GENERAL CSPYBAT OPTIONS

--application_args

--attach_to_running_target

--backend

--code_coverage_file

Passes command line arguments to the debugged
application.

Makes the debugger attach to a running
application at its current location, without
resetting the target system.

Marks the beginning of the parameters to be sent
to the C-SPY driver (mandatory).

Enables the generation of code coverage
information and places it in a specified file.
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--cycles
--debug_file
--device_macro

--download_only

-f
--flash_loader

--leave_target_running

--macro
--macro_param
--plugin
--silent

--suppress_entrypoint_warni
ng

--timeout

Specifies the maximum number of cycles to run.
Specifies an alternative debug file.
Specifies a C-SPY device macro file.

Downloads a code image without starting a
debug session afterwards.

Extends the command line.
Specifies a flash loader specification XML file.

Makes the debugger leave the application
running on the target hardware after the debug
session is closed.

Specifies a macro file to be used.

Assigns a value to a C-SPY macro parameter.
Specifies a plugin file to be used.

Onmits the sign-on message.

Disables the warning when the ELF entry point is
at address 0x0.

Limits the maximum allowed execution time.

OPTIONS AVAILABLE FOR ALL C-SPY DRIVERS

--core Specifies the core to be used.

-p Specifies the device description file to be used.

OPTIONS AVAILABLE FOR THE SIMULATOR DRIVER

--disable_interrupts

Disables the interrupt simulation.

--disable_misalignment_exce Allows accesses to misaligned data.

ption

--function_profiling

- -mapu

Analyzes your source code to find where the most
time is spent during execution.

Activates memory access checking.



--multicore_nr_of_cores
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Specify the number of cores on the device for
multicore debugging.

OPTIONS AVAILABLE FOR ALL HARDWARE DEBUGGER

DRIVERS

--drv_communication
--drv_communication_log

--drv_default_breakpoint

--drv_exclude_from_verify
--drv_reset_to_cpu_start

--drv_restore_breakpoints

--drv_vector_table_base

Specifies the communication link to be used.
Creates a log file.

Sets the type of breakpoint resource to be used
when setting breakpoints.

Excludes memory ranges from being verified.
Omits setting the PC when resetting the application.

Restores automatically any breakpoints that were
destroyed during system startup.

Specifies the location of the Cortex-M reset vector
and the initial stack pointer value.

OPTIONS AVAILABLE FOR THE C-SPY I-JET DRIVER

--drv_catch_exceptions
--drv_interface
--drv_interface_speed

--drv_suppress_download

--drv_system_bus_access

--drv_verify download

--jet_board_cfg

--jet_board_did

Makes the application stop for certain exceptions.
Selects the communication interface.
Specifies the JTAG interface speed.

Suppresses download of the executable image. For
reference information, see Download, page 375,
specifically the option Suppress download.

Enables Live Watch and Live Memory reads for
devices that support system bus access.

Verifies the target program. For reference
information, see Download, page 375, specifically
the option Verify download.

Specifies a probe configuration file.

Selects which CPU to debug on a multicore system.

337



Reference information on C-SPY command line options

--jet_ir_length Specifies the number of IR bits preceding the core
to connect to.

--jet_itc_output Sends text to the stdout and stderr streams by
way of trace output, for SiFive devices with an ITC.

--jet_power_from_probe Specifies the power supply from the I-jet or I-jet
Trace probe.

--jet_script_file Specifies the reset script file.

--jet_sigprobe_opt Sets the main trace mode for the debug probe.

--jet_standard_reset Selects the reset strategy to be used when C-SPY
starts.

--jet_startup_connection_ Prolongs the time that the C-SPY driver tries to

timeout connect to the target board.

--jet_tap_position Selects a specific device in the JTAG scan chain.

--reset_style Specifies the reset strategies that will be available
when debugging.

OPTIONS AVAILABLE FOR THE C-SPY GDB SERVER DRIVER

--gdbserv_exec_command Sends a command string to the GDB Server.

OPTIONS AVAILABLE FOR THE C-SPY THIRD-PARTY DRIVERS

For information about any options specific to the third-party driver you are using, see its
documentation.

Reference information on C-SPY command line options

This section gives detailed reference information about each cspybat option and each
option available to the C-SPY drivers.

--application_args

Syntax --application_args="arg0 argl ..."

Parameters arg

A command line argument.

C-SPY® Debugging Guide
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For use with

Description

Example
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cspybat

Use this option to pass command line arguments to the debugged application. These
variables must be defined in the application:

/* __argc, the number of arguments in __argv. */

__no_init __root int __argc;

/* __argv, an array of pointers to the arguments (strings); must
be large enough to fit the number of arguments.*/

__no_init __root const char * __argv[MAX_ARGS];

/* __argvbuf, a storage area for __argv; must be large enough to

hold all command line arguments. */
__no_init __root char __argvbuf [MAX_ARG_SIZE];

--application_args="--logfile log.txt --verbose"

To set this option, use Project>Options>Debugger>Extra Options

--attach_to_running_target

Syntax

For use with

Description

--attach_to_running_target

cspybat

Note: This option might not be supported by the combination of C-SPY driver and
device that you are using. If you are using this option with an unsupported combination,
C-SPY produces a message.

Use this option to make the debugger attach to a running application at its current
location, without resetting the target system.

If you have defined any breakpoints in your project, the C-SPY driver will set them
during attachment. If the C-SPY driver cannot set them without stopping the target
system, the breakpoints will be disabled. The option also suppresses download and the
Run to option.

Project>Attach to Running Target
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--backend

Syntax

Parameters

For use with

Description

--code_coverage _file

Syntax

Parameters

For use with

Description

See also

C-SPY® Debugging Guide
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--backend {driver options}

driver options

Any option available to the C-SPY driver you are using.
cspybat (mandatory).
Use this option to send options to the C-SPY driver. All options that follow --backend

will be passed to the C-SPY driver, and will not be processed by cspybat itself.

This option is not available in the IDE.

--code_coverage_file file

Note that this option must be placed before the - -backend option on the command line.

file
The name of the destination file for the code coverage information.

cspybat

Use this option to enable the generation of a text-based report file for code coverage
information. The code coverage information will be generated after the execution has
completed and you can find it in the specified file. Because most embedded applications
do not terminate, you might have to use this option in combination with --timeout or
--cycles.

Note that this option requires that the C-SPY driver you are using supports code
coverage. If you try to use this option with a C-SPY driver that does not support code
coverage, an error message will be directed to stderr.

Code coverage, page 225, --cycles, page 341, --timeout, page 364.

To set this option, choose View>Code Coverage, right-click and choose Save As when
the C-SPY debugger is running.
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-=Ccore
Syntax --core=RV32{E|G|I}[M][A][F][D]I[C][P]I[N][_Named_ext[_Named extl..]]
--core=RV64{G|I}[M][A][F][D][C][P][N] [NamedExt|[_NamedExtl..]]
Parameters
The parameters correspond to the RISC-V extension support. This option
reflects the corresponding compiler option. Single letter parameters
corresponding to other standard extensions are accepted but ignored.
For use with All C-SPY drivers.
Description Use this option to specify the core you are using.
See also The IAR C/C++ Development Guide for RISC-V for information about the standard
extensions.
Project>Options>General Options>Target>Device
--cycles
Syntax --cycles cycles
Note that this option must be placed before the --backend option on the command line.
Parameters cycles
The number of cycles to run.
For use with cspybat
Description Use this option to specify the maximum number of cycles to run. If the target program

executes longer than the number of cycles specified, the target program will be aborted.
Using this option requires that the C-SPY driver you are using supports a cycle counter,
and that it can be sampled while executing.

This option is not available in the IDE.
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--debug file

Syntax

Parameters

For use with

Description

--device_macro

Syntax

Parameters

For use with

Description

See also

--disable_interrupts

Syntax

For use with

C-SPY® Debugging Guide
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--debug_file filename

filename

The name of the debug file to use.
cspybat

Use this option to make cspybat use the specified debug file instead of the one used in
the generated cpsybat .bat file. This option can be placed both before and after the
--backend option on the command line.

This option is not available in the IDE.

--device_macro filename

Note that this option must be placed before the --backend option on the command line.

filename

The C-SPY device macro file to be used (filename extension dmac).
cspybat

Use this option to specity a C-SPY device macro file to be loaded before you execute
the target application. A device macro is also loaded when you run a flash loader.

A device macro can include scripted reset styles that can be used by the debugger.

This option can be used more than once on the command line.

Briefly about using C-SPY macros, page 268.

This option is not available in the IDE.

--disable_interrupts

The C-SPY simulator driver.



The C-SPY command line utility—cspybat ___g

Description Use this option to disable the interrupt simulation.

To set this option, choose Simulator>Interrupt Configuration and deselect the
[I:E Enable interrupt simulation command on the context menu.

--disable_misalignment_exception

Syntax --disable_misalignment_exception
For use with The C-SPY Simulator driver.
Description By default, the simulator throws an exception when an access to misaligned data is

detected. Use this option to disable that behavior and, in effect, allow accesses to
misaligned data.

mm To set this option, choose Simulator>Data Alignment Setup and select Notification:
None or Notification: Log.

--download_only
Syntax --download_only
Note that this option must be placed before the --backend option on the command line.

For use with cspybat

Description Use this option to download the code image without starting a debug session afterwards.
Project>Download>Download active application
Alternatively, to set a related option, choose:

Project>Options>Debugger>Setup and deselect Run to.
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--drv_catch_exceptions

Syntax --drv_catch_exceptions=value

Parameters
value A 32-bit value. The lower 28 bits specify which exceptions
and interrupts to catch:

Bit 0 = Reset

Bit 1 = Non-maskable interrupt (NMI)

Bit 2 = Instruction access misaligned (IAM)

Bit 3 = Instruction access fault (IAF)

Bit 4 = Illegal instruction (II)

Bit 5 = Load access maligned (LAM)

Bit 6 = Load access fault (LAF)

Bit 7 = Store/AMO access maligned (SAM)

Bit 8 = Store/AMO access fault (SAF)

Bit 9 = User Mode—Environment call (UEC)

Bit 10 = Supervisor Mode—Environment call (SEC)
Bit 11= Machine Mode—Environment call (MEC)
Bit 12 = Instruction page fault (IPF)

Bit 13 = Load page fault (LPF)

Bit 14 = Store/AMO page fault (SPF)

Bit 15-23 = Not used

Bit 24 = External interrupt

Bit 25 = Timer interrupt

Bit 26 = Software interrupt

Bit 27 = Not used

C-SPY® Debugging Guide
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value (Continued) The upper 4 bits specify in which execution mode (or modes)
the exceptions and interrupts will be caught, except for Reset
and NMI which, if selected, will be caught regardless of the
current exception mode:

Bit 28 = Machine Mode
Bit 29 = Supervisor Mode
Bit 30 = User Mode

Bit 31 = Not used

For use with The C-SPY I-jet driver.

Description Use this option to make the application stop when a certain exception occurs.

Note: Not all exceptions are supported by all devices. Refer to the manufacturer’s
device manual to confirm which exceptions your device supports.

Project>Options>Debugger>I-jet>Breakpoints>Catch exceptions

--drv_communication

Syntax --drv_communication=connection
Parameters Where connection is one of these for the C-SPY GDB Server driver:
Via Ethernet TCPIP:ip_address

TCPIP:ip address, port
TCPIP:hostname
TCPIP:hostname, port

Note that if no port is specified, port 3333 is used by default.
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Where connection is one of these for the I-jet debugger driver:

Via USB port USB: #serial where serial is a string of digits and letters
that identifies which probe you want to connect to. The serial
number can be found either printed on the probe, or obtained
by connecting a single probe, and then starting the debug
session. The serial number is then displayed in the Debug
Log window. The serial number is also displayed in the
Debug Probe Selection dialog box.

USB: #select forces the Debug Probe Selection dialog box
to be displayed each time you start a debug session.

For use with Any C-SPY hardware debugger driver.

Description Use this option to choose the communication link.

Project>Options>Debugger>C-SPY driver>Setup.

--drv_communication_log

Syntax --drv_communication_log=filename
Parameters
filename The name of the log file.
For use with All C-SPY hardware debugger drivers.
Description Use this option to log the communication between C-SPY and the target system to a file.

To interpret the result, detailed knowledge of the communication protocol is required.

Project>Options>Debugger>C-SPY driver>Log communication

--drv_default_breakpoint

Syntax --drv_default_breakpoint={0]|1]|2}
Parameters

0 Auto (default)

1 Hardware

C-SPY® Debugging Guide
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For use with

Description
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2 Software

Any C-SPY hardware debugger driver.

Use this option to select the type of breakpoint resource to be used when setting a
breakpoint.

Project>Options>Debugger>C-SPY driver>Breakpoints>Default breakpoint type

--drv_exclude_from_verify

Syntax

Parameters

For use with

Description

--drv_interface

Syntax

Parameters

For use with

Description

--drv_exclude_from_verify=startaddr-endaddr

startaddr The start of the memory range.

endaddr The end of the memory range.

Any C-SPY hardware debugger driver.

Use this option to exclude memory ranges from being verified when the option
--drv_verify_download, or the option Verify download in the Project>Options

dialog box in the IDE, is used. The option can be specified multiple times to exclude
several ranges.

To set this option, use Project>Options>Debugger>Extra Options.

--drv_interface={JTAG|cJTAG}

JTAG (default) Specifies the JTAG interface

cJTAG Specifies the cJTAG interface.

The C-SPY I-jet driver.

Use this option to specify the communication interface between the debug probe and the
target system.
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--drv_interface_speed

Syntax

Parameters

For use with
Description

See also

Project>Options>Debugger>I-jet>Interface>Interface

--drv_interface_speed=kHz

kHz The frequency in kHz

The C-SPY I-jet driver.
Use this option to set the JTAG communication speed in kHz.

Ljet : Setup, page 383.

Project>Options>Debugger>I-jet>Interface>Interface speed

--drv_reset_to_cpu_start

Syntax
For use with

Description

--drv_reset_to_cpu_start
Any C-SPY hardware debugger driver.

Normally, at reset, the debugger sets PC to the entry point of the application.

This option omits setting the PC each time that the application is reset. This can be useful
when you want to keep the reset value that the CPU sets at reset, for example to start
executing from the first instruction pointed out by the vector table, or to run a bootloader
or OS startup code before entering the start address of the application.

To set this option, use Project>Options>Debugger>Extra Options.

--drv_restore_breakpoints

Syntax

ParametersParameters

C-SPY® Debugging Guide
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--drv_restore_breakpoints=Ilocation

location Address or function name label



For use with

Description
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Any C-SPY hardware debugger driver.

Use this option to restore automatically any software breakpoints that were overwritten
during system startup.

Project>Options>Debugger>Driver>Breakpoints>Restore software breakpoints
at

--drv_suppress_download

Syntax
For use with

Description

--suppress_download
The C-SPY I-jet driver.

Use this option to suppress the downloading of the executable image to a non-volatile
type of target memory. The image corresponding to the debugged application must
already exist in the target.

If this option is combined with the option --verify_ download, the debugger will read
back the executable image from memory and verify that it is identical to the debugged
application.

Project>Options>Debugger>Download>Suppress download

--drv_system_bus_access

Syntax
For use with

Description

--drv_system_bus_access
The C-SPY I-jet driver

Use this option to inform the I-jet driver that the device supports memory access via the
system bus. This is required for Live Watch and live updates of the Memory windows.

To set this option, use Project>Options>Debugger>I-jet>Setup>Allow system bus
access.
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--drv_vector_table_base

Syntax

Parameters

For use with

Description

--drv_verify_download

Syntax
For use with

Description

-f
Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
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--drv_vector_table_base=expression

expression A label or an address

Any C-SPY hardware debugger driver.
Use this option to specity the location of the reset vector. This is useful if you want to
override the default __vector_table label—defined in the system startup code—in

the application or if the application lacks this label, which can be the case if you debug
code that is built by tools from another vendor.

Project>Options>Debugger>Extra Options.

--verify_download
Any C-SPY hardware debugger driver.

Use this option to verify that the downloaded code image can be read back from target
memory with the correct contents.

Project>Options>Debugger>Download>Verify download

-f filename

filename
A text file that contains the command line options (default filename extension
xcl).

cspybat

Use this option to make cspybat read command line options from the specified file.
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In the command file, you format the items exactly as if they were on the command line
itself, except that you may use multiple lines, because the newline character is treated
like a space or tab character.

Both C/C++ style comments are allowed in the file. Double quotes behave in the same
way as in the Microsoft Windows command line environment.

This option can be placed either before or after the --backend option on the command
line.

To set this option, use Project>Options>Debugger>Extra Options.

--flash_loader

Syntax --flash_loader filename

Note that this option must be placed before the --backend option on the command line.

Parameters filename
The flash loader specification XML file, with the filename extension board.

For use with cspybat

Description Use this option to specify a flash loader specification XML file which contains all
relevant information about the flash loading. There can be more than one such argument,
in which case each argument will be processed in the specified order, resulting in several

flash programming passes.

See also The IAR Flash Loader Development Guide.

To set related options, choose:

Project>Options>Debugger>Use flash loader(s)

--function_profiling

Syntax --function_profiling filename

Parameters filename

The name of the log file where the profiling data is saved.

For use with The C-SPY simulator driver.
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Description

Use this option to find the functions in your source code where the most time is spent
during execution. The profiling information is saved to the specified file. For more
information about function profiling, see Profiling, page 215.

C-SPY driver>Function Profiling

--gdbserv_exec_command

Syntax

Parameters

For use with

Description

--jet_board_cfg

Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
for RISC-V

--gdbserv_exec_command="string"

string String or command sent to the GDB Server. For more
information, see the GDB server documentation.

The C-SPY GDB Server driver.

Use this option to send strings or commands to the GDB Server.

Project>Options>Debugger>Extra Options

--jet_board_cfg=probe_configuration_file

probe_configuration_file  The full path to a probe configuration file.

The C-SPY I-jet driver.

Use this option to specify a probe configuration file that defines the debug system on the
board.

Project>Options>Debugger>I-jet>Interface>Probe configuration file



--jet_board_did

Syntax

Parameters

For use with
Description

Example

--jet_ir_length

Syntax

Parameters

The C-SPY command line utility—cspybat ___g

--jet_board_did={cpu | #cpu_number}

cpu If a board configuration file is specified (using
--jet_board_cfg) and the defined debug system
contains more than one CPU, use this parameter to select a
CPU. The value of cpu is a text string. The range of valid
values are located in the probe configuration file.

#cpu_number If the debug system is a JTAG scan chain, and there are
several CPUs at the specified TAP position, then specify the
CPU number on target.

Note that #cpu_number has no effect if a board
configuration file is specified using --jet_board_cfg.

The C-SPY I-jet driver.
Use this option to specify which CPU to debug on a multicore system.

Selecting the CPU on a multicore device with a probe configuration file:
--jet-board-cfg=device.ProbeConfig --jet_board_did=A9_1

Selecting the CPU on a multicore device with a JTAG scan chain, where several CPUs
are found at the specified TAP position:

--jet_tap_position=1 --jet_ir_length=5 --jet_board_did=#2
Project>Options>Debugger>I-jet>Interface>Probe configuration file>CPU

Project>Options>Debugger>I-jet>Interface>Explicit probe configuration>CPU
number on target

--jet_ir_length=Iength

length The number of IR bits preceding the core to connect to, for
JTAG scan chains that mix RISC-V devices with other
devices.
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For use with The C-SPY I-jet driver.
Description Use this option to set the number of IR bits preceding the core to connect to.
See also Ljet : Interface, page 386

m  Project>Options>Debugger>I-jet>Interface>Explicit probe
configuration>Preceding bits

--jet_itc_output

Syntax --jet_itc_output
For use with The C-SPY I-jet driver.
Description Makes the executing application send text to the stdout and stderr streams by way

of trace output, rather than by temporarily stopping the core at a breakpoint. This
requires an Instrumentation Trace Component (ITC), present on some SiFive devices.

See also Trace Settings dialog box, page 180

m  Project>Options>General Options>Library Configuration>Library low-level
interface implementation>Stdout/Stderr>Via SiFive ITC

--jet_power_from_probe

Syntax --jet_power_from_probe=[leave_on | switch_off]

Parameters
leave_on Continues to supply power to the target even after the debug
session has been stopped.

switch off Turns off the power to the target when the debug session
stops.
For use with The C-SPY I-jet driver.
Description Use this option to specity the status of the probe power supply after debugging.

If this option is not specified, the probe will not supply power to the board.

Project>Options>Debugger>I-jet>Setup>Target power

C-SPY® Debugging Guide
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--jet_script_file

Syntax --jet_script_file=path

Parameters
path The path to the file where the scripted reset strategies are

described.

For use with The C-SPY I-jet driver.

Description Use this option to specify the file that describes the available scripted reset strategies, if
any.

See also --reset _style, page 362 and --jet standard reset, page 357.

To set this option, use Project>Options>Debugger>Extra Options.

--jet_sigprobe_opt

Syntax --jet_sigprobe_opt=trace (mode=behavior[,base=address])

Parameters
behavior The trace behavior when you use the I-jet probe. Choose between:

auto — Uses External, Serial, or RAM trace, in that order, depending
on the capabilities of the debug probe. This is the default trace
behavior when using C-SPY without an IDE project.

external — Collects External trace data, see External trace, page
176. If this mode is not supported by the debug probe, trace will
be disabled for the session.

of £ — This disables I-jet trace completely. Trace cannot be enabled in
any trace-related windows for the I-jet driver. This ensures that
trace modules will not do any reading/writing to the target system.

ram— Collects RAM trace data, see RAM trace, page 176. If this mode
is not supported by the debug probe, trace will be disabled for the
session.

serial — Collects Serial trace data, see Serial trace, page 176. If this
mode is not supported by the debug probe, trace will be disabled
for the session.
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For use with

Description

Example

See also

C-SPY® Debugging Guide
for RISC-V

address A device-specific base address for trace hardware registers. If no base
address is specified, the base address 0x1000' 0000 will be used by
default.

The C-SPY I-jet driver and a device that supports trace.

Use this option to change the main trace mode for the debug probe. (This will override
the setting in the Trace Settings dialog box in the IDE.)

--jet_sigprobe_opt=trace (mode=serial,base=0x18020000)

Trace Settings dialog box, page 180.

To set this option in the IDE, use the Mode option in the Trace Settings dialog box.
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--jet_standard_reset
Syntax --jet_standard_reset=strategy,duration,delay
Parameters
strategy The reset strategy. Choose between:
0, reset disabled
1, software reset
2, hardware reset
3, reset just a single hart
4, system reset.

The following reset strategies are available, if present in the
file specified by --jet_script_file and defined by
corresponding instances of --reset_style:

5, custom reset

6, reset by watchdog or reset register

7, reset and halt after bootloader

8, reset and halt before bootloader

9, connect during reset.

For more information, see /-jet : Setup, page 383.

duration The time in milliseconds that the hardware reset asserts the
reset signal (line nSRST/nRESET) low to reset the device.

Some devices might require a longer reset signal than the
default 200 ms.

This parameter applies to the hardware reset, and to those
custom reset strategies that use the hardware reset.
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delay The delay time, in milliseconds, after the reset signal has
been de-asserted, before the debugger attempts to control the
processor.

The processor might be kept internally in reset for some time
after the external reset signal has been de-asserted, and
therefore inaccessible to the debugger.

This parameter applies to the hardware reset, and to those
custom reset strategies that use the hardware reset.

For use with The C-SPY I-jet driver.
Description Use this option to select the reset strategy to be used when the debugger starts.
See also --reset_style, page 362 and --jet_script file, page 355.

Project>Options>Debugger>I-jet>Setup>Reset

--jet_startup_connection_timeout

Syntax --jet_startup_connection_timeout=milliseconds

Parameters
milliseconds The time in milliseconds.

For use with The C-SPY I-jet driver.

Description Use this option to prolong the time that the C-SPY driver tries to connect to the target
board.

To set this option, use Project>Options>Debugger>Extra Options.

--jet_tap_position

Syntax --jet_tap_position=tap_number | multidrop_id

Parameters
tap_number The TAP position of the device you want to connect to.
multidrop_id The target ID in a multi-drop system.

C-SPY® Debugging Guide
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For use with The C-SPY I-jet driver.

Description If there is more than one device on the JTAG scan chain, use this option to select a
specific device.
See also I-jet : Interface, page 386.

o Project>Options>Debugger>I-jet>Interface>Explicit probe configuration>Target
number (TAP or target ID)

--leave_target_running

Syntax --leave_target_running

For use with cspybat.
Any C-SPY hardware debugger driver.
Note: Even if this option is supported by the C-SPY driver you are using, there might
be device-specific limitations.

Description Use this option to make the debugger leave the application running on the target
hardware after the debug session is closed.

Because existing breakpoints might not be automatically removed, consider disabling
all breakpoints before using this option.

C-SPY driver>Leave Target Running

==mMacro
Syntax --macro filename
Note that this option must be placed before the - -backend option on the command line.
Parameters filename
The C-SPY macro file to be used (filename extension mac).
For use with cspybat
Description Use this option to specify a C-SPY macro file to be loaded before executing the target

application. This option can be used more than once on the command line.
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See also

--mMacro_param

Syntax

Parameters

For use with

Description

See also

--mapu
Syntax
For use with

Description

See also

C-SPY® Debugging Guide
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Briefly about using C-SPY macros, page 268.

Project>Options>Debugger>Setup>Setup macros>Use macro file

--macro_param [param=value]

Note that this option must be placed before the --backend option on the command line.

param=value

paramis a parameter defined using the __param C-SPY macro construction.
value is a value.

cspybat

Use this option to assign a value to a C-SPY macro parameter. This option can be used
more than once on the command line.
Macro parameters, page 275.

To set this option, use Project>Options>Debugger>Extra Options

--mapu
The C-SPY simulator driver.

Specify this option to use the section information in the debug file for memory access
checking. During the execution, the simulator will then check for accesses to
unspecified memory ranges. If any such access is found, the C function call stack and a
message will be printed on stderr and the execution will stop.

Monitoring memory and registers, page 133.

To set related options, choose:

Simulator>Memory Access Setup
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--multicore_nr_of cores

Syntax

Parameters

For use with

Description

See also

Syntax

Parameters

For use with
Description

See also

--plugin

Syntax

Parameters

--multicore_nr_of_cores=cores

cores

The number of cores on your device. This must be an integer from 2-8.
The C-SPY simulator driver.
For symmetric multicore debugging, specify the number of cores on your device. This
option is not needed for debugging a single-core system, or for asymmetric multicore

debugging.

Multicore debugging, page 233.

Project>Options>Debugger>Multicore>Number of cores

-p filename

filename

The device description file to be used.
All C-SPY drivers.
Use this option to specify the device description file to be used.

Selecting a device description file, page 43.

Project>Options>Debugger>Setup>Device description file

--plugin filename

Note that this option must be placed before the --backend option on the command line.

filename

The plugin file to be used (filename extension d11).
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For use with

Description

--reset_style

C-SPY® Debugging Guide

for RISC-V

Syntax

Parameters

For use with

Description

cspybat

Certain C/C++ standard library functions, for example print£, can be supported by
C-SPY—for example, the C-SPY Terminal I/0O window—instead of by real hardware
devices. To enable such support in cspybat, a dedicated plugin module called
riscvbat.dll located in the riscv\bin directory must be used.

Use this option to include this plugin during the debug session. This option can be used
more than once on the command line.

Note: You can use this option to also include other plugin modules, but in that case the
module must be able to work with cspybat specifically. This means that the C-SPY
plugin modules located in the common\plugin directory cannot normally be used with
cspybat.

Project>Options>Debugger>Plugins

--reset_style="reset_id, reset_name, selected, menu_command"

reset_id The number of the reset strategy, 0-9, as described for
--jet_standard_reset

reset_name The name of the reset strategy, according to the file specified by
--jet_script_file.

For the built-in reset strategies, this parameter is -. To override
abuilt-in reset strategy, enter the label or function name in your
reset script file.

selected 0 or 1, where 1 sets the default reset strategy for the Reset
drop-down button

menu_command The name of the reset strategy as it will be displayed on the
Reset drop-down menu.

The C-SPY I-jet driver.

Use this option to specify the reset strategies that will be available when debugging,
once for each reset strategy.
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Example This example specifies a script file, sets the standard reset strategy, and specifies the
reset strategies that will be available when debugging:

--jet_script_file=myDir\myProbeScriptFile
--jet_standard_reset=9,0,0

--reset_style="0,-,0,Disabled (no reset)"
--reset_style="1,-,0,Software"
--reset_style="2,-,0,Hardware"
--reset_style="3,-,0,Core"

--reset_style="4,-,0,System"
--reset_style="5,Custom, 0,Custom reset"
--reset_style="9,ConnectUnderReset, 1,Connect during reset"

See also --jet script file, page 355 and --jet standard reset, page 357
To set this option, use Project>Options>Debugger>Extra Options.

--silent
Syntax --silent
Note that this option must be placed before the --backend option on the command line.
For use with cspybat
Description Use this option to omit the sign-on message.

oo This option is not available in the IDE.

[[H

--suppress_entrypoint_warning

Symax --suppress_entrypoint_warning
For use with cspybat
Description Use this option to disable the warning in the debug log when a debug session starts with

the ELF entry point at address 0x0 (which according to the ELF standard means that
there is no entry point). In practice, there is no problem with having the entry point at
address 0x0.

m To set this option, use Project>Options>Debugger>Extra Options

[[H
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--timeout
Syntax --timeout milliseconds
Note that this option must be placed before the - -backend option on the command line.
Parameters milliseconds
The number of milliseconds before the execution stops.
For use with cspybat
Description Use this option to limit the maximum allowed execution time.

This option is not available in the IDE.

C-SPY® Debugging Guide
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e Introduction to the flash loader
e Using flash loaders

e Reference information on the flash loader

Introduction to the flash loader

A flash loader is an agent that is downloaded to the target. It fetches your application
from the debugger and programs it into flash memory. The flash loader uses the file I/O
mechanism to read the application program from the host. You can select one or several
flash loaders, where each flash loader loads a selected part of your application. This
means that you can use different flash loaders for loading different parts of your
application.

Flash loaders for various microcontrollers are provided with IAR Embedded Workbench
for RISC-V. In addition to these, more flash loaders are provided by chip manufacturers
and third-party vendors. The flash loader API, documentation, and several
implementation examples are available to make it possible for you to implement your
own flash loader.

Using flash loaders

These tasks are covered:

e Setting up the flash loader(s)
e Aborting a flash loader

SETTING UP THE FLASH LOADER(S)

To use a flash loader for downloading your application:
Choose Project>Options.
Choose the Debugger category and click the Download tab.

Select the Use Flash loader(s) option. A default flash loader configured for the device
you have specified will be used. The configuration is specified in a preconfigured
board file.
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4 To override the default flash loader or to modify the behavior of the default flash loader
to suit your board, select the Override default .board file option.
ABORTING A FLASH LOADER

To abort a flash loader:
I Press Ctrl+Shift+. (period) for a short while.

2 A message that says that the flash loader has aborted is displayed in the Debug Log
window.

This method can be used if you suspect that something is wrong with the execution, for
example because it seems not to terminate in a reasonable time.

Reference information on the flash loader

Reference information about:

® Flash Loader Overview dialog box, page 366
o Flash Loader Configuration dialog box, page 368

Flash Loader Overview dialog box

The Flash Loader Overview dialog box is available from the
Project>Options>Debugger>Download page.

Flash Loader Overview

CODE : 0x8000000 - 0x80 1fffff - STOOLKIT_DIRS\config\flashloader'... -

Range Offset/Address  Loader Path Loader Relocation Extra Parameters 0K

This dialog box lists all defined flash loaders. If you have selected a device on the
Project>Options>General Options>Target page for which there is a flash loader, this
flash loader is by default listed in the Flash Loader Overview dialog box.

C-SPY® Debugging Guide
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Requirements

Available for supported hardware debugger systems.

Display area

Each row in the display area shows how you have set up one flash loader for flashing a
specific part of memory:

Range
The part of your application to be programmed by the selected flash loader.
Offset/Address

The start of the memory where your application will be flashed. If the address
is preceded by an A, the address is absolute. Otherwise, it is a relative offset to
the start of the memory.

Loader Path

The path to the flash loader * . £1ash file to be used (* . out for old-style flash
loaders).

Loader Relocation

For relocatable flash loaders, this is the start of the target RAM memory where
the flash loader will be downloaded.

Extra Parameters

List of extra parameters that will be passed to the flash loader.

Click on the column headers to sort the list by range, offset/address, etc.

Function buttons

These function buttons are available:

OK
The selected flash loader(s) will be used for downloading your application to
memory.

Cancel
Standard cancel.

New
Displays a dialog box where you can specity what flash loader to use, see Flash
Loader Configuration dialog box, page 368.

Edit

Displays a dialog box where you can modify the settings for the selected flash
loader, see Flash Loader Configuration dialog box, page 368.
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Delete

Deletes the selected flash loader configuration.

Flash Loader Configuration dialog box

Requirements

Memory range

C-SPY® Debugging Guide
for RISC-V

The Flash Loader Configuration dialog box is available from the Flash Loader
Overview dialog box.

Flash Loader Configuration

(o]
All

@ Start:  OxD End: 0x0 Cancel

Relocate
Offset:

Absolute address:| 0x0

Flash loader path:

RAM load address: | 0x077077014

Extra parameters:

Parameter descriptions:

Use the Flash Loader Configuration dialog box to configure the download to suit your
board. A copy of the default board file will be created in your project directory.

Available for supported hardware debugger systems.

Specify the part of your application to be downloaded to flash memory. Choose
between:

All
The whole application is downloaded using this flash loader.

Start/End

Specify the start and the end of the memory area for which part of the
application will be downloaded.
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Relocate

Overrides the default flash base address, in other words, relocates the location of the
application in memory. This means that you can flash your application to a different
location from where it was linked. Choose between:
Offset
A numeric value for a relative offset. This offset will be added to the addresses
in the application file.
Absolute address

A numeric value for an absolute base address where the application will be
flashed. The lowest address in the application will be placed on this address.
Note that you can only use one flash loader for your application when you
specify an absolute address.

You can use these numeric formats:

® 123456, decimal numbers

® 0x123456, hexadecimal numbers

® 0123456, octal numbers

The default base address used for writing the first byte—the lowest address—to flash is
specified in the linker configuration file used for your application. However, it can
sometimes be necessary to override the flash base address and start at a different location

in the address space. This can, for example, be necessary for devices that remap the
location of the flash memory.

Flash loader path

Use the text box to specify the path to the flash loader file (* . £1ash) to be used by your
board configuration.

RAM load address

If the flash loader is relocatable, this option overrides the default address in the target
RAM memory that flash loader is downloaded to, in other words, relocates the flash
loader. Use the text box to specify the address.

Extra parameters

Some flash loaders define their own set of specific options. Use this text box to specify
options to control the flash loader. For information about available flash loader options,
see the Parameter descriptions field.

369



Reference information on the flash loader

Parameter descriptions

Displays a description of the extra parameters specified in the Extra parameters text
box.

C-SPY® Debugging Guide
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Part 4. Additional
reference information

This part of the C-SPY® Debugging Guide for RISC-V includes these chapters:
e Debugger options

e Additional information on C-SPY drivers

.hﬁhhhhm
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Debugger options

e Setting debugger options
e Reference information on general debugger options

e Reference information on C-SPY hardware debugger driver options

Setting debugger options

Before you start the C-SPY debugger you might need to set some options—both C-SPY
generic options and options required for the target system (C-SPY driver-specific
options).

To set debugger options in the IDE:
I Choose Project>Options to display the Options dialog box.
2 Select Debugger in the Category list.

For more information about the generic options, see Reference information on general
debugger options, page 374.

3 On the Setup page, make sure to select the appropriate C-SPY driver from the Driver
drop-down list.

4 To set the driver-specific options, select the appropriate driver from the Category list.
Depending on which C-SPY driver you are using, different options are available.

C-SPY driver Available options pages

GDB Server driver GDB Server: Setup, page 381

GDB Server: Breakpoints, page 382
C-SPY I-Jet driver I-jet : Setup, page 383

I-jet : Interface, page 386

I-jet : Breakpoints, page 388
Third-party driver Third-Party Driver options, page 389

Table 36: Options specific to the C-SPY drivers you are using
5 To restore all settings to the default factory settings, click the Factory Settings button.

6 When you have set all the required options, click OK in the Options dialog box.
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Reference information on general debugger options

Reference information about:

Setup, page 374
Download, page 375
Images, page 376
Multicore, page 377
Extra Options, page 379

Plugins, page 380

Setup

The general Setup options select the C-SPY driver, the setup macro file, and device
description file to use, and specify which default source code location to run to.

Setup

Driver: Run to:
Simulator A main
Setup macros

[ Use macro file:

5PROJ_DIR&\Setup Simulation. mac

Device description file
[ Overide defautt:
STOOLKIT_DIRS corfig'debugger.generic ddf

Driver

Selects the C-SPY driver for the target system you have.

Run to

Specifies the location C-SPY runs to when the debugger starts after a reset. By default,
C-SPY runs to the main function.

To override the default location, specify the name of a different location you want
C-SPY torun to. You can specify assembler labels or whatever can be evaluated as such,
for example function names.

If the option is deselected, the program counter will contain the regular hardware reset
address at each reset.

See also Executing from reset, page 42.

C-SPY® Debugging Guide
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Setup macros
Registers the contents of a setup macro file in the C-SPY startup sequence. Select Use
macro file and specity the path and name of the setup file, for example
SetupSimple.mac. If no extension is specified, the extension mac is assumed. A
browse button is available.

Device description file
A default device description file is selected automatically based on your project settings.
To override the default file, select Override default and specify an alternative file. A
browse button is available.

For information about the device description file, see Modifying a device description
file, page 47.

Download
By default, C-SPY downloads the application to RAM or flash when a debug session
starts. The Download options let you modify the behavior of the download.

Download

[ Verify download
[ Suppress download
Use flash loaden(s)
[T Overide defautt board file

Verify download

Verifies that the downloaded code image can be read back from target memory with the
correct contents.

Suppress download

Disables the downloading of code, while preserving the present content of the flash.
This command is useful if you want to debug an application that already resides in target
memory.
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If this option is combined with the Verify download option, the debugger will read back
the code image from non-volatile memory and verify that it is identical to the debugged
application.

Use flash loader(s)

Use this option to use one or several flash loaders for downloading your application to
flash memory. If a flash loader is available for the selected chip, it is used by default.

See Flash loaders, page 365.

Override default .board file

A default flash loader is selected based on your choice of device on the General
Options>Target page. To override the default flash loader, select Override default
.board file and specify the path to the flash loader you want to use. A browse button is
available.

Images
The Images options control the use of additional debug files to be downloaded.

Images

Download extra image

Path: (=]

Offzet: [ Debug infa onty

[ Download extra image

Debug info only

[ Download extra image

Debug info only

Download extra Images

Controls the use of additional debug files to be downloaded:

Path
Specify the debug file to be downloaded. A browse button is available.
Offset
Specify an integer that determines the destination address for the downloaded
debug file.

C-SPY® Debugging Guide
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Debug info only
Makes the debugger download only debug information, and not the complete
debug file.

If you want to download more than three debug images, use the related C-SPY macro,
see  loadlmage, page 297.

For more information, see Loading multiple debug images, page 45.

The Multicore options configure multicore debugging.

Mutticore

Symmetric multicore

Asymmetric multicore
(O Disabled

(® Simple
Partner workspace: |C:'-.Temp'-.I'\'Ty‘.‘\i'orkspace.eww |

Partner project: | MyProject |

Partner configuration: | Debug
Attach partner to running target Partner cores: IZ
COvemide partner debugger location
Partner debugger: |C:'-.Pn:|gram Files AR Systems'-.Embed|
() Advanced

Number of cores

Disabled

Simple

For symmetric multicore debugging, specify the number of cores on your device. For
asymmetric multicore debugging, specify the number of cores in the master project.
(Normally, this will be 1.)

Selecting this option makes the debug session symmetric multicore.

Selecting this option makes the debug session an asymmetric multicore debugger
master. When you start a debug session, a new instance of the IAR Embedded
Workbench IDE will be started, using the following options:

Partner workspace
Specify the workspace to be opened in the partner (slave) instance.
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Partner project
Specify the name of the project in the workspace to be opened in the partner
instance. For example, if the project filename is MyPartnerProj . ewp, specify
MyPartnerProj.

Partner configuration
Specify the build configuration to be used when debugging the partner. For
example, Debug or Release.

Attach partner to running target
If you have selected the command Attach to Running Target from the Project
menu, which affects the master. You can also select Attach partner to running
target to also make the debugger attach the partner to the running application at
its current location, without resetting the target system.

For information about Attach to Running Target, see the /DE Project
Management and Building Guide for RISC-V.

Partner cores
Specify the number of cores in the partner project.

Override partner debugger location
If the Embedded Workbench instance associated with the partner project is not
installed in the same location as the Embedded Workbench instance associated
with the master project, for example in c: \Program Files\IAR
Systems\Embedded Workbench N. ., you must specify the installation
directory of the Embedded Workbench for the partner project. Note that the
Embedded Workbench must be based on version 9.1.7 or later of the shared
components—to check this, choose Help>About>Product Info.

Advanced

Selecting this option makes the debug session asymmetric multicore with one or more
new instances of the IAR Embedded Workbench IDE.

Session configuration
Use the browse button to specify the XML multicore session file that contains
the settings for the debug session. For more information about this file, see 7he
multicore session file, page 241.
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Extra Options

The Extra Options page provides you with a command line interface to C-SPY.
Extra Options

[ Use command line options

Use command line options

Specify command line arguments that are not supported by the IDE to be passed to
C-SPY.

Note that it is possible to use the /args option to pass command line arguments to the
debugged application.

The syntax is:

/args arg0 argl

Multiple lines with /args are allowed, for example:
/args --logfile log.txt

/args --verbose

If you use /args, these variables must be defined in your application:

/* __argc, the number of arguments in __argv. */
__no_init __root int __argc;
/* __argv, an array of pointers to strings that holds the

arguments; must be large enough to fit the number of
parameters. */
__no_init __root const char * __argv[MAX_ARGS];

/* __argvbuf, a storage area for __argv; must be large enough to
hold all command line parameters. */
__no_init __root char __argvbuf [MAX_ARG_SIZE];
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Plugins
The Plugins options select the C-SPY plugin modules to be loaded and made available
during debug sessions.

Plugins

Select plugins to load:

Code Coverage

Description: Enables code coverage in the debugger.

Location: n 8.0_2common'pluginsCodeCoverage \CodeCoverage dll
Criginator: IAR Systems

Version: 8.05.4818

Select plugins to load

Selects the plugin modules to be loaded and made available during debug sessions. The
list contains the plugin modules delivered with the product installation.

Description
Describes the plugin module.

Location
Informs about the location of the plugin module.
Generic plugin modules are stored in the common\plugins directory. Target-specific
plugin modules are stored in the riscv\plugins directory.

Originator
Informs about the originator of the plugin module, which can be modules provided by
IAR or by third-party vendors.

Version

Informs about the version number.

C-SPY® Debugging Guide
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Reference information on C-SPY hardware debugger driver options
Reference information about:

GDB Server: Setup, page 381

GDB Server: Breakpoints, page 382

Ljet : Setup, page 383

[-jet : Interface, page 386

I-jet : Breakpoints, page 388

Third-Party Driver options, page 389

GDB Server: Setup

The GDB Server Setup options control the C-SPY GDB Server driver.
GDB Server

TCPAP address or hostname [port]
a3a.bbb.coe.ddd

™ Log communication

| o

TCPI/IP address or hosthame

Specify the IP address and port number of a GDB server—by default the port number
3333 is used. The TCP/IP connection is used for connecting to a J-Link server running
on a remote computer.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.

381



Reference information on C-SPY hardware debugger driver options

382

GDB Server: Breakpoints

The Breakpoints options specify the breakpoint behavior for the C-SPY GDB Server
driver.
Breakpoints

Default breakpoint type
® Auto

(O Hardware

(O Software

[] Restore software breakpoints at | _call_main

Default breakpoint type

Selects the type of breakpoint resource to be used when setting a breakpoint. Choose
between:

Auto Uses a software breakpoint. If this is not possible, a
hardware breakpoint will be used. The debugger will use
read/write sequences to test for RAM—in that case, a
software breakpoint will be used.

Hardware Uses hardware breakpoints. If it is not possible, no
breakpoint will be set.

Software Uses software breakpoints. If it is not possible, no
breakpoint will be set.

Restore software breakpoints at

C-SPY® Debugging Guide
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Restores software breakpoints that were overwritten during system startup.

This can be useful if you have an application that is copied to RAM during startup and
is then executing in RAM. This can, for example, be the caseif youuse the initialize
by copy linker directive for code in the linker configuration file.

In this case, all breakpoints will be destroyed during the RAM copying when the C-SPY
debugger starts. By using the Restore software breakpoints at option, C-SPY will
restore the destroyed breakpoints.
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Reset
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Use the text field to specify the location in your application at which point you want
C-SPY to restore the breakpoints. The default location is the label _call main.

The Setup options control the I-jet in-circuit debugging probes:
Setup

Reset
Hardware (default) ~ | Duration: ms
[JOvenide default delay after reset: 200
Target power Emulator
[ From the probe | ;“Je\i\;adyisoﬁmmpt for probe
Leave on after debugging
Switch off after de ']' . ' Serial no: l:l

Allow system bus access
[ Log communication
SPROJ_DIRS

Selects the reset strategy to be used when the debugger starts. Choose between:

Disabled (no reset)

No reset is performed.

Software

Sets pC to the program entry address and SP to the initial stack pointer value.

This is a software reset.

Hardware

The probe toggles the nSRST/nRESET line on the JTAG connector to reset the
device. Usually, this reset also resets the peripheral units.

The processor should stop at the reset handler before executing any instruction.
Some processors might not stop at the reset vector, but will be halted soon after,
executing some instructions.

Core

Resets a single hart but any peripheral units are not affected. Only available for
some devices.
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Duration

System
Resets all harts of the processor and all peripheral units. Reset vector catch is
used for stopping the CPU at the reset vector before the first instruction is
executed. Only available for some devices.

All strategies halt the CPU after the reset.

A software reset of the target does not change the settings of the target system—it only
resets the program counter and the mode register to its reset state.

Normally, a C-SPY reset is only a software reset. If you use the Hardware option,
C-SPY will generate an initial hardware reset when the debugger is started. This is
performed once before download, and if the option Use flash loader(s) is selected, also
once after flash download.

Hardware resets can be a problem if the low-level setup of your application is not
complete. If the low-level setup does not set up memory configuration and clocks, the
application will not work after a hardware reset. To handle this in C-SPY, the setup
macro function execUserReset () is suitable.

The time in milliseconds that the hardware reset asserts the reset signal (line
nSRST/nRESET) low to reset the device.

Some devices might require a longer reset signal than the default 300 ms.

This option applies to the hardware reset, and to those custom reset strategies that use
the hardware reset.

Override default delay after reset

Target power

C-SPY® Debugging Guide
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Use this option to change the default delay time, in milliseconds, after the reset signal
has been de-asserted, before the debugger attempts to control the processor.

The processor might be kept internally in reset for some time after the external reset
signal has been de-asserted, and thus inaccessible for the debugger.

This option applies to the hardware reset, and to those custom reset styles that use the
hardware reset.

These options specify how the target system is powered, and if it is powered from the
debug probe, the status of the power supply after debugging.

From the probe

Supplies the target system with power from the probe. If this option is
deselected, the target system must be powered separately.
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Leave on after debugging

Continues to supply the target system with power from the probe even after the
debug session has been stopped.

Switch off after debugging
Turns off the power to the target when the debug session stops.

Emulator
These options are used for identifying the debug probe to use.

Always prompt for probe selection

Makes C-SPY always ask you to confirm which probe to use, if more than one
debug probe is connected to the host computer.

Serial no
Enter the serial number of the debug probe you are using.

Allow system bus access

Informs the C-SPY driver that the target device supports memory access via the system
bus. This is required for Live Watch and live updates of the Memory windows.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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I-jet : Interface

Probe config

Interface

Interface speed

C-SPY® Debugging Guide
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The Interface options specify the interface between I-jet and the target system.

Interface

Probe corfig Probe configuration file
) futo [F] Overide defautt

@) From file

) Explicit CPU: Select

Interface Explicit probe configuration

@ JTAG [ Multi4arget debug system

©) cITAG Target number (TAF ortarget ID): o

[ Target with muttiple CPUs
Interface speed CPU number on target: 0
[T]JTAG scan chain contains non-RISC-V devices
Preceding bits: 0

Auto

The I-jet driver automatically identifies the target CPU. It uses the default probe
configuration file, if there is one.

This works best if there is only one CPU present.

From file
Specifies that the probe configuration file needs to be overridden, or that there
are several target CPUs.

Explicit
Specify how to find the target CPU.

Selects the communication interface between the debug probe and the target system.
Choose between:

JTAG
Uses the JTAG interface.

cJTAG
Uses the cJTAG interface.

Specity the JTAG communication speed. Choose between:
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Auto detect
Automatically uses the highest possible frequency for reliable operation.
nHz

If there are JTAG communication problems or problems in writing to target
memory (for example during program download), these problems might be
resolved if the speed is set to a lower frequency.

Probe configuration file
Override default

Specify a probe configuration file to be used instead of the default probe
configuration file that comes with the product package.

CPU
Specify the target CPU.

Explicit probe configuration

Multi-target debug system
Select this option to enable the other options in this section. This might be
needed if the automatic probe configuration does not work, regardless of the
number of cores in the target system and the number of TAPs on the JTAG chain.

Target number (TAP or target ID)
If the debug system is a JTAG scan chain, specify the Target number TAP (Test
Access Port) position of the device you want to connect to. The TAP numbers
start from zero. If there are several cores at the TAP position, you also need to
specify the CPU number on target.

Target with multiple CPUs
If you have multiple cores or harts (hardware threads) on the selected TAP, you
can select this option to specify which one you want to debug.

CPU number on target
Specify the index number of the core/hart on selected TAP. Hart numbers start
from 0.

JTAG scan chain contains non-RISC-V devices
Enables JTAG scan chains that mix RISC-V devices with other devices.

Preceding bits

Specify the TAP (Test Access Port) position of the device you want to connect
to. The TAP numbers start from zero.
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I-jet : Breakpoints

The Breakpoints options specify the breakpoint behavior for I-jet.

Breakpoints

Default breakpoint type
@ Auto
() Hardware
() Software
Catch exceptions
[ Reset [ nmi
Machine Mode Supervisor Mode (| User Mode
[ Instruction access misaligned [ Environment call
[ Instruction access fautt [ Instruction page fautt
[ llegal instruction [ Load page fault
[ Load access misaligned [ Store/AMO page fault
[ Load access fault [ Bdtemal intemupt
[] Store/AMO access misaligned [ Timer irtemupt
[ Store/AMO access fault [ Software intemupt

Default breakpoint type

Catch exceptions

C-SPY® Debugging Guide
for RISC-V

Selects the type of breakpoint resource to be used when setting a breakpoint. Choose
between:

Auto Uses a software breakpoint. If this is not possible, a
hardware breakpoint will be used. The debugger will use
read/write sequences to test for RAM—in that case, a
software breakpoint will be used.

Hardware Uses hardware breakpoints. If it is not possible, no
breakpoint will be set.

Software Uses software breakpoints. If it is not possible, no
breakpoint will be set.

Sets a breakpoint directly on a vector in the interrupt vector table, without using a
hardware breakpoint. The settings you make will work as default settings for the project
and are preserved during debug sessions.

Reset Catches reset exceptions.
NMI Catches non-maskable interrupts.
Select which of the exceptions or interrupts listed in the lower half of the group box to

catch, and in which execution modes (Machine Mode, Supervisor Mode, and/or User
Mode) they will be caught. If you do not select at least one execution mode, none of the
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exceptions listed below the mode options will be caught, even if they are selected. By
default, all three mode options are selected.

Note: Not all exceptions are supported by all devices. Refer to the manufacturer’s
device manual to confirm which exceptions your device supports.

Third-Party Driver options

The Third-Party Driver options are used for loading any driver plugin provided by a
third-party vendor. These drivers must be compatible with the C-SPY debugger driver
specification.

Setup

IAR debugger driver plugin:

| Browse to your third-party driver

Driver options (one per line):

[ Log communication
$PROJ_DIRS\cspycol

IAR debugger driver plugin

Specity the file path to the third-party driver plugin DLL file. A browse button is
available for your convenience.

Driver options

This box provides you with a command line interface to C-SPY. Use it to set options for
the third-party driver.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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Additional information on
C-SPY drivers

This chapter describes the additional menus and features provided by the

C-SPY® drivers. You will also find some useful hints about resolving problem:s.

Reference information on C-SPY driver menus

C-SPY driver

Reference information about:

o C-SPY driver, page 391

o Simulator menu, page 392

o GDB Server menu, page 396
® [-jet menu, page 396

Before you start the C-SPY debugger, you must first specify a C-SPY driver in the
Options dialog box, using the option Debugger>Setup>Driver.

When you start a debug session, a menu specific to that C-SPY driver will appear on the
menu bar, with commands specific to the driver.

When we in this guide write “choose C-SPY driver>" followed by a menu command,
C-SPY driver refers to the menu. If the feature is supported by the driver, the command
will be on the menu.
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Simulator menu

When you use the simulator driver, the Simulator menu is added to the menu bar:

Data Alignment Setup...
&, Memory Configuration...

Trace

+|= Function Trace
Function Profiler

Data Log
Data Log Summary
Interrupt Log

Interrupt Summary

Timeline

& B KR

Simulated Frequency...

Interrupt Configuration
Available Interrupts

Interrupt Status

Breakpoint Usage

Menu commands
These commands are available on the menu:

Data Alignment Setup
Displays a dialog box to control the behavior of the simulator when misaligned
data accesses are detected, see Data Alignment Setup dialog box, page 394.
(=] Memory Configuration
o

Displays a dialog box where you configure C-SPY to match the memory of your
device, see Memory Configuration dialog box for the C-SPY simulator, page
162.

+ Trace
Opens a window which displays the collected trace data, see Trace window,

page 183.

e Function Trace
- F Opens a window which displays the trace data for function calls and function
returns, see Function Trace window, page 190.

Function Profiler

Opens a window which shows timing information for the functions, see
Function Profiler window, page 220.

C-SPY® Debugging Guide
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Data Log
Opens a window which logs accesses to up to four different memory locations
or areas, see Data Log window, page 202.

Data Log Summary
Opens a window which displays a summary of data accesses to specific memory
location or areas, see Data Log Summary window, page 205.

Interrupt Log
Opens a window which displays the status of all defined interrupts, see Interrupt
Log window, page 257.

Interrupt Log Summary
Opens a window which displays a summary of the status of all defined
interrupts, see Interrupt Log Summary window, page 260.

Timeline
Opens a window which gives a graphical view of various kinds of information
on a timeline, see The application timeline, page 197.

Simulated Frequency
Opens the Simulated Frequency dialog box where you can specify the
simulator frequency used when the simulator displays time information, for
example in the log windows. Note that this does not affect the speed of the
simulator. For more information, see Simulated Frequency dialog box, page
395.

Interrupt Configuration
Opens a window where you can configure C-SPY interrupt simulation, see
Interrupt Configuration window, page 251.

Available Interrupts
Opens a window with an overview of all available interrupts. You can also force
an interrupt instantly from this window, see Available Interrupts window, page
254.

Interrupt Status
Opens a window from where you can instantly trigger an interrupt, see Interrupt
Status window, page 255.

Breakpoint Usage

Displays a window which lists all active breakpoints, see Breakpoint Usage
window, page 117.
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Reference information on the C-SPY simulator

This section gives additional reference information on the C-SPY simulator, and
reference information not provided elsewhere in this documentation.

Reference information about:

o Data Alignment Setup dialog box, page 394
o Simulated Frequency dialog box, page 395

Data Alignment Setup dialog box

The Data Alignment Setup dialog box is available from the Simulator menu.

Data Alignment Setup *
Action Motification
Force alignment {mask) (O None
(® Add cydes Olog Z=

(O Log and stop execution
(® Log and throw exception

Use this dialog box to control the behavior of the simulator when an access to
misaligned data is detected.

Note: The hardware of your specific core might not support all actions.

Requirements
The C-SPY simulator.

Action

Selects the action to take when an access to misaligned data is detected. Choose
between:

Force alignment

Forces misaligned data to a correct alignment.

Add cycles
Adds one extra bus cycle.

Notification

Selects a suitable notification method. Choose between:

None

Specifies that no notification will be issued.

C-SPY® Debugging Guide
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Log
Displays a message in the Debug Log window.

Log and stop execution
Displays a message in the Debug Log window and stops the execution after the
access to the misaligned data.

Log and throw exception
Displays a message in the Debug Log window and throws an exception after the
access to the misaligned data.

Simulated Frequency dialog box
The Simulated Frequency dialog box is available from the C-SPY driver menu.

Simulated Frequency [iz-,l
Frequency [Hz]:
000000
1 MHz Cancel

Uszed only for converting cycles to time.

L

Use this dialog box to specify the simulator frequency used when the simulator displays
time information.

Requirements
The C-SPY simulator.

Frequency
Specify the frequency in Hz.

Reference information on the C-SPY hardware debugger drivers

This section gives additional reference information on the C-SPY hardware debugger
drivers, reference information not provided elsewhere in this documentation.
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GDB Server menu

When you are using the C-SPY GDB Server driver, the GDB Server menu is added to
the menu bar.

GDE Server

&, Memory Configuration...

Breakpoint Usage

Menu commands

These commands are available on the menu:

Memory Configuration
Displays a dialog box, see Memory Configuration dialog box for C-SPY
hardware debugger drivers, page 166.

Breakpoint Usage
Opens a window which lists all active breakpoints, see Breakpoint Usage
window, page 117.

I-jet menu
When you are using the C-SPY I-jet driver, the I-jet menu is added to the menu bar.

&=, Memory Configuration...
Disable Debugger Cache
Leave Target Running

CPU Halt on Breakpoint Set

Trace

Function Trace

By

Trace Settings

Trace Save...

m Timeline
Function Profiler
Breakpoint Usage

EmuDiag

Menu commands
These commands are available on the menu:
Memory Configuration

Displays a dialog box, see Memory Configuration dialog box for C-SPY
hardware debugger drivers, page 166.

Disable Debugger Cache
Disables memory caching and memory range checking in C-SPY.

C-SPY® Debugging Guide
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Normally, C-SPY uses the memory range information in the Memory
Configuration dialog box both to restrict access to certain parts of target
memory and to cache target memory contents for improved C-SPY
performance. Under certain rare circumstances, this is not appropriate, and you
can choose Disable Debugger Cache to turn off the caching and memory range
checking completely. All accesses from C-SPY will then result in corresponding
accesses to the target system. Some of those circumstances are:

e When memory is remapped at runtime and cannot be specified as a fixed set
of ranges.

e When the memory range setup is incorrect or incomplete.

Leave Target Running
Leaves the application running on the target hardware after the debug session is
closed.

Because existing breakpoints might not be automatically removed, consider
disabling all breakpoints before using this menu command.

CPU Halt on Breakpoint Set
Makes it possible to set a breakpoint in an executing application on hardware
that does not support setting breakpoints while running. Setting a breakpoint
halts the core, sets the breakpoint, and starts the core again.

Trace
Opens the Trace window, see Trace window, page 183.

Function Trace

Opens the Function Trace window, see Function Trace window, page 190.
Trace Settings
Displays a dialog box, see Trace Settings dialog box, page 180.

Trace Save
Displays a standard Save As dialog box where you can save the collected trace
data to a text file, with tab-separated columns.

Timeline

Opens a window, see Reference information on application timeline, page 201.

Function Profiler

Opens a window which shows timing information for the functions, see
Function Profiler window, page 220.
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Breakpoint Usage
Opens a window which lists all active breakpoints, see Breakpoint Usage
window, page 117.

EmuDiag

Starts the EmuDiag application where you can diagnose the connection
between the host computer, the probe, and the board.

Resolving problems

C-SPY® Debugging Guide
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These topics are covered:

e Write failure during load

e No contact with the target hardware

Debugging using the C-SPY hardware debugger systems requires interaction between
many systems, independent from each other. For this reason, setting up this debug
system can be a complex task. If something goes wrong, it might be difficult to locate
the cause of the problem.

This section includes suggestions for resolving the most common problems that can
occur when debugging with the C-SPY hardware debugger systems.

For problems concerning the operation of the evaluation board, refer to the
documentation supplied with it, or contact your hardware distributor.
WRITE FAILURE DURING LOAD

There are several possible reasons for write failure during load. The most common is
that your application has been incorrectly linked:

e Check the contents of your linker configuration file and make sure that your
application has not been linked to the wrong address

e Check that you are using the correct linker configuration file.

In the IDE, the linker configuration file is automatically selected based on your choice
of device.

To choose a device:

Choose Project>Options.

Select the General Options category.
Click the Target tab.

Choose the appropriate device from the Device drop-down list.
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To override the default linker configuration file:
Choose Project>Options.

Select the Linker category.

Click the Config tab.

Select the Override default option, and choose the appropriate linker configuration
file in the Linker configuration file area. A browse button is available.

NO CONTACT WITH THE TARGET HARDWARE

There are several possible reasons for C-SPY to fail to establish contact with the target
hardware. Do this:

Check the communication devices on your host computer

Verify that the cable is properly plugged in and not damaged or of the wrong type

Make sure that the evaluation board is supplied with sufficient power

Check that the correct options for communication have been specified in the IAR
Embedded Workbench IDE.

Examine the linker configuration file to make sure that the application has not been
linked to the wrong address.
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