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Preface

Welcome to the C-SPY® Debugging Guide. The purpose of this guide is to help
you fully use the features in the IAR C-SPY® Debugger for debugging your
application based on the V850 microcontroller.

Who should read this guide

Read this guide if you plan to develop an application using IAR Embedded Workbench
and want to get the most out of the features available in C-SPY.

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

o The architecture and instruction set of the V850 microcontroller family (refer to the
chip manufacturer's documentation)

® The C or C++ programming language
o Application development for embedded systems
o The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer
to their respective documentation, see Other documentation, page 23.

How to use this guide

Each chapter in this guide covers a specific fopic. In many chapters, information is
typically divided in different sections based on information types:

o Concepts, which describes the topic and gives overviews of features related to the
topic. Any requirements or restrictions are also listed. Read this section to learn
about the topic.

o Tasks, which lists useful tasks related to the topic. For many of the tasks, you can
also find step-by-step descriptions. Read this section for information about required
tasks as well as for information about how to perform certain tasks.

® Reference information, which gives reference information related to the topic. Read
this section for information about certain GUI components. You can easily access
this type of information for a certain component in the IDE by pressing F1.
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If you are new to using IAR Embedded Workbench, we suggest that you first read the
guide Getting Started with IAR Embedded Workbench® for an overview of the tools and
the features that the IDE offers. The tutorials, which you can find in the IAR Information
Center, will help you get started using IAR Embedded Workbench.

Finally, we recommend the Glossary if you should encounter any unfamiliar terms in
the IAR Systems user documentation.

What this guide contains

C-SPY® Debugging Guide
for V850

Below is a brief outline and summary of the chapters in this guide.

Note: Some of the screenshots in this guide are taken from a similar product and not
from IAR Embedded Workbench for V850.

PART |. BASIC DEBUGGING

® The IAR C-SPY Debugger introduces you to the C-SPY debugger and to the
concepts that are related to debugging in general and to C-SPY in particular. The
chapter also introduces the various C-SPY drivers. The chapter briefly shows the
difference in functionality that the various C-SPY drivers provide.

o Getting started using C-SPY helps you get started using C-SPY, which includes
setting up, starting, and adapting C-SPY for target hardware.

e Executing your application describes the conceptual differences between source
and disassembly mode debugging, the facilities for executing your application, and
finally, how you can handle terminal input and output.

e Jariables and expressions describes the syntax of the expressions and variables
used in C-SPY, as well as the limitations on variable information. The chapter also
demonstrates the various methods for monitoring variables and expressions.

® Breakpoints describes the breakpoint system and the various ways to set
breakpoints.

® Memory and registers shows how you can examine memory and registers.

PART 2. ANALYZING YOUR APPLICATION

o Collecting and using trace data describes how you can inspect the program flow up
to a specific state using trace data.

o Using the profiler describes how the profiler can help you find the functions in your
application source code where the most time is spent during execution.

® Code coverage describes how the code coverage functionality can help you verify
whether all parts of your code have been executed, thus identifying parts which have
not been executed.
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PART 3. ADVANCED DEBUGGING

Interrupts contains detailed information about the C-SPY interrupt simulation
system and how to configure the simulated interrupts to make them reflect the
interrupts of your target hardware.

Using C-SPY macros describes the C-SPY macro system, its features, the purposes
of these features, and how to use them.

The C-SPY command line utility—cspybat describes how to use C-SPY in batch
mode.

PART 4. ADDITIONAL REFERENCE INFORMATION

Debugger options describes the options you must set before you start the C-SPY
debugger.

Additional information on C-SPY drivers describes menus and features provided by
the C-SPY drivers not described in any dedicated topics.

Using the MINICUBE?2 emulator contains important information about using the
MINICUBE2 OCD Emulator with the V850 Microcontroller Series.

Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online
help system in HTML format. You can access the documentation from the Information
Center or from the Help menu in the IAR Embedded Workbench IDE. The online help
system is also available via the F1 key.

USER AND REFERENCE GUIDES

The complete set of IAR Systems development tools is described in a series of guides.
Information about:

System requirements and information about how to install and register the IAR
Systems products, is available in the booklet Quick Reference (available in the
product box) and the Installation and Licensing Guide.

Getting started using AR Embedded Workbench and the tools it provides, is
available in the guide Getting Started with IAR Embedded Workbench®.

Using the IDE for project management and building, is available in the /DE Project
Management and Building Guide.

Using the IAR C-SPY® Debugger, is available in the C-SPY® Debugging Guide for
V850.

Programming for the IAR C/C++ Compiler for V850, is available in the JAR C/C++
Compiler Reference Guide for V850.
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Using the IAR XLINK Linker, the IAR XAR Library Builder, and the IAR XLIB
Librarian, is available in the /AR Linker and Library Tools Reference Guide.

Programming for the IAR Assembler for V850, is available in the AR Assembler
Reference Guide for V850.

Using the IAR DLIB Library, is available in the DLIB Library Reference
information, available in the online help system.

Performing a static analysis using C-STAT and the required checks, is available in
the .

Developing safety-critical applications using the MISRA C guidelines, is available
in the IAR Embedded Workbench® MISRA C:2004 Reference Guide or the IAR
Embedded Workbench® MISRA C:1998 Reference Guide.

Porting application code and projects created with a previous version of the IAR
Embedded Workbench for V850, is available in the [AR Embedded Workbench®
Migration Guide.

Note: Additional documentation might be available depending on your product
installation.

THE ONLINE HELP SYSTEM

The context-sensitive online help contains:

Information about project management, editing, and building in the IDE
Information about debugging using the IAR C-SPY® Debugger

Reference information about the menus, windows, and dialog boxes in the IDE
Compiler reference information

Keyword reference information for the DLIB library functions. To obtain reference
information for a function, select the function name in the editor window and press
F1.

WEB SITES

Recommended web sites:

The Renesas web site, www.renesas.com, that contains information and news about
the V850 microcontrollers.

The IAR Systems web site, www.iar.com, that holds application notes and other
product information.

The web site of the C standardization working group,
www.open-std.org/jtcl/sc22/wgl4.

The web site of the C++ Standards Committee, www.open-std.org/jtcl/sc22/wg21.
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o Finally, the Embedded C++ Technical Committee web site,
www.caravan.net/ec2plus, that contains information about the Embedded C++
standard.

Document conventions

When, in the IAR Systems documentation, we refer to the programming language C, the
text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example v850\doc, the
full path to the location is assumed, for example ¢: \Program Files\IAR
Systems\Embedded Workbench 7.n\v850\doc.

TYPOGRAPHIC CONVENTIONS

The IAR Systems documentation set uses the following typographic conventions:

Style Used for

computer * Source code examples and file paths.
* Text on the command line.
* Binary, hexadecimal, and octal numbers.

parameter A placeholder for an actual value used as a parameter, for example
filename.h where £ilename represents the name of the file.

[option] An optional part of a directive, where [ and ] are not part of the actual
directive, butany [, 1, {, or } are part of the directive syntax.

{option} A mandatory part of a directive, where { and } are not part of the
actual directive, but any [, ], {, or } are part of the directive syntax.

[option] An optional part of a command.

[a]b|c] An optional part of a command with alternatives.

{a|b]|c} A mandatory part of a command with alternatives.

bold Names of menus, menu commands, buttons, and dialog boxes that

appear on the screen.

italic * A cross-reference within this guide or to another guide.
* Emphasis.

An ellipsis indicates that the previous item can be repeated an arbitrary
number of times.

Identifies instructions specific to the IAR Embedded Workbench® IDE
interface.

Identifies instructions specific to the command line interface.

Table 1: Typographic conventions used in this guide
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Style Used for

@ Identifies helpful tips and programming hints.

& Identifies warnings.

Table 1: Typographic conventions used in this guide (Continued)

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR
Systems®, when referred to in the documentation:

Brand name Generic term

IAR Embedded Workbench® for V850 IAR Embedded Workbench®
IAR Embedded Workbench® IDE for V850 the IDE

IAR C-SPY® Debugger for V850 C-SPY, the debugger
IAR C-SPY® Simulator the simulator

IAR C/C++ Compiler™ for V850 the compiler

IAR Assembler™ for V850 the assembler

IAR XLINK Linker™ XLINK, the linker
IAR XAR Library Builder™ the library builder
IAR XLIB Librarian™ the librarian

IAR DLIB Library™ the DLIB library

Table 2: Naming conventions used in this guide



Part |. Basic debugging

This part of the C-SPY® Debugging Guide for V850 includes these chapters:
e The IAR C-SPY Debugger

e Getting started using C-SPY

e Executing your application

e Variables and expressions

e Breakpoints

o Memory and registers
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The IAR C-SPY Debugger

e Introduction to C-SPY

e Debugger concepts

e C-SPY drivers overview
e The IAR C-SPY Simulator

o The C-SPY hardware debugger drivers

Introduction to C-SPY

These topics are covered:

e An integrated environment
o General C-SPY debugger features

e RTOS awareness

AN INTEGRATED ENVIRONMENT

C-SPY is a high-level-language debugger for embedded applications. It is designed for
use with the IAR Systems compilers and assemblers, and is completely integrated in the
IDE, providing development and debugging within the same application. This will give
you possibilities such as:

e Editing while debugging. During a debug session, you can make corrections directly
in the same source code window that is used for controlling the debugging. Changes
will be included in the next project rebuild.

e Setting breakpoints at any point during the development cycle. You can inspect and
modify breakpoint definitions also when the debugger is not running, and
breakpoint definitions flow with the text as you edit. Your debug settings, such as
watch properties, window layouts, and register groups will be preserved between
your debug sessions.

All windows that are open in the Embedded Workbench workspace will stay open when

you start the C-SPY Debugger. In addition, a set of C-SPY-specific windows are opened.
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GENERAL C-SPY DEBUGGER FEATURES

Because IAR Systems provides an entire toolchain, the output from the compiler and
linker can include extensive debug information for the debugger, resulting in good
debugging possibilities for you.

C-SPY offers these general features:

Source and disassembly level debugging

C-SPY allows you to switch between source and disassembly debugging as required,
for both C or C++ and assembler source code.

Single-stepping on a function call level

Compared to traditional debuggers, where the finest granularity for source level
stepping is line by line, C-SPY provides a finer level of control by identifying every
statement and function call as a step point. This means that each function
call—inside expressions, and function calls that are part of parameter lists to other
functions—can be single-stepped. The latter is especially useful when debugging
C++ code, where numerous extra function calls are made, for example to object
constructors.

Code and data breakpoints

The C-SPY breakpoint system lets you set breakpoints of various kinds in the
application being debugged, allowing you to stop at locations of particular interest.
For example, you set breakpoints to investigate whether your program logic is correct
or to investigate how and when the data changes.

Monitoring variables and expressions

For variables and expressions there is a wide choice of facilities. You can easily
monitor values of a specified set of variables and expressions, continuously or on
demand. You can also choose to monitor only local variables, static variables, etc.
Container awareness

When you run your application in C-SPY, you can view the elements of library data
types such as STL lists and vectors. This gives you a very good overview and
debugging opportunities when you work with C++ STL containers.

Call stack information

The compiler generates extensive call stack information. This allows the debugger to
show, without any runtime penalty, the complete stack of function calls wherever the
program counter is. You can select any function in the call stack, and for each
function you get valid information for local variables and available registers.
Powerful macro system

C-SPY includes a powerful internal macro system, to allow you to define complex
sets of actions to be performed. C-SPY macros can be used on their own or in
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conjunction with complex breakpoints and—if you are using the simulator—the
interrupt simulation system to perform a wide variety of tasks.

Additional general C-SPY debugger features
This list shows some additional features:

Threaded execution keeps the IDE responsive while running the target application
Automatic stepping

The source browser provides easy navigation to functions, types, and variables
Extensive type recognition of variables

Configurable registers (CPU and peripherals) and memory windows

Graphical stack view with overflow detection

Support for code coverage and function level profiling

The target application can access files on the host PC using file I/O

UBRGOF, Intel-extended, and Motorola input formats supported

Optional terminal I/O emulation.

RTOS AWARENESS
C-SPY supports RTOS-aware debugging.

RTOS plugin modules can be provided by IAR Systems, and by third-party suppliers.
Contact your software distributor or IAR Systems representative, alternatively visit the
IAR Systems web site, for information about supported RTOS modules.

Debugger concepts

This section introduces some of the concepts and terms that are related to debugging in
general and to C-SPY in particular. This section does not contain specific information
related to C-SPY features. Instead, you will find such information in the other chapters
of this documentation. The IAR Systems user documentation uses the terms described
in this section when referring to these concepts.

These topics are covered:
C-SPY and target systems
The debugger

The target system
The application

C-SPY debugger systems
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o The ROM-monitor program
o Third-party debuggers
o C-SPY plugin modules

C-SPY AND TARGET SYSTEMS
You can use C-SPY to debug either a software target system or a hardware target system.
This figure gives an overview of C-SPY and possible target systems:

— e e e e g e e e e e e — ==
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I
I
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= Provided by IAR Systems
|:| = Provided by IAR Systems or third-party vendors

Note: In IAR Embedded Workbench for V850, there are no ROM-monitor drivers.

THE DEBUGGER

The debugger, for instance C-SPY, is the program that you use for debugging your
applications on a target system.

THE TARGET SYSTEM

The target system is the system on which you execute your application when you are
debugging it. The target system can consist of hardware, either an evaluation board or
your own hardware design. It can also be completely or partially simulated by software.
Each type of target system needs a dedicated C-SPY driver.

C-SPY® Debugging Guide
32 for V850
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THE APPLICATION

A user application is the software you have developed and which you want to debug
using C-SPY.

C-SPY DEBUGGER SYSTEMS

C-SPY consists of both a general part which provides a basic set of debugger features,
and a target-specific back end. The back end consists of two components: a processor
module—one for every microcontroller, which defines the properties of the
microcontroller, and a C-SPY driver. The C-SPY driver is the part that provides
communication with and control of the target system. The driver also provides the user
interface—menus, windows, and dialog boxes—to the functions provided by the target
system, for instance, special breakpoints. Typically, there are three main types of C-SPY
drivers:

o Simulator driver
o ROM-monitor driver

o Emulator driver.

C-SPY is available with a simulator driver, and depending on your product package,
optional drivers for hardware debugger systems. For an overview of the available C-SPY
drivers and the functionality provided by each driver, see C-SPY drivers overview, page
34.

THE ROM-MONITOR PROGRAM

The ROM-monitor program is a piece of firmware that is loaded to non-volatile memory
on your target hardware; it runs in parallel with your application. The ROM-monitor
communicates with the debugger and provides services needed for debugging the
application, for instance stepping and breakpoints.

THIRD-PARTY DEBUGGERS

You can use a third-party debugger together with the IAR Systems toolchain as long as
the third-party debugger can read any of the output formats provided by XLINK, such
as UBROF, ELF/DWARF, COFF, Intel-extended, Motorola, or any other available
format. For information about which format to use with a third-party debugger, see the
user documentation supplied with that tool.

C-SPY PLUGIN MODULES

C-SPY is designed as a modular architecture with an open SDK that can be used for
implementing additional functionality to the debugger in the form of plugin modules.
These modules can be seamlessly integrated in the IDE.
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Plugin modules are provided by IAR Systems, or can be supplied by third-party vendors.
Examples of such modules are:

Code Coverage, which is integrated in the IDE.
The various C-SPY drivers for debugging using certain debug systems.
RTOS plugin modules for support for real-time OS aware debugging.

C-SPYLink that bridges IAR visual STATE and IAR Embedded Workbench to make
true high-level state machine debugging possible directly in C-SPY, in addition to
the normal C level symbolic debugging. For more information, see the
documentation provided with IAR visualSTATE.

For more information about the C-SPY SDK, contact IAR Systems.

C-SPY drivers overview

C-SPY® Debugging Guide
for V850

These topics are covered:

Differences between the C-SPY drivers, page 35

At the time of writing this guide, the IAR C-SPY Debugger for the V850
microcontrollers is available with drivers for these target systems and evaluation boards:

Simulator

IECUBE Emulator

E1 N-Wire Emulator

E1 Serial Emulator

E1 Nexus for V850E2x

IECUBE2 Emulator for V850E2x
MINICUBE Emulator
MINICUBE2 Emulator
MINICUBE Emulator for V850E2x
TK-V850 Debugger.
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DIFFERENCES BETWEEN THE C-SPY DRIVERS
This table summarizes the key differences between the C-SPY drivers:

El N-Wire El Nexus
El Serial IECUBE2

Feature Simulator |ECUBE TK-V850
MINICUBE MINICUBE

MINICUBE2 for V850E2x

Code breakpoints Unlimited  x X X X
Data breakpointsI X - -- - -
Event breakpoints — X X X X
Execution in real time — X X X X
Zero memory footprint X x -- X X
Simulated interrupts X - - - -
Real interrupts — X X X X
Interrupt logging X - - - -
Data logging X - -- - -
Live watch — X X X X
Cycle counter X X X - X
Code coverage X - - - -
Data coverage X -- -- - -
Function/instruction X -- -- - -
pr'oﬁlingI

Trace! X X - X -

Table 3: Driver differences

1 With specific requirements or restrictions, see the respective chapter in this guide.

The IAR C-SPY Simulator

The C-SPY Simulator simulates the functions of the target processor entirely in
software, which means that you can debug the program logic long before any hardware
is available. Because no hardware is required, it is also the most cost-effective solution
for many applications.

The C-SPY Simulator supports:

e Instruction-level simulation
o Memory configuration and validation

e Interrupt simulation
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e Peripheral simulation (using the C-SPY macro system in conjunction with
immediate breakpoints).

Simulating hardware instead of using a hardware debugging system means that some
limitations do not apply, but that there are other limitations instead. For example:

e You can set an unlimited number of breakpoints in the simulator.

e When you stop executing your application, time actually stops in the simulator.
When you stop application execution on a hardware debugging system, there might
still be activities in the system. For example, peripheral units might still be active
and reading from or writing to SFR ports.

e Application execution is significantly much slower in a simulator compared to when
using a hardware debugging system. However, during a debug session, this might
not necessarily be a problem.

o The simulator is not cycle accurate.

e Peripheral simulation is limited in the C-SPY Simulator and therefore the simulator
is suitable mostly for debugging code that does not interact too much with
peripheral units.

The C-SPY hardware debugger drivers
C-SPY can connect to a hardware debugger using a C-SPY hardware debugger driver as
an interface. IAR Embedded Workbench for V850 comes with several C-SPY hardware
debugger drivers, see C-SPY drivers overview, page 34. Choose
Project>Options>Debugger>Setup to select the driver you want to use.

COMMUNICATION OVERVIEW

The C-SPY hardware debugger drivers use the EXEC interface driver from Renesas to
communicate with the interface on the hardware.

Using the EXEC interface driver, C-SPY can connect to the target system. Many of the
V850 microcontrollers have built-in, on-chip debug support. Because the hardware
debugger logic is built into the microcontroller, no ordinary ROM-monitor program or
extra specific hardware is needed to make the debugging work.

The C-SPY hardware debugger drivers use the USB protocol for communicating with
the interface on the hardware. The connections and cables that are used on different
evaluation boards might vary.

C-SPY® Debugging Guide
36 for V850
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This illustration gives an overview of your host computer and the target system:

=

C-SPY debugger

C-SPY emulator driver
EXEC interface driver

Interface cable

z\)

Debug probe or emulator

-

For further information, refer to the documentation supplied with your target system.

When a debugging session is started, your application is automatically downloaded and
programmed into flash memory. You can disable this feature, if necessary.

INSTALLING THE EXEC INTERFACE DRIVERS

The drivers required to use the hardware debugger are normally installed together with
the IAR Embedded Workbench product package. If you need to install a driver
separately, the first time you connect an emulator to the host computer a setup wizard
will help you locate and install the required driver. The driver is located in the
install_dir\v850\drivers\renesas directory of your IAR Systems product
installation.

Emulator Driver

El N-Wire, El Nexus, El Serial USB driver in the subdirectory E1

MINICUBE, MINICUBE2 USB driver in the subdirectory MINICUBE
|IECUBE, IECUBE2 USB driver in the subdirectory IECUBE
TK-V850 USB driver in the subdirectory FTDI

Table 4: V850 emulators and their drivers

Hardware installation

For information about the hardware installation, see the documentation supplied with
the hardware debugger from Renesas. The following power-up sequence is
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recommended to ensure proper communication between the target board, hardware
debugger, and C-SPY:

I Power up the target board.
2 Power up the hardware debugger.
3 Start the C-SPY debug session.

C-SPY® Debugging Guide
38 for V850
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C-SPY

e Setting up C-SPY

e Starting C-SPY

Adapting for target hardware

Running example projects

e Reference information on starting C-SPY

Setting up C-SPY

These tasks are covered:
Setting up for debugging
Executing from reset
Using a setup macro file

Selecting a device description file

Loading plugin modules

SETTING UP FOR DEBUGGING

Install a USB driver or some other communication driver if your C-SPY driver requires
it.

For more information, see:

o Installing the EXEC interface drivers, page 37

Before you start C-SPY, choose Project>Options>Debugger>Setup and select the
C-SPY driver that matches your debugger system: simulator or a hardware debugger
system.

In the Category list, select the appropriate C-SPY driver and make your settings.
For information about these options, see Debugger options, page 323.

Click OK.
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5 Choose Tools>Options to open the IDE Options dialog box:

o Select Debugger to configure the debugger behavior

o Select Stack to configure the debugger’s tracking of stack usage.

For more information about these options, see the IDE Project Management and
Building Guide.

See also Adapting for target hardware, page 44.

EXECUTING FROM RESET

The Run to option—available on the Debugger>Setup page—specifies a location you
want C-SPY to run to when you start a debug session as well as after each reset. C-SPY
will place a temporary breakpoint at this location and all code up to this point is executed
before stopping at the location.

The default location to run to is the main function. Type the name of the location if you
want C-SPY to run to a different location. You can specify assembler labels or whatever
can be evaluated to such, for instance function names.

If you leave the check box empty, the program counter will contain the regular hardware
reset address at each reset

If no breakpoints are available when C-SPY starts, a warning message notifies you that
single stepping will be required and that this is time-consuming. You can then continue
execution in single-step mode or stop at the first instruction. If you choose to stop at the
first instruction, the debugger starts executing with the PC (program counter) at the
default reset location instead of the location you typed in the Run to box.

Note: This message will never be displayed in the C-SPY Simulator, where breakpoints
are unlimited.

USING A SETUP MACRO FILE

A setup macro file is a macro file that you choose to load automatically when C-SPY
starts. You can define the setup macro file to perform actions according to your needs,
using setup macro functions and system macros. Thus, if you load a setup macro file you
can initialize C-SPY to perform actions automatically.

For more information about setup macro files and functions, see /ntroduction to C-SPY
macros, page 253. For an example of how to use a setup macro file, see Initializing
target hardware before C-SPY starts, page 45.

To register a setup macro file:

Before you start C-SPY, choose Project>Options>Debugger>Setup.
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2 Select Use macro file and type the path and name of your setup macro file, for
example Setup.mac. If you do not type a filename extension, the extension mac is
assumed.

SELECTING A DEVICE DESCRIPTION FILE

C-SPY uses device description files to handle device-specific information.

A default device description file is automatically used based on your project settings. If
you want to override the default file, you must select your device description file. Device
description files are provided in the v850\config directory and they have the filename
extension ddf.

For more information about device description files, see Adapting for target hardware,
page 44.

To override the default device description file:
I Before you start C-SPY, choose Project>Options>Debugger>Setup.

2 Enable the use of a device description file and select a file using the Device
description file browse button.

Note: You can easily view your device description files that are used for your project.
Choose Project>Open Device Description File and select the file you want to view.
LOADING PLUGIN MODULES

On the Plugins page you can specify C-SPY plugin modules to load and make available
during debug sessions. Plugin modules can be provided by IAR Systems, and by
third-party suppliers. Contact your software distributor or IAR Systems representative,
or visit the AR Systems web site, for information about available modules.

For more information, see Plugins, page 327.

Starting C-SPY

When you have set up the debugger, you are ready to start a debug session.
These tasks are covered:

Starting a debug session
Loading executable files built outside of the IDE

°
°
e Starting a debug session with source files missing
°

Loading multiple images
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STARTING A DEBUG SESSION

You can choose to start a debug session with or without loading the current executable
file.

To start C-SPY and download the current executable file, click the Download and
Debug button. Alternatively, choose Project>Download and Debug.

To start C-SPY without downloading the current executable file, click the Debug
without Downloading button. Alternatively, choose Project>Debug without
Downloading.

LOADING EXECUTABLE FILES BUILT OUTSIDE OF THE IDE

You can also load C-SPY with an application that was built outside the IDE, for example
applications built on the command line. To load an externally built executable file and
to set build options you must first create a project for it in your workspace.

To create a project for an externally built file:

Choose Project>Create New Project, and specify a project name.

To add the executable file to the project, choose Project>Add Files and make sure to
choose All Files in the Files of type drop-down list. Locate the executable file.

To start the executable file, click the Download and Debug button. The project can be
reused whenever you rebuild your executable file.

The only project options that are meaningful to set for this kind of project are options in
the General Options and Debugger categories. Make sure to set up the general project
options in the same way as when the executable file was built.

STARTING A DEBUG SESSION WITH SOURCE FILES MISSING

Normally, when you use the AR Embedded Workbench IDE to edit source files, build
your project, and start the debug session, all required files are available and the process
works as expected.
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However, if C-SPY cannot automatically find the source files, for example if the
application was built on another computer, the Get Alternative File dialog box is
displayed:

Get Alternative File g|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

Typically, you can use the dialog box like this:

o The source files are not available: Click If possible, don’t show this dialog again
and then click SKkip. C-SPY will assume that there simply is no source file available.
The dialog box will not appear again, and the debug session will not try to display
the source code.

e Alternative source files are available at another location: Specify an alternative
source code file, click If possible, don’t show this dialog again, and then click Use
this file. C-SPY will assume that the alternative file should be used. The dialog box
will not appear again, unless a file is needed for which there is no alternative file
specified and which cannot be located automatically.

If you restart the JAR Embedded Workbench IDE, the Get Alternative File dialog box
will be displayed again once even if you have clicked If possible, don’t show this
dialog again. This gives you an opportunity to modify your previous settings.

For more information, see Get Alternative File dialog box, page 54.

LOADING MULTIPLE IMAGES

Normally, a debuggable application consists of exactly one file that you debug.
However, you can also load additional debug files (images). This means that the
complete program consists of several images.

Typically, this is useful if you want to debug your application in combination with a
prebuilt ROM image that contains an additional library for some platform-provided

features. The ROM image and the application are built using separate projects in the
IAR Embedded Workbench IDE and generate separate output files.

If more than one image has been loaded, you will have access to the combined debug
information for all the loaded images. In the Images window you can choose whether
you want to have access to debug information for one image or for all images.
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To load additional images at C-SPY startup:

Choose Project>Options>Debugger>Images and specify up to three additional
images to be loaded. For more information, see /mages, page 325.

Start the debug session.
To load additional images at a specific moment:

Use the __loadImage system macro and execute it using either one of the methods
described in Using C-SPY macros, page 255.

To display a list of loaded images:

Choose Images from the View menu. The Images window is displayed, see Images
window, page 53.

Adapting for target hardware

C-SPY® Debugging Guide
for V850

These topics are covered:

o Modifying a device description file

e Initializing target hardware before C-SPY starts

MODIFYING A DEVICE DESCRIPTION FILE

C-SPY uses device description files provided with the product to handle several of the
target-specific adaptations, see Selecting a device description file, page 41. They contain
device-specific information such as:

o Memory information for device-specific memory zones, see C-SPY memory zones,
page 150.

e Definitions for device-specific interrupts, which makes it possible to simulate these
interrupts in the C-SPY simulator; see Interrupts, page 233.

Normally, you do not need to modify the device description file. However, if the
predefinitions are not sufficient for some reason, you can edit the file. Note, however,
that the format of these descriptions might be updated in future upgrades of the product.

Make a copy of the device description file that best suits your needs, and modify it
according to the description in the file. Reload the project to make the changes take
effect.

For information about how to load a device description file, see Selecting a device
description file, page 41.
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INITIALIZING TARGET HARDWARE BEFORE C-SPY STARTS

You can use C-SPY macros to initialize target hardware before C-SPY starts. For
example, if your hardware uses external memory that must be enabled before code can
be downloaded to it, C-SPY needs a macro to perform this action before your
application can be downloaded.

| Create a new text file and define your macro function.

By using the built-in execUserPreload setup macro function, your macro function
will be executed directly after the communication with the target system is established
but before C-SPY downloads your application.

For example, a macro that enables external SDRAM could look like this:

/* Your macro function. */
enableExternal SDRAM ()
{
__message "Enabling external SDRAM\n";
__writeMemory32(...);
}

/* Setup macro determines time of execution. */
execUserPreload()
{
enableExternal SDRAM() ;
}

2 Save the file with the filename extension mac.
Before you start C-SPY, choose Project>Options>Debugger and click the Setup tab.
4 Select the option Use Setup file and choose the macro file you just created.

Your setup macro will now be loaded during the C-SPY startup sequence.

Running example projects

These tasks are covered:

o Running an example project

o Connecting C-SPY with target hardware

RUNNING AN EXAMPLE PROJECT

Example applications are provided with IAR Embedded Workbench. You can use these
examples to get started using the development tools from IAR Systems. You can also
use the examples as a starting point for your application project.
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The examples are ready to be used as is. They are supplied with ready-made workspace
files, together with source code files and all other related files.

To run an example project:
Choose Help>Information Center and click EXAMPLE PROJECTS.

Browse to the example that matches the specific evaluation board or starter kit you are
using.

=
] 1] [ 11] m m [TT1(])
Info Open Name Description

project

This example shows how
Basic LCD fo use the LCD and the
fouch screen controller

This example shows
- basic use of the parallel
EEDEINE IfO, timer and the
interrupt controller

ol JJ

Click the Open Project button.

In the dialog box that appears, choose a destination folder for your project.

The available example projects are displayed in the workspace window. Select one of
the projects, and if it is not the active project (highlighted in bold), right-click it and
choose Set As Active from the context menu.

To view the project settings, select the project and choose Options from the context
menu. Verify the settings for General Options>Target>Device and
Debugger>Setup>Driver. As for other settings, the project is set up to suit the target
system you selected.

For more information about the C-SPY options and how to configure C-SPY to interact
with the target board, see Debugger options, page 323.

Click OK to close the project Options dialog box.

oon 6 To compile and link the application, choose Project>Make or click the Make button.

Lo
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7 To start C-SPY, choose Project>Debug or click the Download and Debug button. If
C-SPY fails to establish contact with the target system, see Resolving problems, page
347.

+++| 8 Choose Debug>Go or click the Go button to start the application.
L

Click the Stop button to stop execution.

CONNECTING C-SPY WITH TARGET HARDWARE

This section demonstrates how to get started with the C-SPY hardware debugger. The
application is built and downloaded to the target system, and then executed.

Running the demo program

This example uses the Tutor example project, but you can apply the procedure to other
projects as well.

I Select the Debug build configuration from the drop-down list at the top of the
Workspace window.

2 Choose Project>Options. In addition to the factory settings, make sure these options
are selected:

Category Page Option/Setting
Debugger Setup Driver: Choose one emulator
Your emulator Setup Download: Verify

Table 5: Project options for demo project

For more information about the C-SPY options and how to configure C-SPY to interact
with the target board, see Debugger options, page 323.

Click OK to close the Options dialog box.
Click the Make button to compile and link the source code.

4 Start C-SPY by clicking the Debug button or by choosing Project>Debug. The
Hardware Setup dialog box appears. Adjust your settings, if needed, and click OK.
C-SPY will then download the application to the target system. If C-SPY fails to
establish contact with the hardware debugger, see Resolving problems, page 347.

To open the Terminal I/O window, choose View>Terminal 1/0.
6 Choose Debug>Go or click the Go button to start the program.

Click the Stop button to stop the execution or wait until program exit is reached.
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Reference information on starting C-SPY

Reference information about:

C-SPY Debugger main window, page 48
Images window, page 53

Get Alternative File dialog box, page 54
Hardware Setup dialog box — IECUBE, page 56

Hardware Setup dialog box — E1 N-Wire, E1 Serial, MINICUBE, MINICUBE?,
TK-V850, page 60

o Hardware Setup dialog box — E1 Nexus, IECUBE2, MINICUBE for V850E2x, page
65

See also:

e Tools options for the debugger in the IDE Project Management and Building Guide.

C-SPY Debugger main window

Menu bar

C-SPY® Debugging Guide
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When you start a debug session, these debugger-specific items appear in the main [AR
Embedded Workbench IDE window:

o A dedicated Debug menu with commands for executing and debugging your
application

o Depending on the C-SPY driver you are using, a driver-specific menu, often
referred to as the Driver menu in this documentation. Typically, this menu contains
menu commands for opening driver-specific windows and dialog boxes.

e A special debug toolbar
o Several windows and dialog boxes specific to C-SPY.

The C-SPY main window might look different depending on which components of the
product installation you are using.

These menus are available during a debug session:

Debug

Provides commands for executing and debugging the source application. Most
of the commands are also available as icon buttons on the debug toolbar.



Debug menu
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C-SPY driver menu

Provides commands specific to a C-SPY driver. The driver-specific menu is only
available when the driver is used. For information about the driver-specific
menu commands, see Reference information on C-SPY driver menus, page 331.

The Debug menu is available during a debug session. The Debug menu provides
commands for executing and debugging the source application. Most of the commands
are also available as icon buttons on the debug toolbar.

Go F5
Break:
Reset

Stop Debugging Chrl+Shift+D

Step Over F10

Step Into Fii

Step Cut Shift+F11
MNext Statement

Run to Cursor

Autostep...

Set Next Statement

C++ Exceptions 3

Memory 3
Refresh

Macros...

Logging 3

These commands are available:

Go F5

Executes from the current statement or instruction until a breakpoint or program
exit is reached.

Break

Stops the application execution.

Reset

Resets the target processor. Click the drop-down button to access a menu with
additional commands.

Enable Run to 'I1abel', where label typically is main. Enables and disables
the project option Run to without exiting the debug session. This menu
command is only available if you have selected Run to in the Options dialog
box.
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Reset strategies, which contains a list of reset strategies supported by the C-SPY
driver you are using. This means that you can choose a different reset strategy
than the one used initially without exiting the debug session. Reset strategies are
only available if the C-SPY driver you are using supports alternate reset
strategies.

Stop Debugging (Ctrl+Shift+D)
Stops the debugging session and returns you to the project manager.

X

Step Over (F10)

Executes the next statement, function call, or instruction, without entering C or
C++ functions or assembler subroutines.

N

Step Into (F11)

Executes the next statement or instruction, or function call, entering C or C++
functions or assembler subroutines.

&

Step Out (Shift+F11)

Executes from the current statement up to the statement after the call to the
current function.

&

Next Statement

|G

Executes directly to the next statement without stopping at individual function
calls.

=+i| Run to Cursor

Executes from the current statement or instruction up to a selected statement or
instruction.

Autostep

Displays a dialog box where you can customize and perform autostepping, see
Autostep settings dialog box, page 86.

Set Next Statement

Moves the program counter directly to where the cursor is, without executing
any source code. Note, however, that this creates an anomaly in the program
flow and might have unexpected effects.

C++ Exceptions>
Break on Throw
This menu command is not supported by your product package.
C++ Exceptions>
Break on Uncaught Exception
This menu command is not supported by your product package.

C-SPY® Debugging Guide
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Memory>Save
Displays a dialog box where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 163.

Memory>Restore
Displays a dialog box where you can load the contents of a file in, for example
Intel-extended or Motorola s-record format to a specified memory zone, see
Memory Restore dialog box, page 164.

Refresh
Refreshes the contents of all debugger windows. Because window updates are
automatic, this is needed only in unusual situations, such as when target memory
is modified in ways C-SPY cannot detect. It is also useful if code that is
displayed in the Disassembly window is changed.

Macros
Displays a dialog box where you can list, register, and edit your macro files and
functions, see Using C-SPY macros, page 255.

Logging>Set Log file
Displays a dialog box where you can choose to log the contents of the Debug
Log window to a file. You can select the type and the location of the log file. You
can choose what you want to log: errors, warnings, system information, user
messages, or all of these. See Log File dialog box, page 85.

Logging>

Set Terminal 1/0 Log file

Displays a dialog box where you can choose to log simulated target access
communication to a file. You can select the destination of the log file. See
Terminal 1/0 Log File dialog box, page 83

C-SPY windows
Depending on the C-SPY driver you are using, these windows specific to C-SPY are
available during a debug session:

C-SPY Debugger main window

Disassembly window

Memory window

Symbolic Memory window

Register window

Watch window

Locals window

Auto window
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Live Watch window
Quick Watch window
Statics window

Call Stack window
Trace window

Function Trace window
Timeline window
Terminal I/O window
Code Coverage window
Function Profiler window
Images window

Stack window

Symbols window.

Additional windows are available depending on which C-SPY driver you are using.

Editing in C-SPY windows

C-SPY® Debugging Guide
for V850

You can edit the contents of the Memory, Symbolic Memory, Register, Auto, Watch,
Locals, Statics, Live Watch, and Quick Watch windows.

Use these keyboard keys to edit the contents of these windows:

Enter Makes an item editable and saves the new value.

Esc Cancels a new value.

In windows where you can edit the Expression field and in the Quick Watch window,
you can specify the number of elements to be displayed in the field by adding a
semicolon followed by an integer. For example, to display only the three first elements

of an array named myArray, or three elements in sequence starting with the element
pointed to by a pointer, write:

myArray; 3
To display three elements pointed to by myPtr, myPtr+1, and myPtr+2, write:
myPtr;3

Optionally, add a comma and another integer that specifies which element to start with.
For example, to display elements 10-14, write:

myArray;5,10
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To display myPtr+10, myPtr+11l, myPtr+12, myPtr+13, and myPtr+14, write:
myPtr;5,10

Note: For pointers, there are no built-in limits on displayed element count, and no
validation of the pointer value.

Images window

The Images window is available from the View menu.

MName Path
<All images> [Combines debug information from all images]
project] ChDocuments and Settingsihy Documentsi| AR Embedded WorkbenchDebughExeyproject! .out

exfralmage ChDocuments and Settingsi\hy Documentst| AR Embedded WorkbenchDebughExehextralmage.out

This window lists all currently loaded images (debug files).

Normally, a source application consists of exactly one image that you debug. However,
you can also load additional images. This means that the complete debuggable unit
consists of several images.

Requirements

None; this window is always available.

Display area

C-SPY can either use debug information from all of the loaded images simultaneously,
or from one image at a time. Double-click on a row to show information only for that
image. The current choice is highlighted.

This area lists the loaded images in these columns:

Name
The name of the loaded image.

Path
The path to the loaded image.
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Context menu

This context menu is available:

Show only 'projectl’
These commands are available:

Show all images
Shows debug information for all loaded debug images.

Show only image
Shows debug information for the selected debug image.

Related information

For related information, see:

® Loading multiple images, page 43
® Images, page 325
® _ loadlmage, page 276.

Get Alternative File dialog box

The Get Alternative File dialog box is displayed if C-SPY cannot automatically find
the source files to be loaded, for example if the application was built on another
computer.

Get Alternative File P§|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

Could not find the following source file

The missing source file.

Suggested alternative

Specify an alternative file.

C-SPY® Debugging Guide
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Use this file

After you have specified an alternative file, Use this file establishes that file as the alias
for the requested file. Note that after you have chosen this action, C-SPY will
automatically locate other source files if these files reside in a directory structure similar
to the first selected alternative file.

The next time you start a debug session, the selected alternative file will be preloaded
automatically.

Skip

C-SPY will assume that the source file is not available for this debug session.

If possible, don’t show this dialog again

Instead of displaying the dialog box again for a missing source file, C-SPY will use the
previously supplied response.

Related information

For related information, see Starting a debug session with source files missing, page 42.
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Hardware Setup dialog box - IECUBE
The Hardware Setup dialog box is available from the Emulator menu.

Hardware Setup for IECUBE VB50ES (D3283)
CPU mode Clock.

Main O5C [MHz)
5.000 v Ceree]

Trigger output event Sub 05C [kHz)
+ Dizabled / Event tigged Mone -
Default
™ Trace start / Break
" Trace start Clock in debug Peripherals in debug
" Break * Main OSC + Running
" Trace stop delay " Current O5C " Stopped

Clock source - Combo-treak | Fai-safe break

" External " Enabled | | IROM: [ Guard access break [ ‘white detect break

@ |ntemal + Disabled ™ Enable program data write

S IRAM: [~ Guard access break

v MMID v HOLD ™ Werification check after guard break

vV NMI Vv NMIZ SFR: ¥ Guard access break W ‘Wiite detect break
W STOP ¥ RESET [¥ Read detect break

W walT W TRESET ExtBus: ¥ Guard access break W ‘white detect break

Memory map
Start address:  Length [Kbytes]: Type: Access size:
| j |IntemaIF|DM j |Aut0 j
0x00000000 - 0<000FFFFF Intemal ROM G40(1024] KB Auto Add
0x03FFO000 - 0x03FFEFFF Internal Rah 48060 KB Auto

Remove
=

Remave Al

Use this dialog box to configure the [IECUBE emulator debugger.
To define a new memory area:

I Select a memory type from the Type drop-down list.

Enter a start address in the Start address text box.

Select the memory length from the Length drop-down list.

Select the memory access size from the Access size drop-down list.

vi A W BN

Click Add to add the memory area to the memory map.

Note: Depending on your device variant, defining new memory areas might not be
supported.

C-SPY® Debugging Guide
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Requirements
An IECUBE emulator debugger.

CPU mode

Selects the CPU mode. Choose between:

e Single chip

e Single-chip + 16-bit data bus

o ROM-less, 8-bit data bus

o ROM-less, 16-bit data bus
Main OSC

Selects the frequency of the clock oscillator before it is multiplied internally in the CPU.
Sub OSC

Selects the frequency of an optional low frequency clock.

Trigger output event
Selects the trigger pin function. Choose between:

Trace Start/Break, Trace start*, Break*
Causes a pulse to be emitted on the trigger pin when the event occurs. For more
information, see Getting started with trace, page 188.

Disabled/Event trigged

Sets the output to low while executing. If you want the trigger pin to emit a pulse
when certain events are triggered, select these events in the Trigger Output
Settings dialog box. See Trigger Output Settings dialog box, page 340.

Trace stop delay

Causes a pulse to be emitted directly when a trace stop event occurs, but tracing
continues according to the setting of the Stop delay option in the Trace Settings
dialog box. See Trace Settings dialog box, page 191. For more information, see
Getting started with trace, page 188.

* The Trace start and Break events can be selected individually. Doing so disables the
settings in the Trigger Output Settings dialog box.

Clock in debug

Selects which clock the CPU uses when the application stops. Choose between:
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Main OSC

Switches to the Main OSC to make the communication between the debugger
and CPU faster.

Current OSC
Uses the current clock oscillator.

Peripherals in debug

Clock source

Combo-break

Pin mask

Fail-safe break

C-SPY® Debugging Guide
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Controls the status of the peripheral units when the application stops. Choose between:

Running
Selects that the peripheral units should be running.

Stopped
Selects that the peripheral units should be stopped.

Selects the CPU clock source. Choose between:

External
Selects the emulator as the CPU clock.

Internal
Selects the target clock as the CPU clock.

Selects the use of combo-breaks. Choose between:

Enabled

Enables combo-breaks. This setting makes it possible to still receive interrupts
when the execution has stopped at a breakpoint.

Disabled
Disables combo-breaks.

Selects the non-connected pod pins, so they do not disturb the execution of the CPU. If
the RESET option is selected, the pod pin is not connected.

Toggles the fail-safe options. See the manufacturer’s hardware debugger guides for
information about these options.



Memory map
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Specify customized memory areas. Typically, you will not need to change or add
memory areas. However, your specific hardware might require customized memory
areas. You can specify:
Start address

Specify the start address of the memory area.

Length
Specity the length of the memory area in Kbytes.
Type
Selects the type of the memory area. Choose between:
Internal ROM, internal ROM must be defined if single-chip mode is selected.

When an internal ROM area is defined, the whole 1-Mbyte address space will
be occupied. The allowed number of memory areas is 1.

Internal RAM, an internal RAM area must always be defined. The allowed
number of memory areas is 1.

External target, the external target memory areas are always 1 Mbyte in size.
The allowed number of memory areas is unlimited.

External target (no power check), the external target memory areas are always
1 Mbyte in size. If you use this memory type, no checks are performed to see if
the memory has a power source. The allowed number of memory areas is
unlimited.

External target ROM, the external target ROM areas are always 1 Mbyte in
size. The allowed number of memory areas is unlimited.

External target ROM (no power check), the external target ROM areas are
always 1 Mbyte in size. If you use this memory type, no checks are performed
to see if the memory has a power source. The allowed number of memory areas
is unlimited.

Access size

Selects the size of memory accesses. Choose between:

8-bit, all memory accesses are performed as 8-bit (byte) read/writes.

16-bit, all memory accesses are performed as 16-bit (half-word) read/writes.
32-bit, all memory accesses are performed as 32-bit (word) read/writes.

Auto, memory accesses are performed in the most efficient way depending on
the alignment of the accessed address.
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Buttons

These buttons are available:

Add

Adds a new memory area.

Remove

Clears an existing memory area.

Remove All

Removes all memory areas.

Note: Unallocated memory areas are always set as guarded, which means that they are
read- and write-protected. If an application reads or writes in guarded memory or writes

in ROM, the execution is stopped.

Hardware Setup dialog box — EI N-Wire, El Serial, MINICUBE, MINICUBE?2,

TK-V850

C-SPY® Debugging Guide
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The Hardware Setup dialog box is available from the Emulator menu.

Hardware Setup for E1 serial VB50ES (DF3707) =

— CPU mode Clock.
ISingIe chip vl Main OSC (MHz] Rate |LI
|5-DDD 'l I‘I 'l Cancel
D code —I

Sub 05C [kHz)

_—
[FFFFFFFFFFFFFFFFFFFF

INone

j Default |

— Feripheralz in debug
& Funning
| Stopped

Clock in debug
& Main 050
 Cument 05C

I UARTAD <z l

" Target connection

Fin mask Combo-break Power supply—
¥ NHID W K2 ™ HOLD ) RESET ||| ¢ Enabled =T g
| K11 ) DEINT ¥ il 2 STOP | || € Disabled ||

— Memory map
Start address:  Length [Kbytes]:  Type: Access size:
0=0 I j I j IAuto j

000000000 - Dx0003FFFF Internal ROM 2! Ak
0+03FFCO00 - 0<03FFEFFF Internal RAM 12 KB Auta

B Auto

Modify |

Femove |
Femoyve Al |

Use this dialog box to configure the hardware debugger.
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To define a new memory area:

I Select a memory type from the Type drop-down list.
Enter a start address in the Start address text box.
Select the memory length from the Length drop-down list.

Select the memory access size from the Access size drop-down list.

vi A W N

Click Add to add the memory area to the memory map.
Note: Depending on your device variant, defining new memory areas might not be

supported.

Requirements
An E1 N-Wire, E1 Serial, MINICUBE, MINICUBE?2, or TK-V850 hardware debugger.

CPU mode
Selects the CPU mode. This option is locked to Single chip.
ID code
Specify the ID code for CPUs that are read-protected with an RSU ID code, a 20-digit
(10 bytes) hexadecimal number. By default, all digits are F.
This example defines the ID code in C:
#pragma constseg=RSU
/* RSU Signature for V850ES */
/* w/ MINICUBE/N-Wire/TK-V850 Interface */
__root const unsigned char
IDCODE[10]={0xFF, OxXFF, 0XFF, 0XFF, 0XFF, 0XFF, 0XFF, OXFF, 0XFF, OXFF} ;
#pragma constseg=default
To define the RSU ID Code in an assembler file (* . s85), this example can be used:
ASEG
ORG 0x70
/* RSU Signature for V850ES */
/* w/ MINICUBE/N-Wire/TK-V850 Interface */
DB OxFF, OxFF, OXFF, OxFF, OxFF, OXFF, OXFF, O0xFF, OXFF, OXFF
END
Main OSC

Selects the frequency of the clock oscillator before it is multiplied internally in the CPU.

Note: This feature is not used by the TK-V850 debugger.

61



Reference information on starting C-SPY

62

Rate

Sub OSC

Selects the multiplication rate of the main clock oscillator.

Note: This feature is not used by the MINICUBE2 debugger.

Selects the frequency of an optional low frequency clock.

Note: This feature is not used by the MINICUBE2 or TK-V850 debuggers.

Peripherals in debug

Clock in debug

Controls the status of the peripheral units when the application stops. Choose between:

Running

Selects that the peripheral units should be running.

Stopped
Selects that the peripheral units should be stopped.

Note: This feature is not used by the MINICUBE?2 or TK-V850 debuggers.

Selects which clock the CPU uses when the application stops. Choose between:

Main OSC

Switches to the Main OSC to make the communication between the debugger
and the CPU faster.

Current OSC
Uses the current clock oscillator.

Note: This feature is not used by the MINICUBE2 or TK-V850 debuggers.

Target connection

Pin mask

C-SPY® Debugging Guide
for V850

Selects the communication port for the emulator.

Note: This feature is only available for the MINICUBE2 debugger.

Selects the non-connected pod pins, so they do not disturb the execution of the CPU. If
the RESET option is selected, the pod pin is not connected.

Note: This feature is not used by the TK-V850 debugger.
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Combo-break
Selects the use of combo-breaks. Choose between:

Enabled

Enables combo-breaks. This setting makes it possible to still receive interrupts
when the execution has stopped at a breakpoint.

Disabled
Disables combo-breaks.

Note: This feature is not used by the MINICUBE2 or TK-V850 debuggers.

Power supply
Selects the source of power supply for the target board. Choose between:

Extern

An external source supplies power.

3v
The E1 emulator supplies 3 V of power.

5V
The E1 emulator supplies 5 V of power.

Note: This feature is only used by the E1 N-Wire and the E1 Serial debuggers.

Memory map

Specify customized memory areas. Typically, you will not need to change or add
memory areas. However, your specific hardware might require customized memory
areas. You can specify:

Start address
Specity the start address of the memory area.

Length
Specify the length of the memory area in Kbytes.

Type
Selects the type of the memory area. Choose between:

Internal ROM, internal ROM must be defined if single-chip mode is selected.
When an internal ROM area is defined, the whole 1-Mbyte address space will
be occupied.

Internal RAM, an internal RAM area must always be defined.
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Buttons
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Access size

Selects the size of memory accesses. Choose between:

8-bit, all memory accesses are performed as 8-bit (byte) read/writes.

16-bit, all memory accesses are performed as 16-bit (half-word) read/writes.
32-bit, all memory accesses are performed as 32-bit (word) read/writes.

Auto, memory accesses are performed in the most efficient way depending on
the alignment of the accessed address.

These buttons are available:
Modify
Modifies a memory area.

Remove
Clears an existing memory area.

Remove All
Removes all memory areas.
Note: Unallocated memory areas, except for SFR areas, are always set as guarded,

which means that they are read- and write-protected. If an application reads or writes in
guarded memory or writes in ROM, the execution is stopped.
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Hardware Setup dialog box — EI Nexus, IECUBE2, MINICUBE for V850E2x

The Hardware Setup dialog box is available from the Emulator menu.

Hardware Setup for E1 Nexus E2x VB50E2M (D 0 =

— CPU mode ~ Clock

ISingIe chip j Main O5C [MHz] Rate |LI
|5-DDD 'l m Cancel |
D ende """ | 55 0SC [kHz]
[FFFFFFFFFFFFFFFFFFFFFFFE || [None 7]
Default |
— Peripheralz in debug———— - Combo-break
" Running " Enabled
" Stopped " Disabled
r— Pin maszk. Power supply
I waT ¥ 5TOP | TRESET S
¥ RESET [ HOLD
— Memory map
Start address:  Length [Kbytes]:  Type: Access size:
0=0 I j I j IAuto j

102 KE_futo Modify |
TAFEDCO000 - DxFEDFEFFFIntemaI RAM 256 KB At

Femove |
Femoyve Al |

Use this dialog box to configure the hardware debugger.
To define a new memory area:

I Select a memory type from the Type drop-down list.

Enter a start address in the Start address text box.

Select the memory length from the Length drop-down list.

Select the memory access size from the Access size drop-down list.

vi A W N

Click Add to add the memory area to the memory map.

Note: Depending on your device variant, defining new memory areas might not be
supported.

Requirements
An E1 Nexus, IECUBE2, or MINICUBE for V850E2x hardware debugger.

65



Reference information on starting C-SPY

66

CPU mode

ID code

Main OSC

Rate

Sub OSC

Selects the CPU mode. This option is locked to Single chip.

Specifies a 95-bit ID code and an internal control flag (on-chip debug enable control).
The ID code is given as a 24-digit hexadecimal number. By default, all digits are F.

When the CPU is unlocked, you can specify a new ID code here. This will be valid when
the next debug session starts.

Note: This feature is not used by the IECUBE2 emulator.

Selects the frequency of the clock oscillator before it is multiplied internally in the CPU.

Selects the multiplication rate of the main clock oscillator.

Selects the frequency of an optional low-frequency clock.

Peripherals in debug

Combo-break

C-SPY® Debugging Guide
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Controls the status of the peripheral units when the program stops. Choose between:

Running
Selects that the peripheral units should be running.

Stopped
Selects that the peripheral units should be stopped.

Selects the use of combo-breaks. Choose between:

Enabled

Enables combo-breaks. This setting makes it possible to still receive interrupts
when the execution has stopped at a breakpoint.

Disabled
Disables combo-breaks.
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Pin mask

Selects the non-connected pod pins, so they do not disturb the execution of the CPU. If
the RESET option is selected, the pod pin is not connected.

Power supply
Selects the source of power supply for the target board. Choose between:
Extern
An external source supplies power.
3V
The E1 emulator supplies 3 V of power.
5v
The E1 emulator supplies 5 V of power.

Note: This feature is only used by the E1 Nexus debugger.

Memory map

Specify customized memory areas. Typically, you will not need to change or add
memory areas. However, your specific hardware might require customized memory
areas. You can specify:

Access size

Selects the size of memory accesses. Choose between:

8-bit, all memory accesses are performed as 8-bit (byte) read/writes.

16-bit, all memory accesses are performed as 16-bit (half-word) read/writes.
32-bit, all memory accesses are performed as 32-bit (word) read/writes.
Auto, memory accesses are performed in the most efficient way depending on

the alignment of the accessed address.

Buttons
These buttons are available:
Modify
Modifies a memory area.

Remove
Clears an existing memory area.

Remove All

Removes all memory areas.
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Executing your application

e Introduction to application execution

e Reference information on application execution

Introduction to application execution
These topics are covered:

Briefly about application execution
Source and disassembly mode debugging
Single stepping

Stepping speed

Running the application

Highlighting

Call stack information

Terminal input and output

Debug logging

BRIEFLY ABOUT APPLICATION EXECUTION

C-SPY allows you to monitor and control the execution of your application. By
single-stepping through it, and setting breakpoints, you can examine details about the
application execution, for example the values of variables and registers. You can also use
the call stack to step back and forth in the function call chain.

The terminal I/O and debug log features let you interact with your application.

You can find commands for execution on the Debug menu and on the toolbar.

SOURCE AND DISASSEMBLY MODE DEBUGGING

C-SPY allows you to switch between source mode and disassembly mode debugging as
needed.

Source debugging provides the fastest and easiest way of developing your application,
without having to worry about how the compiler or assembler has implemented the
code. In the editor windows you can execute the application one statement at a time
while monitoring the values of variables and data structures.
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Disassembly mode debugging lets you focus on the critical sections of your application,
and provides you with precise control of the application code. You can open a
disassembly window which displays a mnemonic assembler listing of your application
based on actual memory contents rather than source code, and lets you execute the
application exactly one machine instruction at a time.

Regardless of which mode you are debugging in, you can display registers and memory,
and change their contents.

SINGLE STEPPING

C-SPY allows more stepping precision than most other debuggers because it is not
line-oriented but statement-oriented. The compiler generates detailed stepping
information in the form of step points at each statement, and at each function call. That
is, source code locations where you might consider whether to execute a step into or a
step over command. Because the step points are located not only at each statement but
also at each function call, the step functionality allows a finer granularity than just
stepping on statements.

There are several factors that can slow down the stepping speed. If you find it too slow,
see Slow stepping speed, page 349 for some tips.

The step commands
There are four step commands:

e Step Into
o Step Over
o Next Statement
e Step Out.

Using the Autostep settings dialog box, you can automate the single stepping. For more
information, see Autostep settings dialog box, page 86.
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Consider this example and assume that the previous step has taken you to the £ (1)
function call (highlighted):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}
int main()

{

£(i);
value ++;

Step Into

While stepping, you typically consider whether to step into a function and continue
stepping inside the function or subroutine. The Step Into command takes you to the first
step point within the subroutine g (n-1):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

The Step Into command executes to the next step point in the normal flow of control,
regardless of whether it is in the same or another function.

Step Over

The Step Over command executes to the next step point in the same function, without
stopping inside called functions. The command would take you to the g (n-2) function
call, which is not a statement on its own but part of the same statement as g (n-1) . Thus,
you can skip uninteresting calls which are parts of statements and instead focus on
critical parts:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}
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Next Statement

The Next Statement command executes directly to the next statement, in this case
return value, allowing faster stepping:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

Step Out

When inside the function, you can—if you wish—use the Step Out command to step
out of it before it reaches the exit. This will take you directly to the statement
immediately after the function call:

extern int g(int);
int f(int n)
{
value = g(n-1) + g(n-2) g(n-3);
return value;

}

int main()

{

£(1i);
value ++;

}

The possibility of stepping into an individual function that is part of a more complex
statement is particularly useful when you use C code containing many nested function
calls. It is also very useful for C++, which tends to have many implicit function calls,
such as constructors, destructors, assignment operators, and other user-defined
operators.

This detailed stepping can in some circumstances be either invaluable or unnecessarily
slow. For this reason, you can also step only on statements, which means faster stepping.

STEPPING SPEED

Stepping in C-SPY is normally performed using breakpoints. When performing a step
command, a breakpoint is set on the next statement and the program executes until
reaching this breakpoint. If you are debugging using a hardware debugger system, the
number of hardware breakpoints—typically used for setting a stepping breakpoint, at
least in code that is located in flash/ROM memory—is limited. If you for example, step
into a C swi tch statement, breakpoints are set on each branch, and hence, this might
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consume several hardware breakpoints. If the number of available hardware breakpoints
is exceeded, C-SPY switches into single stepping at assembly level, which can be very
slow.

For this reason, it can be helpful to keep track of how many hardware breakpoints are
used and make sure to some of them are left for stepping. For more information, see and
Breakpoint consumers, page 127.

In addition to limited hardware breakpoints, these issues might also affect stepping
speed:

If Trace or Function profiling is enabled. This might slow down stepping because
collected Trace data is processed after each step. Note that it is not sufficient to
close the corresponding windows to disable Trace data collection. Instead, you must
disable the Enable/Disable button in both the Trace and the Function profiling
windows.

If the Register window is open and displays SFR registers. This might slow down
stepping because all registers in the selected register group must be read from the
hardware after each step. To solve this, you can choose to view only a limited
selection of SFR register; you can choose between two alternatives. Either type
#SFR_name (Where #SFR_name reflects the name of the SFR you want to monitor)
in the Watch window, or create your own filter for displaying a limited group of
SFRs in the Register window. See Defining application-specific register groups,
page 153.

If any of the Memory or Symbolic memory windows is open. This might slow
down stepping because the visible memory must be read after each step.

If any of the expression related windows such as Watch, Live Watch, Locals,
Statics is open. This might slow down stepping speed because all these windows
reads memory after each step.

If the Stack window is open and especially if the option Enable graphical stack
display and stack usage tracking option is enabled. To disable this option, choose
Tools>Options>Stack and disable it.

If a too slow communication speed has been set up between C-SPY and the target
board/emulator you should consider to increase the speed, if possible.

RUNNING THE APPLICATION

Go

The Go command continues execution from the current position until a breakpoint or
program exit is reached.
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Run to Cursor

The Run to Cursor command executes to the position in the source code where you
have placed the cursor. The Run to Cursor command also works in the Disassembly
window and in the Call Stack window.

HIGHLIGHTING

At each stop, C-SPY highlights the corresponding C or C++ source or instruction with
a green color, in the editor and the Disassembly window respectively. In addition, a
green arrow appears in the editor window when you step on C or C++ source level, and
in the Disassembly window when you step on disassembly level. This is determined by
which of the windows is the active window. If none of the windows are active, it is
determined by which of the windows was last active.

Tutor.c I!EEE

void init_fib{ void |

i

int i = 45;
o root[0] = root[l] = 1;

for { i=2 ; i<MAX _FIE : i++)
{

For simple statements without function calls, the whole statement is typically
highlighted. When stopping at a statement with function calls, C-SPY highlights the first
call because this illustrates more clearly what Step Into and Step Over would mean at
that time.

Occasionally, you will notice that a statement in the source window is highlighted using
a pale variant of the normal highlight color. This happens when the program counter is
at an assembler instruction which is part of a source statement but not exactly at a step
point. This is often the case when stepping in the Disassembly window. Only when the
program counter is at the first instruction of the source statement, the ordinary highlight
color is used.

CALL STACK INFORMATION

The compiler generates extensive backtrace information. This allows C-SPY to show,
without any runtime penalty, the complete function call chain at any time.

Typically, this is useful for two purposes:

e Determining in what context the current function has been called
o Tracing the origin of incorrect values in variables and in parameters, thus locating
the function in the call chain where the problem occurred.

The Call Stack window shows a list of function calls, with the current function at the
top. When you inspect a function in the call chain, the contents of all affected windows
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are updated to display the state of that particular call frame. This includes the editor,
Locals, Register, Watch and Disassembly windows. A function would normally not
make use of all registers, so these registers might have undefined states and be displayed
as dashes (---).

In the editor and Disassembly windows, a green highlight indicates the topmost, or
current, call frame; a yellow highlight is used when inspecting other frames.

For your convenience, it is possible to select a function in the call stack and click the
Run to Cursor command to execute to that function.

Assembler source code does not automatically contain any backtrace information. To
see the call chain also for your assembler modules, you can add the appropriate CFI
assembler directives to the assembler source code. For further information, see the /AR
Assembler Reference Guide for V850.

TERMINAL INPUT AND OUTPUT

Sometimes you might have to debug constructions in your application that use stdin

and stdout without an actual hardware device for input and output. The Terminal I/O
window lets you enter input to your application, and display output from it. You can also
direct terminal I/O to a file, using the Terminal 1/O Log Files dialog box.

This facility is useful in two different contexts:

e If your application uses stdin and stdout

e For producing debug trace printouts.

For more information, see Terminal 1/O window, page 82 and Terminal 1/0 Log File
dialog box, page §3.

DEBUG LOGGING

The Debug Log window displays debugger output, such as diagnostic messages,
macro-generated output, event log messages, and information about trace.

It can sometimes be convenient to log the information to a file where you can easily
inspect it. The two main advantages are:

o The file can be opened in another tool, for instance an editor, so you can navigate
and search within the file for particularly interesting parts

o The file provides history about how you have controlled the execution, for instance,
which breakpoints that have been triggered etc.
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Disassembly window

Code coverage |

Reference information about:

Disassembly window, page 76

Call Stack window, page 80

Terminal 1/0 window, page 82

Terminal 1/0 Log File dialog box, page 83
Debug Log window, page 84

Log File dialog box, page 85

Report Assert dialog box, page 86

Autostep settings dialog box, page 86

See also Terminal I/O options in the IDE Project Management and Building Guide.

The C-SPY Disassembly window is available from the View menu.

[ Go to memory address ] [ Select zone to display ] I Toggle embedded source code
5 l
Disassembly Y | -
Disassembly
-« OO01lEA o7 RET

NextCounter() ;
DoForegroundProcess:

information

[ Current position }

o 0O01EE FLOE701 CALL N:NextCounter
fib = GetFib(callCount] ;

& 0O01EE AFOOEF MOV A¥, N:callCount

& 001F1 FD4502 CALL N:UFOSTR
PutFila{ fily) ;

& 001F4 EDS002 ER N:UF1CTLO
callCount = 0O;

main:

& 001F7 Fi5 CLEW AKX

% 0O0IF®  BFOOBF  MOVW  N:callCount, AX
InitFila() ;

& 001FE FDOEODZ2 CALL N:TCR27

& 001FE EFO03 ER S:5+0x05

DoForegroundProcess() ;

[ Breakpeint }

C-SPY® Debugging Guide
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00200 FDEBOL  CALL  N:DoForegroundProcess
while (callCount = MAX FIE)

& 00203 AFOOEF MOV A¥, N:callCount

* 00206 TCR0 XOR A, #0x80
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This window shows the application being debugged as disassembled application code.

To change the default color of the source code in the Disassembly window:

I Choose Tools>Options>Debugger.
2 Set the default color using the Source code coloring in disassembly window option.

To view the corresponding assembler code for a function, you can select it in the editor
@ window and drag it to the Disassembly window.

Requirements

None; this window is always available.

Toolbar
The toolbar contains:

Go to

The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 150.

Toggle Mixed-Mode

Toggles between displaying only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information

Display area

The display area shows the disassembled application code.
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This area contains these graphic elements:

Green highlight

Yellow highlight

Red dot

Green diamond

Indicates the current position, that is the next assembler
instruction to be executed. To move the cursor to any line in
the Disassembly window, click the line. Alternatively, move
the cursor using the navigation keys.

Indicates a position other than the current position, such as
when navigating between frames in the Call Stack window
or between items in the Trace window.

Indicates a breakpoint. Double-click in the gray left-side
margin of the window to set a breakpoint. For more
information, see Breakpoints, page 123.

Indicates code that has been executed—that is, code
coverage.

If instruction profiling has been enabled from the context menu, an extra column in the
left-side margin appears with information about how many times each instruction has

been executed.

This context menu is available:

Move to PC
Run ko Cursor

Code Coverage
Instruction Profiling

Toggle Breakpoint {Code)
Toggle Breakpoint {Log)

Toggle Breakpoint {Trace Start)
Toggle Breakpoint {Trace Stop)
Enable/disable Ereakpaint

Set Mext Statement

Copy Window Contents
v Mixed-Mode

Note: The contents of this menu are dynamic, which means that the commands on the
menu might depend on your product package.

These commands are available:

Move to PC

Displays code at the current program counter location.
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Run to Cursor
Executes the application from the current position up to the line containing the
Cursor.

Code Coverage

Displays a submenu that provides commands for controlling code coverage.
This command is only enabled if the driver you are using supports it.

Enable Toggles code coverage on or off.

Show Toggles the display of code coverage on or off.
Executed code is indicated by a green diamond.

Clear Clears all code coverage information.

Instruction Profiling

Displays a submenu that provides commands for controlling instruction
profiling. This command is only enabled if the driver you are using supports it.

Enable Toggles instruction profiling on or off.

Show Toggles the display of instruction profiling on or off.
For each instruction, the left-side margin displays
how many times the instruction has been executed.

Clear Clears all instruction profiling information.

Toggle Breakpoint (Code)
Toggles a code breakpoint. Assembler instructions and any corresponding label
at which code breakpoints have been set are highlighted in red. For more
information, see Code breakpoints dialog box, page 137.

Toggle Breakpoint (Log)

Toggles a log breakpoint for trace printouts. Assembler instructions at which log
breakpoints have been set are highlighted in red. For more information, see Log
breakpoints dialog box, page 138.

Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, the trace
data collection starts. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see Trace
Start breakpoints dialog box, page 208.
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Toggle Breakpoint (Trace Stop)
Toggles a Trace Stop breakpoint. When the breakpoint is triggered, the trace
data collection stops. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see Trace
Stop breakpoints dialog box, page 209.

Enable/Disable Breakpoint
Enables and Disables a breakpoint. If there is more than one breakpoint at a
specific line, all those breakpoints are affected by the Enable/Disable
command.

Edit Breakpoint
Displays the breakpoint dialog box to let you edit the currently selected
breakpoint. If there is more than one breakpoint on the selected line, a submenu
is displayed that lists all available breakpoints on that line.

Set Next Statement
Sets the program counter to the address of the instruction at the insertion point.

Copy Window Contents
Copies the selected contents of the Disassembly window to the clipboard.

Mixed-Mode

Toggles between showing only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information.

The Call Stack window is available from the View menu.

Call Stack (=]

T Fibonacci::next()

[
- Drestination for Step Into
'::> malin i

[_call_main + O0x2]

Jump te main from label
plus offset

This window displays the C function call stack with the current function at the top. To
inspect a function call, double-click it. C-SPY now focuses on that call frame instead.
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If the next Step Into command would step to a function call, the name of the function is
displayed in the grey bar at the top of the window. This is especially useful for implicit
function calls, such as C++ constructors, destructors, and operators.

Requirements

None; this window is always available.

Display area
Provided that the command Show Arguments is enabled, each entry in the display area
has the format:
function(values) ***

where

(values) is alist of the current values of the parameters, or empty if the function does
not take any parameters.

**x*_if visible, indicates that the function has been inlined by the compiler. For
information about function inlining, see the /4R C/C++ Compiler Reference Guide for
V850.

Context menu

This context menu is available:
Go to Source
Show Arguments
Run to Cursor
Toggle Breakpoint (Code)
Toggle Breakpoint (Log)
Toggle Breakpoint (Trace Start)
Toggle Breakpoint (Trace Stop)
Enable/Disable Breakpoint

These commands are available:

Go to Source
Displays the selected function in the Disassembly or editor windows.

Show Arguments
Shows function arguments.

Run to Cursor

Executes until return to the function selected in the call stack.

Toggle Breakpoint (Code)
Toggles a code breakpoint.
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Toggle Breakpoint (Log)
Toggles a log breakpoint.

Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, trace data
collection starts. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Toggle Breakpoint (Trace Stop)
Toggles a Trace Stop breakpoint. When the breakpoint is triggered, trace data
collection stops. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Enable/Disable Breakpoint
Enables or disables the selected breakpoint

The Terminal I/O window is available from the View menu.

Terminal I/0 =

Output: Log file: OFff

[ a—

21
34
bh

Input: LCtl codes | InputMode...|

Buffer size: 1]

Use this window to enter input to your application, and display output from it.
To use this window, you must:
Link your application with the option With I/0 emulation modules.

C-SPY will then direct stdin, stdout and stderr to this window. If the Terminal I/O
window is closed, C-SPY will open it automatically when input is required, but not for
output.
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Requirements
None; this window is always available.
Input
Type the text that you want to input to your application.
Ctrl codes
Opens a menu for input of special characters, such as EOF (end of file) and NUL.
0:x00-0x0f  »
O:x10-0:x1F »
EOQF
Input Mode

Opens the Input Mode dialog box where you choose whether to input data from the
keyboard or from a file.

& Buffered e

" Direct ﬂl
" File

& Text

| Binary
$PROJ_DIREAT ermnlOlnput bt J

For reference information about the options available in this dialog box, see Terminal
1/0 options in IDE Project Management and Building Guide.

Terminal I/O Log File dialog box

The Terminal I/O Log File dialog box is available by choosing Debug>Logging>Set
Terminal I/O Log File.

Terminal I/0 Log File

Terminal [/0 Log File 0Ok

™ Enable Teminal 10 log file
J Cancel

Use this dialog box to select a destination log file for terminal I/O from C-SPY.

Requirements

None; this dialog box is always available.
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Requirements

Context menu
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Controls the logging of terminal I/O. To enable logging of terminal I/O to a file, select
Enable Terminal IO log file and specify a filename. The default filename extension is
log. A browse button is available for your convenience.

The Debug Log window is available by choosing View>Messages.

. |

Log

Fri Feb 06 10:41:40 2004: Loaded module
Fri Felb 06 10:41:40 2004: Target reset

This window displays debugger output, such as diagnostic messages, macro-generated
output, event log messages, and information about trace. This output is only available
during a debug session. When opened, this window is, by default, grouped together with
the other message windows, see IDE Project Management and Building Guide.

Double-click any rows in one of the following formats to display the corresponding
source code in the editor window:

<path> (<row>) :<message>
<path> (<row>,<column>) :<message>

None; this window is always available.

This context menu is available:

Copy
Select Al

Clear Al
These commands are available:

Copy
Copies the contents of the window.

Select All
Selects the contents of the window.



Executing your application ___4

Clear All

Clears the contents of the window.

Log File dialog box
The Log File dialog box is available by choosing Debug>Logging>Set Log File.

r Log File
o Include:
¥ Enable log file
¥ Enmors ¥ “wamings
¥ Info IV User
$PROJ_DIR$ LogFile1.log J

()3 I Cancel |

Use this dialog box to log output from C-SPY to a file.

Requirements

None; this dialog box is always available.

Enable Log file
Enables or disables logging to the file.

Include

The information printed in the file is, by default, the same as the information listed in
the Log window. Use the browse button, to override the default file and location of the
log file (the default filename extension is 1og). To change the information logged,
choose between:

Errors

C-SPY has failed to perform an operation.
Warnings
An error or omission of concern.

Info

Progress information about actions C-SPY has performed.

User

Messages from C-SPY macros, that is, your messages using the __message
statement.
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Report Assert dialog box

Abort

Debug

Ignore

The Report Assert dialog box appears if you have a call to the assert function in your
application source code, and the assert condition is false. In this dialog box you can
choose how to proceed.

Report Assert g|
The following Failed:
File: C:\Documents and SettingsiMy DocumentsiIAR Embedded Workbenchiresolve.cpp

Line: 35
Expression Failed:

Abort | Debug |

The application stops executing and the runtime library function abort, which is part
of your application on the target system, will be called. This means that the application
itself terminates its execution.

C-SPY stops the execution of the application and returns control to you.

The assertion is ignored and the application continues to execute.

Autostep settings dialog box

Requirements

Delay

C-SPY® Debugging Guide
for V850

The Autostep settings dialog box is available from the Debug menu.

Autostep settings E

I Step Into [Source level] j Start I
Delay [miIIiseconds]:I‘I ] Cancel |

Use this dialog box to customize autostepping.

The drop-down menu lists the available step commands.

None; this dialog box is always available.

Specify the delay between each step in milliseconds.



Variables and expressions

e Introduction to working with variables and expressions
e Working with variables and expressions

e Reference information on working with variables and expressions

Introduction to working with variables and expressions

This section introduces different methods for looking at variables and introduces some
related concepts.

These topics are covered:

e Briefly about working with variables and expressions
o C-SPY expressions

o Limitations on variable information.

BRIEFLY ABOUT WORKING WITH VARIABLES AND
EXPRESSIONS

There are several methods for looking at variables and calculating their values:

e Tooltip watch—in the editor window—provides the simplest way of viewing the
value of a variable or more complex expressions. Just point at the variable with the
mouse pointer. The value is displayed next to the variable.

o The Auto window displays a useful selection of variables and expressions in, or
near, the current statement. The window is automatically updated when execution
stops.

o The Locals window displays the local variables, that is, auto variables and function
parameters for the active function. The window is automatically updated when
execution stops.

o The Watch window allows you to monitor the values of C-SPY expressions and
variables. The window is automatically updated when execution stops.

o The Live Watch window repeatedly samples and displays the values of expressions
while your application is executing. Variables in the expressions must be statically
located, such as global variables.

o The Statics window displays the values of variables with static storage duration.
The window is automatically updated when execution stops.
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o The Macro Quicklaunch window and the Quick Watch window give you precise
control over when to evaluate an expression.

e The Symbols window displays all symbols with a static location, that is, C/C++
functions, assembler labels, and variables with static storage duration, including
symbols from the runtime library.

e The Data Log window and the Data Log Summary window display logs of
accesses to up to four different memory locations you choose by setting data log
breakpoints. Data logging can help you locate frequently accessed data. You can
then consider whether you should place that data in more efficient memory.

o The Data Sample window displays samples for up to four different variables. You
can also display the data samples as graphs in the Sampled Graphs window. By
using data sampling, you will get an indication of the data value over a length of
time. Because it is a sampled value, data sampling is best suited for slow-changing
data.

o The Trace-related windows let you inspect the program flow up to a specific state.
For more information, see Trace, page 187.

C-SPY EXPRESSIONS

C-SPY expressions can include any type of C expression, except for calls to functions.
The following types of symbols can be used in expressions:

C/C++ symbols
Assembler symbols (register names and assembler labels)

°
°
o C-SPY macro functions
°

C-SPY macro variables.

Expressions that are built with these types of symbols are called C-SPY expressions and
there are several methods for monitoring these in C-SPY. Examples of valid C-SPY
expressions are:

i+ 3

i = 42

myVar = cVar

cVar = myVar + 2

#asm_label

#R2

#PC

my_macro_func(19)

If you have a static variable with the same name declared in several different functions,
use the notation function: : variable to specify which variable to monitor.

C-SPY® Debugging Guide
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C/C++ symbols

C symbols are symbols that you have defined in the C source code of your application,
for instance variables, constants, and functions (functions can be used as symbols but
cannot be executed). C symbols can be referenced by their names. Note that C++
symbols might implicitly contain function calls which are not allowed in C-SPY
symbols and expressions.

Note: Some attributes available in C/C++, like volatile, are not fully supported by
C-SPY. For example, this line will not be accepted by C-SPY:

sizeof (unsigned char volatile __memattr *)
However, this line will be accepted:

sizeof (unsigned char __memattr *)

Assembler symbols

Assembler symbols can be assembler labels or registers, for example the program
counter, the stack pointer, or other CPU registers. If a device description file is used, all
memory-mapped peripheral units, such as I/O ports, can also be used as assembler
symbols in the same way as the CPU registers. See Modifying a device description file,
page 44.

Assembler symbols can be used in C-SPY expressions if they are prefixed by #.

Example What it does
#PC++ Increments the value of the program counter.
myVar = #SP Assigns the current value of the stack pointer register to your

C-SPY variable.
myVar = #label Sets myVar to the value of an integer at the address of label.

myptr = &#label? Sets myptr to an int * pointer pointing at label7.

Table 6: C-SPY assembler symbols expressions

In case of a name conflict between a hardware register and an assembler label, hardware
registers have a higher precedence. To refer to an assembler label in such a case, you
must enclose the label in back quotes * (ASCII character 0x60). For example:

Example What it does
#PC Refers to the program counter.
# PC" Refers to the assembler label PC.

Table 7: Handling name conflicts between hardware registers and assembler labels

Which processor-specific symbols are available by default can be seen in the Register
window, using the CPU Registers register group. See Register window, page 174.
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C-SPY macro functions

Macro functions consist of C-SPY macro variable definitions and macro statements
which are executed when the macro is called.

For information about C-SPY macro functions and how to use them, see Briefly about
the macro language, page 254.

C-SPY macro variables

Macro variables are defined and allocated outside your application, and can be used in
a C-SPY expression. In case of a name conflict between a C symbol and a C-SPY macro
variable, the C-SPY macro variable will have a higher precedence than the C variable.
Assignments to a macro variable assign both its value and type.

For information about C-SPY macro variables and how to use them, see Reference
information on the macro language, page 260.

Using sizeof
According to standard C, there are two syntactical forms of sizeof:

sizeof (type)
sizeof expr

The former is for types and the latter for expressions.

Note: In C-SPY, do not use parentheses around an expression when you use the sizeof
operator. For example, use sizeof x+2 instead of sizeof (x+2).

LIMITATIONS ON VARIABLE INFORMATION

The value of a C variable is valid only on step points, that is, the first instruction of a
statement and on function calls. This is indicated in the editor window with a bright
green highlight color. In practice, the value of the variable is accessible and correct more
often than that.

When the program counter is inside a statement, but not at a step point, the statement or
part of the statement is highlighted with a pale variant of the ordinary highlight color.

Effects of optimizations

The compiler is free to optimize the application software as much as possible, as long
as the expected behavior remains. The optimization can affect the code so that
debugging might be more difficult because it will be less clear how the generated code
relates to the source code. Typically, using a high optimization level can affect the code
in a way that will not allow you to view a value of a variable as expected.
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Consider this example:

myFunction ()

{
int 1 = 42;

x = computer(i); /* Here, the value of i is known to C-SPY */

}

From the point where the variable i is declared until it is actually used, the compiler
does not need to waste stack or register space on it. The compiler can optimize the code,
which means that C-SPY will not be able to display the value until it is actually used. If
you try to view the value of a variable that is temporarily unavailable, C-SPY will
display the text:

Unavailable

If you need full information about values of variables during your debugging session,
you should make sure to use the lowest optimization level during compilation, that is,
None.

Working with variables and expressions

These tasks are covered:

o Using the windows related to variables and expressions
o Viewing assembler variables

o Getting started using data logging

o Getting started using data sampling

USING THE WINDOWS RELATED TO VARIABLES AND
EXPRESSIONS

Where applicable, you can add, modify, and remove expressions, and change the display
format in the windows related to variables and expressions.

To add a value you can also click in the dotted rectangle and type the expression you
want to examine. To modify the value of an expression, click the Value field and modify
its content. To remove an expression, select it and press the Delete key.

For text that is too wide to fit in a column—in any of the these windows, except the
@ Trace window—and thus is truncated, just point at the text with the mouse pointer and
tooltip information is displayed.
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Right-click in any of the windows to access the context menu which contains additional
commands. Convenient drag-and-drop between windows is supported, except for in the
Locals window, Data logging windows, and the Quick Watch window where it is not
relevant.

VIEWING ASSEMBLER VARIABLES

An assembler label does not convey any type information at all, which means C-SPY
cannot easily display data located at that label without getting extra information. To
view data conveniently, C-SPY by default treats all data located at assembler labels as
variables of type int. However, in the Watch, Live Watch, and Quick Watch
windows, you can select a different interpretation to better suit the declaration of the
variables.

In this figure, you can see four variables in the Watch window and their corresponding
declarations in the assembler source file to the left:

. f) + x Watch1
HAME main — | Expression Yalue Location Type
= asmvarl 42 0x00000080 int
PUBLIC _ iar program start asrrvard 456 0=00000084 int
astrvard 55 O0=00000088 <8-bit unsigned>

SECTION .intwec : CODE (2)
CODES2 <clickto ... Default Format

. Binary Format
__iar program start g

B main Octal Format

v Decimal Format

SECTION .text : CODE (2) Hexadecimal Format

Char Format
asmvarl: DC32 42

asmvar2: DC32 456 Show As b Asls
asmvar3: DC8 55 8-bit Signed
asmvard: DC8 10 Saveto File...
16-bit Signed
cope3z 16-bit Unsigned
= main NOE 32-bit Signed
B main 32-bit Unsigned
64-bit Signed
EID 64-bit Unsigned
float
double

Note that asmvard4 is displayed as an int, although the original assembler declaration
probably intended for it to be a single byte quantity. From the context menu you can
make C-SPY display the variable as, for example, an 8-bit unsigned variable. This has
already been specified for the asmvar3 variable.
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GETTING STARTED USING DATA LOGGING
To set a data log breakpoint, use one of these methods:

o In the Breakpoints window, right-click and choose New Breakpoint>Data Log to
open the breakpoints dialog box. Set a breakpoint on the memory location that you
want to collect log information for. This can be specified either as a variable or as an
address.

e Inthe Memory window, select a memory area, right-click and choose Set Data Log
Breakpoint from the context menu. A breakpoint is set on the start address of the
selection.

o In the editor window, select a variable, right-click and choose Set Data Log
Breakpoint from the context menu. The breakpoint will be set on the part of the
variable that the microcontroller can access using one instruction.

You can set up to four data log breakpoints. For more information about data log
breakpoints, see Data Log breakpoints, page 125.

Choose C-SPY driver>Data Log to open the Data Log window. Optionally, you can
also choose:

o C-SPY driver>Data Log Summary to open the Data Log Summary window

o C-SPY driver>Timeline to open the Timeline window to view the Data Log graph.

From the context menu, available in the Data Log window, choose Enable to enable
the logging.

Start executing your application program to collect the log information.

To view the data log information, look in any of the Data Log window, Data Log
Summary window, or the Data graph in the Timeline window.

If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

To disable data logging, choose Disable from the context menu in each window where
you have enabled it.

GETTING STARTED USING DATA SAMPLING

Choose C-SPY driver>Data Sample Setup to open the Data Sample Setup window.
In the Data Sample Setup window, perform these actions:

o In the Expression column, type the name of the variable for which you want to
sample data. The variable must be an integral type with a maximum size of 32 bits
and you can specify up to four variables. Make sure that the checkbox is selected for
the variable that you want to sample data.
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o In the Sampling interval column, type the number of milliseconds to pass between
the samples.

To view the result of data sampling, you must enable it in the window in question:

o Choose C-SPY driver>Data Sample to open the Data Sample window. From the
context menu, choose Enable.

o Choose C-SPY driver>Sampled Graph to open the Sampled Graph window.
From the context menu, choose Enable.

Start executing your application program. This starts the data sampling. When the
execution stops, for example because a breakpoint is triggered, you can view the result
either in the Data Sample window or as the Data Sample graph in the Sampled
Graphs window

If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

To disable data sampling, choose Disable from the context menu in each window
where you have enabled it.

Reference information on working with variables and expressions
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Reference information about:

Auto window, page 95

Locals window, page 97

Watch window, page 99

Live Watch window, page 101

Statics window, page 103

Quick Watch window, page 106
Symbols window, page 108

Resolve Symbol Ambiguity dialog box, page 110
Data Log window, page 111

Data Log Summary window, page 113
Data Sample Setup window, page 115
Data Sample window, page 116

Sampled Graphs window, page 118
See also:

® Reference information on trace, page 190 for trace-related reference information
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® Macro Quicklaunch window, page 305

Auto window

The Auto window is available from the View menu.

Expression Walue Location Type

i 5 0x7 short

Fib[i] 0 Mermory:0xC00C unsigned int
Fik <array> hemony:0xC002 unsigned int[10]
GetFib GetFib (0xBC) unsigned int (*)...

This window displays a useful selection of variables and expressions in, or near, the
current statement. Every time execution in C-SPY stops, the values in the Auto window
are recalculated. Values that have changed since the last stop are highlighted in red.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

Requirements

None; this window is always available.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3

Save to File...

These commands are available:

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 92.
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Options
Displays the IDE Options dialog box where you can set the Update interval
option. The default value of this option is 1000 milliseconds, which means the
Live Watch window will be updated once every second during program
execution. Note that this command is only available from this context menu in
the Live Watch window.

Save to File

Saves content to a file in a tab-separated format.

Locals window
The Locals window is available from the View menu.

Expression Yalue Location Type
i 2 R7 short

This window displays the local variables and parameters for the current function. Every
time execution in C-SPY stops, the values in the window are recalculated. Values that
have changed since the last stop are highlighted in red.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

Requirements

None; this window is always available.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3

Save to File...

These commands are available:

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 92.
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Options
Displays the IDE Options dialog box where you can set the Update interval
option. The default value of this option is 1000 milliseconds, which means the
Live Watch window will be updated once every second during program
execution. Note that this command is only available from this context menu in
the Live Watch window.

Save to File

Saves content to a file in a tab-separated format.

Woatch window

The Watch window is available from the View menu.

Watch 1 =]
Expression Yalue Location Type
2 |vemory.0rEr00 [m
Fib <array> Memory : 0xFEF02 unsigned int...
] 1 Memory : 0xFEF02 unsigned int
1] 1 Memory : 0xFEF04 unsigned int
[2] 2 Memory : 0xFEFO06 unsigned int
[ 3 Memory : 0xFEFO& unsigned int
[4] 5 v unsigned int
[5] a unsigned int
[E] 13 unsigned int
[71 21 unsigned int
8] 34 unsigned int
[4] 55 Memory : 0xFEF14 unsigned int

Use this window to monitor the values of C-SPY expressions or variables. You can open
up to four instances of this window, where you can view, add, modify, and remove
expressions. Tree structures of arrays, structs, and unions are expandable, which means
that you can study each item of these.

Every time execution in C-SPY stops, the values in the Watch window are recalculated.
Values that have changed since the last stop are highlighted in red.

Be aware that expanding very huge arrays can cause an out-of-memory crash. To avoid
& this, expansion is automatically performed in steps of 5000 elements.

For more information about editing in C-SPY windows, see C-SPY Debugger main
window, page 48.

Requirements

None; this window is always available.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3

Save to File...

These commands are available:

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 92.
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Options
Displays the IDE Options dialog box where you can set the Update interval
option. The default value of this option is 1000 milliseconds, which means the
Live Watch window will be updated once every second during program
execution. Note that this command is only available from this context menu in
the Live Watch window.

Save to File

Saves content to a file in a tab-separated format.

Live Watch window
The Live Watch window is available from the View menu.

Live Watch =

Expression | Yalue Location Type
Bl GetFib GetFib (0x218) unsigned int (..
L GetFib (0x218) Logical Code:0x0218 unsigned int {int)

Locals Live Watch | B

This window repeatedly samples and displays the value of expressions while your
application is executing. Variables in the expressions must be statically located, such as
global variables.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.
Requirements

Any supported hardware debugger system.

Display area
This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.
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This column is editable.

Location
The location in memory where this variable is stored.

Type
The data type of the variable.

Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3

Save to File...

These commands are available:

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.
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Show As
Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 92.

Options
Displays the IDE Options dialog box where you can set the Update interval
option. The default value of this option is 1000 milliseconds, which means the
Live Watch window will be updated once every second during program
execution. Note that this command is only available from this context menu in
the Live Watch window.

Save to File

Saves content to a file in a tab-separated format.

Statics window

The Statics window is available from the View menu.

Statics @
“ariable Walue Location Type todule i
= f<CppTutoryf> <class:> 0=00000000  class stdictype<chary CppTutar
; <struct> 0=00000000  stuct std:ctype_base
L vptr 0=20000490 0=00000000 woid (* const™)()

# f <CppTutoryf> <class:> 0x200002F4  class std:numpunct<char> CppTutar
# f<CppTutoryf> <class:> 0=20000308  class stdinurm_put<char, stdio.. CppTutor
= msFib <Fibonacci\FibonaccizmsFib>  <array: 0=2000032C  unsigned long[100] Fibonacci
1 0=2000032C  unsigned long
1 0=20000330  unsigned long
2 0=20000334  unsigned long -

This window displays the values of variables with static storage duration that you have
selected. Typically, that is variables with file scope but it can also be static variables in
functions and classes. Note that volatile declared variables with static storage
duration will not be displayed.

Every time execution in C-SPY stops, the values in the Statics window are recalculated.
Values that have changed since the last stop are highlighted in red.

Click any column header (except for Value) to sort on that column.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.
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Display area
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To select variables to monitor:

In the window, right-click and choose Select statics from the context menu. The
window now lists all variables with static storage duration.

Either individually select the variables you want to display, or choose one of the Select
commands from the context menu.

When you have made your selections, choose Select statics from the context menu to
toggle back to normal display mode.

None; this window is always available.

This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.

Location
The location in memory where this variable is stored.

Type
The data type of the variable.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...

v Select Statics
Select All
Select None
Select All in ‘Tutor'

Select None in ‘Tutor'

These commands are available:

Default Format,
Binary Format,

Octal Format,
Decimal Format,
Hexadecimal Format,
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Save to File
Saves the content of the Statics window to a log file.
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Select Statics
Selects all variables with static storage duration; this command also enables all
Select commands below. Select the variables you want to monitor. When you
have made your selections, select this menu command again to toggle back to
normal display mode.

Select All
Selects all variables.

Select None
Deselects all variables.

Select All in module
Selects all variables in the selected module.

Select None in module

Deselects all variables in the selected module.

The Quick Watch window is available from the View menu and from the context menu
in the editor window.

Quick Watch =]

-

Expression Yalue Location Type
TimerStatus() 'Timer disabled® macro string

Use this window to watch the value of a variable or expression and evaluate expressions
at a specific point in time.

In contrast to the Watch window, the Quick Watch window gives you precise control
over when to evaluate the expression. For single variables this might not be necessary,
but for expressions with possible side effects, such as assignments and C-SPY macro
functions, it allows you to perform evaluations under controlled conditions.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

To evaluate an expression:

In the editor window, right-click on the expression you want to examine and choose
Quick Watch from the context menu that appears.
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2 The expression will automatically appear in the Quick Watch window.
Alternatively:

3 In the Quick Watch window, type the expression you want to examine in the
Expressions text box.

g 4 Click the Recalculate button to calculate the value of the expression.
For an example, see Using C-SPY macros, page 255.

Requirements

None; this window is always available.

Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3

Save to File...

These commands are available:

Default Format,
Binary Format,
Octal Format,
Decimal Format,
Hexadecimal Format,
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.
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All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Structure fields

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 92.

Options
Displays the IDE Options dialog box where you can set the Update interval
option. The default value of this option is 1000 milliseconds, which means the
Live Watch window will be updated once every second during program
execution. Note that this command is only available from this context menu in
the Live Watch window.

Save to File
Saves content to a file in a tab-separated format.

The Symbols window is available from the View menu after you have enabled the
Symbols plugin module.

Symbal | Location | Full Mame |"
call_count 0x00102228 call_count
do_foreground_process  0x000003C8  do_foreground_process()

exit 0x000005E4  exit

get_fib 0x0000028C  get_fib(int)

init_fibh 0x00000248  init_fib()

main 0x000003E2  mainf)

next_counter 0x000003BC  next_counter()

put_fib 0x000002B8  put_fib{unsigned int)

putchar 0x00000464 putchar

root 0x00102200 root v

This window displays all symbols with a static location, that is, C/C++ functions,
assembler labels, and variables with static storage duration, including symbols from the
runtime library.

To enable the Symbols plugin module, choose Project>Options>Debugger>Select
plugins to load>Symbols.
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Requirements

None; this window is always available.

Display area
This area contains these columns:

Symbol
The symbol name.

Location

The memory address.

Full name

The symbol name; often the same as the contents of the Symbol column but
differs for example for C++ member functions.

Click the column headers to sort the list by symbol name, location, or full name.

Context menu

This context menu is available:

Functions
Variables
Labels

These commands are available:

Functions
Toggles the display of function symbols on or off in the list.

Variables
Toggles the display of variables on or off in the list.

Labels
Toggles the display of labels on or off in the list.
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Resolve Symbol Ambiguity dialog box

The Resolve Symbol Ambiguity dialog box appears, for example, when you specify a
symbol in the Disassembly window to go to, and there are several instances of the same
symbol due to templates or function overloading.

Resolve Symbol Ambiguity

Ambiguous symbol: foo

Ok

foo[void]

fon<T: Camcel

Requirements

None; this window is always available.

Ambiguous symbol

Indicates which symbol that is ambiguous.

Please select one symbol

A list of possible matches for the ambiguous symbol. Select the one you want to use.

C-SPY® Debugging Guide
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Data Log window
The Data Log window is available from the C-SPY driver menu.

Time | Program Counter | 11 Address 52 Address &)
. lG6Es === W 0=0000 @ 0=2004
0.160us O=FFEOOD49 = @ 0=x2000
24 .480us O0=FFEOOOBS R 0=0000 @ 0=2006
24 .720us O0=FFEOOOBF W O0=0042 @ 0=2004
24 .760us O=FFEOOOCE R 0O=0042 @ 0=2006
24 .960us O=FFEOODOE4 W O=00004444 @ 0=2000 y
FE FEfGes O=FFE00104 R 0O=0042 @ O=2004+7
79.000us — W O0=0084 @ 0=2004
100.800us O=FFEOO104 R 0=0084 @ 0=2006
101.040us O=FFEOO10E /// W 0=00CA @ 0=2004
JFE Edfus Overflow 2
136.880us 0OxFFEOOL0E~ = @ 0=2004 a3
White rows indicate Grey rows indicate

read accesses write accesses

Use this window to log accesses to up to four different memory locations or areas.

See also Getting started using data logging, page 93.

Requirements
The C-SPY simulator.

Display area
Each row in the display area shows the time, the program counter, and, for every tracked
data object, its value and address in these columns:

Time
If the time is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.
This column is available when you have selected Show time from the context
menu.

Cycles

The number of cycles from the start of the execution until the event. This
information is cleared at reset.

If a cycle is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.
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This column is available when you have selected Show cycles from the context
menu.

Program Counter*

Value

Displays one of these:

An address, which is the content of the PC, that is, the address of the instruction
that performed the memory access.

---, the target system failed to provide the debugger with any information.

Overflow in red, the communication channel failed to transmit all data from the
target system.

Displays the access type and the value (using the access size) for the location or
area you want to log accesses to. For example, if zero is read using a byte access
it will be displayed as 0x00, and for a long access it will be displayed as
0x00000000.

To specify what data you want to log accesses to, use the Data Log breakpoint
dialog box. See Data Log breakpoints, page 125.

Address

The actual memory address that is accessed. For example, if only a byte of a
word is accessed, only the address of the byte is displayed. The address is
calculated as base address + offset, where the base address is retrieved from the
Data Log breakpoint dialog box and the offset is retrieved from the logs. If the
log from the target system does not provide the debugger with an offset, the
offset contains + ?.

* You can double-click a line in the display area. If the value of the pc for that line is
available in the source code, the editor window displays the corresponding source code
(this does not include library source code).

Identical to the context menu of the Interrupt Log window, see Interrupt Log window,
page 247.
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Data Log Summary window

The Data Log Summary window is available from the C-SPY driver menu.

Data
tVarl
tVar2
tvar3

Data Log Summary

Requirements

Display area

Total Accesses Read Accesses Write Accesses Unknown Accesses
42 8 25 17

66 17 49 8

32 32 2] 2]

Approximative time count: 16
Overflow count: 8
Current time: 4301.52 us

This window displays a summary of data accesses to specific memory location or areas.

See also Getting started using data logging, page 93.

The C-SPY simulator.

Each row in this area displays the type and the number of accesses to each memory
location or area in these columns; and summary information is listed at the bottom of
the display area:
Data
The name of the data object you have selected to log accesses to. To specify
what data object you want to log accesses to, use the Data Log breakpoint
dialog box. See Data Log breakpoints, page 125.
Total Accesses
The number of total accesses.
If the sum of read accesses and write accesses is less than the total accesses,
there have been a number of access logs for which the target system for some
reason did not provide valid access type information.
Read Accesses

The number of total read accesses.

Write Accesses
The number of total write accesses.
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Unknown Accesses

The number of unknown accesses, in other words, accesses where the access
type is not known.

Approximative time count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time|cycles

The information displayed depends on the C-SPY driver you are using.
For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

Identical to the context menu of the Interrupt Log window, see Interrupt Log window,
page 247.
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Data Sample Setup window

The Data Sample Setup window is available from the C-SPY driver menu.

Data Sample Setup @
Expression Address Size Sampling interval [ms]
¥ myVarl OxFFFFBO2A 1 18
v myVar2 OxFFFFBO04 4 48
cl OxFFFFBO2B 1 1680

Use this window to specify up to four variables to sample data for. You can view the
sampled data for the variables either in the Data Sample window or as graphs in the
Sampled Graphs window.

See also Getting started using data sampling, page 93.

Requirements

Any supported hardware debugger system.

Display area
This area contains these columns:

Expression

Type the name of the variable which must be an integral type with a maximum
size of 32 bits. Click the check box to enable or disable data sampling for the
variable.

Alternatively, drag an expression from the editor window and drop it in the
display area.

Variables in the expressions must be statically located, for example global
variables.
Address
The actual memory address that is accessed. The column cells cannot be edited.
Size
The size of the variable, either 1, 2, or 4 bytes. The column cells cannot be
edited.
Sampling interval [ms]

Type the number of milliseconds to pass between the samples. The shortest
allowed interval is 10 ms and the interval you specify must be a multiple of that.
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Note that the sampling time you specify is just the interval (according to the
Microsoft Windows calculations) for how often C-SPY checks with the C-SPY
driver (which in turn must check with the MCU for a value). If this takes longer
than the sampling interval you have specified, the next sampling will be omitted.
If this occurs, you might want to consider increasing the sampling time.

This context menu is available:

Rermove

Rermove All

These commands are available:

Remove
Removes the selected variable.

Remove All
Removes all variables.

The Data Sample window is available from the C-SPY driver menu.

Data Sample

Sampling Time myVarl myVar2
1168 ms R @xee R ©x80ee0eEs
1178 ms R exle
1178 ms Stop
1188 ms R exle R @xeeeeeeDs
1198 ms R @x28
1208 ms R exle
1218 ms R ex1e R @xeeeeeeBs
1228 ms R @xee

Use this window to view the result of the data sampling for the variables you have

selected in the Data Sample Setup window.
Choose Enable from the context menu to enable data sampling.

See also Getting started using data sampling, page 93.

Any supported hardware debugger system.
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Display area
This area contains these columns:
Sampling Time
The time when the data sample was collected. Time starts at zero after a reset.
Every time the execution stops, a red Stop indicates when the stop occurred.

The selected expression

The column headers display the names of the variables that you selected in the
Data Sample Setup window. The column cells display the sampling values for
the variable.

There can be up to four columns of this type, one for each selected variable.

* You can double-click a row in the display area. If you have enabled the data sample
graph in the Sampled Graphs window, the selection line will be moved to reflect the
time of the row you double-clicked.

Context menu

This context menu is available:
v Enable

Clear

Hexadecimal (for myVarl)
v | Hexadecimal (for myVar2)

Save to Log File...

Open Setup Window

These commands are available:
Enable

Enables data sampling.

Clear
Clears the sampled data.

Hexadecimal (for var)

Toggles between displaying the values of selected variable in decimal or
hexadecimal format. The display format affects the Data Sample window and
the Sampled Graphs window.

Save to Log File
Displays a standard save dialog box.

Open setup window
Opens the Data Sample Setup window.
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herizental graph

&

The Sampled Graphs window is available from the C-SPY driver menu.

Sampled Graphs @

N

l

1288ms 1488ms 1608ms 1886ms 2008ms 2208ms

4 L 2

Use this window to display graphs for up to four different variables, and where:

The graph displays how the value of the variable changes over time. The area on the
left displays the limits, or range, of the Y-axis for the variable. You can use the
context menu to change these limits. The graph is a graphical representation of the
information in the Data Sample window, see Data Sample window, page 116.

The graph can be displayed as levels, where a horizontal line—optionally
color-filled—shows the value until the next sample. Alternatively, the graph can be
linear, where a line connects consecutive samples.

A red vertical line indicates the time of application execution stops.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.

To navigate in the graph, use any of these alternatives:

Right-click and choose Zoom In or Zoom Out from the context menu.
Alternatively, use the + and - keys to zoom.

Right-click in the graph and choose Navigate and the appropriate command to
move backward and forward on the graph. Alternatively, use any of the shortcut
keys: arrow keys, Home, End, and Ctrl+End.

Double-click on a sample to highlight the corresponding source code in the editor

window and in the Disassembly window.

Click on the graph and drag to select a time interval. Press Enter or right-click and
choose Zoom>Zoom to Selection from the context menu. The selection zooms in.

Hover with the mouse pointer in the graph to get detailed tooltip information for that
location.



See also Getting started using data sampling, page 93.

Requirements

Any supported hardware debugger system.

Context menu

This context menu is available:

<

MNavigate 3
Auto Scroll

Zoom 3

Data Sample
Enable
Clear
myVar2:

Viewing Range...

Size 3
Style 3
Solid Graph

Show Mumerical Values

Hexadecimal

Select Graphs 3

These commands are available:

Navigate

Variables and expressions __¢

Commands for navigating in the graphs. Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:

right arrow.

Previous moves the selection to the previous relevant point in the graph.

Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:

Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words

the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll

Toggles auto scrolling on or off. When on, the most recently collected data is
automatically displayed if you have executed the command Navigate>End.

19
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Zoom
Commands for zooming the window, in other words, changing the time scale.
Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +.
Zoom Out zooms out on the time scale. Shortcut key: -.

1us, 10us, 100us makes an interval of 1 microseconds, 10 microseconds, or 100
microseconds, respectively, fit the window.

1ms, 10ms, 100ms makes an interval of 1 millisecond, 10 milliseconds, or 100
milliseconds, respectively, fit the window.

1s, 10s, 100s makes an interval of 1 second, 10 seconds, or 100 seconds,
respectively, fit the window.

1k s, 10k s, 100k s makes an interval of 1,000 seconds, 10,000 seconds, or
100,000 seconds, respectively, fit the window.

1M s, 10M s, makes an interval of 1,000,000 seconds or 10,000,000 seconds,
respectively, fit the window.

Data Sample
A menu item that shows that the Data Sample-specific commands below are
available.

Open Setup window (Data Sample Graph)
Opens the Data Sample Setup window.

Enable
Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the Data Sample window. If no data has been sampled
for a graph, no data will appear instead of the graph.

Clear
Clears the sampled data.

Variable
The name of the variable for which the Data Sample-specific commands below
apply. This menu item is context-sensitive, which means it reflects the Data
Sample graph you selected in the Sampled Graphs window (one of up to four).
Viewing Range
Displays a dialog box, see Viewing Range dialog box, page 207.
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Size
Controls the vertical size of the graph; choose between Small, Medium, and
Large.

Style
Choose how to display the graph. Choose between:
Levels, where a horizontal line—optionally color-filled—shows the value until
the next sample.
Linear, where a line connects consecutive samples.

Solid Graph

Displays the graph as a color-filled solid graph instead of as a thin line. This is
only possible if the graph is displayed as Levels.
Hexadecimal (for var)

Toggles between displaying the selected variable in decimal or hexadecimal
format. The display format affects the Data Sample window and the Sampled
Graphs window.

Show Numerical Value
Shows the numerical value of the variable, in addition to the graph.

Select Graphs
Selects which graphs to display in the Sampled Graphs window.
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e Introduction to setting and using breakpoints
e Setting breakpoints

e Reference information on breakpoints

Introduction to setting and using breakpoints

These topics are covered:

Reasons for using breakpoints

Briefly about setting breakpoints

Breakpoint types

Breakpoint icons

Breakpoints in the C-SPY simulator

Breakpoints in the C-SPY hardware debugger drivers

Breakpoint consumers

REASONS FOR USING BREAKPOINTS

C-SPY® lets you set various types of breakpoints in the application you are debugging,
allowing you to stop at locations of particular interest. You can set a breakpoint at a code
location to investigate whether your program logic is correct, or to get trace printouts.
In addition to code breakpoints, and depending on what C-SPY driver you are using,
additional breakpoint types might be available. For example, you might be able to set a
data breakpoint, to investigate how and when the data changes.

You can let the execution stop under certain conditions, which you specify. You can also
let the breakpoint trigger a side effect, for instance executing a C-SPY macro function,
by transparently stopping the execution and then resuming. The macro function can be
defined to perform a wide variety of actions, for instance, simulating hardware behavior.

All these possibilities provide you with a flexible tool for investigating the status of your
application.

BRIEFLY ABOUT SETTING BREAKPOINTS

You can set breakpoints in many various ways, allowing for different levels of
interaction, precision, timing, and automation. All the breakpoints you define will
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appear in the Breakpoints window. From this window you can conveniently view all
breakpoints, enable and disable breakpoints, and open a dialog box for defining new
breakpoints. The Breakpoint Usage window also lists all internally used breakpoints,
see Breakpoint consumers, page 127.

Breakpoints are set with a higher precision than single lines, using the same mechanism
as when stepping; for more information about the precision, see Single stepping, page
70.

You can set breakpoints while you edit your code even if no debug session is active. The
breakpoints will then be validated when the debug session starts. Breakpoints are
preserved between debug sessions.

Note: For most hardware debugger systems it is only possible to set breakpoints when
the application is not executing.

BREAKPOINT TYPES

Depending on the C-SPY driver you are using, C-SPY supports different types of
breakpoints.

Code breakpoints

Code breakpoints are used for code locations to investigate whether your program logic
is correct or to get trace printouts. Code breakpoints are triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will stop, before the
instruction is executed.

Log breakpoints

Log breakpoints provide a convenient way to add trace printouts without having to add
any code to your application source code. Log breakpoints are triggered when an
instruction is fetched from the specified location. If you have set the breakpoint on a
specific machine instruction, the breakpoint will be triggered and the execution will
temporarily stop and print the specified message in the C-SPY Debug Log window.

Trace Start and Stop breakpoints

Trace Start and Stop breakpoints start and stop trace data collection—a convenient way
to analyze instructions between two execution points.

Data breakpoints

Data breakpoints are primarily useful for variables that have a fixed address in memory.
If you set a breakpoint on an accessible local variable, the breakpoint is set on the
corresponding memory location. The validity of this location is only guaranteed for

C-SPY® Debugging Guide
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small parts of the code. Data breakpoints are triggered when data is accessed at the
specified location. The execution will usually stop directly after the instruction that
accessed the data has been executed.

Data Log breakpoints

Data log breakpoints are triggered when a specified memory address is accessed. A log
entry is written in the Data Log window for each access. Data logs can also be displayed
on the Data Log graph in the Timeline window, if that window is enabled.

You can set data log breakpoints using the Breakpoints window, the Memory window,
and the editor window.

Using a single instruction, the microcontroller can only access values that are four bytes
or less. If you specify a data log breakpoint on a memory location that cannot be
accessed by one instruction, for example a double or a too large area in the Memory
window, the result might not be what you intended.

Immediate breakpoints

The C-SPY Simulator lets you set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
simulated processor is about to read data from a location or immediately after it has
written data. Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the simulated processor reads from a
memory-mapped location, a C-SPY macro function can intervene and supply
appropriate data. Conversely, when the simulated processor writes to a memory-mapped
location, a C-SPY macro function can act on the value that was written.

Event breakpoints

The C-SPY hardware debugger drivers let you set event breakpoints, which have an
event as condition. The events are defined in the Edit Events dialog box.

Code hardware breakpoints

The C-SPY hardware debugger drivers that support Before fetch events let you set code
hardware breakpoints. This breakpoint type is implemented as an event fetch
breakpoint. For information about Before fetch, see Edit Events dialog box, page 341.

Code hardware breakpoints are triggered when an instruction is fetched from the
specified location. If you have set the breakpoint on a specific machine instruction, the
breakpoint will be triggered and the execution will stop, before the instruction is
executed.
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BREAKPOINT ICONS

A breakpoint is marked with an icon in the left margin of the editor window, and the icon
varies with the type of breakpoint:

Tutor.c m |

unsigned int get_fib({ int nr |

{
| RECinr > ) s (nr <= MAX FIB) |
{
keturn { rooclnr- ] 7
}

I Code breakpoint l

I Log breakpoint l .

I Tooltip information l o {Log@UtiIities.c:S?.S

Memory:0x6a [Fetch ] ‘
‘O return | 0 );:

Disabled code

breakpeint b

If the breakpoint icon does not appear, make sure the option Show bookmarks is
selected, see Editor options in the IDE Project Management and Building Guide.

Just point at the breakpoint icon with the mouse pointer to get detailed tooltip
information about all breakpoints set on the same location. The first row gives user
breakpoint information, the following rows describe the physical breakpoints used for
implementing the user breakpoint. The latter information can also be seen in the
Breakpoint Usage window.

Note: The breakpoint icons might look difterent for the C-SPY driver you are using.

BREAKPOINTS IN THE C-SPY SIMULATOR

The C-SPY simulator supports all breakpoint types and you can set an unlimited amount
of breakpoints.

BREAKPOINTS IN THE C-SPY HARDWARE DEBUGGER
DRIVERS

Using the C-SPY drivers for hardware debugger systems you can set various breakpoint
types. The amount of breakpoints you can set depends on the number of hardware
breakpoints available on the target system or whether you have enabled sofiware
breakpoints, in which case the number of breakpoints you can set is unlimited. Note that
your application must be in RAM if you want to use software breakpoints.

When software breakpoints are enabled, the debugger will first use any available
hardware breakpoints before using software breakpoints. Unless software breakpoints
are enabled and can be used, exceeding the number of available hardware breakpoints
causes the debugger to single step. This will significantly reduce the execution speed.
For this reason you must be aware of the different breakpoint consumers.
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For information about the characteristics of breakpoints for the various target systems,
see the manufacturer’s emulator specification.

In the EI/MINICUBE/TK-V850 drivers

Because the E1, MINICUBE, MINICUBE?2, and the TK-V850 Debugger only have 4
(or 2) breakpoints available for ROM, it is important that you do not have more enabled
breakpoints than you need. Single-stepping functions requires at least one breakpoint
and will be very slow when all breakpoints are already in use. A message in the Log
window informs you of when the debugger has run out of breakpoints.

Instead of using the last breakpoint(s), you can define an event as an OP-fetch
breakpoint. This makes the last breakpoint(s) available for the debugger. C-SPY also
uses breakpoints internally for terminal I/O and the __exi t function. If you deselect the
linker option With runtime control modules and add your own customized copy of
cstartup.s85, where the __exit function has been removed, these breakpoints will
become available to your application.

BREAKPOINT CONSUMERS

A debugger system includes several consumers of breakpoints.

User breakpoints

The breakpoints you define in the breakpoint dialog box or by toggling breakpoints in
the editor window often consume one physical breakpoint each, but this can vary greatly.
Some user breakpoints consume several physical breakpoints and conversely, several
user breakpoints can share one physical breakpoint. User breakpoints are displayed in
the same way both in the Breakpoint Usage window and in the Breakpoints window,
for example Data @[R] callCount.

C-SPY itself
C-SPY itself also consumes breakpoints. C-SPY will set a breakpoint if:

o The debugger option Run to has been selected, and any step command is used.
These are temporary breakpoints which are only set during a debug session. This
means that they are not visible in the Breakpoints window.

e The linker option With I/0 emulation modules has been selected.
In the DLIB runtime environment, C-SPY will set a system breakpoint on the
__DebugBreak label.

These types of breakpoint consumers are displayed in the Breakpoint Usage window,
for example, C-SPY Terminal I/O & libsupport module.
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Normally when you set a breakpoint, C-SPY sets two breakpoints for internal use. To
do this, the software breakpoints in the emulator are used. The fact that C-SPY uses
software breakpoints is normally not a problem.

C-SPY plugin modules

For example, modules for real-time operating systems can consume additional
breakpoints. Specifically, by default, the Stack window consumes one physical
breakpoint.

To disable the breakpoint used by the Stack window:
Choose Tools>Options>Stack.
Deselect the Stack pointer(s) not valid until program reaches: /abel option.

To disable the Stack window entirely, choose Tools>Options>Stack and make sure all
options are deselected.

Setting breakpoints

C-SPY® Debugging Guide
for V850

These tasks are covered:

Various ways to set a breakpoint

Toggling a simple code breakpoint

Setting breakpoints using the dialog box

Setting a data breakpoint in the Memory window

Setting breakpoints using system macros

Useful breakpoint hints.

VARIOUS WAYS TO SET A BREAKPOINT
You can set a breakpoint in various ways:

o Toggling a simple code breakpoint.

o Using the New Breakpoints dialog box and the Edit Breakpoints dialog box
available from the context menus in the editor window, Breakpoints window, and
in the Disassembly window. The dialog boxes give you access to all breakpoint
options.

e Setting a data breakpoint on a memory area directly in the Memory window.

o Using predefined system macros for setting breakpoints, which allows automation.

The different methods offer different levels of simplicity, complexity, and automation.
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TOGGLING A SIMPLE CODE BREAKPOINT

Toggling a code breakpoint is a quick method of setting a breakpoint. The following
methods are available both in the editor window and in the Disassembly window:

e Click in the gray left-side margin of the window

o Place the insertion point in the C source statement or assembler instruction where
you want the breakpoint, and click the Toggle Breakpoint button in the toolbar

o Choose Edit>Toggle Breakpoint

e Right-click and choose Toggle Breakpoint from the context menu.

SETTING BREAKPOINTS USING THE DIALOG BOX

The advantage of using a breakpoint dialog box is that it provides you with a graphical
interface where you can interactively fine-tune the characteristics of the breakpoints.
You can set the options and quickly test whether the breakpoint works according to your
intentions.

All breakpoints you define using a breakpoint dialog box are preserved between debug
sessions.

You can open the dialog box from the context menu available in the editor window,
Breakpoints window, and in the Disassembly window.

To set a new breakpoint:
Choose View>Breakpoints to open the Breakpoints window.

In the Breakpoints window, right-click, and choose New Breakpoint from the context
menu.

On the submenu, choose the breakpoint type you want to set.
Depending on the C-SPY driver you are using, different breakpoint types are available.
In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.
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To modify an existing breakpoint:

In the Breakpoints window, editor window, or in the Disassembly window, select the
breakpoint you want to modify and right-click to open the context menu.

35woid init fib( woid )
36 1
37 imt 1 = 45;
38  root[0] = root[l] = 1:

: 39

S 40 for | 1287 i<MAY FIB ; i++)
LA
L J az —

LAz )
a4
45
ol Complete
47 fnrt
48 4/ Match Brackets
49 unsi Insert Template 3
B Open HeaderfSource File
51 ii 1B |
52 Go ko definition of rook
& Toggle Breakpoint {Code)
54 ) i
55 el Toggle Breakpoint {Log)
56 | Enable/disable Ereakpaint
57 Set Data Breakpoint For 'root[i]'
53 ) Edit Code Breakpoint at column 15
:3 1 cek Next Statement Edit Log Breakpoint at column 7

If there are several breakpoints on the same source code line, the breakpoints will be
listed on a submenu.

On the context menu, choose the appropriate command.
In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.

SETTING A DATA BREAKPOINT IN THE MEMORY WINDOW

You can set breakpoints directly on a memory location in the Memory window.
Right-click in the window and choose the breakpoint command from the context menu
that appears. To set the breakpoint on a range, select a portion of the memory contents.

The breakpoint is not highlighted in the Memory window; instead, you can see, edit,
and remove it using the Breakpoints window, which is available from the View menu.
The breakpoints you set in the Memory window will be triggered for both read and
write accesses. All breakpoints defined in this window are preserved between debug
sessions.
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Note: Setting breakpoints directly in the Memory window is only possible if the driver
you use supports this.

SETTING BREAKPOINTS USING SYSTEM MACROS

You can set breakpoints not only in the breakpoint dialog box but also by using built-in
C-SPY system macros. When you use system macros for setting breakpoints, the
breakpoint characteristics are specified as macro parameters.

Macros are useful when you have already specified your breakpoints so that they fully
meet your requirements. You can define your breakpoints in a macro file, using built-in
system macros, and execute the file at C-SPY startup. The breakpoints will then be set
automatically each time you start C-SPY. Another advantage is that the debug session
will be documented, and that several engineers involved in the development project can
share the macro files.

Note: If you use system macros for setting breakpoints, you can still view and modify
them in the Breakpoints window. In contrast to using the dialog box for defining
breakpoints, all breakpoints that are defined using system macros are removed when you
exit the debug session.

These breakpoint macros are available:

El N-Wire EI Nexus
El Serial IECUBE2

C-SPY macro for breakpoints Simulator IECUBE TK-V850
MINICUBE MINICUBE

MINICUBE2 for V850E2x

__setCodeBreak Yes Yes Yes Yes Yes
__setDataBreak Yes No No No No
__setLogBreak Yes No No No No
__setDatal.ogBreak Yes No No No No
__setSimBreak Yes No No No No
__setTraceStartBreak Yes No No No No
__setTraceStopBreak Yes No No No No
__clearBreak Yes Yes Yes Yes Yes

Table 8: C-SPY macros for breakpoints

For information about each breakpoint macro, see Reference information on C-SPY
system macros, page 267.

Setting breakpoints at C-SPY startup using a setup macro file

You can use a setup macro file to define breakpoints at C-SPY startup. Follow the
procedure described in Using C-SPY macros, page 255.
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USEFUL BREAKPOINT HINTS

Below are some useful hints related to setting breakpoints.

@ Tracing incorrect function arguments

If a function with a pointer argument is sometimes incorrectly called with a NULL
argument, you might want to debug that behavior. These methods can be useful:

e Set a breakpoint on the first line of the function with a condition that is true only
when the parameter is 0. The breakpoint will then not be triggered until the
problematic situation actually occurs. The advantage of this method is that no extra
source code is needed. The drawback is that the execution speed might become
unacceptably low.

® You can use the assert macro in your problematic function, for example:

int MyFunction (int * MyPtr)
{

assert (MyPtr != 0); /* Assert macro added to your source

code. */

/* Here comes the rest of your function. */
}
The execution will break whenever the condition is true. The advantage is that the
execution speed is only very slightly affected, but the drawback is that you will get a
small extra footprint in your source code. In addition, the only way to get rid of the
execution stop is to remove the macro and rebuild your source code.

e Instead of using the assert macro, you can modify your function like this:

int MyFunction (int * MyPtr)
{

if (MyPtr == 0)

MyDummyStatement; /* Dummy statement where you set a
breakpoint. */

/* Here comes the rest of your function. */
}
You must also set a breakpoint on the extra dummy statement, so that the execution
will break whenever the condition is true. The advantage is that the execution speed
is only very slightly affected, but the drawback is that you will still get a small extra
footprint in your source code. However, in this way you can get rid of the execution
stop by just removing the breakpoint.

@ Performing a task and continuing execution

You can perform a task when a breakpoint is triggered and then automatically continue
execution.

C-SPY® Debugging Guide
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You can use the Action text box to associate an action with the breakpoint, for instance
a C-SPY macro function. When the breakpoint is triggered and the execution of your
application has stopped, the macro function will be executed. In this case, the execution
will not continue automatically.

Instead, you can set a condition which returns 0 (false). When the breakpoint is
triggered, the condition—which can be a call to a C-SPY macro that performs a task—
is evaluated and because it is not true, execution continues.

Consider this example where the C-SPY macro function performs a simple task:

__var my_counter;

count ()

{
my_counter += 1;
return 0;

}

To use this function as a condition for the breakpoint, type count () in the Expression
text box under Conditions. The task will then be performed when the breakpoint is
triggered. Because the macro function count returns 0, the condition is false and the
execution of the program will resume automatically, without any stop.

Reference information on breakpoints

Reference information about:

Breakpoints window, page 134

Breakpoint Usage window, page 136

Code breakpoints dialog box, page 137

Log breakpoints dialog box, page 138

Data breakpoints dialog box, page 140

Data Log breakpoints dialog box, page 142
Immediate breakpoints dialog box, page 143
Code hardware breakpoints dialog box, page 144
Event breakpoints dialog box, page 145

Enter Location dialog box, page 146

Resolve Source Ambiguity dialog box, page 147.
See also:

® Reference information on C-SPY system macros, page 267
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Breakpoints window

Requirements

Display area

Context menu
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® Reference information on trace, page 190.

The Breakpoints window is available from the View menu.

Code @ Tutar.c:46.2

This window lists all breakpoints you define.

Use this window to conveniently monitor, enable, and disable breakpoints; you can also
define new breakpoints and modify existing breakpoints.

None; this window is always available.

This area lists all breakpoints you define. For each breakpoint, information about the
breakpoint type, source file, source line, and source column is provided.

This context menu is available:
G0 ko Source
Edit...

Delete
Disable
Enable Al
Disable Al

Mew Breakpoint ¥
These commands are available:

Go to Source
Moves the insertion point to the location of the breakpoint, if the breakpoint has
a source location. Double-click a breakpoint in the Breakpoints window to
perform the same command.
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Edit
Opens the breakpoint dialog box for the breakpoint you selected.
Delete
Deletes the breakpoint. Press the Delete key to perform the same command.

Enable
Enables the breakpoint. The check box at the beginning of the line will be
selected. You can also perform the command by manually selecting the check
box. This command is only available if the breakpoint is disabled.
Disable
Disables the breakpoint. The check box at the beginning of the line will be
deselected. You can also perform this command by manually deselecting the
check box. This command is only available if the breakpoint is enabled.
Enable All
Enables all defined breakpoints.

Disable All
Disables all defined breakpoints.

New Breakpoint

Displays a submenu where you can open the breakpoint dialog box for the
available breakpoint types. All breakpoints you define using this dialog box are
preserved between debug sessions.
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Breakpoint Usage window

Requirements

Display area
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The Breakpoint Usage window is available from the menu specific to the C-SPY driver
you are using.

Breakpoint Usage [ %]

[Fetch
-SSP Terminal 140 & libsupport module

This window lists all breakpoints currently set in the target system, both the ones you
have defined and the ones used internally by C-SPY. The format of the items in this
window depends on the C-SPY driver you are using.

The window gives a low-level view of all breakpoints, related but not identical to the list
of breakpoints displayed in the Breakpoints window.

C-SPY uses breakpoints when stepping. If your target system has a limited number of
hardware breakpoints and software breakpoints are not enabled, exceeding the number
of available hardware breakpoints will cause the debugger to single step. This will
significantly reduce the execution speed. Therefore, in a debugger system with a limited
amount of hardware breakpoints, you can use the Breakpoint Usage window for:

o Identifying all breakpoint consumers

o Checking that the number of active breakpoints is supported by the target system

o Configuring the debugger to use the available breakpoints in a better way, if
possible.

For more information, see Breakpoints in the C-SPY hardware debugger drivers, page
126.

None; this window is always available.

For each breakpoint in the list, the address and access type are displayed. Each
breakpoint in the list can also be expanded to show its originator.
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Code breakpoints dialog box

The Code breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.

& Code
Break &f:
| Edit...l
— Size
&+ Auta I_I—
 Marual
— Action
Expression: I
Condition:
Expression:
' Condition true Skip count; I il
" Condition changed

This figure reflects the C-SPY simulator.

Use the Code breakpoints dialog box to set a code breakpoint.

Requirements

None; this dialog box is always available.

Break At
Specify the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 146.
Size
Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:
Auto
The size will be set automatically, typically to 1.
Manual
Specity the size of the breakpoint range in the text box.
Action

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 132.
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Conditions
Specify simple or complex conditions:
Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 88.
Condition true
The breakpoint is triggered if the value of the expression is true.
Condition changed
The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.

Log breakpoints dialog box

The Log breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.
8 1o
Break At

C:htutorsTutor.c.47.3

Meszage: C-Spy macro "'__message' style
"depth ="', call_count

Conditions
Expression:

(%) Condition true
(O Condition changed

This figure reflects the C-SPY simulator.
Use the Log breakpoints dialog box to set a log breakpoint.

Requirements

None; this dialog box is always available.

C-SPY® Debugging Guide
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Trigger at

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 146.

Message

Specify the message you want to be displayed in the C-SPY Debug Log window. The
message can either be plain text, or—if you also select the option C-SPY macro
""__message' style—a comma-separated list of arguments.

C-SPY macro "__message" style

Select this option to make a comma-separated list of arguments specified in the Message
text box be treated exactly as the arguments to the C-SPY macro language statement
__message, see Formatted output, page 263.

Conditions

Specify simple or complex conditions:

Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 88.

Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed

The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.
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Data breakpoints dialog box

Requirements

Break At

Access Type
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The Data breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.
’ [rata |
Break &f:

| [

5

—Access Type

& Feadfwiite & buto |1—
 Read  Manual
7 wirite - Action
Expression: I
r— Condition:
Expression:

% Condition true Skip count; I 0

" Condition changed

This figure reflects the C-SPY simulator.

Use the Data breakpoints dialog box to set a data breakpoint. Data breakpoints never
stop execution within a single instruction. They are recorded and reported after the
instruction is executed.

The C-SPY simulator.

Specify the data location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 146.

Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read

Reads from location.

Write
Writes to location.



Size

Action

Conditions

Breakpoints °

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:

Auto
The size will automatically be based on the type of expression the breakpoint is
set on. For example, if you set the breakpoint on a 12-byte structure, the size of
the breakpoint will be 12 bytes.

Manual

Specify the size of the breakpoint range in the text box.

For data breakpoints, this can be useful if you want the breakpoint to be triggered on
accesses to data structures, such as arrays, structs, and unions.

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 132.

Specify simple or complex conditions:

Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 88.

Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed
The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.
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Data Log breakpoints dialog box

Requirements

Break At

Access Type
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The Data Log breakpoints dialog box is available from the context menu in the
Breakpoints window.

Data Log

Break at:
myVar

Access Type
~) Readfwrite
' Read

This figure reflects the C-SPY simulator.

Use the Data Log breakpoints dialog box to set a maximum of four data log breakpoints
on memory addresses.

See also Data Log breakpoints, page 125 and Getting started using data logging, page
93.

The C-SPY simulator.

Specify a memory location as a variable (with static storage duration) or as an address.

Selects the type of access to the variable that generates a log entry:
Read/Write

Read and write accesses from or writes to location of the variable.
Read

Read accesses from the location of the variable.

Write

Write accesses to location of the variable.
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Immediate breakpoints dialog box

The Immediate breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

Immediate

Trigger at:
Edit...
Access Type Action
@ Read Expression:
) Write

In the C-SPY simulator, use the Immediate breakpoints dialog box to set an immediate
breakpoint. Immediate breakpoints do not stop execution at all; they only suspend it
temporarily.

Requirements
The C-SPY simulator.

Trigger at
Specify the data location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 146.
Access Type
Selects the type of memory access that triggers the breakpoint:
Read
Reads from location.
Write
Writes to location.
Action

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 132.
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Code hardware breakpoints dialog box

Requirements

Break At
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The Code Hardware breakpoints dialog box is available from the context menu in the
editor window, Breakpoints window, and in the Disassembly window.

New Breakpoint P§|

£ Code Hw ]

Break at:

| Edit..

(] 8 | Cancel |

Use this dialog box to set a code hardware breakpoint. Code hardware breakpoints are
triggered when an instruction is fetched from the specified location. If you have set the
breakpoint on a specific machine instruction, the breakpoint will be triggered and the
execution will stop, before the instruction is executed.

A hardware debugger driver that supports Before fetch events.

Specify the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 146.
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Event breakpoints dialog box

The Event breakpoint dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.
é Ewent |

Break at Event:
I Select Event - j

--- Select Event -

Selected event
’7|< nore>

Wiew Events... | Wiew Sequencer...l

Use this dialog box to specify an event as a breakpoint condition.

Requirements

Any supported hardware debugger system.

Break At Event

Specify the location of the breakpoint. Alternatively, click the Edit button to open the
Enter Location dialog box; see Enter Location dialog box, page 146. The selected
event is displayed in the Selected event field.

Buttons
These buttons are available:

View Events

Opens the Edit Events dialog box in view-only mode, see Edit Events dialog
box, page 341. Use this command to inspect an event.

View Sequencer

Opens the Edit Sequencer Events dialog box in view-only mode, see Edit
Sequencer Events dialog box, page 344. Use this command to inspect a
sequencer event.

Note: To define or modify an event, open these dialog boxes from the Emulator menu.
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Enter Location dialog box

The Enter Location dialog box is available from the breakpoints dialog box, either
when you set a new breakpoint or when you edit a breakpoint.

Enter Location E
Type————— Expression:

' Expression I
7 Absolute address

 Souree location

()3 I Cancel |

Use the Enter Location dialog box to specify the location of the breakpoint.

Note: This dialog box looks different depending on the Type you select.

Type
Selects the type of location to be used for the breakpoint, choose between:

Expression
A C-SPY expression, whose value evaluates to a valid code or data location.

A code location, for example the function main, is typically used for code
breakpoints.

A data location is the name of a variable and is typically used for data
breakpoints. For example, my_var refers to the location of the variable my_var,
and arr [3] refers to the location of the fourth element of the array arr. For
static variables declared with the same name in several functions, use the syntax
my_func: :my_static_variable to refer to a specific variable.

For more information about C-SPY expressions, see C-SPY expressions, page
88.

Absolute address
An absolute location on the form zone: hexaddress or simply hexaddress
(for example Memory: 0x42). zone refers to C-SPY memory zones and
specifies in which memory the address belongs, see C-SPY memory zones, page
150.

Source location
A location in your C source code using the syntax:
{filename} .row.column.

filename specifies the filename and full path.

row specifies the row in which you want the breakpoint.

C-SPY® Debugging Guide
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column specifies the column in which you want the breakpoint.

For example, {C:\src\prog.c}.22.3

sets a breakpoint on the third character position on row 22 in the source file
prog.c. Note that in quoted form, for example in a C-SPY macro, you must
instead write {C:\ \src\\prog.c}.22.3.

Note that the Source location type is usually meaningful only for code locations
in code breakpoints. Depending on the C-SPY driver you are using, Source
location might not be available for data and immediate breakpoints.

Resolve Source Ambiguity dialog box

All

Selected

The Resolve Source Ambiguity dialog box appears, for example, when you try to set a
breakpoint on templates and the source location corresponds to more than one function.

Resolve Source Ambiguity

The zource location coresponds to multiple functions.
‘which onefz] do you mean?

woid foo(T, T #|[with T=unsigned long] Al

woid foo(T, T #|[with T=double]

Cancel

™ Automatically choose all

If you check. this item, the dialog will not be shown again
unless you re-enable it in the Tools->Dptions dialog, on
the Debugger page.

To resolve a source ambiguity, perform one of these actions:

o In the text box, select one or several of the listed locations and click Selected.
e Click AllL

The breakpoint will be set on all listed locations.

The breakpoint will be set on the source locations that you have selected in the text box.
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Cancel

No location will be used.

Automatically choose all

Determines that whenever a specified source location corresponds to more than one
function, all locations will be used.

Note that this option can also be specified in the IDE Options dialog box, see Debugger
options in the IDE Project Management and Building Guide.

C-SPY® Debugging Guide
148  for V850



Memory and registers

e Introduction to monitoring memory and registers
e Monitoring memory and registers

e Reference information on memory and registers

Introduction to monitoring memory and registers

These topics are covered:

e Briefly about monitoring memory and registers
o C-SPY memory zones
e Stack display

o Memory access checking

BRIEFLY ABOUT MONITORING MEMORY AND REGISTERS

C-SPY provides many windows for monitoring memory and registers, each of them
available from the View menu:

o The Memory window

Gives an up-to-date display of a specified area of memory—a memory zone—and
allows you to edit it. Different colors are used for indicating data coverage along with
execution of your application. You can fill specified areas with specific values and
you can set breakpoints directly on a memory location or range. You can open several
instances of this window, to monitor different memory areas. The content of the
window can be regularly updated while your application is executing.

o The Symbolic Memory window

Displays how variables with static storage duration are laid out in memory. This can
be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example by buffer overruns.

o The Stack window

Displays the contents of the stack, including how stack variables are laid out in
memory. In addition, some integrity checks of the stack can be performed to detect
and warn about problems with stack overflow. For example, the Stack window is
useful for determining the optimal size of the stack. You can open up to two instances
of this window, each showing different stacks or different display modes of the same
stack.
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o The Register window

Gives an up-to-date display of the contents of the processor registers and SFRs, and
allows you to edit them. Because of the large amount of registers—memory-mapped
peripheral unit registers and CPU registers—it is inconvenient to show all registers
concurrently in the Register window. Instead you can divide registers into register
groups. You can choose to load either predefined register groups or define your own
application-specific groups. You can open several instances of this window, each
showing a different register group.

o The SFR Setup window

Displays the currently defined SFRs that C-SPY has information about. If required,
you can use this window to customize aspects of the SFRs.

To view the memory contents for a specific variable, simply drag the variable to the
Memory window or the Symbolic memory window. The memory area where the
variable is located will appear.

Reading the value of some registers might influence the runtime behavior of your
application. For example, reading the value of a UART status register might reset a
pending bit, which leads to the lack of an interrupt that would have processed a received
byte. To prevent this from happening, make sure that the Register window containing
any such registers is closed when debugging a running application.

C-SPY MEMORY ZONES

In C-SPY, the term zone is used for a named memory area. A memory address, or
location, is a combination of a zone and a numerical offset into that zone. The V850
architecture has only one zone, Memory, which covers the whole V850 memory range.
0x00000000

OxXFFFFFFFF

Default zone Memory

Memory zones are used in several contexts, most importantly in the Memeory and
Disassembly windows, and in C-SPY macros. In the windows, use the Zone box to
choose which memory zone to display.
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Device-specific zones

Memory information for device-specific zones is defined in the device description files.
When you load a device description file, additional zones that adhere to the specific
memory layout become available.

See the device description file for information about available memory zones.

If your hardware does not have the same memory layout as any of the predefined device
description files, you can define customized zones by adding them to the file.

For more information, see Selecting a device description file, page 41 and Modifying a
device description file, page 44.

STACK DISPLAY

The Stack window displays the contents of the stack, overflow warnings, and it has a
graphical stack bar. These can be useful in many contexts. Some examples are:

e Investigating the stack usage when assembler modules are called from C modules
and vice versa

Investigating whether the correct elements are located on the stack
Investigating whether the stack is restored properly

°
°
o Determining the optimal stack size
°

Detecting stack overflows.

For microcontrollers with multiple stacks, you can select which stack to view.

Stack usage

When your application is first loaded, and upon each reset, the memory for the stack area
is filled with the dedicated byte value 0xCD before the application starts executing.
Whenever execution stops, the stack memory is searched from the end of the stack until
a byte with a value different from 0xCD is found, which is assumed to be how far the
stack has been used. Although this is a reasonably reliable way to track stack usage,
there is no guarantee that a stack overflow is detected. For example, a stack can
incorrectly grow outside its bounds, and even modify memory outside the stack area,
without actually modifying any of the bytes near the stack range. Likewise, your
application might modify memory within the stack area by mistake.

The Stack window cannot detect a stack overflow when it happens, but can only detect
the signs it leaves behind. However, when the graphical stack bar is enabled, the
functionality needed to detect and warn about stack overflows is also enabled.

Note: The size and location of the stack is retrieved from the definition of the segment
holding the stack, made in the linker configuration file. If you, for some reason, modify
the stack initialization made in the system startup code, cstartup, you should also
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change the segment definition in the linker configuration file accordingly; otherwise the
Stack window cannot track the stack usage. For more information about this, see the /AR
C/C++ Compiler Reference Guide for V850.

MEMORY ACCESS CHECKING

The C-SPY simulator can simulate various memory access types of the target hardware
and detect illegal accesses, for example a read access to write-only memory. If a memory
access occurs that does not agree with the access type specified for the specific memory
area, C-SPY will regard this as an illegal access. Also, a memory access to memory
which is not defined is regarded as an illegal access. The purpose of memory access
checking is to help you to identify any memory access violations.

The memory areas can either be the zones predefined in the device description file, or
memory areas based on the segment information available in the debug file. In addition
to these, you can define your own memory areas. The access type can be read and write,
read-only, or write-only. You cannot map two different access types to the same memory
area. You can check for access type violation and accesses to unspecified ranges. Any
violations are logged in the Debug Log window. You can also choose to have the
execution halted.

Monitoring memory and registers

C-SPY® Debugging Guide
for V850

These tasks are covered:

o Defining application-specific register groups, page 153.
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DEFINING APPLICATION-SPECIFIC REGISTER GROUPS

Defining application-specific register groups minimizes the amount of registers
displayed in the Register window and speeds up the debugging.

Choose Tools>Options>Register Filter during a debug session.

IDE Dptions [ %]
Comrmon Fonts X §
¥ Use register filter Groups:
IMyFiIter.fIt Filter Files. .. | I VI

- CPU Reqisters

: Group members:

Register Filker
erminal IjO

QK | Cancel | Apply | Help |

For information about the register filter options, see the IDE Project Management and
Building Guide.

Select Use register filter and specify the filename and destination of the filter file for
your new group in the dialog box that appears.

Click New Group and specify the name of your group, for example My Timer Group.

New Group x|

IMy Timer Group

()8 I Cancel |

In the register tree view on the Register Filter page, select a register and click the
arrow button to add it to your group. Repeat this process for all registers that you want
to add to your group.

Optionally, select any registers for which you want to change the integer base, and
choose a suitable base.

When you are done, click OK. Your new group is now available in the Register
window.
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If you want to add more groups to your filter file, repeat this procedure for each group
you want to add.

Note: The registers that appear in the list of registers are retrieved from the ddf file that
is currently used. If a certain SFR that you need does not appear, you can register your
own SFRs. For more information, see SFR Setup window, page 176.

Reference information on memory and registers

Reference information about:

Memory window, page 155

Data Flash Emulation dialog box, page 159
Data Flash Memory window, page 160
Data Flash dialog box, page 162

Memory Save dialog box, page 163
Memory Restore dialog box, page 164

Fill dialog box, page 164

Live Memory window, page 166

Symbolic Memory window, page 167

Stack window, page 170

Register window, page 174

SFR Setup window, page 176

Edit SFR dialog box, page 179

Memory Monitoring Settings dialog box, page 180
Memory Access Setup dialog box, page 182

Edit Memory Access dialog box, page 184.

C-SPY® Debugging Guide
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Requirements

Toolbar
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The Memory window is available from the View menu.

Available zones Context menu button

‘ Live update

LY

_\ \ =
- & &

oy -
000feefd £f £f £f £f £f £f £f £f

O0COfeefs ff f£ff £ff £f ff ff f£f ff
‘ 000fefo0 48 65 6c 6c 6f 20 57 6f

- Memory ~
Go to location

I —Goto

[ Hello Wo
Memory

addresses i

O00fefo8 72 6c 64 21 00 00 58 Ga
000fefl0 Be 74 7a 4c 00 00 OO OO
O0COfefl® 00 OO0 OO0 OO OO OO OO OO
O0C0fef20 00 OO0 OO OO OO OO OO OO0
O00fef28 OO0 00 OO0 OO0 cd cd cd ed
| 000fef30 ed od cd ed cd ed cd ed

O00fef38 3c 01 00 ed ff £f £f ff
000fefd0

r £ff £ff £ff £f £f £f ff ff
Oo0fefd48 f£f £f ff £f ff ff ff ff
nNNfefsn  ff Ff ff ff FfFf FFf Ff £F

rldly...

Data coverage
information

Mem ory contents Mem ory contents in ASCII format

This window gives an up-to-date display of a specified area of memory—a memory
zone—and allows you to edit it. You can open several instances of this window, which
is very convenient if you want to keep track of several memory or register zones, or
monitor different parts of the memory.

To view the memory corresponding to a variable, you can select it in the editor window
and drag it to the Memory window.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

None; this window is always available.

The toolbar contains:

Go to

The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 150.
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Context menu button

Displays the context menu.

Update Now

Updates the content of the Memory window while your application is
executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing.

Live Update

Updates the contents of the Memory window regularly while your application
is executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing. To set
the update frequency, specify an appropriate frequency in the IDE
Options>Debugger dialog box.

Display area

The display area shows the addresses currently being viewed, the memory contents in
the format you have chosen, and—provided that the display mode is set to

1x Units—the memory contents in ASCII format. You can edit the contents of the
display area, both in the hexadecimal part and the ASCII part of the area.

Data coverage is displayed with these colors:

Yellow Indicates data that has been read.
Blue Indicates data that has been written
Green Indicates data that has been both read and written.

Note: Data coverage is not supported by all C-SPY drivers. Data coverage is supported
by the C-SPY Simulator.

C-SPY® Debugging Guide
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Context menu

This context menu is available:

Copy
Paste

Zone 3

v lxUnits
2x Units
4x Units
8x Units

v Little Endian
Big Endian

Data Coverage 3

Find...

Replace...

Mermory Fill...
Memory Save...

Mermory Restore...
Set Data Breakpoint

Set Data Log Breakpoint

These commands are available:

Copy, Paste

Standard editing commands.

Zone
Selects a memory zone, see C-SPY memory zones, page 150.

1x Units

Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
8x Units

Displays the memory contents as 8-byte groups.

Little Endian
Displays the contents in little-endian byte order.
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Big Endian

Displays the contents in big-endian byte order.

Data Coverage
Choose between:

Enable toggles data coverage on or off.
Show toggles between showing or hiding data coverage.
Clear clears all data coverage information.

These commands are only available if your C-SPY driver supports data
coverage.

Find
Displays a dialog box where you can search for text within the Memory
window; read about the Find dialog box in the IDE Project Management and
Building Guide.

Replace

Displays a dialog box where you can search for a specified string and replace
each occurrence with another string; read about the Replace dialog box in the
IDE Project Management and Building Guide.

Memory Fill

Displays a dialog box, where you can fill a specified area with a value, see Fill
dialog box, page 164.

Memory Save

Displays a dialog box, where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 163.

Memory Restore
Displays a dialog box, where you can load the contents of a file in Intel-hex or
Motorola s-record format to a specified memory zone, see Memory Restore
dialog box, page 164.

Set Data Breakpoint

Sets breakpoints directly in the Memory window. The breakpoint is not
highlighted; you can see, edit, and remove it in the Breakpoints dialog box. The
breakpoints you set in this window will be triggered for both read and write
access. For more information, see Setting a data breakpoint in the Memory
window, page 130.

C-SPY® Debugging Guide
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Set Data Log Breakpoint

Sets a breakpoint on the start address of a memory selection directly in the
Memory window. The breakpoint is not highlighted; you can see, edit, and
remove it in the Breakpoints dialog box. The breakpoints you set in this
window will be triggered by both read and write accesses; to change this, use the
Breakpoints window. For more information, see Data Log breakpoints, page
125 and Getting started using data logging, page 93.

Data Flash Emulation dialog box

The Data Flash Emulation dialog box is available from the Emulator menu.

x

[V Enable data flash oK

Data Flash Map
Cancel
* cs0 (0% 1F8000-0x IFFFFF)
" C51 (0x3F8000-0x3FFFFF) Default

€ £52 (0x7F8000-0xTFFFFF)

Elel

" £S3 (0xFF8000-0xFFFFFF)

¥ Enable data emulation

rError Emulation
v write ™ Internal verify
| 0x1F8080 | 0x0
[ Erase [~ Blank chedk

I 0x0 I 0x0

r—Timing emulation

v write V¥ Erase
£ Min £ Min
% Typical % Typical

" Typical worst " Typical worst
 Max  Max

Use this dialog box to be able to access the data flash memory from the Data Flash
Memory window. The Data Flash Emulation dialog box also provides options for
testing error handling and timing issues in the data flash memory.

Requirements

Any supported hardware debugger system.

Enable data flash

Enables the data flash emulation and the Data Flash Memory window.
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Data flash map

Selects the memory area (Chip select) that the data flash will be mapped to.

Enable data emulation

Enables the error emulation and timing emulation.

Use Error Emulation to control the error emulation. This option has no default setting.
Choose between:

Write

Erase

Internal verify
Blank check.

Note: A generation address is the address where the error occurs. If this address is
outside the data flash memory area, an error message is issued.

Use Timing Emulation to control the timing emulation. For Write and Erase, choose
between:

Min

Typical
Typical worst
Max.

Data Flash Memory window

The Data Flash Memory window is available from the Emulator menu.

|
Address I j
ooifgooo0 11 22 33 ff ff ff f£f f£f f£f f£f f£f f£f f£f f£f ff ff o1 0 1 ﬁl
ooifaolo  f£f £f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 0 1 0
ooifsozo f£f f£f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 1 1 1
ooifao3n  f£f f£f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 1 1 1
onifao4n  £f £f £f f£f ff ff £f f£f f£f f£f f£f f£f f£f f£f ff ff 1 1 1 1
onifaoso  f£f ff £f f£f ff ff f£f f£f f£f f£f f£f f£f f£f f£f ff ff 1 1 1 1
onifaoen f£f f£f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 1 1 1
ooifao7o  f£f f£f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 1 1 1
onifaoso  f£f f£f f£f f£f ff ff £f f£f f£f f£f £f f£f f£f f£f ff ff 1 1 1 1 LI
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Use this window to save and restore the data flash memory area. This saving/restoring
includes the value and the ID tag. To save or restore, use the commands Save memory
to file and Restore memory from file available on the context menu.



Requirements

Toolbar

Display area

Context menu
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o Any supported hardware debugger system

o The option Enable data flash must be selected in the Data Flash Emulation dialog
box, see Data Flash Emulation dialog box, page 159.

The toolbar contains:

Address

The location you want to view. This can be a memory address, or the name of a
variable, function, or table.

The display area shows the addresses currently being viewed, the memory contents in
the format you have chosen. You can edit the contents of the Memory window.

Data Flash Memory coverage is displayed with these colors:
Yellow

Indicates data that has been read.
Blue

Indicates data that has been written.

Green
Indicates data that has been both read and written.

Note: Data Flash Memory coverage is not supported by all C-SPY drivers.

To view the memory corresponding to a variable, you can select it in the editor window
and drag it to the Data Flash Memory window.

This context menu is available:

v 1x Units
2x Units
4 Units

Save memory to file
Restore memory from file

These commands are available:

1x Units
Displays the memory contents in units of 8 bits.
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Data Flash dialog box

Requirements

Start address

End address

File

C-SPY® Debugging Guide
162  for V850

2x Units

Displays the memory contents in units of 16 bits.

4x Units
Displays the memory contents in units of 32 bits.

Save memory to file
Displays the a dialog box, where you can save the contents of a specified
memory area to a file, see Data Flash dialog box, page 162.

Restore memory from file
Displays the Open dialog box, where you can choose the file to restore from.

The Data Flash dialog box is available by choosing Save memory to file from the
context menu in the Data Flash Memory window.

Data Flash LI
Start address End address
0x02000000 I 0x02000050
Cancel |
File
I DataFlash.hex Browse... |

Use this dialog box to save the contents of a specified data flash memory area to a file.

Any supported hardware debugger system.

Specify the start address of the memory range to be saved.

Specify the end address of the memory range to be saved.

Specify the destination file to be used; a browse button is available for your convenience.
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Memory Save dialog box

Requirements

Zone

Start address

End address

File format

Filename

Save

The Memory Save dialog box is available by choosing Debug>Memory>Save or from
the context menu in the Memory window.

Memory Save P§|

Zone:

| Memary ¥ | [ Save ]

Close

Start address: End address:
[ oxs0 | [ oxFr |

File: Farmat:

| intel-extended v |

Filename:
| Ciiprojectsimemary, hex | E]

Use this dialog box to save the contents of a specified memory area to a file.

None; this dialog box is always available.

Selects a memory zone, see C-SPY memory zones, page 150.

Specify the start address of the memory range to be saved.

Specify the end address of the memory range to be saved.

Selects the file format to be used, which is Intel-extended by default.

Specify the destination file to be used; a browse button is available for your convenience.

Saves the selected range of the memory zone to the specified file.
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Memory Restore dialog box

Requirements

Zone

Filename

Restore

Fill dialog box

C-SPY® Debugging Guide

for V850

The Memory Restore dialog box is available by choosing Debug>Memory>Restore
or from the context menu in the Memory window.

Memory Restore E

Zone:

= 5
Close |
Filename:

I Ciiprojectsimemary, hex e |

Use this dialog box to load the contents of a file in Intel-extended or Motorola S-record
format to a specified memory zone.

None; this dialog box is always available.

Selects a memory zone, see C-SPY memory zones, page 150.

Specify the file to be read; a browse button is available for your convenience.

Loads the contents of the specified file to the selected memory zone.

The Fill dialog box is available from the context menu in the Memory window.

Start address:  Length: Zone:
101D [0 |Memay x|
Walue: Operation

FF ' Copy  AND

" HOR  0OR

()3 I Cancel |

Use this dialog box to fill a specified area of memory with a value.



Requirements

Start address

Length

Zone

Value

Operation

Memory and registers °

None; this dialog box is always available.

Type the start address—in binary, octal, decimal, or hexadecimal notation.

Type the length—in binary, octal, decimal, or hexadecimal notation.

Selects a memory zone, see C-SPY memory zones, page 150.

Type the 8-bit value to be used for filling each memory location.

These are the available memory fill operations:

Copy
Value will be copied to the specified memory area.

AND

An AND operation will be performed between Value and the existing contents of
memory before writing the result to memory.

XOR

An XOR operation will be performed between Value and the existing contents of
memory before writing the result to memory.

OR

An OR operation will be performed between Value and the existing contents of
memory before writing the result to memory.
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Live Memory window

Requirements

Toolbar

C-SPY® Debugging Guide
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The Live Memory window is available from the Emulator menu.
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This window shows the selected memory area in real-time when the application is being
executed.

Note: The MINICUBE and MINICUBE?2 Emulators, and the TK-V850 Debugger will
always use the Dynamic Memory Modification (DMM) reading method, if possible.

Any supported hardware debugger system.

The toolbar contains:
x1, x2, x4
Displays the memory contents in units of 8, 16, or 32 bits.

Memory

Selects a memory zone.

Address
Specify the start address of the memory area. It must be a legal memory address.

Length
Specify the length of the memory area, in the range 0x001-0x400. The length
can be adjusted due to emulator restrictions.

Refresh interval

Specify the number of milliseconds between each update. The refresh interval
is 100 to 10000 milliseconds in steps of 10.
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Display area

The display area shows the addresses currently being viewed, the memory contents in
the format you have chosen, and—provided that the display mode is set to

1x Units—the memory contents in ASCII format. You can edit the contents of the
display area, both in the hexadecimal part and the ASCII part of the area.

All changes during the execution are displayed in red.

Symbolic Memory window

The Symbolic Memory window is available from the View menu during a debug

session.
Go ko I j IMemory j Previousl TMext |
Location | Data | ‘ariable | Walue | Tvpe | ;I
0x5C 0x0200C300
0x60 0x0002 call count 10 int
0x62 0x0001 root[0] 1 unsigned int
0x64 0x0001 root1] 1 unsigned int
0x66 0x0002 root[2] 2 unsigned int
0x68 0x0003 root3] 3 unsigned int
0x6A 0x0005 root[4] 5 unsigned int
0x6C 0x0008 root[5] ] unsigned int
0x6E 0x000D rootfB] 13 unsigned int
0x70 0x0015 root[7] 21 unsigned int
0x72 0x0022 rootf8] 34 unsigned int
0x74 0x0037 root[9] 55 unsigned int
0x76 0xCDCDCDCD
Ox7A 0xCDCDCICD x|

This window displays how variables with static storage duration, typically variables
with file scope but also static variables in functions and classes, are laid out in memory.
This can be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example buffer overruns. Other areas of use
are spotting alignment holes or for understanding problems caused by buffers being
overwritten.

To view the memory corresponding to a variable, you can select it in the editor window
@ and drag it to the Symbolic Memory window.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

Requirements

None; this window is always available.
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Toolbar

Display area
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The toolbar contains:

Go to
The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 150.

Previous
Highlights the previous symbol in the display area.

Next
Highlights the next symbol in the display area.

This area contains these columns:

Location

The memory address.

Data
The memory contents in hexadecimal format. The data is grouped according to
the size of the symbol. This column is editable.

Variable
The variable name; requires that the variable has a fixed memory location. Local
variables are not displayed.

Value
The value of the variable. This column is editable.

Type

The type of the variable.
There are several different ways to navigate within the memory space:

Text that is dropped in the window is interpreted as symbols
The scroll bar at the right-side of the window

°
°
o The toolbar buttons Next and Previous
°

The toolbar list box Go to can be used for locating specific locations or symbols.

Note: Rows are marked in red when the corresponding value has changed.
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This context menu is available:

Mext Symbol
Previous Symbaol

1 Units
2x Units
¢ Units

&dd B Watch Windaw

These commands are available:

Next Symbol
Highlights the next symbol in the display area.

Previous Symbol
Highlights the previous symbol in the display area.

1x Units

Displays the memory contents as single bytes. This applies only to rows which
do not contain a variable.

2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
Add to Watch window

Adds the selected symbol to the Watch window.
Default format

Displays the memory contents in the default format.
Binary format

Displays the memory contents in binary format.
Octal format

Displays the memory contents in octal format.
Decimal format

Displays the memory contents in decimal format.
Hexadecimal format

Displays the memory contents in hexadecimal format.

Char format
Displays the memory contents in char format.
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Stack window

The Stack window is available from the View menu.

[ Current stack pointer ] { Used memory stack, in grey ‘
I T

5 The graphic.al

[ Stack view } stack bar with

S— """-——-IStack vl || toaltip

- - - information
| Locat|0n| Data Yariable Yalue | Frame \f .
[oxerFe] oxo0s .

— 1.1 +1 0x08 ————————
Cu.rrent stack ' +2  0x0000 p.mStatus i [1]__exit Unused stack
pointer +4 OxdR memory, in

+5 Ox67 light grey
+6 OxEOD '
+7 0Ox04

Requirements

Toolbar
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This window is a memory window that displays the contents of the stack. In addition,
some integrity checks of the stack can be performed to detect and warn about problems
with stack overflow. For example, the Stack window is useful for determining the
optimal size of the stack.

To view the graphical stack bar:

Choose Tools>Options>Stack.
Select the option Enable graphical stack display and stack usage.

You can open up to two Stack windows, each showing a different stack—if several
stacks are available—or the same stack with different display settings.

Note: By default, this window uses one physical breakpoint. For more information, see
Breakpoint consumers, page 127.

For information about options specific to the Stack window, see the IDE Project
Management and Building Guide.

None; this window is always available.

The toolbar contains:

Stack

Selects which stack to view. This applies to microcontrollers with multiple
stacks.
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The graphical stack bar
Displays the state of the stack graphically.
The left end of the stack bar represents the bottom of the stack, in other words, the
position of the stack pointer when the stack is empty. The right end represents the end

of the memory space reserved for the stack. The graphical stack bar turns red when the
stack usage exceeds a threshold that you can specity.

When the stack bar is enabled, the functionality needed to detect and warn about stack
overflows is also enabled.

@ Place the mouse pointer over the stack bar to get tooltip information about stack usage.

Display area
This area contains these columns:

Location
Displays the location in memory. The addresses are displayed in increasing
order. The address referenced by the stack pointer, in other words the top of the
stack, is highlighted in a green color.

Data
Displays the contents of the memory unit at the given location. From the Stack
window context menu, you can select how the data should be displayed; as a 1-,
2-, or 4-byte group of data.

Variable

Displays the name of a variable, if there is a local variable at the given location.
Variables are only displayed if they are declared locally in a function, and
located on the stack and not in registers.

Value
Displays the value of the variable that is displayed in the Variable column.

Frame

Displays the name of the function that the call frame corresponds to.
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Context menu
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This context menu is available:

v Show Variables
Show Offsets
1x Units
2x Units

v dxUnits

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format

Options...

These commands are available:

Show variables

Displays separate columns named Variables, Value, and Frame in the Stack
window. Variables located at memory addresses listed in the Stack window are
displayed in these columns.

Show offsets

Displays locations in the Location column as offsets from the stack pointer.
When deselected, locations are displayed as absolute addresses.

1x Units
Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.

4x Units
Displays the memory contents as 4-byte groups.
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Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Options

Opens the IDE Options dialog box where you can set options specific to the
Stack window, see the IDE Project Management and Building Guide.
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Register window

Requirements

C-SPY® Debugging Guide
for V850

The Register window is available from the View menu.

Register =]
I[;PU[egiste[S—vl <find reg: -

RO (zr) = (000000000 R19 = 0x4C4C4652
R1 = 0x10660EAR R20 = 0x35334E00
R2 (hp) = Ox5254432E R21 = 0x00000000
R3 (sp) = OxFFFF3008 R22 = 0x0000000F
R4 (gp) = OxFFFF2008 R23 = 0x00000532
RS = 0x00000280 R24 = 0x00000001
Ré& = 0x00000254 R25 = 0x0OF038E39
R7 = 0x00000000 R2& = 0xB0003D&5
R# = OxFFFF8004 R27 = 0x10660E87
R9 = 0x4C5Z0E0L R2% = 0x081EBEFAO0
R10 = 0x00000254 R29 = 0x10660F18
R11 = 0xOF038E3E R30 (ep) = (0x35334E489
Ri12 = 0xB000432E R31 (1p) = (0x000001CC
R13 = 0x10660E2C BPC = 0x00000210
R14 = 0x00000254 CYCLECOUNTER = 56

R15 = 0x10660F28 CCTIMER1 = B6

R1& = 0x4C333141 CCTIMER2 = B6

R17 = 0x4E414300 CCSTEP = B6

Rlg = 0x45324330

This window gives an up-to-date display of the contents of the processor registers and
special function registers, and allows you to edit the content of some of the registers.
Optionally, you can choose to load either predefined register groups or to define your
own application-specific groups.

You can open several instances of this window, which is very convenient if you want to
keep track of different register groups.

For information about editing in C-SPY windows, see C-SPY Debugger main window,
page 48.

To enable predefined register groups:

Select a device description file that suits your device, see Selecting a device description
file, page 41.

The register groups appear in the Register window, provided that they are defined in
the device description file. Note that the available register groups are also listed on the
Register Filter page.

To define application-specific register groups:

See Defining application-specific register groups, page 153.

None; this window is always available.



Memory and registers °

Toolbar

The toolbar contains:

CPU Registers
Selects which register group to display, by default CPU Registers. Additional
register groups are predefined in the device description files that make SFR
registers available in the register window. The device description file contains a
section that defines the special function registers and their groups. If some of
your SFRs are missing, you can register your own SFRs in a Custom group, see
SFR Setup window, page 176.

<find register>
Specify the name of a register that you want to find. Press the Enter key and the
first group where this register is found is displayed. The register search box has
a history depth of 20 search entries.

Display area
Displays registers and their values. Every time C-SPY stops, a value that has changed
since the last stop is highlighted. Some of the registers are read-only, some of the
registers are write-only (marked with w), and some of the registers are editable. To edit
the contents of an editable register, click it, and modify its value. Press Esc to cancel the
new value.

Some registers are expandable, which means that the register contains interesting bits or
subgroups of bits.

To change the display format, change the Base setting on the Register Filter
page—available by choosing Tools>Options.
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SFR Setup window

Requirements
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These additional support registers are available in the CPU Registers group:

CYCLECOUNTER Cleared when an application is started or reset and is
incremented with the number of used cycles during

execution.
CCSTEP Shows the number of used cycles during the last performed
C/C++ source or assembler step.
CCTIMERI1 and Two trip counts that can be cleared manually at any given
CCTIMER2 time. They are incremented with the number of used cycles

during execution.

The SFR Setup window is available from the Project menu.

SFR Setup =]
Name Address Zone Size Access *

+ MyOwnSFR 0x20004000 Memory 8 Read only

+ MyHideSFR 0x20004004 Memory 16 MNone
TIM2_CR1 0x40000000 Memory 32 Read/Write

c TIM2_CR2 0x40000004 Memory 32 Read only
TIM2_SMCR 0x40000008 Memory 32 Read/Write
TIM2_DIER 0x4000000C Memory 32 Read/Write
TIM2_SR 0x40000010 Memory 32 Read/Write -

This window displays the currently defined SFRs that C-SPY has information about.
You can choose to display only factory-defined or custom-defined SFRs, or both. If
required, you can use this window to customize the aspects of the SFRs. For
factory-defined SFRs (that is, retrieved from the ddf file that is currently used), you can
only customize the access type.

Any custom-defined SFRs are added to a dedicated register group called Custom, which
you can choose to display in the Register window. Your custom-defined SFRs are saved
in projectCustomSFR.sfr.

You can only add or modify SFRs when the C-SPY debugger is not running.

None; this window is always available.



Display area

Memory and registers °

This area contains these columns:

Status
A character that signals the status of the SFR, which can be one of:

blank, a factory-defined SFR.
C, a factory-defined SFR that has been modified.
+, a custom-defined SFR.

?, an SFR that is ignored for some reason. An SFR can be ignored when a
factory-defined SFR has been modified, but the SFR is no longer available, or it
is located somewhere else or with a different size. Typically, this might happen
if you change to another device.

Name
A unique name of the SFR.

Address
The memory address of the SFR.

Zone
Selects a memory zone, see C-SPY memory zones, page 150.

Size
The size of the register, which can be any of 8, 16, 32, or 64.

Access

The access type of the register, which can be one of Read/Write, Read only,
Write only, or None.

You can click a name or an address to change the value. The hexadecimal 0x prefix for
the address can be omitted, the value you enter will still be interpreted as hexadecimal.
For example, if you enter 4567, you will get 0x4567.

You can click a column header to sort the SFRs according to the column property.
Color coding used in the display area:

o Green, which indicates that the corresponding value has changed

o Red, which indicates an ignored SFR.
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Context menu

C-SPY® Debugging Guide
for V850

This context menu is available:
v Show All
Show Custom SFRs only
Show Factory SFRs only

Add...

Edit...

Delete

Delete/Revert All Custom SFRs
Save Custom SFRs...

& bits

16 bits

32 bits

64 bits
Read/Write
Read only
Write only

MNone

These commands are available:

Show All
Shows all SFR.
Show Custom SFRs only
Shows all custom-defined SFRs.
Show Factory SFRs only
Shows all factory-defined SFRs retrieved from the ddf file.
Add
Displays the Edit SFR dialog box where you can add a new SFR, see Edit SFR
dialog box, page 179.
Edit
Displays the Edit SFR dialog box where you can edit an SFR, see Edit SFR
dialog box, page 179.
Delete

Deletes an SFR. This command only works on custom-defined SFRs.

Delete/revert All Custom SFRs

Deletes all custom-defined SFRs and reverts all modified factory-defined SFRs
to their factory settings.
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Save Custom SFRs
Opens a standard save dialog box to save all custom-defined SFRs.
8|16|32|64 bits
Selects display format for the selected SFR, which can be 8, 16, 32, or 64 bits.
Note that the display format can only be changed for custom-defined SFRs.
Read/Write|Read only|Write only|None

Selects the access type of the selected SFR, which can be Read/Write, Read
only, Write only, or None. Note that for factory-defined SFRs, the default
access type is indicated.

Edit SFR dialog box
The Edit SFR dialog box is available from the SFR Setup window.
Edit SFR (=23
SFR
M ame:
MyDwnSFR Cancel
Address: Zone:
0400004567 Memary -
Size Access
@ 8 bits @ Read wiite
16 bitz Fiead only
32 bitz write: only
B4 bits MHone

Use this dialog box to define the SFRs.

Requirements

None; this dialog box is always available.

Name

Specify the name of the SFR that you want to add or edit.

Address

Specify the address of the SFR that you want to add or edit. The hexadecimal 0x prefix
for the address can be omitted, the value you enter will still be interpreted as
hexadecimal. For example, if you enter 4567, you will get 0x4567.
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Zone
Selects the memory zone for the SFR you want to add or edit. The list of zones is
retrieved from the ddf file that is currently used.

Size
Selects the size of the SFR. Choose between 8, 16, 32, or 64 bits. Note that the display
format can only be changed for custom-defined SFRs.

Access

Selects the access type of the SFR. Choose between Read/Write, Read only, Write
only, or None. Note that for factory-defined SFRs, the default access type is indicated.

Memory Monitoring Settings dialog box

The Memory Monitoring Settings dialog box is available from the Emulator menu.

Memory Monitoring Settings E

— Code coverage address mapping

Ok I
Fange INot available j |

Cancel

— Data coverage address mapping

Range INot available j

 Live watch

™ Use read break if not mapped

Current mapping
0x003FF0000 - 0x003FFO0FF Realtime+Live

0x003FFC100 - 0<003FFCTFF Live
0x003FFEFOD - 0<003FFEFFF Live

Use this dialog box to define address ranges to be monitored by code coverage and data
coverage. For information about code coverage and data coverage, see Code coverage,
page 227 and Memory window, page 155. Live watch variables which are not
automatically mapped can be set but will then use a more time-consuming read.

Requirements

Any supported hardware debugger system.

C-SPY® Debugging Guide
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Code coverage address mapping

Selects the range you want to monitor.

Data coverage address mapping

Selects the range you want to monitor.

Use read break if not mapped (IECUBE)

Makes all live watch variables be read even if they are not automatically mapped.

Variables that cannot be mapped automatically can be read during execution by breaking
the execution, which consumes a few cycles. (The application stops, the read is
performed, and execution resumes.) This read sequence is performed by the emulator.

When the Live Memory window is open, the address mapping defined in that window
overrides the address mapping for the live watch. This means that variables located
outside of that area will not be readable by the Live Watch window.

Use read break (TK-V850, El, MINICUBE, MINICUBE2, and IECUBE?2)

Makes variables be read using the time-consuming method, see above.

This option will always be used and cannot be deselected. Reading live watch variables
and/or real-time data will always use the Dynamic Memory Modification (DMM)
method, if possible.

Current mapping

Displays the current mappings for the Live Memory and/or Live Watch windows.
This table shows the memory monitoring mappings:

Emulator Mapping

IECUBE A maximum of 2 Kbytes in up to 8 areas
IECUBE2 —
El —
MINICUBE —
MINICUBE2 —
TK-V850 —

Table 9: Memory monitoring mappings
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Memory Access Setup dialog box
The Memory Access Setup dialog box is available from the C-SPY driver menu.

Memory Access Setup _|

™ Use ranges based on

X

% Deyvice description file

it

| Debug file segment information [anly shovwn while debugging) Cancel
Zone | Start Addr | End Addr | Accesz Type |
Memory 0x0 0x1FF R

Memory 0200 0x9FF R
Memory 01000 0«10FF R
Memory 0x1100 0«FFFF R

™ Use manual ranges
Zone | Start Addr| End Addr| Accesz Type | e

Exdit....

Delete

[elete &l

L

Memony aczess checking
Check far: Schor:
¥ Access bype violation € Log violations
¥ Access tounspeciied ranges % [Log and stop execution

This dialog box lists all defined memory areas, where each column in the list specifies
the properties of the area. In other words, the dialog box displays the memory access
setup that will be used during the simulation.

Note: If you enable both the Use ranges based on and the Use manual ranges option,
memory accesses are checked for all defined ranges.

For information about the columns and the properties displayed, see Edit Memory

Access dialog box, page 184.

Requirements
The C-SPY simulator.

Use ranges based on

Selects any of the predefined alternatives for the memory access setup. Choose between:

Device description file
Loads properties from the device description file.

C-SPY® Debugging Guide
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Debug file segment information

Properties are based on the segment information available in the debug file. This
information is only available while debugging. The advantage of using this
option, is that the simulator can catch memory accesses outside the linked
application.

Use manual ranges

Specify your own ranges manually via the Edit Memory Access dialog box. To open
this dialog box, choose New to specify a new memory range, or select a memory zone
and choose Edit to modify it. For more information, see Edit Memory Access dialog
box, page 184.

The ranges you define manually are saved between debug sessions.

Memory access checking
Check for determines what to check for;

® Access type violation

o Access to unspecified ranges

Action selects the action to be performed if an access violation occurs; choose between:
o Log violations

o Log and stop execution

Any violations are logged in the Debug Log window.

Buttons
These buttons are available:

New
Opens the Edit Memory Access dialog box, where you can specify a new
memory range and attach an access type to it, see Edit Memory Access dialog
box, page 184.

Edit
Opens the Edit Memory Access dialog box, where you can edit the selected
memory area. See Edit Memory Access dialog box, page 184.

Delete
Deletes the selected memory area definition.

Delete All
Deletes all defined memory area definitions.
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Note that except for the OK and Cancel buttons, buttons are only available when the
option Use manual ranges is selected.

Edit Memory Access dialog box

Requirements

Memory range

Access type

C-SPY® Debugging Guide
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The Edit Memory Access dialog box is available from the Memory Access Setup
dialog box.

Edit Memory Access E

— Memory range

Zone:
I Memory - l Cancel |
Start address: End address:
Jo [1FFF
—Access lype

 Fead and write
' Fead only
© Wfrite anly

Use this dialog box to specify the memory ranges, and assign an access type to each
memory range, for which you want to detect illegal accesses during the simulation.

The C-SPY simulator.

Defines the memory area specific to your device:
Zone

Selects a memory zone, see C-SPY memory zones, page 150.
Start address

Specify the start address for the memory area, in hexadecimal notation.

End address
Specify the end address for the memory area, in hexadecimal notation.

Selects an access type to the memory range; choose between:

o Read and write
e Read only
o Write only.



Part 2. Analyzing your
application

This part of the C-SPY® Debugging Guide for V850 includes these chapters:
e Trace

o Profiling

e Code coverage

.hmuhhhhi
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e Introduction to using trace
e Collecting and using trace data

e Reference information on trace

Introduction to using trace

These topics are covered:

o Reasons for using trace

e Briefly about trace

o Requirements for using trace

See also:

o Getting started using data logging, page 93

o Getting started using interrupt logging, page 240
e Profiling, page 217

REASONS FOR USING TRACE

By using trace, you can inspect the program flow up to a specific state, for instance an
application crash, and use the trace data to locate the origin of the problem. Trace data
can be useful for locating programming errors that have irregular symptoms and occur
sporadically.

BRIEFLY ABOUT TRACE

To use trace in C-SPY requires that your target system can generate trace data. Once
generated, C-SPY can collect it and you can visualize and analyze the data in various
windows and dialog boxes.

Depending on your target system, different types of trace data can be generated.

Trace data is a continuously collected sequence of every executed instruction for a
selected portion of the execution.

187



Collecting and using trace data

188

Trace features in C-SPY

In C-SPY, you can use the trace-related windows Trace, Function Trace, Timeline, and
Find in Trace.

Depending on your C-SPY driver, you:

o Can set various types of trace breakpoints and triggers to control the collection of
trace data.

o Have access to windows such as the Interrupt Log, Interrupt Log Summary,
Data Log, and Data Log Summary.

In addition, several other features in C-SPY also use trace data, features such as
Profiling, Code coverage, and Instruction profiling.

REQUIREMENTS FOR USING TRACE

The C-SPY simulator supports trace-related functionality, and there are no specific
requirements.

To use trace in your hardware debugger systems you need an IECUBE or IECUBE2
emulator.

Collecting and using trace data

C-SPY® Debugging Guide
for V850

These tasks are covered:

o Getting started with trace
e Trace data collection using breakpoints
e Searching in trace data

o Browsing through trace data.

GETTING STARTED WITH TRACE
Before you start C-SPY:

o For the C-SPY hardware debugger drivers that support trace, choose
Emulator>Trace Settings and check whether you need to change any of the default
settings. For details, see Trace Settings dialog box, page 191. For information about
trace-related settings for IECUBE, see Hardware Setup dialog box — IECUBE, page
56..

Note: If you are using the C-SPY simulator you can ignore this step.
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After you have built your application and started C-SPY, open the Trace
window—available from the driver-specific menu—and click the Activate button to
enable collecting trace data.

Start the execution. When the execution stops, for example because a breakpoint is
triggered, trace data is displayed in the Trace window. For more information about the
window, see Trace window, page 194.

TRACE DATA COLLECTION USING BREAKPOINTS

A convenient way to collect trace data between two execution points is to start and stop
the data collection using dedicated breakpoints. Choose between these alternatives:

o In the editor or Disassembly window, position your insertion point, right-click, and
toggle a Trace Start or Trace Stop breakpoint from the context menu.

o In the Breakpoints window, choose Trace Start or Trace Stop.

o The C-SPY system macros __setTraceStartBreak and
__setTraceStopBreak can also be used.

For more information about these breakpoints, see Trace Start breakpoints dialog box,
page 208 and Trace Stop breakpoints dialog box, page 209, respectively.
SEARCHING IN TRACE DATA

When you have collected trace data, you can perform searches in the collected data to
locate the parts of your code or data that you are interested in, for example, a specific
interrupt or accesses of a specific variable.

You specify the search criteria in the Find in Trace dialog box and view the result in the
Find in Trace window.

Note: The Find in Trace dialog box depends on the C-SPY driver you are using.

The Find in Trace window is very similar to the Trace window, showing the same
columns and data, but only those rows that match the specified search criteria.
Double-clicking an item in the Find in Trace window brings up the same item in the
Trace window.

To search in your trace data:

On the Trace window toolbar, click the Find button.

In the Find in Trace dialog box, specify your search criteria.
Typically, you can choose to search for:

e A specific piece of text, for which you can apply further search criteria

o An address range

189



Reference information on trace

190

o A data value

o A combination of these, like a specific piece of text within a specific address range.

For more information about the various options, see Find in Trace dialog box (in the
C-SPY Simulator), page 211.

When you have specified your search criteria, click Find. The Find in Trace window
is displayed, which means you can start analyzing the trace data. For more information,
see Find in Trace window, page 214.

BROWSING THROUGH TRACE DATA

To follow the execution history, simply look and scroll in the Trace window.
Alternatively, you can enter browse mode.

To enter browse mode, double-click an item in the Trace window, or click the Browse
toolbar button.

The selected item turns yellow and the source and disassembly windows will highlight
the corresponding location. You can now move around in the trace data using the up and
down arrow keys, or by scrolling and clicking; the source and Disassembly windows
will be updated to show the corresponding location. This is like stepping backward and
forward through the execution history.

Double-click again to leave browse mode.

Reference information on trace

C-SPY® Debugging Guide
for V850

Reference information about:

Trace Settings dialog box, page 191

Trace window, page 194

Function Trace window, page 198

Timeline window, page 199

Viewing Range dialog box, page 207

Trace Start breakpoints dialog box, page 208

Trace Stop breakpoints dialog box, page 209

Trace Expressions window, page 210

Find in Trace dialog box (in the C-SPY Simulator), page 211

Find In Trace dialog box (in the hardware debugger drivers), page 212

Find in Trace window, page 214.
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Trace Settings dialog box
The Trace Settings dialog box is available from the Emulator menu.

Trace Settings
Trace operation Trace mode

" Trace disabled * Realtime - o
ear trace buffer before Go
Full trace " Non realtime [Full trace] m

L ™ Relative time stamp
iy
Fipeline hald level:
" Qualify trace
~
~

Section [start/stop] trace

L : Time stamp source
Section & Qualiy trace Fipeline resume level: & CPU chock

Overflow resume level: |0+ ‘8 Bl el i=saitiiond) 1 :|v

On trace buffer ful Trace
* Ovenwrite oldest frames Trace information: i
™ Stop tracing ; Branch PC addresses + Data accesses j g
™ Break execution
Trace conditions r
Start trace Stop trace Qualify trace .
Trace buffer size:
[(Jewventl
[event2 B d
Cevents
Ceventd

Stop delay: |0

Use this dialog box to configure trace generation and collection.

The trace function has a circular frame buffer where the emulator can save frames. When
the Go or a step command is executed, the trace function can save information for each
executed instruction. The information saved is:

e Execution time

o Emulator probe signature
o OP-fetch address and data
°

Data access address and data.

See also Getting started with trace, page 188.

Requirements

An IECUBE or IECUBE2 emulator.
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Trace operation

Trace mode

C-SPY® Debugging Guide
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Selects the trace operation. Choose between:

Trace disabled
Disables the trace function.

Full trace

Starts trace generation at any Go or step command. Trace generation then stops
at break.

Section (start/stop) trace
Starts and stops trace generation once, controlled by the events defined in the
Start trace and Stop trace lists, respectively.

Qualify trace
Makes trace active as long as the qualify trace event is true. Select the qualify
trace event in the Qualify trace list, in the Trace conditions area.

Section & Qualify trace

Starts and stops trace once, controlled by the events in the Start trace and Stop
trace lists, respectively. The trace is active as long as the qualify trace event is
true.

Repeated section trace

Starts and stops trace repeatedly, controlled by the events in the Start trace and
Stop trace lists, respectively.

Selects the trace mode. Choose between:

Realtime

Prevents trace from interfering with CPU execution. However, this means that if
the trace pipeline overflows, tracing will stop and information will be lost.
Tracing starts again when the overflow resume level reaches the specified
setting.

Non realtime (Full trace)
Puts CPU execution on hold (for example, by executing NOP instructions) if the

trace pipeline overflows.

In addition, you must specify the trace behavior at different levels of the trace pipeline
contents. Choose between:
Pipeline hold level

Selects the level that, when overflowed, puts CPU execution on hold. The
default level is 12.
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Pipeline resume level
Selects the level at which CPU execution will resume. The default level is 11.

Overflow resume level
Selects the level at which tracing will resume. The default level is O.

Clear trace buffer before Go

Clears the trace buffer before each Go or step command is performed.

Relative time stamp

Shows the time relative to the previous trace frame.

Time stamp source
Controls the counter that counts each traced instruction. Choose between:

CPU clock
Bases the counter on the CPU clock.

External clock
Bases the counter on an external source, supplied by the emulator.

Resolution

Selects a time resolution for the counter. A coarser resolution gives more
instructions the same time stamp and makes the times count last longer. This is
useful when you trace longer executions and want to prevent the counter from
reaching its limit and starting over from 0 again.

On trace buffer full

Controls what happens when the trace buffer is full. Choose between:

Overwrite oldest frame
Overwrites the oldest frames.

Stop tracing
Stops the trace generation.

Break execution

Stops the entire execution.

Trace information

Selects which trace data to generate, to reduce the chances that the trace pipeline
overflows. Choose between:
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Trace priority

Trace conditions

All PC addresses

Generates trace data for all program counter addresses. A PC address is output
by the CPU after each instruction.

Branch PC addresses

Generates trace data only for the program counter addresses output by the CPU
when a jump occurs.

Data accesses

Generates trace data for the data and its address for every read/write operation.

OP codes
Generates trace data for the operation code bytes of the instructions.

PC
Generates trace data for the addresses of instructions that perform data accesses.

Note: If the Live Memory window is open, generating trace data for data accesses has
no effect.

These settings are not available.

Selects the trace events that control the trace. If more than one event is selected in the
same list, the trace condition will be true when one of the selected events has occurred.

Select the events that are to be used to start, stop, or qualify for the trace session.

Trace DMA accesses

Trace buffer size

Stop delay

Trace window

C-SPY® Debugging Guide
for V850

These settings are not available.

Selects the size of the trace buffer. The trace buffer can be 1-256 Kbytes in size.

Delays the trace stop. Specify the number of frames you want the trace generation to
continue after the stop condition has been met.

The Trace window is available from the C-SPY driver menu.

This window displays the collected trace data.
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The content of the Trace window depends on the C-SPY driver you are using and the
trace support of your debug probe. For the C-SPY hardware debugger drivers, the
window also displays information about, for example, events, time stamps, and probe
values.

One of these alternatives:

o The C-SPY Simulator
e An IECUBE or IECUBE2 emulator

The toolbar in the Trace window and in the Function Trace window contains:

Enable/Disable
Enables and disables collecting and viewing trace data in this window. This
button is not available in the Function Trace window.

Clear trace data
Clears the trace buffer. Both the Trace window and the Function Trace window
are cleared.

Toggle source
Toggles the Trace column between showing only disassembly or disassembly
together with the corresponding source code.

Browse
Toggles browse mode on or off for a selected item in the Trace window, see
Browsing through trace data, page 190.

Find
Displays a dialog box where you can perform a search, see Find in Trace dialog
box (in the C-SPY Simulator), page 211.

Save
isplays a standard Save As dialog box where you can save the collected trace
data to a text file, with tab-separated columns.

Edit Settings
In the C-SPY simulator, this button is not enabled.

For the C-SPY hardware debugger drivers, this button displays the Trace
Settings dialog box, see Trace Settings dialog box, page 191.
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Edit Expressions (C-SPY simulator only)

Opens the Trace Expressions window, see Trace Expressions window, page
210.

Display area (in the C-SPY simulator)

C-SPY® Debugging Guide
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This area displays a collected sequence of executed machine instructions. In addition,
the window can display trace data for expressions.

oxXBevYE A ]
# Cycles Trace callCount e
5064 13582 00044F JC 0x043C 5
5065 13588 00043C LCALL DoForegrou... &
DoForegroundProcess: : Prelay:
5066 13594 0ooos3 18 Bt 5
?YBDISPATCH_FF:
5067 13597 000075 POP LDFH 5
5068 13600 000077 POP DPL 5
5069 13604 000072 PUSH ?CBANE 5 w
Trace |Trace Expressions =

This area contains these columns for the C-SPY simulator:

#

A serial number for each row in the trace buffer. Simplifies the navigation within
the buffer.

Cycles
The number of cycles elapsed to this point.

Trace

The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

Expression
Each expression you have defined to be displayed appears in a separate column.
Each entry in the expression column displays the value after executing the
instruction on the same row. You specify the expressions for which you want to
collect trace data in the Trace Expressions window, see Trace Expressions
window, page 210.

A red-colored row indicates that the previous row and the red row are not consecutive.
This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.
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Display area (in the C-SPY hardware debugger drivers)

This area displays a collected sequence of executed machine instructions and other trace

data.
Trace @
X Y|
Frame Ewent Time  Probe Fetch  Address  Opcode  Trace i
ooz naoo?s  0ooo BRt1  00000GBE CHF R1.R&
noz3z nao?s  0ooo kA1 0000060 EZ 0=6BC
00233 nao?? o 0ooo BRh1  00000GBC IHP [LF]
00234 noorg  0ooo BRM1  000006AC JARL main, LP
00235 noogo 0ooo BRt1  00000GFC PREPARE {LF}.0 il
4 n 3

This area contains these columns for the C-SPY hardware debugger drivers:
Frame

The number of the trace buffer frame. Double-click the frame number to display
the traced fetch address in the editor window.

Event

The name of the single events that have been triggered by the event conditions.
For information about event conditions, see Edit Events dialog box, page 341.

Time

The time stamp of the trace frame.
Probe

The probe value of the trace frame.
Fetch

The fetch type of the instruction associated with the trace frame.
Address

The address of the instruction associated with the trace frame.
Opcode

The operation code of the instruction associated with the trace frame. After the
hexadecimal value, extra information can be displayed:

x2 if two instructions were executed

¢ if the instruction was read from the I-Cache.
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Trace
The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

Access
The access type of the instruction associated with the trace frame. DMA stands
for DMA transfer. The address and data information shows which transfer that
was performed.

Address
The address of the accessed data.

Data

The data that the access has read or written.

Function Trace window

Requirements

Toolbar

C-SPY® Debugging Guide
for V850

The Function Trace window is available from the C-SPY driver menu during a debug
session.

Function Trace @
@ [/ |

# Cycles  Trace rmyariable i
475 1050 O0=000000E4: PutFib{unsigned int} + 76
4176 10585 0xz00000242: DoForegroundProces=() + 22
477 1058 0=0000025C main() + 24

483 1069 0xz0000022C: DoForegroundProcess()

485 1074 0xz00000220: HextCounter()

491 1086 0xz00000232: DoForegroundProce==() + 6

494 1092 0=00000074: GetFib{int)
ED4 1109 0xz00000234: DoForegroundProces=() + 14

PO M3 P — o

Function Trace | Trace | Trace Expressions =

This window displays a subset of the trace data displayed in the Trace window. Instead
of displaying all rows, the Function Trace window only shows trace data corresponding
to calls to and returns from functions.

One of these alternatives:

® The C-SPY simulator
e An IECUBE or IECUBE2 emulator

For information about the toolbar, see Trace window, page 194.
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Timeline window
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For information about the columns in the display area, see Trace window, page 194

The Timeline window is available from the C-SPY driver menu during a debug session.
This window displays trace data in different graphs in relation to a common time axis:

o Call Stack graph
e Data Log graph
e Interrupt Log graph

To display a graph:
Choose Timeline from the C-SPY driver menu to open the Timeline window.

In the Timeline window, click in the graph area and choose Enable from the context
menu to enable a specific graph.

For the Data Log graph, you need to set a Data Log breakpoint for each variable you
want a graphical representation of in the Timeline window. See Data Log breakpoints
dialog box, page 142.

Click Go on the toolbar to start executing your application. The graph appears.
To navigate in the graph, use any of these alternatives:

e Right-click and from the context menu choose Zoom In or Zoom Out.
Alternatively, use the + and - keys. The graph zooms in or out depending on which
command you used.

o Right-click in the graph and from the context menu choose Navigate and the
appropriate command to move backwards and forwards on the graph. Alternatively,
use any of the shortcut keys: arrow keys, Home, End, and Ctrl+End.

o Double-click on a sample of interest and the corresponding source code is
highlighted in the editor window and in the Disassembly window.

e Click on the graph and drag to select a time interval. Press Enter or right-click and
from the context menu choose Zoom>Zoom to Selection. The selection zooms in.
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Requirements
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Point in the selection with the mouse pointer to get detailed tooltip information
about the selected part of the graph:

Start time of

S 127
selection in
seconds and yﬂw
cycles tl: 181.70 us (1817 cycles)

—— B t2: 194.50 us (1945 cycles) /The frequency that N
i u
End of selection T (2 11): 1280 us (128 cycles) correspends tothe

in seconds and i time interval.
cycles = 18 /T; 78125 H ———————— Typically, useful for
; T < periadically

~ — — occurring events.
T fme s S8 0.00020s 0.00025s L

of the selection

Point in the graph with the mouse pointer to get detailed tooltip information for that
location.

The C-SPY simulator.
The display area can be populated with different graphs:

Call Stack Data Log Interrupt
Target system
graph graph Log graph

C-SPY simulator X X X
C-SPY hardware debugger drivers -- - -

Table 10: Supported graphs in the Timeline window

For more information about requirements related to trace data, see Requirements for
using trace, page 188.
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Display area for the Call Stack graph
The Call Stack graph displays the sequence of calls and returns collected by trace.

Timing information

Timeline =
b =
__w| _w _w
putchar| putchar| [putchar]| [putchar]| [putchar]| 3
) |?Sprlngboa| |?Sprlngboa| |?Springboa| |?Springboa| |?Springboa|
putch [_printf 517
?Spring [printf 537 |
_Printf | [nmiHandler::??INTVEC 16 1
printf | [nmiHandler:??INTVEC 16 ;
main 87 / <
0.000022s/ ©.000024s 0.806626s 0.0000828s 6.6606630s 0.606832s

Comm

[ — >

on time axis ] { Selection for current graph

At the bottom of the graph you will usually find main, and above it, the functions called

frommain, and so on. The horizontal bars, which represent invocations of functions, use

four different colors:

o Medium green for normal C functions with debug information

o Light green for functions known to the debugger only through an assembler label

o Medium or light yellow for interrupt handlers, with the same distinctions as for
green.

The timing information represents the number of cycles spent in, or between, the

function invocations.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.
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Display area for the Data Log graph
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The Data Log graph displays the data logs generated by trace, for up to four different
variables or address ranges specified as Data Log breakpoints.

Graph in Levels style ] [ Graph in Linear style ]

. Y 3 &
Timeline , N

| 0x10 —— ox0n 0x10 Ox10 -

8.80398s 8.80399s 8.80400s 8.80401s 8.80402s

[

Commaon time axis ]

Where:

The label area at the left end of the graph displays the variable name or the address
for which you have specified the Data Log breakpoint.

The graph itself displays how the value of the variable changes over time. The label
area also displays the limits, or range, of the Y-axis for a variable. You can use the

context menu to change these limits. The graph is a graphical representation of the
information in the Data Log window, see Data Log window, page 111.

The graph can be displayed either as a thin line between consecutive logs or as a
rectangle for every log (optionally color-filled).

A red vertical line indicates overflow, which means that the communication channel
failed to transmit all data logs from the target system. A red question mark indicates
a log without a value.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.
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Display area for the Interrupt Log graph

The Interrupt Log graph displays interrupts reported by the C-SPY simulator. In other
words, the graph provides a graphical view of the interrupt events during the execution
of your application.

Active interrupt l |Overf|ow |

Timeline |E |

— (N

e [
= i ===

2.90815s 8.000208s 8.00025s 8.00038s 8.90835s

Commaon time axis

Where:

o The label area at the left end of the graph displays the names of the interrupts.

o The graph itself shows active interrupts as a thick green horizontal bar where the
white figure indicates the time spent in the interrupt. This graph is a graphical
representation of the information in the Interrupt Log window, see Interrupt Log
window, page 247.

e If the bar is displayed without horizontal borders, there are two possible causes:

o The interrupt is reentrant and has interrupted itself. Only the innermost interrupt
will have borders.

o There are irregularities in the interrupt enter-leave sequence, probably due to
missing logs.

e If the bar is displayed without a vertical border, the missing border indicates an
approximate time for the log.

o A red vertical line indicates overflow, which means that the communication channel
failed to transmit all interrupt logs from the target system.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.

Selection and navigation

Click and drag to select. The selection extends vertically over all graphs, but appears
highlighted in a darker color for the selected graph. You can navigate backward and
forward in the selected graph using the left and right arrow keys. Use the Home and End
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keys to move to the first or last relevant point, respectively. Use the navigation keys in
combination with the Shift key to extend the selection.

Context menu

This context menu is available:

MNavigate 3
v Auto Scroll
Zoom 3
Call Stack
v Enable

v | Show Timing
Go to Source

Save to File...

Select Graphs 3
Time Axis Unit 3

Note: The context menu contains some commands that are common to all graphs and
some commands that are specific to each graph. The figure reflects the context menu for
the Call Stack graph, which means that the menu looks slightly different for the other
graphs.

These commands are available:

Navigate (All graphs)
Commands for navigating over the graph(s); choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.
Auto Scroll (All graphs)

Toggles auto scrolling on or off. When on, the most recently collected data is
automatically displayed if you have executed the command Navigate>End.

C-SPY® Debugging Guide
204  for V850
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Zoom (All graphs)
Commands for zooming the window, in other words, changing the time scale;
choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +.
Zoom Out zooms out on the time scale. Shortcut key: -.

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Data Log (Data Log graph)
A heading that shows that the Data Log-specific commands below are available.

Call Stack (Call Stack graph)
A heading that shows that the Call stack-specific commands below are available.

Interrupt (Interrupt Log graph)
A heading that shows that the Interrupt Log-specific commands below are
available.

Enable (All graphs)
Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the Timeline window. If no trace data has been collected
for a graph, no data will appear instead of the graph.

Show Timing (Call Stack graph)
Toggles the display of the timing information on or off.

Variable (Data Log graph)

The name of the variable for which the Data Log-specific commands below
apply. This menu command is context-sensitive, which means it reflects the
Data Log graph you selected in the Timeline window (one of up to four).

Solid Graph (Data Log graph)
Displays the graph as a color-filled solid graph instead of as a thin line.

Viewing Range (Data Log graph)
Displays a dialog box, see Viewing Range dialog box, page 207.
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Size (Data Log graph)
Determines the vertical size of the graph; choose between Small, Medium, and
Large.

Show Numerical Value (Data Log graph)
Shows the numerical value of the variable, in addition to the graph.

Go To Source (Common)

Displays the corresponding source code in an editor window, if applicable.

Save to File (Call Stack graph)
Saves all contents (or the selected contents) of the Call Stack graph to a file. The
menu command is only available when C-SPY is not running.

Sort by (Interrupt graph)
Sorts the entries according to their ID or name. The selected order is used in the
graph when new interrupts appear.

Select Graphs (Common)
Selects which graphs to be displayed in the Timeline window.

Time Axis Unit (Common)
Selects the unit used in the time axis; choose between Seconds and Cycles.

Profile Selection

Enables profiling time intervals in the Function Profiler window. Note that this
command is only available if the C-SPY driver supports PC Sampling.
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Viewing Range dialog box

Range for ...

Scale

The Viewing Range dialog box is available from the context menu that appears when
you right-click in the Data Log graph in the Timeline window.

Viewing Range Pz|

Range for power:
(& Auto {currently 0 - 70)
O Factory (5 - 200)
O Custom

Lowest value:

Scale:

O Linear
(%) Logarithmic

Highest value:

[ ok |[ Cancel ]

Use this dialog box to specify the value range, that is, the range for the Y-axis for the
graph.

Selects the viewing range for the displayed values:

Auto
Uses the range according to the range of the values that are actually collected,
continuously keeping track of minimum or maximum values. The currently
computed range, if any, is displayed in parentheses. The range is rounded to
reasonably even limits.

Factory
For the Data Log graph: Uses the range according to the value range of the
variable, for example 0-65535 for an unsigned 16-bit integer.

Custom
Use the text boxes to specify an explicit range.

Selects the scale type of the Y-axis:

e Linear

o Logarithmic.
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Trace Start breakpoints dialog box

Requirements

Trigger at
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4

The Trace Start dialog box is available from the context menu that appears when you
right-click in the Breakpoints window.

New Breakpoint g|
2 Trace Start l

Trigger At:

| Ed,.

(] 8 | Cancel |

Use this dialog box to set a Trace Start breakpoint where you want to start collecting
trace data. If you want to collect trace data only for a specific range, you must also set a
Trace Stop breakpoint where you want to stop collecting data.

See also, Trace Stop breakpoints dialog box, page 209.

To set a Trace Start breakpoint:

In the editor or Disassembly window, right-click and choose Trace Start from the
context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.
In the Breakpoints window, right-click and choose New Breakpoint>Trace Start.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Trigger At text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection starts.

The C-SPY simulator.

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 146.
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Trace Stop breakpoints dialog box

Requirements

Trigger at

The Trace Stop dialog box is available from the context menu that appears when you
right-click in the Breakpoints window.

x
& Trace Stop |

Trigger At:

| Edit.. |

()8 I Cancel |

Use this dialog box to set a Trace Stop breakpoint where you want to stop collecting
trace data. If you want to collect trace data only for a specific range, you might also need
to set a Trace Start breakpoint where you want to start collecting data.

See also, Trace Start breakpoints dialog box, page 208.
To set a Trace Stop breakpoint:

In the editor or Disassembly window, right-click and choose Trace Stop from the
context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.
In the Breakpoints window, right-click and choose New Breakpoint>Trace Stop.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Trigger At text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection stops.

The C-SPY simulator.

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 146.
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Trace Expressions window

Requirements

Toolbar

Display area
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The Trace Expressions window is available from the Trace window toolbar.

Trace Expressions B
4 3
Expression | Format

H Default

; ~ Trace Expression:

Use this window to specify, for example, a specific variable (or an expression) for which
you want to collect trace data.

The C-SPY simulator.

The toolbar buttons change the order between the expressions:
Arrow up
Moves the selected row up.

Arrow down

Moves the selected row down.

Use the display area to specify expressions for which you want to collect trace data:
Expression

Specify any expression that you want to collect data from. You can specify any
expression that can be evaluated, such as variables and registers.

Format

Shows which display format that is used for each expression. Note that you can
change display format via the context menu.

Each row in this area will appear as an extra column in the Trace window.
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Find in Trace dialog box (in the C-SPY Simulator)

Requirements

Text search

The Find in Trace dialog box is available by clicking the Find button on the Trace
window toolbar or by choosing Edit>Find and Replace>Find.

Note that the Edit>Find and Replace>Find command is context-dependent. It displays
the Find in Trace dialog box if the Trace window is the current window or the Find
dialog box if the editor window is the current window.

Find in Trace §|

W' Text search
| =l
Cancel

[~ Match case
I Match whale word

™ only search in one colurnn

| I

™ Address range

Use this dialog box to specify the search criteria for advanced searches in the trace data.

The search results are displayed in the Find in Trace window—available by choosing
the View>Messages command, see Find in Trace window, page 214.

See also Searching in trace data, page 189.

The C-SPY simulator.

Specify the string you want to search for. To specify the search criteria, choose between:

Match Case
Searches only for occurrences that exactly match the case of the specified text.
Otherwise int will also find INT and Int and so on.

Match whole word

Searches only for the string when it occurs as a separate word. Otherwise int
will also find print, sprintf and so on.

Only search in one column
Searches only in the column you selected from the drop-down list.
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Address Range

Specify the address range you want to display or search. The trace data within the
address range is displayed. If you also have specified a text string in the Text search
field, the text string is searched for within the address range.

Find In Trace dialog box (in the hardware debugger drivers)

The Find In Trace dialog box is available in the Trace window as a button or by
choosing Edit>Find and Replace>Find.

x
— Addre: oK
g x|
Cancel |

Current frame:

C—

Start: 0 h

End  |OsFFFFFF -]

— Drata and control

Imd [rata size: Access type:
by & Feadfwiite
Walue:  |0x0 - R
" Half word = wWiite
Mask: IDxFF vl
£ word € Ay OP fetch
Pattem: IxxxxxxxxxxxxxxxxxxxxxxxxDDDDDDDD " Branch OP fetch

— Probe —
Find First |
v

Walue: o0 -

Mask: |0xF -

Pattern: IDDDD

Find All |

Use this dialog box to define conditions for trace buffer searching and to search the trace
buffer.

The search results are displayed in the Find in Trace window, see Find in Trace window,
page 214.

See also Searching in trace data, page 189.
Use the check boxes to enable search conditions. If more than one search condition is

enabled, all conditions must be true.

Requirements
An IECUBE or IECUBE2 emulator.

C-SPY® Debugging Guide
212 for V850



Trace __4

Address

Specify the address or address range you want to display or search. The trace data within
the address range is displayed. These options specifty the address or address range:

Start

Specifies the single address or the start of the address range.
End

Specity the end of the address range.

Note: You can enter a label instead of an address value.

Current frame

Lists all found frames.

Data and control
Defines the data value, data size, and type of access to search for in the trace buffer.
These options specify a value:
Value
Specify a value to search for in the trace buffer.
Mask
Specity a mask to apply to the value.
Pattern
Displays the bit pattern for the value with the applied mask.
For Data size, choose between:
Any
Matches data accesses of any size.
Byte
Matches byte size accesses.
Half word

Matches halfword accesses.

Word
Matches word size accesses.

For Access type, choose between:

Read/Write
Reads from or writes to location.
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Probe

Buttons

Find in Trace window
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Read

Reads from location.

Write
Writes to location.

Any OP fetch
Matches an operation code (instruction) fetch.

Branch OP fetch

Matches a fetch of a branch instruction.

Defines a probe value to search for:
Value
Specify a probe value.
Mask
Specity a mask to apply to the value.

Pattern
Displays the bit pattern for the value with the applied mask.

These buttons are available:

Find First

Starts the search in the trace buffer.

Find Next
Searches from the current position in the trace buffer or from a frame set in the
Current frame drop-down list.

Find All

Searches for all frames that match your search criteria and displays them in the
Find In Trace window.

The Find in Trace window is available from the View>Messages menu. Alternatively,
it is automatically displayed when you perform a search using the Find in Trace dialog
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box or perform a search using the Find in Trace command available from the context
menu in the editor window.

Find In Trace B

Trace

008034 CHP RS, #0 2

Find In Trace

This window displays the result of searches in the trace data. Double-click an item in the
Find in Trace window to bring up the same item in the Trace window.

Before you can view any trace data, you must specity the search criteria in the Find in
Trace dialog box, see Find in Trace dialog box (in the C-SPY Simulator), page 211.

For more information, see Searching in trace data, page 189.

Requirements
One of these alternatives:

o The C-SPY simulator
e An IECUBE or IECUBE2 emulator

Display area

The Find in Trace window looks like the Trace window and shows the same columns
and data, but only those rows that match the specified search criteria.
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Profiling

e Introduction to the profiler
e Using the profiler

e Reference information on the profiler

Introduction to the profiler

These topics are covered:

o Reasons for using the profiler
e Briefly about the profiler

o Requirements for using the profiler

REASONS FOR USING THE PROFILER

Function profiling can help you find the functions in your source code where the most
time is spent during execution. You should focus on those functions when optimizing
your code. A simple method of optimizing a function is to compile it using speed
optimization. Alternatively, you can move the data used by the function into more
efficient memory. For detailed information about efficient memory usage, see the /4R
C/C++ Compiler Reference Guide for V850.

Alternatively, you can use filtered profiling, which means that you can exclude, for
example, individual functions from being profiled. To profile only a specific part of your
code, you can select a time interval—using the Timeline window—for which C-SPY
produces profiling information.

Instruction profiling can help you fine-tune your code on a very detailed level, especially
for assembler source code. Instruction profiling can also help you to understand where
your compiled C/C++ source code spends most of its time, and perhaps give insight into
how to rewrite it for better performance.

BRIEFLY ABOUT THE PROFILER

Function profiling information is displayed in the Function Profiler window, that is,
timing information for the functions in an application. Profiling must be turned on
explicitly using a button on the window’s toolbar, and will stay enabled until it is turned
off.
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Instruction profiling information is displayed in the Disassembly window, that is, the
number of times each instruction has been executed.

Profiling sources

The profiler can use different mechanisms, or sources, to collect profiling information.
Depending on the available trace source features, one or more of the sources can be used
for profiling:

o Trace (calls)

The full instruction trace is analyzed to determine all function calls and returns.
When the collected instruction sequence is incomplete or discontinuous, the
profiling information is less accurate.

o Trace (flat)

Each instruction in the full instruction trace or each PC Sample is assigned to a
corresponding function or code fragment, without regard to function calls or returns.
This is most useful when the application does not exhibit normal call/return
sequences, such as when you are using an RTOS, or when you are profiling code
which does not have full debug information.

REQUIREMENTS FOR USING THE PROFILER

The C-SPY simulator supports the profiler; there are no specific requirements.

Using the profiler

C-SPY® Debugging Guide
for V850

These tasks are covered:

o Getting started using the profiler on function level
® Analyzing the profiling data

o Getting started using the profiler on instruction level

GETTING STARTED USING THE PROFILER ON FUNCTION
LEVEL

To display function profiling information in the Function Profiler window:

Build your application using these options:

Category Setting
C/C++ Compiler Output>Generate debug information
Linker Output>Format>Debug information for C-SPY

Table 11: Project options for enabling the profiler
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When you have built your application and started C-SPY, choose C-SPY
driver>Function Profiler to open the Function Profiler window, and click the
Enable button to turn on the profiler. Alternatively, choose Enable from the context
menu that is available when you right-click in the Function Profiler window.

Start executing your application to collect the profiling information.

Profiling information is displayed in the Function Profiler window. To sort, click on
the relevant column header.

When you start a new sampling, you can click the Clear button—alternatively, use the
context menu—to clear the data.

ANALYZING THE PROFILING DATA
Here follow some examples of how to analyze the data.

The first figure shows the result of profiling using Source: Trace (calls). The profiler

follows the program flow and detects function entries and exits.

o For the InitFib function, Flat Time 231 is the time spent inside the function itself.

e For the InitFib function, Acc Time 487 is the time spent inside the function itself,
including all functions InitFib calls.

o For the InitFib/GetFib function, Acc Time 256 is the time spent inside GetFib (but
only when called from InitFib), including any functions GetFib calls.
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o Further down in the data, you can find the GetFib function separately and see all of
its subfunctions (in this case none).

Ol

Function Calls Flat Time  FlatTime (*%6)  Acc. Time  Acc Time (*
= rain 1 165 3.58 4358 94.39
; DoForegroundProcess 10 3704
InitFik 1 487
PutFib 10 3174 58,78 3174 58,78
MextCaounter 10 100 2.17 100 2.17
= InitFib 1 @ 5.01 5'497; 10.55
e GetFib 16 (256
GetFib 26 416 9.01 118 9.01
DoForegroundProcess 10 270 3704 80.26

MextCounter
PutFib 10
= <Other> o 25

v Enable

98.85

v

Source: Trace (calls)

The second figure shows the result of profiling using Source: Trace (flat). In this case,
the profiler does not follow the program flow, instead the profiler only detects whether
the pC address is within the function scope. For incomplete trace data, the data might
contain minor errors.
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For the InitFib function, Flat Time 231 is the time (number of hits) spent inside the
function itself.

»

FCSamp... PCSamples ..

__iar_lookup_ttich
__iar_sh_stdout

CEL S
Source: Trace (flat) h
To secure valid data when using a debug probe, make sure to use the maximum trace
buffer size and set a breakpoint in your code to stop the execution before the buffer is
full.

<ldle> 0 0.00

<Mo function> 5 0.21
DoForegroundProcess a0 3.85

GetFib 260 11.12

InitFik 141 65.03 =
MNextCounter [s] 2.57

PutFib 230 9.84

__crain, ?main 4 0.17

_ dhwrite Enable R
__exit

__iar_close_ttio Clear

_?ar_copy_.in.itS Filtering 3
__iar_data_init3

__iar_get_ttio g

GETTING STARTED USING THE PROFILER ON INSTRUCTION
LEVEL

To display instruction profiling information in the Disassembly window:

When you have built your application and started C-SPY, choose View>Disassembly
to open the Disassembly window, and choose Instruction Profiling>Enable from the
context menu that is available when you right-click in the left-hand margin of the
Disassembly window.

Make sure that the Show command on the context menu is selected, to display the
profiling information.

Start executing your application to collect the profiling information.

When the execution stops, for instance because the program exit is reached or a
breakpoint is triggered, you can view instruction level profiling information in the
left-hand margin of the window.
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toeclod
08005F92 BO82

02005F94 EDOS

FD1lw100us_1:

08005F96 9900
08005F98 1E49
08005F94 9100

'Dlyl00us 2.
08005F9C 9900
0800SF9E 2900
08005FAD DI1F9
while(Dly——}
?Dlyl00us

08005FA2 0001
08005FA4 1E483

for{wolatile int 1

SUB

£320 Dlvy = {Int32Wiarg:

SP. SP. #0=8

B ??D1lyl00us_0
= LOCP_DLY_10 i

0USy i di==)s

LDR R1. [SF]

SUBS El, R1. #0=1

STR R1. [5SF]
for{volatile int i = LOOP_DLY_100US; i; i——):

LDR R1. [SFP]

CHP E1l, #0=0

EHE ??D1lyl00us_1

HOVS R1. RO

SUBS RO, R1. #0=1

o

For each instruction, the number of times it has been executed is displayed.

Reference information on the profiler

Reference information about:

® Function Profiler window, page 222

See also:

e Disassembly window, page 76

Function Profiler window

The Function Profiler window is available from the C-SPY driver menu.
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Function Profiler

E|

[© tl@|E]]

Function | calls | FlatTime | Flat Time (%) | Acc. Time | Acc. Time (%) |

main() 1 165 3.57 4356 54.18
FutFib{unsigned int) 10 3174 62.63 3174 68.63
MextCounter() 10 100 2.16 100 2.16

InitFib) 1 231 4.93 487 10.53
GetFih(int) 26 416 8.99 416 8.93

#  DoForegroundProcess() 10 270 5.84 3704 80.09

<Other> o 269 5.82 4572 98.4a5

This window displays function profiling information.
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When Trace(flat) is selected, a checkbox appears on each line in the left-side margin of
the window. Use these checkboxes to include or exclude lines from the profiling.
Excluded lines are dimmed but not removed.

Requirements
The C-SPY simulator.

Toolbar
The toolbar contains:
Enable/Disable
Enables or disables the profiler.
Clear
Clears all profiling data.

Save

o= e

Opens a standard Save As dialog box where you can save the contents of the
window to a file, with tab-separated columns. Only non-expanded rows are
included in the list file.

Graphical view

Overlays the values in the percentage columns with a graphical bar.

Progress bar

Displays a backlog of profiling data that is still being processed. If the rate of
incoming data is higher than the rate of the profiler processing the data, a
backlog is accumulated. The progress bar indicates that the profiler is still
processing data, but also approximately how far the profiler has come in the
process. Note that because the profiler consumes data at a certain rate and the
target system supplies data at another rate, the amount of data remaining to be
processed can both increase and decrease. The progress bar can grow and shrink
accordingly.

Display area

The content in the display area depends on which source that is used for the profiling
information:

e For the Trace (calls) source, the display area contains one line for each function
compiled with debug information enabled. When some profiling information has
been collected, it is possible to expand rows of functions that have called other
functions. The child items for a given function list all the functions that have been
called by the parent function and the corresponding statistics.
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e For the Trace (flat) source, the display area contains one line for each C function of
your application, but also lines for sections of code from the runtime library or from
other code without debug information, denoted only by the corresponding
assembler labels. Each executed pc address from trace data is treated as a separate
sample and is associated with the corresponding line in the Profiling window. Each
line contains a count of those samples.

For information about which views that are supported in the C-SPY driver you are using,
see Requirements for using the profiler, page 218.

More specifically, the display area provides information in these columns:

Function (All sources)
The name of the profiled C function.

Calls (Trace (calls))

The number of times the function has been called.

Flat time (Trace (calls))
The time expressed as the estimated number of cycles spent inside the function.

Flat time (%) (Trace (calls))
Flat time expressed as a percentage of the total time.

Acc. time (Trace (calls))

The time expressed as the estimated number of cycles spent inside the function
and everything called by the function.

Acc. time (%) (Trace (calls))
Accumulated time expressed as a percentage of the total time.

PC Samples (Trace (flat))

The number of PC samples associated with the function.

PC Samples (%) (Trace (flat))

The number of PC samples associated with the function as a percentage of the
total number of samples.
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Context menu
This context menu is available:
[V Ebe '
Clear

| ¥ Source: Trace (calls)

Source: Trace (flat)

Save to Log File...
The contents of this menu depend on the C-SPY driver you are using.
These commands are available:

Enable

Enables the profiler. The system will collect information also when the window
is closed.

Clear
Clears all profiling data.

Filtering
Selects which part of your code to profile. Choose between:

Check All—Excludes all lines from the profiling.
Uncheck All—Includes all lines in the profiling.
Load—Reads all excluded lines from a saved file.

Save—Saves all excluded lines to a file. Typically, this can be useful if you are
a group of engineers and want to share sets of exclusions.

These commands are only available when using Trace (flat).

Source*
Selects which source to be used for the profiling information. Choose between:

Trace (calls)—the instruction count for instruction profiling is only as complete
as the collected trace data.

Trace (flat)}—the instruction count for instruction profiling is only as complete
as the collected trace data.

Save to Log File
Saves all profiling data to a file.

* The available sources depend on the C-SPY driver you are using.
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Code coverage

e Introduction to code coverage

e Reference information on code coverage.

Introduction to code coverage
These topics are covered:

o Reasons for using code coverage
e Briefly about code coverage

o Requirements and restrictions for using code coverage.

REASONS FOR USING CODE COVERAGE

The code coverage functionality is useful when you design your test procedure to verify
whether all parts of the code have been executed. It also helps you identity parts of your
code that are not reachable.

BRIEFLY ABOUT CODE COVERAGE

The Code Coverage window reports the status of the current code coverage analysis.
For every program, module, and function, the analysis shows the percentage of code that
has been executed since code coverage was turned on up to the point where the
application has stopped. In addition, all statements that have not been executed are
listed. The analysis will continue until turned off.

REQUIREMENTS AND RESTRICTIONS FOR USING CODE
COVERAGE

Code coverage is supported by the C-SPY Simulator and there are no specific
requirements or restrictions.

Reference information on code coverage
Reference information about:

o Code Coverage window, page 228.
See also Single stepping, page 70.
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The Code Coverage window is available from the View menu.

[© sl[c]le & &

=% project] 91.18%
=@ Tutor 100.00%
¢ DoFaregroundProcess 100.00%
¢ NextCounter 100.00%
% main 100.00%
=% Utilities 86.96%
=@ GetFib 66.67%
< 5-13:54 addr((xDE)
4 InitFib 100.00%
=@ PutFib 84.62%
< 5-17:65 addr(IxEB)
< 5-11:66 addr(0xF0)

This window reports the status of the current code coverage analysis. For every program,
module, and function, the analysis shows the percentage of code that has been executed
since code coverage was turned on up to the point where the application has stopped. In
addition, all statements that have not been executed are listed. The analysis will continue
until turned off.

An asterisk (*) in the title bar indicates that C-SPY has continued to execute, and that
the Code Coverage window must be refreshed because the displayed information is no
longer up to date. To update the information, use the Refresh button.

To get started using code coverage:

Before using the code coverage functionality you must build your application using
these options:

Category Setting

C/C++ Compiler Output>Generate debug information

Linker Format>Debug information for C-SPY

Debugger Plugins>Code Coverage

Table 12: Project options for enabling code coverage

After you have built your application and started C-SPY, choose View>Code
Coverage to open the Code Coverage window.

Click the Activate button, alternatively choose Activate from the context menu, to
switch on code coverage.

Start the execution. When the execution stops, for instance because the program exit is
reached or a breakpoint is triggered, click the Refresh button to view the code
coverage information.
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Requirements
The C-SPY simulator.

Display area

The code coverage information is displayed in a tree structure, showing the program,
module, function, and statement levels. The window displays only source code that was
compiled with debug information. Thus, startup code, exit code, and library code is not
displayed in the window. Furthermore, coverage information for statements in inlined
functions is not displayed. Only the statement containing the inlined function call is
marked as executed. The plus sign and minus sign icons allow you to expand and
collapse the structure.

These icons give you an overview of the current status on all levels:

Red diamond Signifies that 0% of the modules or functions has been
executed.

Green diamond Signifies that 100% of the modules or functions has been
executed.

Red and green diamond ~ Signifies that some of the modules or functions have been
executed.

Yellow diamond Signifies a statement that has not been executed.

The percentage displayed at the end of every program, module, and function line shows
the amount of statements that has been covered so far, that is, the number of executed
statements divided with the total number of statements.

For statements that have not been executed (yellow diamond), the information displayed
is the column number range and the row number of the statement in the source window,
followed by the address of the step point:

<column_start>-<column_end>:row address.

A statement is considered to be executed when one of its instructions has been executed.
When a statement has been executed, it is removed from the window and the percentage
is increased correspondingly.

Double-clicking a statement or a function in the Code Coverage window displays that
statement or function as the current position in the editor window, which becomes the
active window. Double-clicking a module on the program level expands or collapses the
tree structure.
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This context menu is available:

v Activate
Clear
Refresh
Auko-refresh
Save As...

These commands are available:

Activate

Switches code coverage on and off during execution.

Clear
Clears the code coverage information. All step points are marked as not
executed.
Refresh
Updates the code coverage information and refreshes the window. All step
points that have been executed since the last refresh are removed from the tree.
Auto-refresh

Toggles the automatic reload of code coverage information on and off. When
turned on, the code coverage information is reloaded automatically when
C-SPY stops at a breakpoint, at a step point, and at program exit.

Save As

Saves the current code coverage result in a text file.

Save session

Saves your code coverage session data to a * . dat file. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command is available on the toolbar. This command might not be
supported by the C-SPY driver you are using.

Restore session

Restores previously saved code coverage session data. This is useful if you for
some reason must abort your debug session, but want to continue the session
later on. This command is available on the toolbar. This command might not be
supported by the C-SPY driver you are using.



Part 3. Advanced
debugging

This part of the C-SPY® Debugging Guide for V850 includes these chapters:
o Interrupts

o C-SPY macros

e The C-SPY command line utility—cspybat

.hmuhhhhi
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Interrupts

e Introduction to interrupts
e Using the interrupt system

e Reference information on interrupts

Introduction to interrupts

These topics are covered:

Briefly about interrupt logging

Briefly about the interrupt simulation system
Interrupt characteristics

Interrupt simulation states

C-SPY system macros for interrupt simulation

Target-adapting the interrupt simulation system
See also:
® Reference information on C-SPY system macros, page 267

® Breakpoints, page 123
o The IAR C/C++ Compiler Reference Guide for V850

BRIEFLY ABOUT INTERRUPT LOGGING

Interrupt logging provides you with comprehensive information about the interrupt
events. This might be useful for example, to help you locate which interrupts you can
fine-tune to become faster. You can log entrances and exits to and from interrupts. You
can also log internal interrupt status information, such as triggered, expired, etc. In the
IDE:

e The logs are displayed in the Interrupt Log window

o A summary is available in the Interrupt Log Summary window

o The Interrupt graph in the Timeline window provides a graphical view of the
interrupt events during the execution of your application program.

Requirements for interrupt logging

Interrupt logging is supported by the C-SPY simulator.

233



Introduction to interrupts

234

C-SPY® Debugging Guide
for V850

See also Getting started using interrupt logging, page 240.

BRIEFLY ABOUT THE INTERRUPT SIMULATION SYSTEM

By simulating interrupts, you can test the logic of your interrupt service routines and

debug the interrupt handling in the target system long before any hardware is available.
If you use simulated interrupts in conjunction with C-SPY macros and breakpoints, you
can compose a complex simulation of, for instance, interrupt-driven peripheral devices.

The C-SPY Simulator includes an interrupt simulation system where you can simulate
the execution of interrupts during debugging. You can configure the interrupt simulation
system so that it resembles your hardware interrupt system.

The interrupt system has the following features:

Simulated interrupt support for the V850 microcontroller
Single-occasion or periodical interrupts based on the cycle counter
Predefined interrupts for various devices

Configuration of hold time, probability, and timing variation

State information for locating timing problems

Configuration of interrupts using a dialog box or a C-SPY system macro—that is,
one interactive and one automating interface. In addition, you can instantly force an
interrupt.

o A log window that continuously displays events for each defined interrupt.
e A status window that shows the current interrupt activities.
All interrupts you define using the Interrupt Setup dialog box are preserved between

debug sessions, unless you remove them. A forced interrupt, on the other hand, exists
only until it has been serviced and is not preserved between sessions.

The interrupt simulation system is activated by default, but if not required, you can turn
off the interrupt simulation system to speed up the simulation. To turn it off, use either
the Interrupt Setup dialog box or a system macro.
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INTERRUPT CHARACTERISTICS

The simulated interrupts consist of a set of characteristics which lets you fine-tune each
interrupt to make it resemble the real interrupt on your target hardware. You can specify
a first activation time, a repeat interval, a hold time, a variance, and a probability.

H H H
Activation | |_‘ |_|—| | | |
signal } I | I I
F‘meI ] | | | l |
cycles
B Ton ot wt it
A A+R A+2R A+3R

*If probability is less than 100%, some interrupts may be omitted.

A = Activation time
R = Repeat interval
H =Hold time

Y =Variance

The interrupt simulation system uses the cycle counter as a clock to determine when an
interrupt should be raised in the simulator. You specify the first activation time, which
is based on the cycle counter. C-SPY will generate an interrupt when the cycle counter
has passed the specified activation time. However, interrupts can only be raised between
instructions, which means that a full assembler instruction must have been executed
before the interrupt is generated, regardless of how many cycles an instruction takes.

To define the periodicity of the interrupt generation you can specify the repeat interval
which defines the amount of cycles after which a new interrupt should be generated. In
addition to the repeat interval, the periodicity depends on the two options
probability—the probability, in percent, that the interrupt will actually appear in a
period—and variance—a time variation range as a percentage of the repeat interval.
These options make it possible to randomize the interrupt simulation. You can also
specify a hold time which describes how long the interrupt remains pending until
removed if it has not been processed. If the hold time is set to infinite, the corresponding
pending bit will be set until the interrupt is acknowledged or removed.

INTERRUPT SIMULATION STATES

The interrupt simulation system contains status information that you can use for locating
timing problems in your application. The Interrupt Status window displays the
available status information. For an interrupt, these states can be displayed: /dle,
Pending, Executing, or Suspended.
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Normally, a repeatable interrupt has a specified repeat interval that is longer than the
execution time. In this case, the status information at different times looks like this:

Hold time
- >
| T

| | 1
Interrupt A B | C DI E F | G H
activation | I \ - = -
signal
& | | I

——— Iq

| .
Execution time for

interrupt handler

Time Status

A Idle

B Pending
D Executing

E Idle

F Pending

G, H Executing

Note: The interrupt activation signal—also known as the pending bit—is automatically
deactivated the moment the interrupt is acknowledged by the interrupt handler.

However, if the interrupt repeat interval is shorter than the execution time, and the
interrupt is reentrant (or non-maskable), the status information at different times looks
like this:

Hold time
-
T
| |
Interrupt Br C D Er F G
activation : : L
signal | L
' Execution time for ! on time
interrupt invocation (1) !Execunon'nme or
interrupt invocation (2)
Time Status
A Idle
B Pending

C,DE Executing
FG 1st interrupt: Suspended
2nd interrupt: Executing

An execution time that is longer than the repeat interval might indicate that you should
rewrite your interrupt handler and make it faster, or that you should specify a longer
repeat interval for the interrupt simulation system.

C-SPY SYSTEM MACROS FOR INTERRUPT SIMULATION

Macros are useful when you already have sorted out the details of the simulated interrupt
so that it fully meets your requirements. If you write a macro function containing
definitions for the simulated interrupts, you can execute the functions automatically
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when C-SPY starts. Another advantage is that your simulated interrupt definitions will
be documented if you use macro files, and if you are several engineers involved in the
development project you can share the macro files within the group.

The C-SPY Simulator provides these predefined system macros related to interrupts:
__enableInterrupts

__disablelInterrupts

__orderInterrupt

__cancelInterrupt

__cancelAllInterrupts

__popSimulatorInterruptExecutingStack

The parameters of the first five macros correspond to the equivalent entries of the
Interrupts dialog box.

For more information about each macro, see Reference information on C-SPY system
macros, page 267.

TARGET-ADAPTING THE INTERRUPT SIMULATION SYSTEM

The interrupt simulation system is easy to use. However, to take full advantage of the
interrupt simulation system you should be familiar with how to adapt it for the processor
you are using.

The interrupt simulation has the same behavior as the hardware. This means that the
execution of an interrupt is dependent on the status of the global interrupt enable bit. The
execution of maskable interrupts is also dependent on the status of the individual
interrupt enable bits.

To simulate device-specific interrupts, the interrupt system must have detailed
information about each available interrupt. This information is provided in the device
description files.

For information about device description files, see Selecting a device description file,
page 41.

Using the interrupt system

These tasks are covered:

e Simulating a simple interrupt
e Simulating an interrupt in a multi-task system

o Getting started using interrupt logging.
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See also:

o Using C-SPY macros, page 255 for details about how to use a setup file to define
simulated interrupts at C-SPY startup

o The tutorial Simulating an interrupt in the Information Center.

SIMULATING A SIMPLE INTERRUPT

This example demonstrates the method for simulating a timer interrupt. However, the
procedure can also be used for other types of interrupts.

To simulate and debug an interrupt:

Assume this simple application which contains an interrupt service routine for a basic
timer, which increments a tick variable. The main function sets the necessary status
registers. The application exits when 100 interrupts have been generated.

#pragma language = extended
#include "i070£3747.h"
#include <intrinsics.h>

volatile int ticks = 0;
void main (void)
{

/* Add your timer setup code here */
__enable_interrupt() ; /* Enable interrupts */

while (ticks < 100); /* Endless loop */
printf ("Done\n") ;

}

/* Timer interrupt service routine */
#pragma vector = INTTMOEQO_vector
__interrupt void timerll_compare (void)

{
ticks += 1;

}

Add your interrupt service routine to your application source code and add the file to
your project.

Select an appropriate device, for this example upd70£3747, by choosing
Project>Options>General Options>Target>Device and then
V8S0ES>VS8S0ES-70F37>V850ES-uPD70F3747. Based on your choice of device, a
linker configuration file and a device description file are automatically selected. The
device description file provides information that C-SPY needs to be able to simulate
the interrupt.
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4 Build your project and start the simulator.

5 Choose Simulator>Interrupt Setup to open the Interrupts Setup dialog box. Select
the Enable interrupt simulation option to enable interrupt simulation. Click New to
open the Edit Interrupt dialog box. For the timer example, verify these settings:

Option Settings

Interrupt INTTMOEQO
Description 0x0260 | TMOEQICO
First activation 2000

Repeat interval 600

Hold time 10

Probability (%) 100

Variance (%) 0

Table 13: Timer interrupt settings

Click OK.

6 Execute your application. If you have enabled the interrupt properly in your application
source code, C-SPY will:

o Generate an interrupt when the cycle counter has passed 2000

o Continuously repeat the interrupt after approximately 600 cycles.

7 To watch the interrupt in action, choose Simulator>Interrupt Log to open the
Interrupt Log window.

8 From the context menu, available in the Interrupt Log window, choose Enable to
enable the logging. If you restart program execution, status information about
entrances and exits to and from interrupts will now appear in the Interrupt Log
window.

For information about how to get a graphical representation of the interrupts correlated
with a time axis, see Timeline window, page 199.

SIMULATING AN INTERRUPT IN A MULTI-TASK SYSTEM

If you are using interrupts in such a way that the normal instruction used for returning
from an interrupt handler is not used, for example in an operating system with
task-switching, the simulator cannot automatically detect that the interrupt has finished
executing. The interrupt simulation system will work correctly, but the status
information in the Interrupt Setup dialog box might not look as you expect. If too
many interrupts are executing simultaneously, a warning might be issued.
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To simulate a normal interrupt exit:

Set a code breakpoint on the instruction that returns from the interrupt function.

Specify the __popSimulatorInterruptExecutingStack macro as a condition to
the breakpoint.

When the breakpoint is triggered, the macro is executed and then the application
continues to execute automatically.

GETTING STARTED USING INTERRUPT LOGGING

Choose C-SPY driver>Interrupt Log to open the Interrupt Log window. Optionally,
you can also choose:

o C-SPY driver>Interrupt Log Summary to open the Interrupt Log Summary
window

o C-SPY driver>Timeline to open the Timeline window and view the Interrupt
graph.

From the context menu in the Interrupt Log window, choose Enable to enable the

logging.

Start executing your application program to collect the log information.

To view the interrupt log information, look in any of the Interrupt Log, Interrupt Log
Summary, or the Interrupt graph in the Timeline window.

If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

To disable interrupt logging, from the context menu in the Interrupt Log window,
toggle Enable off.

Reference information on interrupts

C-SPY® Debugging Guide
for V850

Reference information about:

Interrupt Setup dialog box, page 241
Edit Interrupt dialog box, page 242
Forced Interrupt window, page 244
Interrupt Status window, page 245
Interrupt Log window, page 247

Interrupt Log Summary window, page 250.
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Interrupt Setup dialog box

The Interrupt Setup dialog box is available by choosing Simulator>Interrupt Setup.

Interrupt Setup

Enable interrupt simulation

Intermupt [} Type Timing [cycles] 0K
MM 2 Fepeat 0+ n*2000

Edit...

Delete

% 4

This dialog box lists all defined interrupts. Use this dialog box to enable or disable the
interrupt simulation system, as well as to enable or disable individual interrupts.

Requirements
The C-SPY simulator.

Enable interrupt simulation

Enables or disables interrupt simulation. If the interrupt simulation is disabled, the
definitions remain but no interrupts are generated. Note that you can also enable and
disable installed interrupts individually by using the check box to the left of the interrupt
name in the list of installed interrupts.

Display area
This area contains these columns:

Interrupt

Lists all interrupts. Use the checkbox to enable or disable the interrupt.

ID
A unique interrupt identifier.

Type
Shows the type of the interrupt. The type can be one of:

Forced, a single-occasion interrupt defined in the Forced Interrupt Window.

Single, a single-occasion interrupt.
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Buttons

Repeat, a periodically occurring interrupt.
If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).

Timing
The timing of the interrupt. For a Single and Forced interrupt, the activation
time is displayed. For a Repeat interrupt, the information has the form:
Activation Time + n*Repeat Time. For example, 2000 + n*2345. This

means that the first time this interrupt is triggered, is at 2000 cycles and after that
with an interval of 2345 cycles.

These buttons are available:
New

Opens the Edit Interrupt dialog box, see Edit Interrupt dialog box, page 242.
Edit

Opens the Edit Interrupt dialog box, see Edit Interrupt dialog box, page 242.
Delete

Removes the selected interrupt.

Delete All
Removes all interrupts.

Edit Interrupt dialog box

C-SPY® Debugging Guide
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The Edit Interrupt dialog box is available from the Interrupt Setup dialog box.

Edit Interrupt g|
Interrupt:
UBRT v

Drescription:

1 0x40 UART.INTEN UART INTPEND

First activatior:

4000 Hold tirne
(&) Infinite
Fiepeat interval:
2000 o
Wariance [%]: Probability [%]:
a v 100 .

Use this dialog box to interactively fine-tune the interrupt parameters. You can add the
parameters and quickly test that the interrupt is generated according to your needs.
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Note: You can only edit or remove non-forced interrupts.

Requirements
The C-SPY simulator.

Interrupt

Selects the interrupt that you want to edit. The drop-down list contains all available
interrupts. Your selection will automatically update the Description box. The list is
populated with entries from the device description file that you have selected.

Description

A description of the selected interrupt, if available. The description is retrieved from the
selected device description file and consists of a string describing the vector number, the
interrupt type (0 for NMI interrupts and 1 for INT interrupts), and the control register
(only for INT interrupts), separated by space characters. For interrupts specified using
the system macro __orderInterrupt, the Description box is empty.

First activation

Specify the value of the cycle counter after which the specified type of interrupt will be
generated.

Repeat interval

Specify the periodicity of the interrupt in cycles.

Variance %

Selects a timing variation range, as a percentage of the repeat interval, in which the
interrupt might occur for a period. For example, if the repeat interval is 100 and the
variance 5%, the interrupt might occur anywhere between T=95 and T=105, to simulate
a variation in the timing.

Hold time
Specify how long, in cycles, the interrupt remains pending until removed if it has not
been processed. If you select Infinite, the corresponding pending bit will be set until the
interrupt is acknowledged or removed.

Probability %

Selects the probability, in percent, that the interrupt will actually occur within the
specified period.
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The Forced Interrupt window is available from the C-SPY driver menu.

Forced Interrupt =]
Interrupt Description it
PORT 0x0C 2 P2IEFT1 P2IFG.F1 £
PORTZ 0x10 2 P2IEF2 P2IFG.PZ

Use this window to force an interrupt instantly. This is useful when you want to check
your interrupt logic and interrupt routines. Just start typing an interrupt name and focus
shifts to the first line found with that name.

The hold time for a forced interrupt is infinite, and the interrupt exists until it has been
serviced or until a reset of the debug session.

To sort the window contents, click on either the Interrupt or the Description column
header. A second click on the same column header reverses the sort order.

To force an interrupt:
Enable the interrupt simulation system, see Interrupt Setup dialog box, page 241.

Double-click the interrupt in the Forced Interrupt window, or activate by using the
Force command available on the context menu.

The C-SPY simulator.

This area lists all available interrupts and their definitions. The description field is
editable and the information is retrieved from the selected device description file. See
this file for a detailed description.

This context menu is available:

Force

This command is available:

Force
Triggers the interrupt you selected in the display area.
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Interrupt Status window

The Interrupt Status window is available from the C-SPY driver menu.

Interrupt Status @
Interrupt Id | Type Status Mext Time Timing [eycles]

MNRAI 2 Forced Executing — —

IRQ0 1 Repeat(macro) Suspended — —

[R1E]] 0 Repeat Idle 4345 2000 + n*2345

IRQ0 1 Repeat(macro) Idle 5020 3010 + n*2010

This window shows the status of all the currently active interrupts, in other words
interrupts that are either executing or waiting to be executed.

Requirements

The C-SPY simulator.

Display area
This area contains these columns:

Interrupt

Lists all interrupts.

ID
A unique interrupt identifier.

Type
The type of the interrupt. The type can be one of:

Forced, a single-occasion interrupt defined in the Forced Interrupt window.
Single, a single-occasion interrupt.
Repeat, a periodically occurring interrupt.

If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).

Status
The state of the interrupt:

Idle, the interrupt activation signal is low (deactivated).

Pending, the interrupt activation signal is active, but the interrupt has not been
yet acknowledged by the interrupt handler.
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Executing, the interrupt is currently being serviced, that is the interrupt handler
function is executing.

Suspended, the interrupt is currently suspended due to execution of an interrupt
with a higher priority.

(deleted) is added to Executing and Suspended if you have deleted a currently
active interrupt. (deleted) is removed when the interrupt has finished executing.

Next Time

The next time an idle interrupt is triggered. Once a repeatable interrupt stats
executing, a copy of the interrupt will appear with the state Idle and the next time
set. For interrupts that do not have a next time—that is pending, executing, or
suspended—the column will show --.

The timing of the interrupt. For a Single and Forced interrupt, the activation
time is displayed. For a Repeat interrupt, the information has the form:
Activation Time + n*Repeat Time. For example, 2000 + n*2345. This
means that the first time this interrupt is triggered, is at 2000 cycles and after that
with an interval of 2345 cycles.
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Interrupt Log window
The Interrupt Log window is available from the C-SPY driver menu.

Interrupt Leg @
Time Interrupt Status Program Counter Execution Time *
189.32 us IRQTO Triggered Bx13E8 £
111.26 us IRQTO Enter Bx13F@
135.78 us IRQT1 Enter Bx1126
148.72 us IRQT1 Leave Bx1378 12.94 us
189.34 us  Overflow
2087.30 us IRQTO Leave Bx1126 96.84 us
230.80 us IRQTO Triggered 9x1118
231.34 us IRQTO Enter 0x1126
240.26, us IRQTO Leave 0x1122 . 8.92 us
300.00 \us  IRQT1 Enter _
371.12 i'x_ls IRQT1 Leave \ 8x1120 171.12 us -
Red indicates overflows Light-colored rows Darker rews
and italic indicates indicate entrances indicate exits
approximate values tointerrupts from interrupts

This window logs entrances to and exits from interrupts. The C-SPY simulator also logs
internal state changes.

The information is useful for debugging the interrupt handling in the target system.
When the Interrupt Log window is open, it is updated continuously at runtime.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
entries in the beginning of the buffer are erased.

For more information, see Getting started using interrupt logging, page 240.
For information about how to get a graphical view of the interrupt events during the

execution of your application, see Timeline window, page 199.

Requirements
The C-SPY simulator.

Display area
This area contains these columns:
Time

The time for the interrupt entrance, based on an internally specified clock
frequency.
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This column is available when you have selected Show Time from the context
menu.

Cycles
The number of cycles from the start of the execution until the event.

This column is available when you have selected Show Cycles from the context
menu.

Interrupt
The interrupt as defined in the device description file.

Status
Shows the event status of the interrupt:

Triggered, the interrupt has passed its activation time.

Forced, the same as Triggered, but the interrupt was forced from the Forced
Interrupt window.

Enter, the interrupt is currently executing.
Leave, the interrupt has been executed.

Expired, the interrupt hold time has expired without the interrupt being
executed.

Rejected, the interrupt has been rejected because the necessary interrupt
registers were not set up to accept the interrupt.

Program Counter
The value of the program counter when the event occurred.

Execution Time/Cycles
The time spent in the interrupt, calculated using the Enter and Leave
timestamps. This includes time spent in any subroutines or other interrupts that
occurred in the specific interrupt.

C-SPY® Debugging Guide
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This context menu is available in the Data Log window, the Data Log Summary
window, the Interrupt Log window, and in the Interrupt Log Summary window:

v

Enable
Clear

Save to Log File...

Show Time

Show Cycles

Note: The commands are the same in each window, but they only operate on the specific
window.

These commands are available:

Enable

Enables the logging system. The system will log information also when the
window is closed.

Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.

Save to log file

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF. An X in the Approx column indicates that the timestamp is an
approximation.

Show Time

Displays the Time column in the Data Log window and in the Interrupt Log
window, respectively.

This menu command might not be available in the C-SPY driver you are using,
which means that the Time column is by default displayed in the Data Log
window.

Show Cycles

Displays the Cycles column in the Data Log window and in the Interrupt Log
window, respectively.

This menu command might not be available in the C-SPY driver you are using,
which means that the Cycles column is not supported.
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Interrupt Log Summary window

The Interrupt Log Summary window is available from the C-SPY driver menu.

Interrupt Log Summary @
Interrupt Count First Time  Total (Time)  Total (%) Fastest Slowest in Intersal Max Interval
ADC |3 25 BElus 95 400us 17 .61 16.320us 30.120us 192 640us 1284 . 100us
RTC 4 41 700us EE . 200us 22 BB 13 . 800us 13.800us 27 .060us 2687 420us

Approximative time count. 1
COwerflow count. 1
Currenttime:  3350.080us us

Requirements

Display area

C-SPY® Debugging Guide

for V850

This window displays a summary of logs of entrances to and exits from interrupts.
For more information, see Getting started using interrupt logging, page 240.

For information about how to get a graphical view of the interrupt events during the
execution of your application, see Timeline window, page 199.

The C-SPY simulator.

Each row in this area displays statistics about the specific interrupt based on the log
information in these columns; and summary information is listed at the bottom of the
display area:

Interrupt

The type of interrupt that occurred.

Count
The number of times the interrupt occurred.

First time
The first time the interrupt was executed.

Total (Time)**
The accumulated time spent in the interrupt.

Total (%)

The time in percent of the current time.

Fastest**

The fastest execution of a single interrupt of this type.
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Slowest**

The slowest execution of a single interrupt of this type.

Min interval
The shortest time between two interrupts of this type.
The interval is specified as the time interval between the entry time for two
consecutive interrupts.
Max interval
The longest time between two interrupts of this type.
The interval is specified as the time interval between the entry time for two
consecutive interrupts.
Approximative time count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time|cycles
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

** Calculated in the same way as for the Execution time/cycles in the Interrupt Log
window.
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This context menu is available in the Data Log window, the Data Log Summary
window, the Interrupt Log window, and in the Interrupt Log Summary window:

v | Enable
Clear

Save to Log File...

v | Show Time
Show Cycles

Note: The commands are the same in each window, but they only operate on the specific
window.

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.

Save to log file

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF. An X in the Approx column indicates that the timestamp is an
approximation.

Show Time
Displays the Time column in the Data Log window and in the Interrupt Log
window, respectively.

This menu command might not be available in the C-SPY driver you are using,
which means that the Time column is by default displayed in the Data Log
window.

Show Cycles
Displays the Cycles column in the Data Log window and in the Interrupt Log
window, respectively.

This menu command might not be available in the C-SPY driver you are using,
which means that the Cycles column is not supported.



C-SPY macros

Introduction to C-SPY macros

Using C-SPY macros

Reference information on the macro language

Reference information on reserved setup macro function names
Reference information on C-SPY system macros

Graphical environment for macros

Introduction to C-SPY macros

These topics are covered:

Reasons for using C-SPY macros
Briefly about using C-SPY macros
Briefly about setup macro functions and files

Briefly about the macro language

REASONS FOR USING C-SPY MACROS

You can use C-SPY macros either by themselves or in conjunction with complex
breakpoints and interrupt simulation to perform a wide variety of tasks. Some examples
where macros can be useful:

Automating the debug session, for instance with trace printouts, printing values of
variables, and setting breakpoints.

o Hardware configuring, such as initializing hardware registers.

e Feeding your application with simulated data during runtime.

Simulating peripheral devices, see the chapter /nterrupts. This only applies if you
are using the simulator driver.

Developing small debug utility functions, for instance performing actions at
breakpoint trigger without stopping the execution. See the provided example
setBreak.mac located in the directory
\v850\examples\simulator\break_during_run\.
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BRIEFLY ABOUT USING C-SPY MACROS
To use C-SPY macros, you should:

o Write your macro variables and functions and collect them in one or several macro
files

e Register your macros

e Execute your macros.

For registering and executing macros, there are several methods to choose between.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register or execute your macro.

BRIEFLY ABOUT SETUP MACRO FUNCTIONS AND FILES

There are some reserved setup macro function names that you can use for defining
macro functions which will be called at specific times, such as:

o Once after communication with the target system has been established but before
downloading the application software

o Once after your application software has been downloaded

o FEach time the reset command is issued

o Once when the debug session ends.

To define a macro function to be called at a specific stage, you should define and register

a macro function with one of the reserved names. For instance, if you want to clear a

specific memory area before you load your application software, the macro setup

function execUserPreload should be used. This function is also suitable if you want

to initialize some CPU registers or memory-mapped peripheral units before you load
your application software.

You should define these functions in a setup macro file, which you can load before
C-SPY starts. Your macro functions will then be automatically registered each time you
start C-SPY. This is convenient if you want to automate the initialization of C-SPY, or
if you want to register multiple setup macros.

For more information about each setup macro function, see Reference information on
reserved setup macro function names, page 265.

BRIEFLY ABOUT THE MACRO LANGUAGE

The syntax of the macro language is very similar to the C language. There are:

® Macro statements, which are similar to C statements.

® Macro functions, which you can define with or without parameters and return
values.
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o Predefined built-in system macros, similar to C library functions, which perform
useful tasks such as opening and closing files, setting breakpoints, and defining
simulated interrupts.

® Macro variables, which can be global or local, and can be used in C-SPY
expressions.

® Macro strings, which you can manipulate using predefined system macros.

For more information about the macro language components, see Reference information
on the macro language, page 260.

Example

Consider this example of a macro function which illustrates the various components of
the macro language:

__var oldval;
CheckLatest (val)
{
if (oldval !'= wval)
{
__message "Message: Changed from ", oldval, " to ", wval, "\n";
oldval = val;
}
}

Note: Reserved macro words begin with double underscores to prevent name conflicts.

Using C-SPY macros

These tasks are covered:

Registering C-SPY macros—an overview

Executing C-SPY macros—an overview

Registering and executing using setup macros and setup files
Executing macros using Quick Watch

Executing a macro by connecting it to a breakpoint

Aborting a C-SPY macro

For more examples using C-SPY macros, see:

o The tutorial about simulating an interrupt, which you can find in the Information
Center

e I[nitializing target hardware before C-SPY starts, page 45.
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REGISTERING C-SPY MACROS—AN OVERVIEW

C-SPY must know that you intend to use your defined macro functions, and thus you
must register your macros. There are various ways to register macro functions:

You can register macro functions during the C-SPY startup sequence, see
Registering and executing using setup macros and setup files, page 257.

You can register macros interactively in the Macro Registration window, see
Macro Registration window, page 301. Registered macros appear in the Debugger
Macros window, see Debugger Macros window, page 303.

You can register a file containing macro function definitions, using the system
macro __registerMacroFile. This means that you can dynamically select which
macro files to register, depending on the runtime conditions. Using the system
macro also lets you register multiple files at the same moment. For information
about the system macro, see __registerMacroFile, page 286.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register your macro.

EXECUTING C-SPY MACROS—AN OVERVIEW

There are various ways to execute macro functions:

You can execute macro functions during the C-SPY startup sequence and at other
predefined stages during the debug session by defining setup macro functions in a
setup macro file, see Registering and executing using setup macros and setup files,
page 257.

The Quick Watch window lets you evaluate expressions, and can thus be used for
executing macro functions. For an example, see Executing macros using Quick
Watch, page 257.

The Macro Quicklaunch window is similar to the Quick Watch window, but is
more specified on designed for C-SPY macros. See Macro Quicklaunch window,
page 305.

A macro can be connected to a breakpoint; when the breakpoint is triggered the
macro is executed. For an example, see Executing a macro by connecting it to a
breakpoint, page 258.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to execute your macro.
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REGISTERING AND EXECUTING USING SETUP MACROS AND
SETUP FILES

It can be convenient to register a macro file during the C-SPY startup sequence. To do
this, specify a macro file which you load before starting the debug session. Your macro
functions will be automatically registered each time you start the debugger.

If you use the reserved setup macro function names to define the macro functions, you
can define exactly at which stage you want the macro function to be executed.

To define a setup macro function and load it during C-SPY startup:
Create a new text file where you can define your macro function.
For example:

execUserSetup ()
{

_ _registerMacroFile("MyMacroUtils.mac") ;
_ _registerMacroFile("MyDeviceSimulation.mac") ;

}

This macro function registers the additional macro files MyMacroUtils.mac and
MyDeviceSimulation.mac. Because the macro function is defined with the function
name execUserSetup, it will be executed directly after your application has been
downloaded.

Save the file using the filename extension mac.

Before you start C-SPY, choose Project>Options>Debugger>Setup. Select Use
Setup file and choose the macro file you just created.

The macros will now be registered during the C-SPY startup sequence.

EXECUTING MACROS USING QUICK WATCH

The Quick Watch window lets you dynamically choose when to execute a macro
function.

Consider this simple macro function that checks the status of a timer enable bit:

TimerStatus ()
{
if ((TimerStatreg & 0x01) != 0)/* Checks the status of reg */
return "Timer enabled"; /* C-SPY macro string used */
else
return "Timer disabled"; /* C-SPY macro string used */
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Save the macro function using the filename extension mac.

To load the macro file, choose View>Macros>Macro Registration. The Macro
Registration window is displayed. Click Add and locate the file using the file browser.
The macro file appears in the list of macros in the Macro Registration window.

Select the macro you want to register and your macro will appear in the Debugger
Macros window.

Choose View>Quick Watch to open the Quick Watch window, type the macro call
TimerStatus () in the text field and press Return,

Alternatively, in the macro file editor window, select the macro function name
TimerStatus (). Right-click, and choose Quick Watch from the context menu that
appears.

Quick Watch =]
@ TimerStatus]] -
Expression Yalue Location Type
TimerStatus() 'Timer disabled® macro string

The macro will automatically be displayed in the Quick Watch window.

For more information, see Quick Watch window, page 106.

EXECUTING A MACRO BY CONNECTINGITTO A
BREAKPOINT

You can connect a macro to a breakpoint. The macro will then be executed when the
breakpoint is triggered. The advantage is that you can stop the execution at locations of
particular interest and perform specific actions there.

For instance, you can easily produce log reports containing information such as how the
values of variables, symbols, or registers change. To do this you might set a breakpoint
on a suspicious location and connect a log macro to the breakpoint. After the execution
you can study how the values of the registers have changed.

To create a log macro and connect it to a breakpoint:
Assume this skeleton of a C function in your application source code:

int fact(int x)
{

}
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2 Create a simple log macro function like this example:

logfact ()
{
__message "fact(" ,x, ")";

}
The __message statement will log messages to the Log window.
Save the macro function in a macro file, with the filename extension mac.

3 To register the macro, choose View>Macros>Macro Registration to open the Macro
Registration window and add your macro file to the list. Select the file to register it.
Your macro function will appear in the Debugger Macros window.

4 To set a code breakpoint, click the Toggle Breakpoint button on the first statement
within the function fact in your application source code. Choose View>Breakpoints
to open the Breakpoints window. Select your breakpoint in the list of breakpoints and
choose the Edit command from the context menu.

5 To connect the log macro function to the breakpoint, type the name of the macro
function, logfact (), in the Action field and click Apply. Close the dialog box.

6 Execute your application source code. When the breakpoint is triggered, the macro
function will be executed. You can see the result in the Log window.

o Note that the expression in the Action field is evaluated only when the breakpoint
causes the execution to really stop. If you want to log a value and then automatically
continue execution, you can either:

Use a Log breakpoint, see Log breakpoints dialog box, page 138

o Use the Condition field instead of the Action field. For an example, see Performing
a task and continuing execution, page 132.

7 You can easily enhance the log macro function by, for instance, using the __fmessage
statement instead, which will print the log information to a file. For information about
the __fmessage statement, see Formatted output, page 263.

For an example where a serial port input buffer is simulated using the method of
connecting a macro to a breakpoint, see the tutorial Simulating an interrupt in the
Information Center.

ABORTING A C-SPY MACRO

To abort a C-SPY macro:
I Press Ctrl+Shift+. (period) for a short while.

2 A message that says that the macro has terminated is displayed in the Debug Log
window.
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This method can be used if you suspect that something is wrong with the execution, for
example because it seems not to terminate in a reasonable time.

Reference information on the macro language
Reference information about:

Macro functions, page 260
Macro variables, page 260
Macro parameters, page 261
Macro strings, page 261

Macro statements, page 262

Formatted output, page 263.

MACRO FUNCTIONS

C-SPY macro functions consist of C-SPY variable definitions and macro statements
which are executed when the macro is called. An unlimited number of parameters can
be passed to a macro function, and macro functions can return a value on exit.

A C-SPY macro has this form:

macroName (parameterList)
{

macroBody

}

where parameterList is a list of macro parameters separated by commas, and
macroBody is any series of C-SPY variable definitions and C-SPY statements.

Type checking is neither performed on the values passed to the macro functions nor on
the return value.
MACRO VARIABLES

A macro variable is a variable defined and allocated outside your application. It can then
be used in a C-SPY expression, or you can assign application data—values of the
variables in your application—to it. For more information about C-SPY expressions, see
C-SPY expressions, page 88.

The syntax for defining one or more macro variables is:
__var nameList;

where nameList is a list of C-SPY variable names separated by commas.

C-SPY® Debugging Guide
260 for V850
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A macro variable defined outside a macro body has global scope, and it exists
throughout the whole debugging session. A macro variable defined within a macro body
is created when its definition is executed and destroyed on return from the macro.

By default, macro variables are treated as signed integers and initialized to 0. When a
C-SPY variable is assigned a value in an expression, it also acquires the type of that
expression. For example:

Expression What it means
myvar = 3.5; myvar is now type double, value 3.5.
myvar = (int*)i; myvar is now type pointer to int, and the value is the same as i.

Table 14: Examples of C-SPY macro variables

In case of a name conflict between a C symbol and a C-SPY macro variable, C-SPY
macro variables have a higher precedence than C variables. Note that macro variables
are allocated on the debugger host and do not affect your application.

MACRO PARAMETERS

A macro parameter is intended for parameterization of device support. The named

parameter will behave as a normal C-SPY macro variable with these differences:

o The parameter definition can have an initializer

e Values of a parameters can be set through options (either in the IDE or in cspybat).

o A value set from an option will take precedence over a value set by an initializer

e A parameter must have an initializer, be set through an option, or both. Otherwise, it
has an undefined value, and accessing it will cause a runtime error.

The syntax for defining one or more macro parameters is:

__param param|[ = value, ...;]

Use the command line option --macro_param to specify a value to a parameter, see
--macro_param, page 316.

MACRO STRINGS

In addition to C types, macro variables can hold values of macro strings. Note that
macro strings differ from C language strings.

When you write a string literal, such as "Hello! ", in a C-SPY expression, the value is
a macro string. It is not a C-style character pointer char*, because char* must point to
a sequence of characters in target memory and C-SPY cannot expect any string literal to
actually exist in target memory.

You can manipulate a macro string using a few built-in macro functions, for example
__strFind or __subString. The result can be a new macro string. You can
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concatenate macro strings using the + operator, for example str + "tail". You can
also access individual characters using subscription, for example s##[3]. You can get the
length of a string using sizeof (str). Note that a macro string is not
NULL-terminated.

The macro function __toString is used for converting from a NULL-terminated C
string in your application (char* or char []) to a macro string. For example, assume
this definition of a C string in your application:

char const *cstr = "Hello";

Then examine these macro examples:

__var str; /* A macro variable */

str = cstr /* str is now just a pointer to char */

sizeof str /* same as sizeof (char*), typically 2 or 4 */
str = __toString(cstr,512) /* str is now a macro string */
sizeof str /* 5, the length of the string */

str[l] /* 101, the ASCII code for 'e' */

str += " World!" /* str is now "Hello World!" */

See also Formatted output, page 263.

MACRO STATEMENTS

Statements are expected to behave in the same way as the corresponding C statements
would do. The following C-SPY macro statements are accepted:

Expressions
expression;

For more information about C-SPY expressions, see C-SPY expressions, page 88.

Conditional statements

if (expression)
Sstatement

if (expression)
statement
else
statement

C-SPY® Debugging Guide
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Loop statements

for (init_expression; cond_expression; update_expression)
statement

while (expression)
statement

do
Sstatement
while (expression);

Return statements
return;

return expression;

If the return value is not explicitly set, signed int 0 is returned by default.

Blocks

Statements can be grouped in blocks.

{
statementl
statement2

statementN

FORMATTED OUTPUT

C-SPY provides various methods for producing formatted output:

__message argList; Prints the output to the Debug Log window.
__fmessage file, argList; Prints the output to the designated file.

__smessage argList; Returns a string containing the formatted output.

where argList is acomma-separated list of C-SPY expressions or strings, and £ileis
the result of the __openFile system macro, see _ openkFile, page 280.
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To produce messages in the Debug Log window:

varl = 42;
var2 = 37;
__message "This line prints the values ", varl, " and ", var2,

" in the Log window.";

This produces this message in the Log window:

This line prints the values 42 and 37 in the Log window.
To write the output to a designated file:

__fmessage myfile, "Result is ", res, "!\n";

To produce strings:

myMacroVar = __smessage 42, " is the answer.";

myMacroVar now contains the string "42 is the answer.".

Specifying display format of arguments

To override the default display format of a scalar argument (number or pointer) in
argList, suffix it with a : followed by a format specifier. Available specifiers are:

%b for binary scalar arguments

%0 for octal scalar arguments

sd for decimal scalar arguments

X for hexadecimal scalar arguments
%c for character scalar arguments

These match the formats available in the Watch and Locals windows, but number
prefixes and quotes around strings and characters are not printed. Another example:

__message "The character '", cvar:%c, "' has the decimal value
", cvar;

Depending on the value of the variables, this produces this message:
The character 'A' has the decimal value 65

Note: A character enclosed in single quotes (a character literal) is an integer constant
and is not automatically formatted as a character. For example:

__message 'A', " is the numeric value of the character ",
'A':%C;
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would produce:
65 is the numeric value of the character A

Note: The default format for certain types is primarily designed to be useful in the
Watch window and other related windows. For example, a value of type char is
formatted as 'A' (Ox41), while a pointer to a character (potentially a C string) is
formatted as 0x8102 "Hello", where the string part shows the beginning of the string
(currently up to 60 characters).

When printing a value of type char*, use the $x format specifier to print just the pointer
value in hexadecimal notation, or use the system macro __toString to get the full
string value.

Reference information on reserved setup macro function names

There are reserved setup macro function names that you can use for defining your setup
macro functions. By using these reserved names, your function will be executed at
defined stages during execution. For more information, see Briefly about setup macro
functions and files, page 254.

Reference information about:

execUserPreload
execUserExecutionStarted

execUserExecutionStopped

execUserPreReset

[}

[ J

[}

® execUserSetup
[ J

® execUserReset
[}

execUserExit

execUserPreload
Syntax execUserPreload
For use with All C-SPY drivers.
Description Called after communication with the target system is established but before

downloading the target application.

Implement this macro to initialize memory locations and/or registers which are vital for
loading data properly.
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execUserExecutionStarted

Syntax
For use with

Description

execUserExecutionStarted

All C-SPY drivers.

Called when the debugger is about to start or resume execution. The macro is not called
when performing a one-instruction assembler step, in other words, Step or Step Into in
the Disassembly window.

execUserExecutionStopped

Syntax
For use with

Description

execUserSetup

Syntax
For use with

Description
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execUs erExecutionStopped
All C-SPY drivers.

Called when the debugger has stopped execution. The macro is not called when
performing a one-instruction assembler step, in other words, Step or Step Into in the
Disassembly window.

execUserSetup
All C-SPY drivers.

Called once after the target application is downloaded.

Implement this macro to set up the memory map, breakpoints, interrupts, register macro
files, etc.

If you define interrupts or breakpoints in a macro file that is executed at system start
(using execUserSetup) we strongly recommend that you also make sure that they are
removed at system shutdown (using execUserExit). An example is available in
SetupSimple.mac, see the tutorials in the Information Center.

The reason for this is that the simulator saves interrupt settings between sessions and if
they are not removed they will get duplicated every time execUserSetup is executed
again. This seriously affects the execution speed.



execUserPreReset

Syntax
For use with

Description

execUserReset

Syntax
For use with

Description

execUserExit

Syntax
For use with

Description
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execUserPreReset

All C-SPY drivers.

Called each time just before the reset command is issued.

Implement this macro to set up any required device state.

execUserReset
All C-SPY drivers.

Called each time just after the reset command is issued.

Implement this macro to set up and restore data.

execUserExit

All C-SPY drivers.

Called once when the debug session ends.

Implement this macro to save status data etc.

Reference information on C-SPY system macros

This section gives reference information about each of the C-SPY system macros.
This table summarizes the pre-defined system macros:

Macro Description

__cancelAllInterrupts Cancels all ordered interrupts

__cancelInterrupt Cancels an interrupt
__clearBreak Clears a breakpoint
__closeFile Closes a file that was opened by __openFile

Table 15: Summary of system macros
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Macro

Description

__delay
__disablelInterrupts
__driverType
__enableInterrupts

__evaluate

__fillMemory8
__fillMemorylé6
__fillMemory32
__1isBatchMode
__loadImage

__memoryRestore

_ _memorySave

__messageBoxYesCancel

_ _messageBoxYesNo
__openFile

__orderInterrupt

__popSimulatorInterruptExecu

tingStack
__readFile
__readFileByte

__readMemorys8,
__readMemoryByte

__readMemoryl6

__readMemory32

__registerMacroFile
__resetFile
__setCodeBreak

__setDhataBreak

Delays execution

Disables generation of interrupts
Verifies the driver type

Enables generation of interrupts

Interprets the input string as an expression and
evaluates it.

Fills a specified memory area with a byte value.
Fills a specified memory area with a 2-byte value.
Fills a specified memory area with a 4-byte value.
Checks if C-SPY is running in batch mode or not.
Loads an image.

Restores the contents of a file to a specified
memory zone

Saves the contents of a specified memory area to a
file

Displays a Yes/Cancel dialog box for user interaction
Displays a Yes/No dialog box for user interaction
Openis a file for I/O operations

Generates an interrupt

Informs the interrupt simulation system that an
interrupt handler has finished executing

Reads from the specified file
Reads one byte from the specified file

Reads one byte from the specified memory location

Reads two bytes from the specified memory
location

Reads four bytes from the specified memory
location

Registers macros from the specified file
Rewinds a file opened by __openFile
Sets a code breakpoint

Sets a data breakpoint

Table 15: Summary of system macros (Continued)
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Macro Description

__setDatalLogBreak Sets a data log breakpoint

_ _setLogBreak Sets a log breakpoint

__setSimBreak Sets a simulation breakpoint
__setTraceStartBreak Sets a trace start breakpoint
__setTraceStopBreak Sets a trace stop breakpoint
__sourcePosition Returns the file name and source location if the

current execution location corresponds to a source
location

__strFind Searches a given string for the occurrence of
another string

__subString Extracts a substring from another string
_ _targetDebuggerVersion Returns the version of the target debugger
__toLower Returns a copy of the parameter string where all the

characters have been converted to lower case
__toString Prints strings

_toUpper Returns a copy of the parameter string where all the

characters have been converted to upper case

__unloadImage Unloads a debug image

__writeFile Werites to the specified file

__writeFileByte Werites one byte to the specified file

__writeMemoryS$, Writes one byte to the specified memory location

__writeMemoryByte

__writeMemoryl6 Writes a two-byte word to the specified memory
location

__writeMemory32 Writes a four-byte word to the specified memory
location

Table 15: Summary of system macros (Continued)

__cancelAlllnterrupts
Syntax __cancelAllInterrupts ()
Return value int 0
For use with The C-SPY Simulator.
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Description Cancels all ordered interrupts.
__cancellnterrupt

Syntax __cancelInterrupt (interrupt_id)

Parameters interrupt_id

The value returned by the corresponding __orderInterrupt macro call
(unsigned long).

Return value

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 16: __cancellnterrupt return values

For use with The C-SPY Simulator.

Description Cancels the specified interrupt.
__clearBreak

Syntax __clearBreak (break_id)

Parameters break_id

The value returned by any of the set breakpoint macros.

Return value int 0

For use with All C-SPY drivers.

Description Clears a user-defined breakpoint.
See also Breakpoints, page 123.

C-SPY® Debugging Guide
270 for V850



__closeFile

Syntax

Parameters

Return value
For use with

Description

__delay

Syntax

Parameters

Return value
For use with

Description

__disablelnterrupts

Syntax

Return value

For use with

Description
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__closeFile(fileHandle)

fileHandle
A macro variable used as filehandle by the __openFile macro.

int 0
All C-SPY drivers.

Closes a file previously opened by __openFile.

_delay(value)

value

The number of milliseconds to delay execution.
int 0
All C-SPY drivers.

Delays execution the specified number of milliseconds.

__disableInterrupts|()

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 17: __disablelnterrupts return values
The C-SPY Simulator.

Disables the generation of interrupts.
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__driverType

__enablelnterrupts
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Syntax

Parameters

Return value

For use with

Description

Example

Syntax

Return value

For use with

__driverType (driver_id)

driver_id

A string corresponding to the driver you want to check for. Choose one of these:
"sim" corresponds to the simulator driver.

"iecube" corresponds to the C-SPY IECUBE driver.

"iec2mice2r" corresponds to the C-SPY IECUBE2 Emulator driver.
"minicube" corresponds to the C-SPY MINICUBE Emulator driver.
"minicube2" corresponds to the C-SPY MINICUBE?2 Emulator driver.

"tkserial" corresponds to the C-SPY TK-V850 Emulator driver.

Result Value
Successful 1
Unsuccessful 0

Table 18: __driverType return values
All C-SPY drivers

Checks to see if the current C-SPY driver is identical to the driver type of the
driver_id parameter.

__driverType("sim")

If the simulator is the current driver, the value 1 is returned. Otherwise 0 is returned.

__enableInterrupts()

Result Value

Successful int 0

Unsuccessful Non-zero error number

Table 19: __enablelnterrupts return values

The C-SPY Simulator.
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Description Enables the generation of interrupts.
__evaluate

Syntax __evaluate(string, valuePtr)

Parameters string

Expression string.

valuePtr

Pointer to a macro variable storing the result.

Return value

Result Value
Successful int 0
Unsuccessful int 1

Table 20: __evaluate return values
For use with All C-SPY drivers.

Description This macro interprets the input string as an expression and evaluates it. The result is
stored in a variable pointed to by valuePtr.

Example This example assumes that the variable i is defined and has the value 5:
__evaluate("i + 3", &myVar)

The macro variable myvar is assigned the value 8.

__fillMemory8
Syntax __fillMemory8 (value, address, zone, length, format)
Parameters value

An integer that specifies the value.

address

An integer that specifies the memory start address.

zone

A string that specifies the memory zone, see C-SPY memory zones, page 150.
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Return value
For use with
Description

Example

__fillMemoryl 6

Syntax

Parameters
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length
An integer that specifies how many bytes are affected.

format

One of these alternatives:

Copy value will be copied to the specified memory area.

AND An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.

OR An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.

XOR An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.

int 0
All C-SPY drivers.
Fills a specified memory area with a byte value.

__fillMemory8(0x80, 0x700, "Memory", 0x10, "OR");

__fillMemorylé6 (value, address, zone, length, format)
value
An integer that specifies the value.

address
An integer that specifies the memory start address.

zone

A string that specifies the memory zone, see C-SPY memory zones, page 150.

length
An integer that defines how many 2-byte entities to be affected.

format
One of these alternatives:



Return value
For use with
Description

Example

__fillMemory32

Syntax

Parameters

Copy

AND

OR

XOR

int 0

All C-SPY drivers.

C-SPY macros __4

value will be copied to the specified memory area.

An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.

An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.

An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.

Fills a specified memory area with a 2-byte value.

__fillMemoryl6 (0xCDCD, 0x7000, "Memory", 0x200, "Copy"):;

__fillMemory32 (value, address, zone, length, format)

value

An integer that specifies the value.

address

An integer that specifies the memory start address.

zone

A string that specifies the memory zone, see C-SPY memory zones, page 150.

length

An integer that defines how many 4-byte entities to be affected.

format

One of these alternatives:

Copy

AND

value will be copied to the specified memory area.

An AND operation will be performed between value
and the existing contents of memory before writing
the result to memory.
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OR An OR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

XOR An XOR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

Return value int 0

For use with All C-SPY drivers.

Description Fills a specified memory area with a 4-byte value.

Example __fillMemory32 (0x0000FFFF, 0x4000, "Memory", 0x1000, "XOR");
__isBatchMode

Syntax __isBatchMode ()

Return value

Result Value
True int 1
False int 0

Table 21: __isBatchMode return values

For use with All C-SPY drivers.
Description This macro returns True if the debugger is running in batch mode, otherwise it returns
False.
__loadlmage
Syntax __loadImage(path, offset, debugInfoOnly)
Parameters path

A string that identifies the path to the image to download. The path must either
be absolute or use argument variables. For information about argument
variables, see the IDE Project Management and Building Guide.
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offset
An integer that identifies the offset to the destination address for the downloaded
image.

debugInfoOnly

A non-zero integer value if no code or data should be downloaded to the target
system, which means that C-SPY will only read the debug information from the
debug file. Or, 0 (zero) for download.

Return value
Value Result

Non-zero integer number A unique module identification.

int 0 Loading failed.

Table 22: __loadlmage return values

For use with All C-SPY drivers.
Description Loads an image (debug file).
Example | Your system consists of a ROM library and an application. The application is your active

project, but you have a debug file corresponding to the library. In this case you can add
this macro call in the execUserSetup macro in a C-SPY macro file, which you
associate with your project:

__loadImage (ROMfile, 0x8000, 1);

This macro call loads the debug information for the ROM library rOM£1i 1e without
downloading its contents (because it is presumably already in ROM). Then you can
debug your application together with the library.

Example 2 Your system consists of a ROM library and an application, but your main concern is the
library. The library needs to be programmed into flash memory before a debug session.
While you are developing the library, the library project must be the active project in the
IDE. In this case you can add this macro call in the execUserSetup macro in a C-SPY
macro file, which you associate with your project:

__loadImage(ApplicationFile, 0x8000, 0);

The macro call loads the debug information for the application and downloads its
contents (presumably into RAM). Then you can debug your library together with the
application.

See also Images, page 325 and Loading multiple images, page 43.
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__memoryRestore
Swﬁax __memoryRestore (zone, filename)
Parameters zone
A string that specifies the memory zone, see C-SPY memory zones, page 150.
filename
A string that specifies the file to be read. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the IDE Project Management and Building Guide.
Return value int 0
For use with All C-SPY drivers.
Description Reads the contents of a file and saves it to the specified memory zone.
Exmnpk _ _memoryRestore ("Memory", "c:\\temp\\saved_memory.hex") ;
See also Memory Restore dialog box, page 164.
__memorySave
Swwax __memorySave (start, stop, format, filename)
Parameters start

A string that specifies the first location of the memory area to be saved.

stop
A string that specifies the last location of the memory area to be saved.

format

A string that specifies the format to be used for the saved memory. Choose
between:

intel-extended
motorola
motorola-sl19
motorola-s28

motorola-s37.
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filename
A string that specifies the file to write to. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the IDE Project Management and Building Guide.

Return value int 0

For use with All C-SPY drivers.

Description Saves the contents of a specified memory area to a file.

Example __memorySave ("Memory:0x00", "Memory:0xFF", "intel-extended",

"c:\\temp\\saved_memory.hex") ;

See also Memory Save dialog box, page 163.

__messageBoxYesCancel

Syntax __messageBoxYesCancel (string message, string caption)

Parameters message
A message that will appear in the message box.
caption

The title that will appear in the message box.

Return value

Result Value
Yes 1
No 0

Table 23: __messageBoxYesCancel return values
For use with All C-SPY drivers.
Description Displays a Yes/Cancel dialog box when called and returns the user input. Typically, this

is useful for creating macros that require user interaction.

__messageBoxYesNo

Syntax __messageBoxYesNo (string message, string caption)
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Parameters

Return value

For use with

Description

__openFile
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Syntax

Parameters

message
A message that will appear in the message box.
caption

The title that will appear in the message box.

Result Value
Yes 1
No 0

Table 24: __messageBoxYesNo return values

All C-SPY drivers.

Displays a Yes/No dialog box when called and returns the user input. Typically, this is
useful for creating macros that require user interaction.

__openFile(filename, access)

filename

The file to be opened. The filename must include a path, which must either be
absolute or use argument variables. For information about argument variables,
see the IDE Project Management and Building Guide.

access

The access type (string).

These are mandatory but mutually exclusive:

"a" append, new data will be appended at the end of the open file

"r" read (by default in text mode; combine with b for binary mode: rb)
"w" write (by default in text mode; combine with b for binary mode: wb)
These are optional and mutually exclusive:

"b" binary, opens the file in binary mode

"t ASCII text, opens the file in text mode



Return value

For use with

Description

Example

See also

__orderinterrupt

Syntax

Parameters
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This access type is optional:

"+ together with r, w, or a; r+ or w+ is read and write, while a+ is read and

append
Result Value
Successful The file handle
Unsuccessful An invalid file handle, which tests as False

Table 25: __openFile return values
All C-SPY drivers.

Opens a file for I/O operations. The default base directory of this macro is where the
currently open project file (* . ewp) is located. The argument to __openFile can
specify a location relative to this directory. In addition, you can use argument variables
such as $PROJ_DIRS$ and $TOOLKIT_DIRS in the path argument.

__var myFileHandle; /* The macro variable to contain */
/* the file handle */

myFileHandle = __openFile("$PROJ_DIRS\\Debug\\Exe\\test.tst",

"r");

if (myFileHandle)

{

/* successful opening */

For information about argument variables, see the IDE Project Management and
Building Guide.

__orderInterrupt (specification, first_activation,
repeat_interval, variance, infinite_hold time,
hold_time, probability)

specification
The interrupt (string). The specification can either be the full specification used
in the device description file (dd£) or only the name. In the latter case the
interrupt system will automatically get the description from the device
description file.

281



Reference information on C-SPY system macros

Return value

For use with
Description

Example

first_activation

The first activation time in cycles (integer)

repeat_interval

The periodicity in cycles (integer)

variance

The timing variation range in percent (integer between 0 and 100)

infinite_hold_time

1 if infinite, otherwise 0.

hold_time
The hold time (integer)

probability
The probability in percent (integer between 0 and 100)

The macro returns an interrupt identifier (unsigned long).

If the syntax of specificationis incorrect, it returns -1.
The C-SPY Simulator.
Generates an interrupt.

This example generates a repeating interrupt using an infinite hold time first activated
after 4000 cycles:

__orderInterrupt( "INTCC1l10", 4000, 2000, O, O, 100, 50 );

__popSimulatorinterruptExecutingStack

Syntax
Return value
For use with

Description
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_ _popSimulatorInterruptExecutingStack (void)
int 0
The C-SPY Simulator.

Informs the interrupt simulation system that an interrupt handler has finished executing,
as if the normal instruction used for returning from an interrupt handler was executed.

This is useful if you are using interrupts in such a way that the normal instruction for
returning from an interrupt handler is not used, for example in an operating system with
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task-switching. In this case, the interrupt simulation system cannot automatically detect
that the interrupt has finished executing.

See also Simulating an interrupt in a multi-task system, page 239.
__readFile

Syntax __readFile(fileHandle, valuePtr)

Parameters fileHandle

A macro variable used as filehandle by the __openFile macro.

valuePtr

A pointer to a variable.

Return value

Result Value
Successful 0
Unsuccessful Non-zero error number

Table 26: __readFile return values
For use with All C-SPY drivers.

Description Reads a sequence of hexadecimal digits from the given file and converts them to an
unsigned long which is assigned to the value parameter, which should be a pointer
to a macro variable.

Only printable characters representing hexadecimal digits and white-space characters
are accepted, no other characters are allowed.

Example __var number;
if (__readFile(myFileHandle, &number) == 0)
{
// Do something with number

}

In this example, if the file pointed to by myFileHandle contains the ASCII characters
1234 abcd 90ef, consecutive reads will assign the values 0x1234 0Oxabcd 0x90ef
to the variable number.
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__readFileByte
Syntax __readFileByte (fileHandle)
Parameters fileHandle
A macro variable used as filehandle by the __openFile macro.
Return value -1 upon error or end-of-file, otherwise a value between 0 and 255.
For use with All C-SPY drivers.
Description Reads one byte from a file.
Example __var byte;

while ( (byte = __readFileByte (myFileHandle)) != -1 )
{
/* Do something with byte */

__readMemory8, __readMemoryByte

Syntax __readMemory8 (address, zone)
__readMemoryByte (address, zone)

Parameters address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value The macro returns the value from memory.
For use with All C-SPY drivers.
Description Reads one byte from a given memory location.
Example _ _readMemory$8 (0x0108, "Memory") ;
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__readMemoryl 6

Syntax __readMemorylé6 (address, zone)
Parameters address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value The macro returns the value from memory.
For use with All C-SPY drivers.
Description Reads a two-byte word from a given memory location.
Example __readMemoryl6 (0x0108, "Memory");

__readMemory32

Syntax __readMemory32 (address, zone)
Parameters address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value The macro returns the value from memory.
For use with All C-SPY drivers.
Description Reads a four-byte word from a given memory location.
Example __readMemory32 (0x0108, "Memory") ;
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__registerMacroFile

Syntax __registerMacroFile(filename)

Parameters filename
A file containing the macros to be registered (string). The filename must include
a path, which must either be absolute or use argument variables. For information
about argument variables, see the /DE Project Management and Building

Guide.
Return value int 0
For use with All C-SPY drivers.
Description Registers macros from a setup macro file. With this function you can register multiple

macro files during C-SPY startup.

Example __registerMacroFile("c:\\testdir\\macro.mac") ;
See also Using C-SPY macros, page 255.
__resetFile
Syntax __resetFile(fileHandle)
Parameters fileHandle

A macro variable used as filehandle by the __openFile macro.

Return value int 0
For use with All C-SPY drivers.
Description Rewinds a file previously opened by __openFile.
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__setCodeBreak
Syntax __setCodeBreak(location, count, condition, cond_type, action)
Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 146.

count
The number of times that a breakpoint condition must be fulfilled before a break
occurs (integer).

condition

The breakpoint condition (string).

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 27: __setCodeBreak return values
For use with All C-SPY drivers.

Description Sets a code breakpoint, that is, a breakpoint which is triggered just before the processor
fetches an instruction at the specified location.

Examples __setCodeBreak ("{D:\\src\\prog.c}.12.9", 3, "d>16", "TRUE",
"ActionCode()");

This example sets a code breakpoint on the label main in your source:

__setCodeBreak("main", 0, "1", "TRUE", "");

See also Breakpoints, page 123.
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__setDataBreak

Syntax

Parameters

Return value

For use with

Description

Example
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__setDataBreak(location, count, condition, cond_type, access,

action)

location
A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
more information about the location types, see Enter Location dialog box, page
25.

count
The number of times that a breakpoint condition must be fulfilled before a break
occurs (integer).

condition

The breakpoint condition (string).
cond_type
The condition type; either "CHANGED" or "TRUE" (string).

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 28: __setDataBreak return values
The C-SPY Simulator.

Sets a data breakpoint, that is, a breakpoint which is triggered directly after the processor
has read or written data at the specified location.

__var brk;
brk = __setDataBreak("Memory:0x4710", 3, "d>6", "TRUE",

"W", "ActionData()");

__clearBreak (brk) ;



See also

__setDatalLogBreak

Syntax

Parameters

Return value

For use with

Description

Example

See also

C-SPY macros __4

Breakpoints, page 123.

__setDataLogBreak (variable, access)

variable

A string that defines the variable the breakpoint is set on, a variable of integer
type with static storage duration. The microcontroller must also be able to
access the variable with a single-instruction memory access, which means that
you can only set data log breakpoints on 8-, 16-, and 32-bit variables.

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 29: __setDatalLogBreak return values

The C-SPY Simulator.

Sets a data log breakpoint, that is, a breakpoint which is triggered when a specified
variable is accessed. Note that a data log breakpoint does not stop the execution, it just

generates a data log.

var brk;

brk = __setDataLogBreak ("MyVar", "R");
__clearBreak (brk) ;

Breakpoints, page 123 and Getting started using data logging, page 93.
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__setLogBreak

Syntax

Parameters

Return value

For use with

Description
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__setLogBreak (location, message, msg_type, condition,
cond_type)

location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 146.

message

The message text.

msg_type
The message type; choose between:

TEXT, the message is written word for word.

ARGS, the message is interpreted as a comma-separated list of C-SPY
expressions or strings.

condition

The breakpoint condition (string).

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful 0

Table 30: __setLogBreak return values
All C-SPY drivers.

Sets a log breakpoint, that is, a breakpoint which is triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will temporarily halt and
print the specified message in the C-SPY Debug Log window.



Example

See also

__setSimBreak

Syntax

Parameters

Return value

For use with
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__var logBpl;
__var logBp2;
logOn ()
{
logBpl = __setLogBreak ("{C:\\temp\\Utilities.c}.23.1",
"\"Entering trace zone at :\", #PC:%X", "ARGS", "1", "TRUE");
logBp2 = __setLogBreak ("{C:\\temp\\Utilities.c}.30.1",
"Leaving trace zone...", "TEXT", "1", "TRUE");
}
logOff ()

{
__clearBreak(logBpl) ;
__clearBreak (logBp2) ;

Formatted output, page 263 and Breakpoints, page 123.

__setSimBreak(location, access, action)

location

A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
more information about the location types, see Enter Location dialog box, page
146.

access

The memory access type: "R" for read or "w" for write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 31: __setSimBreak return values

The C-SPY Simulator.
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Description Use this system macro to set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
processor is about to read data from a location or immediately after it has written data.
Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the processor reads at a
memory-mapped location, a C-SPY macro function can intervene and supply the
appropriate data. Conversely, when the processor writes to a memory-mapped location,
a C-SPY macro function can act on the value that was written.

__setTraceStartBreak
Syntax __setTraceStartBreak (location)
Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 146.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful 0

Table 32: __setTraceStartBreak return values
For use with The C-SPY Simulator.

Description Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is started.

C-SPY® Debugging Guide
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Example __var startTraceBp;
__var stopTraceBp;

traceOn ()
{
startTraceBp = __setTraceStartBreak
("{C:\\TEMP\\Utilities.c}.23.1");
stopTraceBp = __setTraceStopBreak

("{C:\\temp\\Utilities.c}.30.1");

traceOff ()

{
__clearBreak(startTraceBp) ;
__clearBreak (stopTraceBp) ;

See also Breakpoints, page 123.
__setTraceStopBreak

Syntax __setTraceStopBreak (location)

Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 146.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful int 0

Table 33: __setTraceStopBreak return values
For use with The C-SPY Simulator.

Description Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is stopped.

Example See _setTraceStartBreak, page 292.
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See also Breakpoints, page 123.
__sourcePosition

Syntax __sourcePosition(linePtr, colPtr)

Parameters linePtr

Pointer to the variable storing the line number

colPtr
Pointer to the variable storing the column number

Return value

Result Value
Successful Filename string
Unsuccessful Empty (" ") string

Table 34: __sourcePosition return values
For use with All C-SPY drivers.

Description If the current execution location corresponds to a source location, this macro returns the
filename as a string. It also sets the value of the variables, pointed to by the parameters,
to the line and column numbers of the source location.

__strFind
Syntax __strFind(macroString, pattern, position)
Parameters macroString
A macro string.
pattern
The string pattern to search for
position
The position where to start the search. The first position is 0
Return value The position where the pattern was found or -1 if the string is not found.
For use with All C-SPY drivers.

C-SPY® Debugging Guide
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Description This macro searches a given string (macroString) for the occurrence of another string
(pattern).

Example __strFind("Compiler", "pile", 0) = 3
__strFind("Compiler", "foo", 0) = -1

See also Macro strings, page 261.

__subString
Syntax __subString (macroString, position, length)
Parameters macroString

A macro string.
position
The start position of the substring. The first position is 0.

length
The length of the substring

Return value A substring extracted from the given macro string.

For use with All C-SPY drivers.

Description This macro extracts a substring from another string (macroString).
Example __subString("Compiler", 0, 2)

The resulting macro string contains Co.
__subString("Compiler", 3, 4)

The resulting macro string contains pile.

See also Macro strings, page 261.

__targetDebuggerVersion

Syntax __targetDebuggerVersion ()
Return value A string that represents the version number of the C-SPY debugger processor module.
For use with All C-SPY drivers.
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Description

Example

__toLower

Syntax

Parameters

Return value
For use with

Description

Example

See also

__toString

Syntax

Parameters

Return value

For use with
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This macro returns the version number of the C-SPY debugger processor module.

__var toolVer;
toolVer =
__message

__targetDebuggerVersion() ;
"The target debugger version 1is,

__toLower (macroString)

macroString

A macro string.
The converted macro string.

All C-SPY drivers.

This macro returns a copy of the parameter macroString where all the characters have

been converted to lower case.

__toLower ("IAR")
The resulting macro string contains iar.
__toLower ("Mix42")

The resulting macro string contains mix42.

Macro strings, page 261.

__toString(C_string, maxlength)

C_string

Any null-terminated C string.

maxlength

"
v

The maximum length of the returned macro string.

Macro string.

All C-SPY drivers.

toolVer;



Description

Example

See also

__toUpper

Syntax

Parameters

Return value
For use with

Description

Example

See also

__unloadlmage

Syntax

Parameters
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This macro is used for converting C strings (char* or char []) into macro strings.

Assuming your application contains this definition:

char const * hptr = "Hello World!";
this macro call:
__toString (hptr, 5)

would return the macro string containing Hello.

Macro strings, page 261.

__toUpper (macroString)

macroString

A macro string.
The converted string.

All C-SPY drivers.

This macro returns a copy of the parameter macroString where all the characters have

been converted to upper case.

_toUpper ("string")

The resulting macro string contains STRING.

Macro strings, page 261.

__unloadImage (module_id)

module_id

An integer which represents a unique module identification, which is retrieved
as a return value from the corresponding __loadImage C-SPY macro.
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Return value

For use with
Description

See also

__writeFile

__writeFileByte

C-SPY® Debugging Guide
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Syntax

Parameters

Return value
For use with

Description

Syntax

Parameters

Value Result

module_id A unique module identification (the same as the input
parameter).

int 0 The unloading failed.

Table 35: __unloadlmage return values
All C-SPY drivers.
Unloads debug information from an already downloaded image.

Loading multiple images, page 43 and Images, page 325.

__writeFile(fileHandle, value)
fileHandle
A macro variable used as filehandle by the __openFile macro.
value
An integer.
int 0

All C-SPY drivers.

Prints the integer value in hexadecimal format (with a trailing space) to the file file.

Note: The __fmessage statement can do the same thing. The __writeFile macro is
provided for symmetry with __readfFile.

__writeFileByte(fileHandle, value)

fileHandle
A macro variable used as filehandle by the __openFile macro.

value

An integer.
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Return value int 0
For use with All C-SPY drivers.
Description Writes one byte to the file £ileHandle.

__writeMemory8, __writeMemoryByte

Syntax __writeMemory8 (value, address, zone)
__writeMemoryByte(value, address, zone)

Parameters value
An integer.

address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value int 0
For use with All C-SPY drivers.
Description Writes one byte to a given memory location.
Example _ _writeMemory8 (0x2F, 0x8020, "Memory");
__writeMemoryl 6
Syntax __writeMemoryl6 (value, address, zone)
Parameters value
An integer.
address
The memory address (integer).
zone
A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value int 0
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For use with All C-SPY drivers.
Description Writes two bytes to a given memory location.
Example __writeMemoryl6 (0x2FFF, 0x8020, "Memory"):;
__writeMemory32

Syntax __writeMemory32 (value, address, zone)
Parameters value

An integer.

address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 150.
Return value int 0
For use with All C-SPY drivers.
Description Writes four bytes to a given memory location.
Example __writeMemory32 (0x5555FFFF, 0x8020, "Memory");

Graphical environment for macros
Reference information about:
® Macro Registration window, page 301
® Debugger Macros window, page 303
® Macro Quicklaunch window, page 305
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Macro Registration window

The Macro Registration window is available from the View>Macros submenu during a
debug session.

Macro Registration =]
Add Remove Remove Al Reload
File Full Path
V| SetupSimple.mac ChtutonSetupSimple.mac
SetupAdvanced.mac ChtutonSetupAdvanced.mac

Use this window to list, register, and edit your debugger macro files.

Double-click a macro file to open it in the editor window and edit it.

Requirements

None; this window is always available.

Display area

This area contains these columns:

File
The name of an available macro file. To register the macro file, select the check
box to the left of the filename. The name of a registered macro file appears in
bold style.

Full path

The path to the location of the added macro file.
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Context menu
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This context menu is available:
Add...

Remove
Rermove All

Reload
Open File

Open Debugger Macros Window

These commands are available:

Add
Opens a file browser where you can locate the macro file that you want to add
to the list. This menu command is also available as a function button at the top
of the window.

Remove

Removes the selected debugger macro file from the list. This menu command is
also available as a function button at the top of the window.

Remove All

Removes all macro files from the list. This menu command is also available as
a function button at the top of the window.

Reload

Registers the selected macro file. Typically, this is useful when you have edited
a macro file. This menu command is also available as a function button at the
top of the window.

Open File
Opens the selected macro file in the editor window.

Open Debugger Macros Window
Opens the Debugger Macros window.
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Debugger Macros window

Requirements

Display area

The Debugger Macros window is available from the View>Macro submenu during a

debug session.

Debugger Macros |
MName Parameters File i
Access i} SetupSimple.mac =
__cancelAllinterrupts i}

__cancellnterrupt {inf)
__clearBreak {id)
closeFile file
_delay Eval)ue) Select a macro and
_disablelnterrupts " click Fl for reference
__driverType (string) information -

Use this window to list all registered debugger macro functions, either predefined
system macros or your own. This window is useful when you edit your own macro
functions and want an overview of all available macros that you can use.

Double-clicking a macro defined in a file opens that file in the editor window.

To open a macro in the Macro Quicklaunch window, drag it from the Debugger
Macros window and drop it in the Macro Quicklaunch window.

Select a macro and press F1 to get online help information for that macro.

None; this window is always available.

This area contains these columns:

Name
The name of the debugger macro.

Parameters
The parameters of the debugger macro.

File
For macros defined in a file, the name of the file is displayed. For predefined
system macros, -System Macro- is displayed.
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Context menu
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This context menu is available:

Open File

Add to Quicklaunch Window

User Macros
System Macros

v All Macros

Open Macro Registration Window

These commands are available:
Open File

Opens the selected debugger macro file in the editor window.
Add to Quicklaunch Window

Adds the selected macro to the Macro Quicklaunch window.
User Macros

Lists only the debugger macros that you have defined yourself.
System Macros

Lists only the predefined system macros.
All Macros

Lists all debugger macros, both predefined system macros and your own.

Open Macro Registration Window
Opens the Macro Registration window.
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Macro Quicklaunch window

al'

Requirements

The Macro Quicklaunch window is available from the View menu.

x
Expression Result

testEval()
nval Error (col 1): Unknown or ambiguous symbol. nval
testEval2() 0

s2 = 37
ineVal()

0DOOOO

w

Macro Quicklaunch

Macro Quicklaunch x
Use this window to evaluate expressions, typically C-SPY macros.

For some devices, there are predefined C-SPY macros available with device support,
typically provided by the chip manufacturer. These macros are useful for performing
certain device-specific tasks. The macros are available in the Macro Quicklaunch
window and are easily identified by their green icon,

The Macro Quicklaunch window is similar to the Quick Watch window, but is
primarily designed for evaluating C-SPY macros. The window gives you precise control
over when to evaluate an expression.

To add an expression:
Choose one of these alternatives:

o Drag the expression to the window

e In the Expression column, type the expression you want to examine.

If the expression you add and want to evaluate is a C-SPY macro, the macro must first
be registered, see Using C-SPY macros, page 255.

To evaluate an expression:

Double-click the Recalculate icon to calculate the value of that expression.

None; this window is always available.
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Display area
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Context menu
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This area contains these columns:

Recalculate icon
To evaluate the expression, double-click the icon. The latest evaluated
expression appears in bold style.

Expression
One or several expressions that you want to evaluate. Click <click to add>
to add an expression. If the return value has changed since last time, the value
will be displayed in red.

Result
Shows the return value from the expression evaluation.

This context menu is available:

Evaluate Now
Rermove

Rermove All

These commands are available:

Evaluate Now

Evaluates the selected expression.

Remove
Removes the selected expression.

Remove All
Removes all selected expressions.



The C-SPY command line
utility—cspybat

e Summary of C-SPY command line options

e Reference information on C-SPY command line options.

Using C-SPY in batch mode

You can execute C-SPY in batch mode if you use the command line utility cspybat,
installed in the directory common\bin.

These topics are covered:

e Starting cspybat
e Output

e Invocation syntax

STARTING CSPYBAT

I To start cspybat you must first create a batch file. An easy way to do that is to use one
of the batch files that C-SPY automatically generates when you start C-SPY in the
IDE.

C-SPY generates a batch file projectname. buildconfiguration.cspy.bat every
time C-SPY is initialized. In addition, two more files are generated:

® project.buildconfiguration.general .xcl, which contains options specific
to cspybat.

® project.buildconfiguration.driver.xcl, which contains options specific to
the C-SPY driver you are using.

You can find the files in the directory $PROJ_DIR$\settings. The files contain the
same settings as the IDE, and provide hints about additional options that you can use.

2 To start cspybat, you can use this command line:

project.cspybat.bat [debugfile]
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Note that debugfileis optional. You can specify it if you want to use a different debug
file than the one that is used in the project.buildconfiguration.general .xcl
file.

Before you run cspybat for the first time using an emulator debugger, you
must:

Add the subdirectory v850\config\renesas to the path environment variable.

For example, assuming IAR Embedded Workbench has been installed in the default

location: path=%path%;C:\Program Files\IAR Systems\IAR Embedded
Workbench 7.n\v850\config\renesas

Start the ITAR Embedded Workbench IDE and set up the emulator in the Hardware
Setup dialog box—available from the Emulator menu when you start an emulator
debug session. Save the project. The settings are saved to a file.

Set up the environment variable CSPYBAT_INIFILE to point to the saved hardware
settings file (*.dni) in the settings subdirectory in your project directory.

For example, SET CSPYBAT INIFILE=C:\my_proj\settings\myproject.dni

OUTPUT
When you run cspybat, these types of output can be produced:

e Terminal output from cspybat itself

All such terminal output is directed to stderr. Note that if you run cspybat from
the command line without any arguments, the cspybat version number and all
available options including brief descriptions are directed to stdout and displayed
on your screen.

o Terminal output from the application you are debugging

All such terminal output is directed to stdout, provided that you have used the
--plugin option. See --plugin, page 319.

o Error return codes
cspybat returns status information to the host operating system that can be tested in
abatch file. For successful, the value int 0 is returned, and for unsuccessful the value
int 1 is returned.

INVOCATION SYNTAX

The invocation syntax for cspybat is:

cspybat processor_ DLL driver_DLL debug file
[cspybat_options] --backend driver_ options
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Note: In those cases where a filename is required—including the DLL files—you are
recommended to give a full path to the filename.

Parameters
The parameters are:

Parameter

Description

processor_DLL
driver_ DLL

debug file

cspybat_options

--backend

driver_options

The processor-specific DLL file; available in v850\bin.
The C-SPY driver DLL file; available in v850\bin.

The object file that you want to debug (filename extension d85). See
also —debugfile, page 313.

The command line options that you want to pass to cspybat. Note
that these options are optional. For information about each option,
see Reference information on C-SPY command line options, page 311.

Marks the beginning of the parameters to the C-SPY driver; all
options that follow will be sent to the driver. Note that this option is
mandatory.

The command line options that you want to pass to the C-SPY driver.
Note that some of these options are mandatory and some are
optional. For information about each option, see Reference information
on C-SPY command line options, page 311.

Table 36: cspybat parameters

Summary of C-SPY command line options

Reference information about:

General cspybat options

Options available for all C-SPY drivers

°
°
o Options available for the simulator driver
°

Options available for the C-SPY hardware debugger drivers

GENERAL CSPYBAT OPTIONS

--backend

--code_coverage_file

--cycles

Marks the beginning of the parameters to be sent to the
C-SPY driver (mandatory).

Enables the generation of code coverage information and
places it in a specified file.

Specifies the maximum number of cycles to run.
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--debugfile Specifies an alternative debug file.

--download_only Downloads a code image without starting a debug session
afterwards.

-f Extends the command line.

--leave_running Starts the execution on the target and then exits but leaves

the target running.

--macro Specifies a macro file to be used.
--macro_param Assigns a value to a C-SPY macro parameter.
--plugin Specifies a plugin file to be used.

--silent Onmits the sign-on message.

--timeout Limits the maximum allowed execution time.

OPTIONS AVAILABLE FOR ALL C-SPY DRIVERS

-d Specifies the C-SPY driver to be used.
-p Specifies the device description file to be used.
-v Specifies the CPU type to be used.

OPTIONS AVAILABLE FOR THE SIMULATOR DRIVER

--disable_interrupts Disables the interrupt simulation.

--mapu Activates memory access checking.

OPTIONS AVAILABLE FOR THE C-SPY HARDWARE
DEBUGGER DRIVERS

-c2 Verifies the downloaded executable image.

-el Creates a communication log file.

--emulator_type Specifies that the driver is used with an E1
emulator.

--misaligned_action Specifies the action for a memory access to

misaligned data.

C-SPY® Debugging Guide
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--misaligned notification Specifies the notification method for accesses to
misaligned data.

-n Suppresses download of the executable image.

Reference information on C-SPY command line options

This section gives detailed reference information about each cspybat option and each
option available to the C-SPY drivers.

--backend
Syntax --backend {driver options}
Parameters driver options
Any option available to the C-SPY driver you are using.
For use with cspybat (mandatory).
Description Use this option to send options to the C-SPY driver. All options that follow --backend
will be passed to the C-SPY driver, and will not be processed by cspybat itself.
This option is not available in the IDE.
-c2
Syntax -c2
For use with Any C-SPY hardware debugger driver.
Description Use this option to verify that the downloaded executable image can be read back with

the correct contents.

Project>Options>Debugger>Driver>Setup>Download>Verify




Reference information on C-SPY command line options

312

--code_coverage _file

Syntax

Parameters

For use with

Description

See also

--cycles

Syntax

Parameters

For use with

Description
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--code_coverage_file file
Note that this option must be placed before the - -backend option on the command line.

file
The name of the destination file for the code coverage information.

cspybat

Use this option to enable the generation of code coverage information. The code
coverage information will be generated after the execution has completed and you can
find it in the specified file.

Note that this option requires that the C-SPY driver you are using supports code
coverage. If you try to use this option with a C-SPY driver that does not support code
coverage, an error message will be directed to stderr.

Code coverage, page 227.

To set this option, choose View>Code Coverage, right-click and choose Save As when
the C-SPY debugger is running.

--cycles cycles

Note that this option must be placed before the - -backend option on the command line.

cycles

The number of cycles to run.
cspybat

Use this option to specify the maximum number of cycles to run. If the target program
executes longer than the number of cycles specified, the target program will be aborted.
Using this option requires that the C-SPY driver you are using supports a cycle counter,
and that it can be sampled while executing.

This option is not available in the IDE.



Syntax

Parameters

For use with
Description

See also

--debugfile

Syntax

Parameters

For use with

Description
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-d
{sim|iecube|iecube2-e2r|minicube |minicube-e2r |minicube2 |tkserial}

sim Specifies the C-SPY simulator driver

iecube Specifies the C-SPY IECUBE driver
iecube2-e2r Specifies the C-SPY IECUBE2 driver for E2R
minicube Specifies the C-SPY MINICUBE driver
minicube-e2r  Specifies the C-SPY MINICUBE driver for E2R
minicube2 Specifies the C-SPY MINICUBE?2 driver
tkserial Specifies the C-SPY TK-V850 driver

All C-SPY drivers.

Use this option to specify the C-SPY driver to be used.

--emulator_type

Project>Options>Debugger>Setup>Driver

--debugfile filename

filename

The name of the debug file to use.

cspybat

This option can be placed both before and after the --backend option on the command
line.

Use this option to make cspybat use the specified debugfile instead of the one used in

the generated cpsybat .bat file.

This option is not available in the IDE.
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--disable_interrupts

Syntax
For use with

Description

--download_only

Syntax

For use with

Description

-el

Syntax

Parameters

For use with

Description

--emulator_type

Syntax
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--disable_interrupts
The C-SPY Simulator driver.

Use this option to disable the interrupt simulation.

To set this option, choose Simulator>Interrupt Setup and deselect the Enable
interrupt simulation option.

--download_only

Note that this option must be placed before the - -backend option on the command line.
cspybat

Use this option to download the code image without starting a debug session afterwards.
To set related option, choose:

Project>Options>Debugger>Setup and deselect Run to.

-el filename

filename The name of the log file.

Any C-SPY hardware debugger driver.

Use this option to log the communication between C-SPY and the target system to a file.
To interpret the result, a detailed knowledge of the EXEC interface is required.

Project>Options>Debugger>Driver>Setup>Communication log>Use
communication log file

-emulator_type El1



Parameters

For use with

Description

See also

Syntax

Parameters

For use with

Description

--leave_running

Syntax

For use with

The C-SPY command line utility—cspybat ___¢

El The emulator type.

The C-SPY MINICUBE, MINICUBE?2, and MINICUBE for ER2 drivers.

Specifies that the driver is used with an E1 emulator. Use this option together with the
options -d minicube, -d minicube2, and -d minicube-e2r.
-d

This option is not available in the IDE.

-f filename

filename

A text file that contains the commands (default filename extension xc1).

cspybat

This option can be placed both before and after the - -backend option on the command
line.

Use this option to make cspybat read command line options from the named file.

In the command file, you format the items exactly as if they were on the command line
itself, except that you may use multiple lines, because the newline character is treated
like a space or tab character.

Both C and C++ style comments are allowed in the file. Double quotes behave in the
same way as in the Microsoft Windows command line environment.

To set this option, use Project>Options>Debugger>Extra Options.

--leave_running

Note that this option must be placed before the --backend option on the command line.

cspybat
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Description

=-=mMacro

Syntax

Parameters

For use with

Description

See also

--Macro_param

Syntax

Parameters

For use with

Description

See also
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Makes cspybat start the execution on the target and then exits but leaves the target
running.

This option is not available in the IDE.

--macro filename

Note that this option must be placed before the - -backend option on the command line.

filename

The C-SPY macro file to be used (filename extension mac).
cspybat

Use this option to specify a C-SPY macro file to be loaded before executing the target
application. This option can be used more than once on the command line.

Briefly about using C-SPY macros, page 254.

Project>Options>Debugger>Setup>Setup macros>Use macro file

--macro_param [param=value]

Note that this option must be placed before the --backend option on the command line.

param = value
paramis a parameter defined using the __param C-SPY macro construction.
value is a value.

cspybat

Use this option to assign av value to a C-SPY macro parameter.This option can be used
more than once on the command line.

Macro parameters, page 261.

Project>Options>Debugger>Extra Options



--mapu
Syntax

For use with

Description

See also

--misaligned_action

Syntax

Parameters

For use with

Description

The C-SPY command line utility—cspybat ___¢

--mapu
The C-SPY simulator driver.

Specify this option to use the segment information in the debug file for memory access
checking. During the execution, the simulator will then check for accesses to
unspecified memory ranges. If any such access is found, the C function call stack and a
message will be printed on stderr and the execution will stop.

Memory access checking, page 152.

To set related options, choose:

Simulator>Memory Access Setup

--misaligned_action {force|cycles}

force Misaligned data will be forced to a correct alignment.

cycles One extra bus cycle will be added.

Any C-SPY hardware debugger driver.

Use this option to specify which action to take when a memory access to misaligned data
is detected. Note that the hardware of your specific core might not support all actions.

Simulator>Data Alignment Setup>Action

--misaligned_notification

Syntax

Parameters

--misaligned_notification {none|log|stop}

none No notification.

log A message is displayed in the Debug Log window.
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For use with

Description

Syntax
For use with

Description

Syntax

Parameters

For use with
Description

See also

stop A message is displayed in the Debug Log window and the
execution stops after the access to the misaligned data.

Any C-SPY hardware debugger driver.

This option specifies the notification method for memory accesses to misaligned data.

Simulator>Data Alignment Setup>Notification

Any C-SPY hardware debugger driver.

Use this option to suppress the downloading of the executable image to a non-volatile
type of target memory. The image corresponding to the debugged program must already
exist in the target.

If this option is combined with the option -c2, the debugger will read back the
executable image from memory and verify that it is identical to the debugged program.

Project>Options>Debugger>Driver>Setup>Download>Suppress

-p filename

filename

The device description file to be used.
All C-SPY drivers.
Use this option to specify the device description file to be used.

Selecting a device description file, page 41.

Project>Options>Debugger>Setup>Device description file



--plugin

Syntax

Parameters

For use with

Description

--silent

Syntax

For use with

Description

--timeout

Syntax

The C-SPY command line utility—cspybat ___¢

--plugin filename

Note that this option must be placed before the - -backend option on the command line.

filename

The plugin file to be used (filename extension d11).
cspybat

Certain C/C++ standard library functions, for example print £, can be supported by
C-SPY—for example, the C-SPY Terminal I/0O window—instead of by real hardware
devices. To enable such support in cspybat, a dedicated plugin module called
v850bat.dll located in the \bin directory must be used.

Use this option to include this plugin during the debug session. This option can be used
more than once on the command line.

Note: You can use this option to include also other plugin modules, but in that case the
module must be able to work with cspybat specifically. This means that the C-SPY
plugin modules located in the common\plugin directory cannot normally be used with
cspybat.

Project>Options>Debugger>Plugins

--silent

Note that this option must be placed before the - -backend option on the command line.
cspybat

Use this option to omit the sign-on message.

This option is not available in the IDE.

--timeout milliseconds

Note that this option must be placed before the - -backend option on the command line.
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Parameters

For use with

Description

Syntax

Parameters

For use with

Description

milliseconds

cspybat

The number of milliseconds before the execution stops.

Use this option to limit the maximum allowed execution time.

This option is not available in the IDE.

-v {00]10]11]20]30}

00

10

11

20

30

Specifies the plain V850 CPU type
Specifies the V850E CPU type
Specifies the VS850ES CPU type
Specifies the V850E2 CPU type
Specifies the V850E2M CPU type

All C-SPY drivers (mandatory).

Use this option to specify the CPU type you are using. For a description of the CPU
types, see the AR C/C++ Compiler Reference Guide for V850.

Project>Options>General Options>Target>Device



Part 4. Additional
reference information

This part of the C-SPY® Debugging Guide for V850 includes these chapters:

e Debugger options
e Additional information on C-SPY drivers

o Using the MINICUBE2 emulator
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Debugger options

e Setting debugger options
e Reference information on general debugger options

e Reference information on C-SPY hardware debugger driver options

Setting debugger options

Before you start the C-SPY debugger you might need to set some options—both C-SPY
generic options and options required for the target system (C-SPY driver-specific
options).

To set debugger options in the IDE:
I Choose Project>Options to display the Options dialog box.
2 Select Debugger in the Category list.

For more information about the generic options, see Reference information on general
debugger options, page 323.

3 On the Setup page, make sure to select the appropriate C-SPY driver from the Driver
drop-down list.

4 To set the driver-specific options, select the appropriate driver from the Category list.
Depending on which C-SPY driver you are using, different options are available.

To restore all settings to the default factory settings, click the Factory Settings button.

6 When you have set all the required options, click OK in the Options dialog box.

Reference information on general debugger options
Reference information about:
e Setup
o Images
o Extra Options

o Plugins
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Setup

The general Setup options select the C-SPY driver, the setup macro file, and device
description file to use, and specify which default source code location to run to.

Setup |
Driver———————————— ¥ Funto
I Simulator j Imain
— Setup macro

™ Use macra file
| L

— Device description file

™ Overide default

| L

Driver

Selects the C-SPY driver for the target system you have.

Run to

Specifies the location C-SPY runs to when the debugger starts after a reset. By default,
C-SPY runs to the main function.

To override the default location, specify the name of a different location you want
C-SPY to run to. You can specify assembler labels or whatever can be evaluated as such,
for example function names.

If the option is deselected, the program counter will contain the regular hardware reset
address at each reset.

Setup macros

Registers the contents of a setup macro file in the C-SPY startup sequence. Select Use
macro file and specify the path and name of the setup file, for example
SetupSimple.mac. If no extension is specified, the extension mac is assumed. A
browse button is available for your convenience.

Device description file

A default device description file is selected automatically based on your project settings.
To override the default file, select Override default and specify an alternative file. A
browse button is available for your convenience.

C-SPY® Debugging Guide
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For information about the device description file, see Modifying a device description
file, page 44.

Device description files are provided in the directory v850\config and have the
filename extension ddf.

Images

The Images options control the use of additional debug files to be downloaded.

Images

[ Download extra image

=

i

[ Download extra image

:

[ Download extra image

:

Note: Flash loading will not be performed; using the Images options you can only
download images to RAM.

Download extra Images
Controls the use of additional debug files to be downloaded:

Path

Specify the debug file to be downloaded. A browse button is available for your
convenience.

Offset

Specity an integer that determines the destination address for the downloaded
debug file.

Debug info only

Makes the debugger download only debug information, and not the complete
debug file.

If you want to download more than three images, use the related C-SPY macro, see
__loadlmage, page 276.

For more information, see Loading multiple images, page 43.
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Extra Options

The Extra Options page provides you with a command line interface to C-SPY.

Extra Dptions |
™ Use command line options
[Eammand line optians: [aneipenline]
=
e

Use command line options

Specify command line arguments that are not supported by the IDE to be passed to
C-SPY.

Note that it is possible to use the /args option to pass command line arguments to the
debugged application.

Syntax: /args arg0 argl

Multiple lines with /args are allowed, for example:
/args --logfile log.txt

/args --verbose

If you use /args, these variables must be defined in your application:

/* __argc, the number of arguments in __argv. */
__no_init int __argc;
/* __argv, an array of pointers to strings that holds the

arguments; must be large enough to fit the number of
parameters.*/
__no_init const char * __argv[MAX_ ARGS];

/* __argvbuf, a storage area for __argv; must be large enough to
hold all command line parameters. */
__no_init __root char __argvbuf [MAX_ARG_SIZE];

C-SPY® Debugging Guide
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Debugger options °

The Plugins options select the C-SPY plugin modules to be loaded and made available

during debug sessions.

Flugins

Select pluging to load:

Code Coverage

Description:  |[Enables code coverage in the debugger.

Lacatian: |\common\plugins\EodeEoverage\EodeEoverage.dII

Originator: |IAF| Systems
Wersior: |4.B.D.D

Select plugins to load

Description

Location

Originator

Version

Selects the plugin modules to be loaded and made available during debug sessions. The
list contains the plugin modules delivered with the product installation.

Describes the plugin module.

Informs about the location of the plugin module.

Generic plugin modules are stored in the common\plugins directory. Target-specific

plugin modules are stored in the v850\plugins directory.

Informs about the originator of the plugin module, which can be modules provided by

IAR Systems or by third-party vendors.

Informs about the version number.

Reference information on C-SPY hardware debugger driver options

Reference information about:

o Setup, page 328

327



Reference information on C-SPY hardware debugger driver options

328

Setup

Suppress

Verify

Speed

With the options on the driver Setup page you can control the C-SPY hardware
debugger drivers and modify the behavior of the download. The page looks slightly
different for the different emulator drivers.

Setup |
Download Speed
™ Suppress " 10MHz
™ Werify + 20MHz

[™ Erase entire flazsh mermory

Communication log
™ Use communication log file

| L]

Choose Project>Options>Debugger and select the C-SPY debugger driver you are
using from the Category list.

Disables the downloading of code, while preserving the present content of the flash.
This command is useful if you want to debug an application that already resides in target
memory. The implicit RESET performed by C-SPY at startup is not disabled, though.

If this option is combined with the Verify option, the debugger will read back the code
image from non-volatile memory and verify that it is identical to the debugged
application.

Verifies that the downloaded code image can be read back from target memory with the
correct contents.

Sets the clock frequency of the communication. Use 10 MHz if you are using a long
N-Wire communication cable.

Note: This option is only available for MINICUBE.

Erase entire flash memory

C-SPY® Debugging Guide
for V850

Erases the entire contents of the flash memory before download, and not just the areas
where the downloaded code will be placed.
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Note: This option is only available for MINICUBE.

Use serial port

Specifies the serial port on your host PC to be used for communication using the FTDI
driver.

Note: The option Use serial port is only available for TK-V850.

To determine which port to specify, open the Device Manager from the Windows
Control Panel. Expand the category Ports (COM & LPT) and locate USB Serial Port.

To configure the port, right-click on USB Serial Port and choose Properties. On the
page Port Settings, click Advanced. Set the option Latency to a small value, 2—4. If
your computer is fast, choose 1.

Use communication log file

Logs the communication between C-SPY and the target system to a file, which can be
useful for troubleshooting purposes. To interpret the result, a detailed knowledge of the
EXEC interface is required. The communication will be logged in the file

cspycomm. log located in the current working directory. If required, use the browse
button to locate a different file.
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Additional information on
C-SPY drivers

This chapter describes the additional menus and features provided by the

C-SPY® drivers. You will also find some useful hints about resolving problems.

Reference information on C-SPY driver menus

C-SPY driver

Reference information about:

o C-SPY driver, page 331
o Simulator menu, page 332

o Emulator menu, page 334

Before you start the C-SPY debugger, you must first specify a C-SPY driver in the
Options dialog box, using the option Debugger>Setup>Driver.

When you start a debug session, a menu specific to that C-SPY driver will appear on the
menu bar, with commands specific to the driver.

When we in this guide write “choose C-SPY driver>" followed by a menu command,
C-SPY driver refers to the menu. If the feature is supported by the driver, the command
will be on the menu.
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Simulator menu
When you use the simulator driver, the Simulator menu is added to the menu bar.
Data Alignment Setup...

Memory Access Setup...

Trace

Function Trace
Function Profiler

Data Log

Data Leg Summary

Interrupt Log

Interrupt Summary

Tirmeline

Simulated Frequency...
v | Interrupt Setup...

Forced Interrupt

Interrupt Status

Breakpoint Usage

Menu commands

These commands are available on the menu:

Data Alignment Setup

Displays a dialog box to control the behavior of the simulator when misaligned
data accesses are detected, see Data Alignment Setup dialog box, page 336.

Memory Access Setup

Displays a dialog box to simulate memory access checking by specifying
memory areas with different access types, see Memory Access Setup dialog box,
page 182.

Trace

Opens a window which displays the collected trace data, see Trace window,
page 194.

Function Trace

Opens a window which displays the trace data for function calls and function
returns, see Function Trace window, page 198.

Function Profiler
Opens a window which shows timing information for the functions, see
Function Profiler window, page 222.

C-SPY® Debugging Guide
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Data Log
Opens a window which logs accesses to up to four different memory locations
or areas, see Data Log window, page 111.

Data Log Summary
Opens a window which displays a summary of data accesses to specific memory
location or areas, see Data Log Summary window, page 113.

Interrupt Log
Opens a window which displays the status of all defined interrupts, see Interrupt
Log window, page 247.

Interrupt Log Summary
Opens a window which displays a summary of the status of all defined
interrupts, see Interrupt Log Summary window, page 250.

Timeline
Opens a window which gives a graphical view of various kinds of information
on a timeline, see Timeline window, page 199.

Interrupt Setup
Displays a dialog box where you can configure C-SPY interrupt simulation, see
Interrupt Setup dialog box, page 241.

Forced Interrupts
Opens a window from where you can instantly trigger an interrupt, see Forced
Interrupt window, page 244.

Interrupt Status
Opens a window from where you can instantly trigger an interrupt, see Interrupt
Status window, page 245.

Breakpoint Usage

Displays a window which lists all active breakpoints, see Breakpoint Usage
window, page 136.
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Emulator menu

When you are using one of the C-SPY hardware debugger drivers, the Emulator menu
is added to the menu bar.
Hardware Setup...

v | Breakpoint Toggle During Run

Trace Settings...
Trace

Function Trace

Data Sample Setup
Data Sample

Sampled Graphs

Memory Menitoring Settings...
Timer Settings...

Trigger OQutput Settings...

Edit Events...

Edit Sequencer Events...

Self Programming Emulation...

Data Flash Emulation...

Live Memory

Data Flash Memaory

Breakpoint Usage

Menu commands
These commands are available on the menu:

Hardware Setup
Displays a dialog box, in which the basic configuration for the emulator is done.
There are separate dialog boxes for the different drivers:

Hardware Setup dialog box — IECUBE, page 56

Hardware Setup dialog box — E1 N-Wire, E1 Serial, MINICUBE, MINICUBE?2,
TK-V850, page 60

Hardware Setup dialog box — E1 Nexus, [IECUBE2, MINICUBE for V850E2x,
page 65

Breakpoint Toggle During Run

Toggles breakpoints on or off during emulator execution. Toggling a breakpoint
on or off will temporarily halt the application.
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Trace Settings
Displays a dialog box where you can configure the trace generation and
collection, see Trace Settings dialog box, page 191.

Trace
Opens a window which displays the collected trace data, see Trace window,
page 194.

Function Trace
Opens a window which displays the trace data for function calls and function
returns, see Function Trace window, page 198.

Data Sample Setup

Opens a window where you can specify variables to sample data for, see Data
Sample Setup window, page 115.

Data Sample

Opens a window where you can view the result of the data sampling, see Data
Sample window, page 116.

Sampled Graphs
Opens a window which gives a graphical view of various kinds of sampled
information, see Data Sample window, page 116.

Memory Monitoring Settings

Displays a dialog box, where you define the address ranges for code coverage,
data coverage, and live watch; see Memory Monitoring Settings dialog box, page
180.

Timer Settings
Displays a dialog box, where you can define the timer behavior; see Timer
Settings dialog box, page 338.

Trigger Output Settings

Displays a dialog box, where you can select which events that shall emit a pulse
when triggered; see Trigger Output Settings dialog box, page 340. Only
available for the IECUBE driver.

Edit Events

Displays a dialog box, where you can define the events used as breakpoint, trace,
timer, trigger output, and sequencer events; see Edit Events dialog box, page
341.
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Edit Sequencer Events
Displays a dialog box, where you can define sequences of events that must occur
before a sequencer event is triggered; see Edit Sequencer Events dialog box,
page 344.
Self Programming Emulation
Opens a window; see Self Programming Emulation dialog box, page 346.
Data Flash Emulation

Opens a window; see Data Flash Emulation dialog box, page 159. Only
available for the IECUBE driver.

Live Memory

Opens a window, which displays a selected memory area in real time while your
application is being executed. See Live Memory window, page 166.

Data Flash Memory
Opens a window; see Data Flash Memory window, page 160.
Breakpoint Usage

Displays a window which lists all active breakpoints, see Breakpoint Usage
window, page 136.

Reference information on the C-SPY simulator

This section gives additional reference information the C-SPY simulator, reference
information not provided elsewhere in this documentation.

Reference information about:

e Data Alignment Setup dialog box

Data Alignment Setup dialog box

C-SPY® Debugging Guide
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The Data Alignment Setup dialog box is available from the Simulator menu.

Data Alignment Setup

Action Matification

+ Force alignment {mask) " Mone
e~ & Lag Cancel

" Log and stop execution
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Use this dialog box to control the behavior of the simulator when an access to
misaligned data is detected.

Note: The device you have selected might not support all actions.

Requirements
The C-SPY simulator.

Action

Selects the action to take when an access to misaligned data is detected. Choose
between:

Force alignment
Forces misaligned data to a correct alignment.

Add cycles
Adds one extra bus cycle.

Notification
Selects a suitable notification method. Choose between:
None
Specifies that no notification will be issued.
Log
Displays a message in the Debug Log window.

Log and stop execution

Displays a message in the Debug Log window and stops the execution after the
access to the misaligned data.

Reference information on the C-SPY hardware debugger drivers
This section gives additional reference information on the C-SPY hardware debugger
drivers, reference information not provided elsewhere in this documentation.

Reference information about:

Timer Settings dialog box, page 338

Trigger Output Settings dialog box, page 340
Edit Events dialog box, page 341

Edit Sequencer Events dialog box, page 344

Self Programming Emulation dialog box, page 346
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Timer Settings dialog box

The Timer Settings dialog box is available from the Emulator menu.

Timer Settings

Meazurement source

& 50 MHz clock Resalution |1 'l

' CPU clock Time per unit: 20 ng Cancel

di.

— Timer condition:

Mame lm ¥ Clear timer before Ga

Start tirner Stop tirmer [+ Break when > pass time limit Add
eventl Pass time: lirnit I‘IDDD units
event?2 : I adify |
Time: 20.0 us
™ Stop measuring when > pass count limit Eemaye |
™ Break when > pass count limit
— Femove Al |
Pass count limit IU _|;
Mame | Start Event | Stop Event | Time Limit | Faszs Limit | Clear |
tirmer1 avent] avent?2 Break @ 1000 [20.0 us] N

Use this dialog box to define the timer behavior for the [IECUBE emulator. The timer
measures the time between events that you select with the Timer conditions options.
The result is displayed in the C-SPY Debug Log window.

To modify an existing timer:
I Select the timer in the list at the bottom of the dialog box.
2 Make changes in the Timer conditions options group.

3 Click Modify.

Requirements

An IECUBE hardware debugger.

Measurement source
Selects the clock that the timers are based on. Choose between:

50 MHz clock

Bases the timers on a 50 MHz clock, making each time unit 20 nanoseconds (ns)
long.
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CPU clock

Bases the timers on the external CPU clock.

Resolution

Selects the timer resolution. A coarser resolution gives more instructions the
same time stamp, which makes the timer count last longer.

Timer conditions

Sets the conditions for the timer. You can specify:

Name

Specity a name for each new timer or choose among previously defined timers.

Start timer
Selects the timer events that should start the time measuring for the named timer.
If more than one event is selected, the timer condition is true when one of the
events has occurred.

Stop timer
Selects the timer events that should stop the time measuring for the named timer.
If more than one event is selected, the timer condition is true when one of the
events has occurred.

Clear timer before Go
Clears the timer before any Go or step command is performed.

Break when > pass time limit
Sets a time limit to the execution of one pass. Select this option and type a
number in the Time limit box. The execution will stop when the specified time
has been exceeded and the time will be displayed as the Max value in the Debug
Log window. How long each time unit is, depends on the settings in the
Measurement source option group.

Stop measuring when > pass count limit
Stops the time measurement after a certain number of measurement cycles.
Select this option and type a number from 1 to 65535 in the Pass count limit
box. The time measurement stops when the counter value has been exceeded,
that is, when the measurement cycle from a start event to a stop event has been
executed more than the specified number of times.
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Break when > pass count limit

Stops the execution after a certain number of measurement cycles. Select this
option and type a number from 1 to 65535 in the Pass count limit box.
Execution breaks when the counter value has been reached, that is, when the
measurement cycle from start event to stop event has been executed the
specified number of times.

Buttons
These buttons are available:
Add
Adds a new timer, which you have defined using the Timer conditions options.
Modify
Modifies an existing timer.
Remove

Removes one or more timers.

Remove All
Removes all existing timers.

Trigger Output Settings dialog box

The Trigger Output Settings dialog box is available from the Emulator menu when
the trigger output is set to Disabled/Event trigged in the Hardware Setup dialog box

for the IECUBE Emulator.

Ok

o ]
Cancel |

Trigger event conditions

12 [ ImyEwnl
[ ImyEwn2

Use this dialog box to configure the trigger pin to emit a pulse when certain events are
triggered.

Requirements
An IECUBE hardware debugger.
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Selects the events that will make the trigger pin emit a pulse.

Edit Events dialog box

The Edit Events dialog box is available from the Emulator menu.

Edit Events E
Mame Ievent2 VI
Cancel |
— Addre: Frobe
¥ Stat |nx33n | M Walue [0 E
End IDRSSD vl Mask IDxFF vl
" Use Range Pattem IDDDDDDDD
— Drata & Control
o [rata Size Accesz Type Add
i - .
Value 040 & by  Feadfwiite el |
o  Read
Mask [0 | iz it
= HE o e Hemove |
€ 0P Fetch
Pattern IxxxxxxxxxxxxxxxxxxxxxxxxDDDDDDDD ) % Before Fetch Framave Al |
Mame | Uszage | Start Addr. | End Addr. | Size | Accessl [ratast ask | Fin Mask |
event] Mot Used Ox312 0320 Any F Any Any
event? Breakpoint 04330 04330 Any  BF Any Any

Use this dialog box to define or modify the events used as breakpoint, trace, timer and
sequencer events.

In real-time, the emulator compares the address, data, access type, and probe signals
with the events that you have defined. When all defined conditions are true, the event is
raised.

Requirements

Any supported hardware debugger system.

Name

Selects an existing event or you can specify a new event name.
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342

Address

ASID

External trigger

Probe

Data & Control

C-SPY® Debugging Guide
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Specify an address or an address range. Any access to the area causes the event to be
triggered. You can specify:

Start

Specify a single address to define a start value.
End

Specity an end value for a range.
Use Range

Specity the start and end values of the range in the Start and End fields.

Note: You can enter a label instead of an address value.

Triggers an event when a specific task is running. The Value field contains the ASID
register’s value, a hexadecimal value between 0x0 and 0xFF.

The ASID CPU register is used for storing the current task in RTOS-aware debugging.

Note: This option is only available when using the IECUBE emulator debugger.

Enables the use of an external trigger. An external trigger works like a 1-byte probe.

Note: This option is only available when using the IECUBE emulator debugger.

Defines a probe value that triggers the event. You can specify:

Value
Specify a probe value.

Mask
Specity a mask to apply to the value.

Pattern
Displays the bit pattern for the value with the applied mask.

Note: This option is not available when using the IECUBE emulator debugger.

Defines the data value, data size, and type of access that triggers the event. Specify these
options for the event trigger:
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Value

Specity a value to search for in the trace buffer.
Mask
Specity a mask to apply to the value.
Pattern
Displays the bit pattern for the value with the applied mask.
For Data size, choose between:
Any
Matches data accesses of any size.
Byte
Matches byte size accesses.
Half word
Matches halfword accesses.
Word

Matches word size accesses.

For Access type, choose between:

Read/Write
Determines that a data read or a data write triggers the event.
Read
Determines that a data read triggers the event.
Write
Determines that a data write triggers the event.
OP fetch
Determines that an OP fetch triggers the event. The execution stops after the
fetched instruction. This setting can be used with ranges.
Note: The MINICUBE and MINICUBE?2 Emulators, the N-Wire OCD
Debugger, and the TK-V850 debugger cannot use this access type.
Before fetch

Determines that a Before fetch triggers the event. The execution stops on the
fetched instruction. This setting cannot be used with ranges. Also, it can only be
used as a breakpoint, not for tracing or timing.
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Buttons

These buttons are available:
Add
Adds a new event.
Modify
Modifies an existing event.
Remove

Removes one or more events.

Remove All

Removes all existing events.

Edit Sequencer Events dialog box

C-SPY® Debugging Guide
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The Edit Sequencer Events dialog box is available from the Emulator menu.

Edit Sequencer Events

Mame ISECﬂ 'l Count I‘I _:|

[ ]
Ok |
Cancel |
Enable 1 Enable 2 Enable3d Enable 4 Disable
eventd eventd eventd
eventd eventd .
event] event] ey |
event event event
Hemove |
Remave Al |
Mame | Uszage | Enable 1 | Enable 2 | Enable 3 | Enable 4 | Dizable | Count |
zeql Mot Used  event3 event] eventd event? 1

Use this dialog box to define or modify sequencer events. A sequencer event can consist
of up to four events that must be triggered in a sequence. The events must be defined in
the Edit Events dialog box, see Edit Events dialog box, page 341.

To define a new sequencer event:

Specity the name in the Name drop-down list.
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2 Specify a value for Count.
Make your selections in the Enable and Disable lists.

4 Click Add.

Requirements

Any supported hardware debugger system.

Name

Selects an existing sequencer event or you can specify a new sequencer event name.

Count

Sets the number of times the sequence must be repeated before the whole event sequence
is fulfilled.

Enable/Disable

Selects the events that will be part of the sequencer event. You can select more than one
event in each Enable list. You do not have to use all Enable lists.

If the Disable event occurs, the sequence starts over with the first Enable event again.

Display area

Each event is uniquely named and listed with its settings at the bottom of the dialog box.
The Usage column shows how the event is used, that is, as breakpoint, trace, timer, or
sequencer event.

Buttons
These buttons are available:
Add
Adds a new sequencer event.
Modify
Modifies an existing sequencer event.

Remove

Removes one or more sequencer events.

Remove All
Removes all existing sequencer events.
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Self Programming Emulation dialog box

The Self Programming Emulation dialog box is available from the Emulator menu
for IECUBE emulators.

Self Programming Emulation =

[V Enable oK

—Version
Cancel

1% Flash Macra Yer 2,00
= Flash Macra Yer 3,00 Default

Elel

—Reset Vector

| 0x00000000

—Error Emulation

¥ Block Erase ™ FLMD Chedk
™ Block verify ¥ setInfo

I Block Blank Check [~ write

—Security Flags
¥ Chip Erase ™ wirite
¥ Block Erase [ Read

™ Boot Cluster Reprogramming

Use this dialog box to set Self Programming Emulation options.

Requirements
An IECUBE hardware debugger.

Version

Selects the version of the flash macro for UC2 devices, choose between:

Flash Macro Ver 2.00
Selects the old specification.

Flash Macro Ver 3.00
Selects the new specification.

Reset Vector

Sets the reset vector address. This address must be located in the flash area. If not, an
error message will be issued.

The default address is 0x0.

Note: This option is device-dependent.
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Security Flags
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Emulates errors of flash macro services. When the emulation is enabled, it generates the
return of an error value as if the flash execution had suffered a problem. By default, a
non-error value is returned.

You can choose which functions that should return an error:

Flash block erase

Flash block verify
Flash block blank check
Flash FLMD Check
Flash set info

Flash word write.

Emulates the default values of the security flags as if writing to flash with the flash
memory programmer PG-FP4:

Chip erase

Block erase

Bootcluster Reprogramming

Write

Read.

Note: Not all devices support all security flags.

Resolving problems

These topics are covered:

o Write failure during load

o No contact with the target hardware

o Slow stepping speed

Debugging using the C-SPY hardware debugger systems requires interaction between
many systems, independent from each other. For this reason, setting up this debug

system can be a complex task. If something goes wrong, it might be difficult to locate
the cause of the problem.

This section includes suggestions for resolving the most common problems that can
occur when debugging with the C-SPY hardware debugger systems.
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For problems concerning the operation of the evaluation board, refer to the
documentation supplied with it, or contact your hardware distributor.
WRITE FAILURE DURING LOAD

There are several possible reasons for write failure during load. The most common is
that your application has been incorrectly linked:

o Check the contents of your linker configuration file and make sure that your
application has not been linked to the wrong address

o Check that you are using the correct linker configuration file.

In the IDE, the linker configuration file is automatically selected based on your choice
of device.

To choose a device:

Choose Project>Options.

Select the General Options category.

Click the Target tab.

Choose the appropriate device from the Device drop-down list.
To override the default linker configuration file:
Choose Project>Options.

Select the Linker category.

Click the Config tab.

Choose the appropriate linker configuration file in the Linker configuration file area.

NO CONTACT WITH THE TARGET HARDWARE

There are several possible reasons for C-SPY to fail to establish contact with the target
hardware. Do this:

Check the communication devices on your host computer

Verify that the cable is properly plugged in and not damaged or of the wrong type

Make sure that the evaluation board is supplied with sufficient power

Check that the correct options for communication have been specified in the IAR
Embedded Workbench IDE.

Examine the linker configuration file to make sure that the application has not been
linked to the wrong address.
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SLOW STEPPING SPEED

If you find that the stepping speed is slow, these troubleshooting tips might speed up
stepping:

e If you are using a hardware debugger system, keep track of how many hardware
breakpoints that are used and make sure some of them are left for stepping.

Stepping in C-SPY is normally performed using breakpoints. When C-SPY performs
a step command, a breakpoint is set on the next statement and the application
executes until it reaches this breakpoint. If you are using a hardware debugger
system, the number of hardware breakpoints—typically used for setting a stepping
breakpoint in code that is located in flash/ROM memory—is limited. If you, for
example, step into a C switch statement, breakpoints are set on each branch; this
might consume several hardware breakpoints. If the number of available hardware
breakpoints is exceeded, C-SPY switches into single stepping on assembly level,
which can be very slow.

For more information, see Breakpoints in the C-SPY hardware debugger drivers,
page 126 and Breakpoint consumers, page 127.

e Disable trace data collection, using the Enable/Disable button in both the Trace
and the Function Profiling windows. Trace data collection might slow down
stepping because the collected trace data is processed after each step. Note that it is
not sufficient to just close the corresponding windows to disable trace data
collection.

o Choose to view only a limited selection of SFR registers. You can choose between
two alternatives. Either type #SFR_name (where SFR_name reflects the name of the
SFR you want to monitor) in the Watch window, or create your own filter for
displaying a limited group of SFRs in the Register window. Displaying many SFR
registers might slow down stepping because all registers must be read from the
hardware after each step. See Defining application-specific register groups, page
153.

o Close the Memory and Symbolic Memory windows if they are open, because the
visible memory must be read after each step and that might slow down stepping.

o Close any window that displays expressions such as Watch, Live Watch, Locals,
Statics if it is open, because all these windows read memory after each step and that
might slow down stepping.

o Close the Stack window if it is open. Choose Tools>Options>Stack and disable the
Enable graphical stack display and stack usage tracking option if it is enabled.

e If possible, increase the communication speed between C-SPY and the target
board/emulator.
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Using the MINICUBE2
emulator

This chapter contains important information about using the MINICUBE2
OCD Emulator with the V850 Microcontroller Series.

Read this chapter as a supplement to the chapter Additional information on
C-SPY drivers.

Overview

The following table shows the debugging features of the MINICUBE?2 emulator:

Feature Availability

Security 10-byte ID code authentication

Application download Yes

Execution variants Go & Go, Start from here, Come Here, Restart, Single
step

Hardware breakpoints 2 (commonly used by execution and data access)

Software breakpoints 4 in ROM
2000 in RAM

Forced breakpoints Yes*

RAM monitoring Yes

Pin masking For reset pin

Time measurement (from execution  Resolution: 100 ps,
start to break) Max. time:
~100 hours

Table 37: MINICUBE?2 debug features

* A forced break cannot be executed if one of the following conditions is true:

e Interrupts are disabled

e Interrupts of the serial interface used for the communication between MINICUBE2
and the target device are masked

e Standby mode is entered while standby release by a maskable interrupt is prohibited
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o UART communication between MINICUBE?2 and target device is used and the
main clock is stopped.

When the MINICUBE2 emulator is debugging an application, some resources cannot
be used by the application and must be reserved.

All ROM areas used by the monitor program must be reserved by your application. Any
modification of these areas is prohibited. These areas must be excluded from the usable
address space in the linker configuration file.

Device-specific linker configuration files to be used as templates are included in the
$TOOLKIT_DIRS\config directory.

If unused ROM addresses are filled using the XLINK option -H, the XLINK option -h
must be used to exclude the resources required by the debug monitor program.

// Monitor program areas 00002-00003, 007E-018F must be excluded

-h0004-007D
-h0190-ROM-END

V850 MINICUBE?2 reserved resources
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Some resources must be reserved by your application. Any modification of these areas
is prohibited.

ROM AREAS USED FOR ON-CHIP DEBUGGING

These ROM areas must be reserved:

o The reset vector, which will be overwritten by the monitor program during
debugging

The IRQ vector at address 0x0060, 0x0063, which is used by the monitor program
The CSI or UART receive interrupt, which is used by the monitor program

The Security ID area at 0x0070—0x0079, which contains the authentication code

The monitor area: 2048 bytes at the end of the internal ROM, which is used by the
monitor program.

RAM SPACE

These RAM area must be reserved:
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o An additional 10-16 bytes of the stack area.

PINS

These pins must be reserved:

o The UART connection: pin RXD, TXD
o The CSI-H/S connection: pins SI, SO, SCK, H/S.

SECURITY ID AND OPTION BYTES
The Security ID and the option bytes must be defined in assembler, as in this example:

COMMON INTVEC:CODE:ROOT (2)
ORG 0x00000070
“SECUID :

DB s0

DB s1

DB s2

DB s3

DB s4

DB s5

DB s6

DB s7

DB s8

DB s9

COMMON INTVEC:CODE:ROOT (2)
ORG 0x0000007A
“OPTBYTES :

DB vO0

DB v1

DB v2

DB v3

DB v4

DB v5

In the Renesas device file package available on the Renesas Development Tools web
(www.renesas.eu/update), you will find ready-to-use assembler files named
DFxxx_HWInit.s85.

This device-specific assembler file includes the definition of the security ID and the
definition of the option bytes, if option bytes are supported by the device. The file must
be added to your application and the values must be set according to the application
requirements.

The device-specific values v0-v5 are described in the device documentation.
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The ten bytes s0—s9 make up the ID Code that you are defining. By default, all values
are OxFF. See Hardware Setup dialog box — E1 N-Wire, E1 Serial, MINICUBE,
MINICUBE?2, TK-V850, page 60.

You can change the segment names OPTBYTE and SECUID. New names must be defined
in the linker configuration file.

RESERVING THE ROM MEMORY AREA FOR THE MONITOR

The addresses 0x02, 0x03, the interrupt vector area 0x0060—0x0063, the receive
interrupt vector of the UART or the CSI, and the last 2048 bytes of the internal ROM
must be reserved for the debug monitor program. If this area is rewritten by the flash
self-programming, on-chip debugging can no longer be performed. Reserve these areas
in the linker configuration file.

Device-specific linker configuration file templates reserving all necessary areas are
included with the product. The templates are located in the $TOOLKIT_DIR$\config\
directory. The end-address definitions for of all segments must be modified to reserve
the highest 2048 bytes of the internal ROM.

The naming convention for the device-specific linker configuration files is transparent.
The template for the uPD70F3385 device is named 1nk70£3385.xc1, for example.

STACK AREA

On-chip debugging requires an additional 10-16 bytes of stack. Therefore, the stack size
of the application must be increased. In the IAR Embedded Workbench IDE, choose
Project>Options>General Options>Stack/Heap. If you are debugging from the
command line, the stack size is defined in the linker configuration file:

// Size of the stack. Remove the comment and modify
// the number if used from the command line.

//-D_CSTACK_SIZE=1000

RESERVING RESOURCES OF THE SERIAL INTERFACE

The UART or the CSI-H/S is used for the communication between MINICUBE? and the
target system. The configuration of the serial interface is performed by the debug
monitor program and should not be changed by your application. Make sure that:

® You do not write to the registers of the UART and the CSI-H/S

o If the UART is used:

e you do not mask receive end interrupts
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o you do not mask the receive error interrupt for the V8S50ES/IE2, V850ES/IK1,
V850E/1A3, V850E/IA4, V850E/IF3, or V850E/IG3 devices

o you do not set the port registers to make the TxD and RxD pins invalid.
o If the CSI-H/S is used:
o you do not mask receive end interrupts

e you do not set the port registers to make the SI, SO, SCK, and H/S pins invalid.
The H/S pin is used as the output port for debugging.

CAUTIONS ON DEBUGGING FOR V850

There are a number of important things you need to know when debugging with the
MINICUBE2 emulator. Refer to chapter 3.2.6 of the QB-MINI2 On-Chip Debug
Emulator with Programming Function User s Manual, document number U18371,
available from the Renesas website www . renesas . eu/docuweb.

Further reading

For more information about using the OCD emulator MINICUBE2, see the QB-MINI2
On-Chip Debug Emulator with Programming Function User s Manual, document
number U18371, available from the Renesas website www . renesas . eu/docuweb.

For information about known problems and for a list of supported devices, see the
OB-MINI2-EE Universal Flash Memory Programmer and Serial On-chip Debugger
Operating Precautions guide. It has document number U18674 and is available from the
Renesas website www. renesas . eu/docuweb.

TARGET SYSTEM DESIGN

The target system design is described in the MINICUBE2 (QB-MINI2) User’s Manual
for all microcontroller series.

FLASH PROGRAMMING

Using the MINICUBE2 emulator as a flash programmer is described in MINICUBE2
(QB-MINI2) User’s Manual for all microcontroller series.
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